Ask Your Question

Nivas's profile - activity

2018-10-16 04:43:52 -0600 received badge  Famous Question (source)
2018-10-16 04:43:52 -0600 received badge  Notable Question (source)
2018-10-16 04:43:52 -0600 received badge  Popular Question (source)
2017-07-27 12:11:07 -0600 received badge  Nice Question (source)
2017-01-03 20:12:52 -0600 received badge  Notable Question (source)
2017-01-03 20:12:52 -0600 received badge  Famous Question (source)
2016-12-04 08:59:32 -0600 received badge  Famous Question (source)
2016-08-09 03:41:34 -0600 received badge  Notable Question (source)
2016-06-22 01:13:19 -0600 received badge  Popular Question (source)
2016-06-08 00:32:47 -0600 commented answer Mirantis Fuel: what is nailgun server?

Thanks again! all these same named open sources are leading to confusion!

2016-06-06 23:13:06 -0600 commented answer Mirantis Fuel: what is nailgun server?

mpetason : Thanks for the answer. So the nailgun used in Fuel is developed by mirantis which is different from the existing nailgun servers.

2016-06-06 07:13:27 -0600 asked a question Mirantis Fuel: what is nailgun server?

Sorry for my naive question :(. But i am unable to figure out what is NailGun server and whats its use in Mirantis Fuel? When I searched internet, i came across 2 nailgun servers,

 1)Nailgun Server helps to run all your Java apps in the same JVM 
 2)Nailgun python library which facilitates easy usage of the Satellite 6 API

But I also not clear what Satellite 6 API means!. Could some one help me in knowing what Nailgun is? and how it is used in Mirantis Fuel?

Thanks in advance!

2016-05-12 07:58:12 -0600 asked a question Glance returns 404 when url contains "image name' instead of ID

Hi all,

when you query by image UUID it works

    curl -g -i -X HEAD -H 'Accept-Encoding: gzip, deflate' -H 'Accept: */*' -H 'User-Agent: python-glanceclient' -H    'Connection: keep-alive' -H 'X-Auth-Token: xxxxxxxxxxxxxxxxx' -H 'Content-Type: application/octet-stream'  http://192.168.2.11:9292/v1/images/yyyy-yyyy-yyyyyyyy-yyyyyy

but when you do the same with 'name', it returns 404

    curl -g -i -X HEAD -H 'Accept-Encoding: gzip, deflate' -H 'Accept: */*' -H 'User-Agent: python-glanceclient' -H 'Connection: keep-alive' -H 'X-Auth-Token: xxxxxxxxxxxxxxxxx' -H 'Content-Type: application/octet-stream' http://192.168.2.11:9292/v1/images/image1

Glace version : 1.1.1 Openstack client version : 1.7.2

Any idea?

thanks in advance!

2016-05-11 21:57:31 -0600 received badge  Popular Question (source)
2016-05-04 07:04:21 -0600 asked a question Invalid resource type oslo::log - Pupper Error while installing Undercloud

Dear All,

I am encountering this issue while installing undercloud in a baremetal machine.

      Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Invalid resource type oslo::log at                   /etc/puppet/modules/keystone/manifests/logging.pp:167 on node undercloud.localcom
      Wrapped exception:
      Invalid resource type oslo::log
      Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Invalid resource type oslo::log at  /etc/puppet/modules/keystone/manifests/logging.pp:167 on node undercloud.localcom

My undercloud node details:

    OS: RHEL Server 7.2 (  lsb_release -i -r )

    [stack@localhost ~]$ yum repolist
     Loaded plugins: product-id, search-disabled-repos, subscription-manager
     Repo rhel-7-server-openstack-7.0-rpms forced skip_if_unavailable=True due to:          /etc/pki/entitlement/837869533901661430-key.pem
     Repo rhel-ha-for-rhel-7-server-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/837869533901661430-key.pem
     Repo rhel-7-server-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/837869533901661430-key.pem
      repo id                                        repo name                             status
     --------------------------------------------------------------------------------------------
     delorean                                      delorean-python-proliantutils  461
     delorean-liberty-testing/x86_64    delorean-liberty-testing          848
     *epel/x86_64                               Extra Packages - x86_64         10,021
     rhel-7-server-openstack-7.0-
         rpms/7Server/x86_64              OpenStack Platform 7.0 (RPMs) 1,208
    rhel-7-server-rpms/7Server/x86_64  RHEL 7 Server (RPMs)            10,684
    rhel-ha-for-rhel-7-server-rpms/7Server/x86_64  Red Hat Enterprise Linux High Availability (for  RHEL 7 Server) (RPMs)  205

Could someone help me in fixing the issue?

Thanks in advance!

2016-04-05 00:58:35 -0600 asked a question How to access nova REST apis in mirantis fuel

Hi All, I have a script that queries the nova endpoint from service catalogue returned from keystone. That script works well in normal openstack but not with fuel. Nova endpoint is not returned from keystone in FUEL. I need to get the list of flavors from nova enpoint. May i know how to do this?

Thanks in advance!

2016-03-04 00:31:25 -0600 received badge  Famous Question (source)
2016-03-01 23:33:51 -0600 received badge  Notable Question (source)
2016-02-29 21:57:20 -0600 commented answer Mirantis FUEL 8.0 - unable to build ISO

Thanks for the quick reply. I am going to modify the FUEL source and need to build ISO from that. To begin with, i was testing with the 8.0 source from git (unmodified) to build ISO but got the above error.

2016-02-29 14:01:03 -0600 received badge  Popular Question (source)
2016-02-29 03:52:04 -0600 asked a question Mirantis FUEL 8.0 - unable to build ISO

Hi all,

I am getting this error while building Fuel ISO .

My Environment : Ubuntu 14.04 LT2 64 bit, FUEL Stable V8.0

Steps I have followed to create FUEL ISO:

   git clone https://github.com/openstack/fuel-main -b stable/8.0
   cd fuel-main
   ./prepare-build-env.sh
   make iso

Error I am getting

Processing files: rubygem-astute-8.0.0-1.noarch
Provides: config(rubygem-astute) = 8.0.0-1 ruby(Astute) = 8.0.0 rubygem-  astute = 8.0.0-1
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh systemd-units
Requires(preun): /bin/sh systemd-units
Requires(postun): /bin/sh systemd-units
Requires: /bin/bash /usr/bin/env
Processing files: nailgun-mcagents-8.0.0-1.noarch
error: File must begin with "/": %changelog\n*
......
......
RPM build errors:
  File must begin with "/": %changelog\n*
  File must begin with "/": Mon
  File must begin with "/": Feb
  File must begin with "/": 29
  File must begin with "/": 2016
  .......
  .......

Could some one point me how to fix this? or anyone successful in building ISO of FUEL 8.0 stable version on Ubuntu 14.04 LT2 64 bit machine?

Thanks in advance.

2015-08-15 23:59:32 -0600 received badge  Taxonomist
2015-08-12 08:40:04 -0600 received badge  Student (source)
2015-07-02 01:29:23 -0600 received badge  Famous Question (source)
2015-06-30 07:54:31 -0600 received badge  Enthusiast
2015-06-24 09:21:25 -0600 received badge  Notable Question (source)
2015-06-24 07:56:13 -0600 received badge  Popular Question (source)
2015-06-24 05:14:17 -0600 commented question Issue in migrating a neutron plugin(icehouse) to neutron(kilo).

Thanks petason..we fixed a lot but this is evasive..anyway thanks for your answer

2015-06-23 08:59:27 -0600 asked a question Issue in migrating a neutron plugin(icehouse) to neutron(kilo).

we are migrating a plugin written for neutron(icehouse) to neutron(kilo). We are experiencing an issue in neutron.db.api.py file.

here is the error,

TRACEneutron.service   File...
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py", line 445, in inner
TRACEneutron.service     return f(*args, **kwargs)
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/neutron/manager.py", line 204, in _create_instance
TRACEneutron.service     cls._instance = cls()
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/neutron/manager.py", line 128, in __init__
TRACEneutron.service     self._load_service_plugins()
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/neutron/manager.py", line 177, in _load_service_plugins
TRACEneutron.service     provider)
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/neutron/manager.py", line 145, in _get_plugin_instance
TRACEneutron.service     return plugin_class()
TRACEneutron.service   File "/usr/lib/python2.7/dist-packages/neutron/services/trafficontroller/tcass_plugin.py", line 41, in __init__
TRACEneutron.service     qdbapi.register_models()
TRACEneutron.service AttributeError: 'module' object has no attribute 'register_models'

Is register_model( in neutron.db.api.py) is obsolete in Kilo? Could anyone provide us a link on where to check the architectural changes between each openstack releases?

could anyone help us to get out of the issue?

Thanks in advance!

2015-01-30 05:44:50 -0600 received badge  Scholar (source)
2014-07-28 04:06:13 -0600 received badge  Famous Question (source)
2014-06-27 01:56:33 -0600 received badge  Notable Question (source)
2014-06-26 10:14:41 -0600 commented question VMs unable to connect to Internet

i already enabled it ..but still the problem persists. thanks for your comments!

2014-06-26 03:02:43 -0600 received badge  Popular Question (source)
2014-06-25 11:26:51 -0600 asked a question VMs unable to connect to Internet

Hi All, I have deployed a simple two node architecture i.e. a Compute Node and a Controller node. There are 6 VMs running inside Compute Node that was configured with FLATDHCPManager. The issue is, I have only one NIC. So in the nova.conf of the compute node, i gave same interface for "flat_interface" and "public_interface" configuration.

   allow_same_net_traffic=False
   multi_host=True
   flat_interface=eth0
   flat_network_bridge=br100
   public_interface=eth0

Now, everything works fine i.e. I can access VMs using their Public and internal IPs. But from the VM, i am unable to access internet. I gone through the iptables in the compute node and they are proper.

When i do ping from inside the VM, i am getting

            PING google.com (74.125.232.135) 56(84) bytes of data.
            From 10.0.0.1: icmp_seq=2 Redirect Host(New nexthop: 10.11.71.1)
            From 10.0.0.1: icmp_seq=3 Redirect Host(New nexthop: 10.11.71.1)
            From 10.0.0.1: icmp_seq=4 Redirect Host(New nexthop: 10.11.71.1)

where 10.0.0.1 is the IP of the bridge br100. I am also unable to ping 10.11.71.1 from my VM.

and this is the route -n of my VM

    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0
    0.0.0.0         10.0.0.1        0.0.0.0         UG    0      0        0 eth0

May i know where it could have went wrong?

Using:

Openstack Havana Centos 64 bit 6.5 nova-network

Thanks in advance

2014-01-21 01:25:13 -0600 received badge  Famous Question (source)
2014-01-16 00:00:01 -0600 received badge  Notable Question (source)
2014-01-15 21:22:08 -0600 received badge  Popular Question (source)
2014-01-15 05:25:40 -0600 received badge  Editor (source)
2014-01-15 05:21:21 -0600 commented answer I am able to Ping but not able to SSH in to the VMs

how to check if ssh server is running in VM? Could you please explain how to do that? yes, security rules allow TCP connections.

2014-01-15 05:03:02 -0600 asked a question I am able to Ping but not able to SSH in to the VMs

Hi All, I am able to ping my VMs but i am unable to do SSH. the same VM image works fine inside VirtualBox. I can start/stop/reboot/resize my images with out any issues but while doing ssh, i am getting

"ssh: connect to host 10.0.0.9 port 22: Connection refused"

There is also no valuable log in compute.log too. may i know the issue could be?

Here are my details,

OpenstackHavanna with keystone,glance, nova on 2 centos machines Image : raw qcow2

ssh and ping rules are added by default to the security group

Thanks in advance,