thewizardofOZ's profile - activity

2016-10-10 07:58:45 -0600 answered a question No valid host was found. There are not enough hosts available.

The compute node might not have enough cpu or memory. Check the flavor you choose and system sources.

2016-10-10 07:46:17 -0600 answered a question Is there a size limit to the images you can upload through horizon?

300GB is quite big for http upload, your token will timeout eventually, I'd recommend you to use cli http://docs.openstack.org/cli-referen...

glance image-create command will work for you.

2016-09-29 02:26:39 -0600 received badge  Supporter (source)
2016-04-01 09:45:02 -0600 commented answer RDO quickstart "Juno" release guide for fedora 20

Hi Rich;

I would like to help, just let me know what should I do.

2015-04-30 01:07:19 -0600 received badge  Enthusiast
2015-04-28 02:41:05 -0600 answered a question packstack --allinone stuck

we need more details about the error but I had an error like:

ERROR : Error appeared during Puppet run: 172.17.150.100_keystone.pp
Error: /Stage[main]/Apache::Service/Service[httpd]: Failed to call refresh: Could not start Service[httpd]: Execution of '/sbin/service httpd start' returned 1: Redirecting to /bin/systemctl start  httpd.service
You will find full trace in log /var/tmp/packstack/20150321-101313-Y4ltZn/manifests/172.17.150.100_keystone.pp.log

you should add https services manually sudo yum httpd -y and add Include conf.modules.d/*.conf on /etc/httpd/conf/httpd.conf file

2015-04-06 09:11:36 -0600 received badge  Famous Question (source)
2015-04-03 03:48:07 -0600 received badge  Student (source)
2015-04-02 03:09:48 -0600 received badge  Notable Question (source)
2015-04-01 13:06:17 -0600 received badge  Popular Question (source)
2015-03-24 10:10:08 -0600 asked a question RDO quickstart "Juno" release guide for fedora 20

I successfuly installed OpenStack on one host machine, of course there was some errors, here is how I fix them.

First thing first: update kernel

yum -y install gcc kernel-headers kernel-devel

and fedora itself

sudo yum update -y

now you can check kernel version, it should be like this;

uname -r
3.18.9-100.fc20.x86_64

in case your system is running with NetworkManager, you need to disable it.

systemctl stop NetworkManager
systemctl disable NetworkManager
systemctl enable network

after this, you should check your connectivity, make sure you have internet access. In my scenario I had to add default gateway.

route add default gw YOUR.DEFAULT.GATEWAY

you have to take down all interfaces (but the one via you're connected to the machine) but I must say I didn't get the second code on the website so I fallow the commands below(I have only two interfaces):

ifdown em2

ifdown em1 && systemctl start network

To avoid this error message during the installation;

ERROR : Error appeared during Puppet run: 172.17.150.100_keystone.pp
Error: /Stage[main]/Apache::Service/Service[httpd]: Failed to call refresh: Could not start Service[httpd]: Execution of '/sbin/service httpd start' returned 1: Redirecting to /bin/systemctl start  httpd.service
You will find full trace in log /var/tmp/packstack/20150321-101313-Y4ltZn/manifests/172.17.150.100_keystone.pp.log

you should add https services manually sudo yum httpd -y and add Include conf.modules.d/*.conf on /etc/httpd/conf/httpd.conf file

Update your current packages:

sudo yum update -y

Setup the RDO repositories:

sudo yum install -y https://rdo.fedorapeople.org/rdo-release.rpm

again, if you get an error message like this during the installation,

Error: /Stage[main]/Neutron::Keystone::Auth/Keystone_service[neutron]: Could not evaluate: Execution of '/usr/bin/openstack service list --quiet --format csv --long --os-token 636c43645dbc442088a4862a9b1046f0 --os-url http://127.0.0.1:35357/v2.0/' returned 1: ERROR: openstack Internal Server Error (HTTP 500)

you should change SELINUX /etc/selinux/config file and make the line:

SELINUX=permissive

you have to

reboot

and finally

packstack --allinone

thats it.

enjoy your single node OpenStack!

2013-12-31 12:42:47 -0600 answered a question What's the correct way to specify username for glance?

if your openrc file was not sourced correctly you can see that error message. Also I recommend to use su command and log on as root.