Ask Your Question

Julian Zhu's profile - activity

2014-09-30 02:45:37 -0600 received badge  Famous Question (source)
2014-09-30 02:45:37 -0600 received badge  Notable Question (source)
2014-09-30 02:45:37 -0600 received badge  Popular Question (source)
2014-06-27 11:37:30 -0600 received badge  Famous Question (source)
2014-05-08 23:21:46 -0600 received badge  Famous Question (source)
2014-04-08 22:16:06 -0600 commented question Fail to launch the 10th instance on one compute node

after I changed the quota in /etc/nova/nova.conf and restart nova-* service, the issue is resolved. It seems that the modification to project quota doesn't work at all.

2014-04-08 09:33:05 -0600 asked a question Fail to launch the 10th instance on one compute node

I have setup an openstack env (1 controller + 1 network node + 1 compute node) with packstack, and everything is ok for 9 instances running on my compute node. But when I try to launch the 10th instance, it hangs in the build state and neven moves on. I check the nova log and find nothing but the scheduler log below:

2014-04-08 22:16:32.017 3665 INFO nova.scheduler.filter_scheduler [req-8e2bdb2e-fac1-4904-82d0-d51f337fe108 d52f7f2cb8c54bd4b0ba8728f8f2208e 36fca0c3329a4ce68be6f1cb952d10e0] Attempting to build 1 instance(s) uuids: [u'd8fce202-e416-4002-9a55-5c1a05b9e07d']
2014-04-08 22:16:32.047 3665 INFO nova.scheduler.filter_scheduler [req-8e2bdb2e-fac1-4904-82d0-d51f337fe108 d52f7f2cb8c54bd4b0ba8728f8f2208e 36fca0c3329a4ce68be6f1cb952d10e0] Choosing host WeighedHost [host: nova-vhio, weight: 59277.0] for instance d8fce202-e416-4002-9a55-5c1a05b9e07d

I have already increased the instance number in project quota from 10 to 100, and there is still enough vcpus, memory and disk on the compute node for 10+ instance. I doubt it is a configuration issue but I can't figure it out. Can anyone help to look into this issue? Any suggestions are greatly appreciated.

2014-04-08 06:24:05 -0600 received badge  Notable Question (source)
2014-04-07 16:47:35 -0600 received badge  Notable Question (source)
2014-04-07 01:14:34 -0600 received badge  Popular Question (source)
2014-04-01 00:10:32 -0600 commented answer how to allow multiple neutron dhcp agent

Thank you!

2014-03-31 07:04:31 -0600 received badge  Student (source)
2014-03-31 05:47:07 -0600 asked a question how to allow multiple neutron dhcp agent

i am trying to setup an openstack havana environment with 2 network nodes. I have successfully started the l3-agent on both nodes, but failed to start the 2nd dhcp agent without any error message. The 2nd dhcp agent process just exits with log below:

2014-03-31 15:27:33.955 5882 INFO neutron.common.config [-] Logging enabled!
2014-03-31 15:27:33.956 5882 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver
2014-03-31 15:27:33.965 5882 INFO neutron.agent.linux.dhcp [-] dnsmasq version: 2.48
2014-03-31 15:27:34.009 5882 INFO neutron.openstack.common.rpc.impl_qpid [-] Connected to AMQP server on 192.168.49.136:5672
2014-03-31 15:27:34.011 5882 INFO neutron.openstack.common.rpc.impl_qpid [-] Connected to AMQP server on 192.168.49.136:5672
2014-03-31 15:27:34.030 5882 INFO neutron.openstack.common.rpc.impl_qpid [-] Connected to AMQP server on 192.168.49.136:5672
2014-03-31 15:27:34.034 5882 INFO neutron.agent.dhcp_agent [-] DHCP agent started
2014-03-31 15:27:34.096 5882 INFO neutron.agent.dhcp_agent [-] Synchronizing state

if I stop the 1st dhcp agent, the 2nd dhcp agent will start successfully and work fine. I think it should be a configuration issue but I can't find the root. Can anyone help to check it?

2014-03-30 23:23:40 -0600 received badge  Popular Question (source)
2014-03-16 21:01:14 -0600 commented answer why the 'routes' in 'neutron router-show' is empty?

i see, thank you.

2014-03-12 05:08:19 -0600 received badge  Editor (source)
2014-03-12 05:06:06 -0600 asked a question why the 'routes' in 'neutron router-show' is empty?

Hi Guys, Now I am studying the implement of l3-agent and I have setup a network node with l3-agent successfully, where i can see the routes in 'ip netns exec qrouter-xxxx ip route'. I checked the code and found that the routes information is from the router['routes'], but when I use 'neutron router-show' to check the router details, i got the result below:

[root@test02 openstack(keystone_admin)]# neutron router-show 7e7c305d-6b3b-4ae9-9fe6-c2cf93584b9f
+-----------------------+-----------------------------------------------------------------------------+
| Field                 | Value                                                                       |
+-----------------------+-----------------------------------------------------------------------------+
| admin_state_up        | True                                                                        |
| external_gateway_info | {"network_id": "f0c4bd9a-6be3-450c-94a7-742cc774dba1", "enable_snat": true} |
| id                    | 7e7c305d-6b3b-4ae9-9fe6-c2cf93584b9f                                        |
| name                  | router-1                                                                    |
| routes                |                                                                             |
| status                | ACTIVE                                                                      |
| tenant_id             | a6ca870473544c3596411c030b5e3d06                                            |
+-----------------------+-----------------------------------------------------------------------------+

the routes is empty.

Can anyone help to explain why the routes is empty? Thanks.