Ask Your Question

chenshake's profile - activity

2014-11-12 18:56:39 -0500 received badge  Popular Question (source)
2014-11-12 18:56:39 -0500 received badge  Famous Question (source)
2014-11-12 18:56:39 -0500 received badge  Notable Question (source)
2014-03-31 00:25:32 -0500 received badge  Famous Question (source)
2014-03-05 20:35:34 -0500 received badge  Notable Question (source)
2014-03-05 20:23:02 -0500 answered a question How to access neutron node from compute node installed with packstack

Now I have confirm this is rdo bug.

https://bugs.launchpad.net/packstack/+bug/1288447 (https://bugs.launchpad.net/packstack/...)

https://review.openstack.org/#/c/78442/

https://bugzilla.redhat.com/show_bug.cgi?id=1073100#c1 (https://bugzilla.redhat.com/show_bug....)

2014-02-27 19:57:15 -0500 received badge  Scholar (source)
2014-02-27 19:57:06 -0500 commented answer How to access neutron node from compute node installed with packstack

Thanks. right, add the iptables rules and work well. I think this is bug for RDO.

2014-02-27 16:19:15 -0500 received badge  Popular Question (source)
2014-02-26 10:38:43 -0500 asked a question How to access neutron node from compute node installed with packstack

Now I try to test mutinode deploy Opentack with packstack. I use centos 6.5, GRE netwrok, two nic. (172.28.1.132 is my control node.)

The bug is if you separate roles install, and the control node not install compute service, the dashboard can not login, becasue the separate roles node, lack a iptables rule to allow the control node access the roles node.

1: All in one test: no problem

2: all in one + compute node: no problem

3: all in one (not include neutron) + neutron node+ compute node: no problem

4: all in one ( not include Neutron and compute ) + neutron node +compute node: problem

after finish installed , I can not login dashboard, debug, can not connected neutron via ssh. Why? this is my answer files http://paste2.org/GDCVUVd9

2013-12-24 21:15:30 -0500 received badge  Editor (source)
2013-12-24 21:14:15 -0500 answered a question qpid in ssl

the puppet version is

# rpm -qa | grep puppet
puppet-3.4.0-1.el6.noarch
2013-12-24 07:41:25 -0500 asked a question qpid in ssl

Now I try to enable ssl for qpid.

CONFIG_QPID_ENABLE_SSL=y
CONFIG_QPID_ENABLE_AUTH=y

but when I install, would show the error

ERROR : Error appeared during Puppet run: 172.28.1.132_qpid.pp
Error: Definition 'add_allow_host' is already defined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifests/172.28.1.132_qpid.pp:60; cannot be redefined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifests/172.28.1.132_qpid.pp:79 on node g132.chenshake.co
You will find full trace in log /var/tmp/packstack/20131224-212808-YiY0Ii/manifests/172.28.1.132_qpid.pp.log

check the qpid log

^[[1;31mError: Definition 'add_allow_host' is already defined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifest
s/172.28.1.132_qpid.pp:60; cannot be redefined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifests/172.28.1.132_
qpid.pp:79 on node g132.chenshake.com^[[0m
^[[1;31mError: Definition 'add_allow_host' is already defined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifest
s/172.28.1.132_qpid.pp:60; cannot be redefined at /var/tmp/packstack/02bcd037268c4fbd968243fb850dc732/manifests/172.28.1.132_
qpid.pp:79 on node g132.chenshake.com^[[0m