Ask Your Question

amansuri's profile - activity

2013-12-19 16:47:27 -0500 commented answer Instance fails to start after host is rebooted

I did a grep for bdrv_open and it didn't turn up any entries in the logs

2013-12-19 16:09:28 -0500 received badge  Famous Question (source)
2013-12-19 12:56:47 -0500 commented question Instance fails to start after host is rebooted

I checked and the service is running. How do I check if the cinder-volume is available?

2013-12-19 12:55:34 -0500 commented answer Instance fails to start after host is rebooted

I checked the log files, but there is no error such as that. Also, attaching a volume and booting the instance works OK, but the problem is when booting an instance from an image.

2013-12-19 03:31:46 -0500 received badge  Nice Question (source)
2013-12-19 01:36:21 -0500 received badge  Notable Question (source)
2013-12-18 23:21:53 -0500 received badge  Popular Question (source)
2013-12-18 20:58:17 -0500 received badge  Student (source)
2013-12-18 16:56:17 -0500 asked a question Instance fails to start after host is rebooted

Hi Folks,

When creating a new instance, I selected the option "Boot from image (creates a new volume)" as the Instance Boot Source. The instance starts up OK. Then when I reboot the openstack server and try to start the instance, it fails. It says "(not found)" under 'Image Name'

In the /var/log/nova/compute.log, it shows the following error:

TRACE nova.openstack.common.rpc.amqp OSError: [Errno 2] No such file or directory: '/var/lib/nova/instances/8e4a79dc-8eeb-4766-9c4b-0199a5ca28d4/disk'

This file does not exist on the openstack server.

I can terminate the instance, attach the volume to a new instance, it starts up OK. However, I'm trying to determine why it doesn't start up in this case.

Thanks! -Ali

2013-12-18 13:59:37 -0500 answered a question packstack - how to reconfigure br-ex ?

Hi,

What OS are you using?

2013-12-18 13:30:39 -0500 received badge  Editor (source)
2013-12-18 13:24:46 -0500 answered a question RDO AllinOne network not working as expected