Ask Your Question

claura's profile - activity

2019-03-22 16:21:48 -0600 received badge  Enthusiast
2019-03-21 16:32:11 -0600 answered a question Stack.sh problem error ./stack.sh:main:1438 err_trap

Hi Bernd, I resolved my issue, was in my network, delays to contacts controller node...thanks a lot for your support.

Cecilia

2019-03-21 12:15:36 -0600 received badge  Famous Question (source)
2019-03-21 12:13:45 -0600 received badge  Notable Question (source)
2019-03-14 16:45:49 -0600 answered a question Stack.sh problem error ./stack.sh:main:1438 err_trap

Hi all,

my local.conf:

HOST_IP=192.168.1.225 SERVICE_HOST=192.168.1.224 DATABASE_HOST=mysql MYSQL_HOST=$SERVICE_HOST RABBIT_HOST=$SERVICE_HOST GLANCE_HOSTPORT=$SERVICE_HOST:9292 Q_USE_SECGROUP=True

FLOATING_RANGE="192.168.1.0/24"

Q_FLOATING_ALLOCATION_POOL=start=192.168.1.226,end=192.168.1.230

PUBLIC_NETWORK_GATEWAY="192.168.1.1"

PUBLIC_INTERFACE=ens3 FLAT_INTERFACE=ens3 ENABLED_SERVICES=n-cpu,q-agt,n-api-meta,c-vol,placement-client NOVA_VNC_ENABLED=True NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html" VNCSERVER_LISTEN=$HOST_IP VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN Q_USE_PROVIDERNET_FOR_PUBLIC=True OVS_PHYSICAL_BRIDGE=br-ex PUBLIC_BRIDGE=br-ex OVS_BRIDGE_MAPPINGS=public:br-ex

But services witch systemctl are running! The dashboard ia active...

root@openstack1:~# systemctl|grep devstack devstack@c-vol.service loaded active running Devstack devstack@c-vol.service devstack@dstat.service loaded active running Devstack devstack@dstat.service devstack@etcd.service loaded active running Devstack devstack@etcd.service devstack@g-api.service loaded active running Devstack devstack@g-api.service devstack@g-reg.service loaded active running Devstack devstack@g-reg.service devstack@keystone.service loaded active running Devstack devstack@keystone.service devstack@n-api.service loaded active running Devstack devstack@n-api.service devstack@n-cauth.service loaded active running Devstack devstack@n-cauth.service devstack@n-cpu.service loaded active running Devstack devstack@n-cpu.service devstack@n-sch.service loaded active running Devstack devstack@n-sch.service devstack@n-super-cond.service loaded active running Devstack devstack@n-super-cond.service devstack@placement-api.service loaded active running Devstack devstack@placement-api.service devstack@q-agt.service loaded active running Devstack devstack@q-agt.service devstack@q-dhcp.service loaded active running Devstack devstack@q-dhcp.service devstack@q-l3.service loaded active running Devstack devstack@q-l3.service devstack@q-meta.service loaded active running Devstack devstack@q-meta.service devstack@q-svc.service loaded active running Devstack devstack@q-svc.service

Thanks a lot

2019-03-14 11:12:05 -0600 received badge  Popular Question (source)
2019-03-12 11:48:38 -0600 received badge  Supporter (source)
2019-03-12 10:29:58 -0600 asked a question Stack.sh problem error ./stack.sh:main:1438 err_trap

Hi all, I try to install devstack on ubuntu 18LTS with two nodes, but I have problems with stack.sh, the main program exit with err_trap 563, I see in log file:

Error on exit
nova-compute: no process found
neutron-dhcp-agent: no process found
neutron-l3-agent: no process found
neutron-metadata-agent: no process found
neutron-openvswitch-agent: no process found

WARN: Device /dev/loop0 (/snap/core/4917) is 100% full, might be an issue
WARN: Device /dev/loop1 (/snap/core/6405) is 100% full, might be an issue
Filesystem                         Size  Used Avail Use% Mounted on
udev                               7.8G     0  7.8G   0% /dev
tmpfs                              1.6G  1.5M  1.6G   1% /run
/dev/mapper/ubuntu--vg-ubuntu--lv   14G  5.8G  7.4G  45% /
tmpfs                              7.9G     0  7.9G   0% /dev/shm
tmpfs                              5.0M     0  5.0M   0% /run/lock
tmpfs                              7.9G     0  7.9G   0% /sys/fs/cgroup
/dev/loop0                          87M   87M     0 100% /snap/core/4917
/dev/loop1                          91M   91M     0 100% /snap/core/6405
/dev/sda2                          976M  142M  767M  16% /boot
tmpfs                              1.6G     0  1.6G   0% /run/user/1000
tmpfs                              512M  123M  390M  24% /opt/stack/data/etcd

*** Failed to run 'killall -e -USR2 nova-compute': Command 'killall -e -USR2 nova-compute' returned non-zero exit status 1
guru meditation report in nova-compute log

*** Failed to run 'killall -e -USR2 neutron-dhcp-agent': Command 'killall -e -USR2 neutron-dhcp-agent' returned non-zero exit status 1
guru meditation report in neutron-dhcp-agent log

*** Failed to run 'killall -e -USR2 neutron-l3-agent': Command 'killall -e -USR2 neutron-l3-agent' returned non-zero exit status 1
guru meditation report in neutron-l3-agent log

*** Failed to run 'killall -e -USR2 neutron-metadata-agent': Command 'killall -e -USR2 neutron-metadata-agent' returned non-zero exit status 1
guru meditation report in neutron-metadata-agent log

*** Failed to run 'killall -e -USR2 neutron-openvswitch-agent': Command 'killall -e -USR2 neutron-openvswitch-agent' returned non-zero exit status 1
guru meditation report in neutron-openvswitch-agent log

local.conf

ADMIN_PASSWORD=openstack
DATABASE_PASSWORD=openstack
RABBIT_PASSWORD=openstack
SERVICE_PASSWORD=$ADMIN_PASSWORD
HOST_IP=192.168.1.226
LOGFILE=$DEST/logs/stack.sh.log
LOGDAYS=2
SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
SWIFT_REPLICAS=1
SWIFT_DATA_DIR=$DEST/data

my local.conf:

HOST_IP=192.168.1.225
SERVICE_HOST=192.168.1.224
DATABASE_HOST=mysql
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
Q_USE_SECGROUP=True
#FLOATING_RANGE="192.168.1.0/24"
Q_FLOATING_ALLOCATION_POOL=start=192.168.1.226,end=192.168.1.230
#PUBLIC_NETWORK_GATEWAY="192.168.1.1"
PUBLIC_INTERFACE=ens3
FLAT_INTERFACE=ens3
ENABLED_SERVICES=n-cpu,q-agt,n-api-meta,c-vol,placement-client
NOVA_VNC_ENABLED=True
NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html"
VNCSERVER_LISTEN=$HOST_IP
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN
Q_USE_PROVIDERNET_FOR_PUBLIC=True
OVS_PHYSICAL_BRIDGE=br-ex
PUBLIC_BRIDGE=br-ex
OVS_BRIDGE_MAPPINGS=public:br-ex

But services witch systemctl are running! The dashboard ia active...

root@openstack1:~# systemctl|grep devstack
devstack@c-vol.service                                                                      loaded active running   Devstack devstack@c-vol.service
devstack@dstat.service                                                                      loaded active running   Devstack devstack@dstat.service
devstack@etcd.service                                                                       loaded active running   Devstack devstack@etcd.service
devstack@g-api.service                                                                      loaded active running   Devstack devstack@g-api.service
devstack@g-reg.service                                                                      loaded active running   Devstack devstack@g-reg.service
devstack@keystone.service                                                                   loaded active running   Devstack devstack@keystone.service
devstack@n-api.service                                                                      loaded active running   Devstack devstack@n-api.service
devstack@n-cauth.service                                                                    loaded active ...
(more)