Ask Your Question

Pepi_par's profile - activity

2019-04-09 04:27:56 -0500 received badge  Famous Question (source)
2019-04-09 04:27:56 -0500 received badge  Notable Question (source)
2019-04-09 04:27:56 -0500 received badge  Popular Question (source)
2019-01-13 13:29:15 -0500 asked a question sahara failure

Tried setting up openstack using queens release in ubuntu 16.04 and getting the below error while trying Create the database schema: $ sahara-venv/bin/sahara-db-manage --config-file sahara-venv/etc/sahara.conf upgrade head

error: Traceback (most recent call last): File "sahara-venv/bin/sahara-db-manage", line 11, in <module> sys.exit(main()) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 109, in main CONF.command.func(config, CONF.command.name) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 49, in do_upgrade_downgrade do_alembic_command(config, cmd, revision, sql=CONF.command.sql) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 30, in do_alembic_command getattr(alembic_cmd, cmd)(config, args, *kwargs) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/command.py", line 254, in upgrade script.run_env() File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/script/base.py", line 427, in run_env util.load_python_file(self.dir, 'env.py') File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/util/pyfiles.py", line 81, in load_python_file module = load_module_py(module_id, path) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/util/compat.py", line 198, in load_module_py mod = imp.load_source(module_id, path, fp) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/alembic_migrations/env.py", line 95, in <module> run_migrations_online() File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/alembic_migrations/env.py", line 79, in run_migrations_online poolclass=pool.NullPool) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/__init__.py", line 386, in create_engine return strategy.create(args, *kwargs) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/strategies.py", line 51, in create entrypoint = u._get_entrypoint() File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/url.py", line 131, in _get_entrypoint cls = registry.load(name) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/util/langhelpers.py", line 212, in load (self.group, name)) sqlalchemy.exc.NoSuchModuleError: Can't load plugin: sqlalchemy.dialects:mysql.pymsql

2019-01-13 06:24:07 -0500 asked a question sahara installation problem

i am trying to install sahara for queens version (only for learning purposes ) and when i am trying to create database schema shows the below error sahara-venv/bin/sahara-db-manage --config-file sahara-venv/etc/sahara.conf upgrade head Traceback (most recent call last): File "sahara-venv/bin/sahara-db-manage", line 11, in <module> sys.exit(main()) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 109, in main CONF.command.func(config, CONF.command.name) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 49, in do_upgrade_downgrade do_alembic_command(config, cmd, revision, sql=CONF.command.sql) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 30, in do_alembic_command getattr(alembic_cmd, cmd)(config, args, *kwargs) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/command.py", line 254, in upgrade script.run_env() File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/script/base.py", line 427, in run_env util.load_python_file(self.dir, 'env.py') File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/util/pyfiles.py", line 81, in load_python_file module = load_module_py(module_id, path) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/alembic/util/compat.py", line 198, in load_module_py mod = imp.load_source(module_id, path, fp) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/alembic_migrations/env.py", line 95, in <module> run_migrations_online() File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sahara/db/migration/alembic_migrations/env.py", line 79, in run_migrations_online poolclass=pool.NullPool) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/__init__.py", line 386, in create_engine return strategy.create(args, *kwargs) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/strategies.py", line 49, in create u = url.make_url(name_or_url) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/url.py", line 186, in make_url return _parse_rfc1738_args(name_or_url) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/url.py", line 232, in _parse_rfc1738_args return URL(name, **components) File "/home/user/sahara-venv/local/lib/python2.7/site-packages/sqlalchemy/engine/url.py", line 60, in __init__ self.port = int(port) ValueError: invalid literal for int() with base 10: 'port' please help!

2018-12-27 09:13:55 -0500 received badge  Notable Question (source)
2018-12-27 04:03:10 -0500 received badge  Notable Question (source)
2018-12-27 03:56:35 -0500 asked a question sahara installation in queens

Hello, Iam done with all my problems installing openstack (minimum deploy for queens version -keystone-glance-nova-neutron-dashboard) and i would like to install sahara package for hadoop cluster, i would like to ask if i need some extra packages in order to install sahara? (except from the above packages)

2018-12-27 03:42:26 -0500 received badge  Notable Question (source)
2018-12-27 00:42:59 -0500 received badge  Popular Question (source)
2018-12-27 00:42:54 -0500 received badge  Popular Question (source)
2018-12-26 23:34:24 -0500 received badge  Popular Question (source)
2018-12-26 18:05:13 -0500 commented question dashboard-openstack

p.s i installed queens version with os 16.04 ubuntu

2018-12-26 17:59:27 -0500 commented question dashboard-openstack

also this is the message from apache2 log AH00526: Syntax error on line 74 of /etc/apache2/apache2.conf: Invalid Mutex directory in argument file:${APACHE_LOCK_DIR}

2018-12-26 17:39:16 -0500 asked a question dashboard-openstack

hi everyone i install all packages for openstack including Horizon (dashboard), now i tried to log in to the dashboard (http://controller/horizon) and it has an error

internal server error, th server encountered an internal error or misconfiguration and was unable to complete your request.

What i have to do ?

2018-12-26 15:25:23 -0500 asked a question neutron network

hello and Merry Christmas,

i am in neutron package and i checked the /etc/sysctl.conf file but i dont have these variables ( net.bridge.bridge-nf-call-iptables net.bridge.bridge-nf-call-ip6tables) can i add them and set them to 1?

(Ensure your Linux operating system kernel supports network bridge filters by verifying all the following sysctl values are set to 1:

net.bridge.bridge-nf-call-iptables net.bridge.bridge-nf-call-ip6tables)

2018-12-25 12:25:36 -0500 received badge  Popular Question (source)
2018-12-25 11:31:13 -0500 asked a question neutron network

I have access in virtual sources of my University, i am trying to install openstack for learning purposes (version Queens) i made 2 virtual machines (one for controller & one for compute) but the university gives only one ipv4 per account so i made the controller as a router and i attached compute to it. Now i am in neutron service and i was wondering which option for network configuration is the best (https://docs.openstack.org/neutron/queens/install/controller-install-ubuntu.html (https://docs.openstack.org/neutron/qu...))

p.s i am using os ubuntu 16.04

Thank you!

2018-12-24 16:06:18 -0500 commented question glance cirros

i am trying to install queens version due to the fact that i have 16.04 ubuntu os

2018-12-24 15:28:33 -0500 commented question glance cirros

could you be more specific? what i have to do?

2018-12-24 15:28:33 -0500 answered a question glance cirros

could you be more specific? is it something with apache server?

2018-12-24 04:41:44 -0500 asked a question glance cirros

I am trying to install glance service and in the command ''openstack image create "cirros" \ --file cirros-0.4.0-x86_64-disk.img \ --disk-format qcow2 --container-format bare \ --public''

says: ''Error finding address for http://controller:9292/v2/schemas/image: HTTPConnectionPool(host='controller', port=9292): Max retries exceeded with url: /v2/schemas/image (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7fb06de05e10="" at="" object="">: Failed to establish a new connection: [Errno 111] Connection refused',))''</urllib3.connection.httpconnection>

What i am doing wrong?

2018-12-23 16:08:32 -0500 asked a question requirements in keystone installation and configuration

I am trying to install keystone identity service, i did all the steps for queens version up to this step (https://docs.openstack.org/keystone/queens/install/keystone-openrc-ubuntu.html (https://docs.openstack.org/keystone/q...)) i was wondering if i need to move on to the next section (https://docs.openstack.org/keystone/queens/getting-started/index.html (https://docs.openstack.org/keystone/q...)) or move on to the next package for queens which is installation of glance. Please help me!

2018-12-20 05:04:20 -0500 asked a question queens vs rocky

Which is the difference between version rocky and queens Iam going to install openstack for learning purposes and i was wondering if i have problem to install queens version of openstack

Thank you