Ask Your Question

os_user's profile - activity

2018-11-26 11:28:33 -0600 asked a question Packstack Create a new VM using a newly created port

I have currently created one nic port using Packstack and Ansible and now I am trying to create a new VM using the newly created port.

- os_port:
       state: present
       fixed_ips:
        - ip_address: 10.10.157.138
       allowed_address_pairs:
        - ip_address: 10.10.157.128/27
       name: port-3
       security_groups: sg_default
      network: nw1
    register: port3
    tags: neutron_ports 
  - name: Create the VM
    os_server:
      state: present
      flavor: m1.small
      name: vm1
      image: cirros 
      nics:
      - port-id: "{{port3.id}}"
      tags: vm

I am getting an error after creating it: Error in creating the server. If I am looking into the dashboard, I am seeing the instance, but its state is "Error". Inside the VM, I have the following message: "No valid host was found" with the 500 code. When I am looking at the hosts, all of them are running and available:

[dante@localhost roles(keystone_admin)]$ nova service-list +--------------------------------------+------------------+-----------------------+----------+---------+-------+----------------------------+-----------------+-------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | Forced 
down |
+--------------------------------------+------------------+-----------------------+----------+---------+-------+----------------------------+-----------------+-------------+
    | 21ac1600-fc5a-481e-a725-3e12265bdb66 | nova-conductor   | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:38.000000 | -               | False       |
    | 6d9393da-42ea-4290-83f6-af4af2c377e3 | nova-scheduler   | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:40.000000 | -               | False       |
    | 6eb82482-d6df-4fb7-ad77-46bdacf442de | nova-consoleauth | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:38.000000 | -               | False       |
    | 46b5e512-da96-4066-b45e-57336da6cfec | nova-compute     | localhost.localdomain | nova     | enabled | up    | 2018-08-07T17:08:40.000000 | -               | False       |

Any idea what can be?

Best regards, Dan

2018-11-26 11:28:32 -0600 asked a question Packstack Create a new VM using a newly created port

I have currently created one nic port using Packstack and Ansible and now I am trying to create a new VM using the newly created port.

  - os_port:
       state: present
       fixed_ips:
        - ip_address: 10.10.157.138
       allowed_address_pairs:
        - ip_address: 10.10.157.128/27
       name: port-3
       security_groups: sg_default
       network: nw1
    register: port3
    tags: neutron_ports

  - name: Create the VM
    os_server:
      state: present
      flavor: m1.small
      name: vm1
      image: cirros 
      nics:
      - port-id: "{{port3.id}}"
    tags: vm

I am getting an error after creating it: Error in creating the server. If I am looking into the dashboard, I am seeing the instance, but its state is "Error". Inside the VM, I have the following message: "No valid host was found" with the 500 code. When I am looking at the hosts, all of them are running and available:

[dante@localhost roles(keystone_admin)]$ nova service-list +--------------------------------------+------------------+-----------------------+----------+---------+-------+----------------------------+-----------------+-------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | Forced down |

+--------------------------------------+------------------+-----------------------+----------+---------+-------+----------------------------+-----------------+-------------+
| 21ac1600-fc5a-481e-a725-3e12265bdb66 | nova-conductor   | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:38.000000 | -               | False       |
| 6d9393da-42ea-4290-83f6-af4af2c377e3 | nova-scheduler   | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:40.000000 | -               | False       |
| 6eb82482-d6df-4fb7-ad77-46bdacf442de | nova-consoleauth | localhost.localdomain | internal | enabled | up    | 2018-08-07T17:08:38.000000 | -               | False       |
| 46b5e512-da96-4066-b45e-57336da6cfec | nova-compute     | localhost.localdomain | nova     | enabled | up    | 2018-08-07T17:08:40.000000 | -               | False       |

Any idea what can be?

Best regards, Dan

2018-10-29 18:16:37 -0600 asked a question Cloud-init not working when using Packstack

Hi guys,

I was deploying a Cirros VM using Packstack with cloud-init config included. According to this https://ask.openstack.org/en/question/58749/cirros-image-have-cloud-init-in-it/ (question), Cirros have also cloud-init installed. I am running Packstack on top of Centos 7 in VMWare player. On my environment I have cloud-init installed as well. However, when I have deployed one VM using the Cirros image in Packstack, cloud-init config introduced was not working. I was looking into the /var/log, but I couldn't find any cloud-init log.

I have tried to insert the cloud config part as follows inside the Dashboard when launching the VM:

#cloud-config
runcmd:
   - echo "This is a test" > /home/cirros/test.txt

Any idea what I can try more? The target is to push some configuration when launching the VM.

Many thanks

2018-10-23 02:00:25 -0600 received badge  Enthusiast