Ask Your Question

Joe89's profile - activity

2018-10-15 05:22:01 -0500 received badge  Famous Question (source)
2018-10-15 05:22:01 -0500 received badge  Notable Question (source)
2018-10-15 05:22:01 -0500 received badge  Popular Question (source)
2018-06-24 19:23:09 -0500 commented answer Nova VNC works, but not in Dashboard

I am using OpenStack Queens.

Thanks Joe

2018-06-24 19:23:08 -0500 answered a question Nova VNC works, but not in Dashboard

Hi everyone,

I have also problem with VNC setup (I guess). My setup has one controller node and two compute nodes.

enter code here` nova.conf of the controller node

[vnc] enabled = True

novncproxy_host = 0.0.0.0

novncproxy_port = 6080

server_proxyclient_address = 172.16.16.100

server_listen = 0.0.0.0

novncproxy_base_url = http://172.16.16.100:6080/vnc_auto.html

nova.conf of the compute nodes

[vnc] enabled = True

server_listen = 0.0.0.0

server_proxyclient_address = 172.16.16.10

novncproxy_base_url = http://172.16.16.100:6080/vnc_auto.html

I don't know why I still can't access to the instance via vnc console. Error code is "Failed to connect to server (code: 1006)".

Log from /var/log/nova/nova-novncproxy.log:

[15/May/2018 17:57:42] 172.16.16.1: Path: '/websockify' 2018-05-15 17:57:42.914 4582 INFO nova.console.websocketproxy [req-40a6c465-32a9-4ec0-a539-314c485b8839 - - - - -] handler exception: The token '84b0f7fc-eacb-4468-8f85-7696c52b32bc' is invalid or has expired

Have anyone seen and solve this?

Many thanks

Joe

2018-06-24 19:23:08 -0500 asked a question vnc console failed "Failed to connect to server (code: 1006)"

Hi all,

I am currently facing a problem with vnc console through dashboard. The most weird thing is that it works without any problem for some instances but not for all and I don't know what is the reason behind it. The logs that I got from /var/log/nova/nova-novncproxy.log are as follows:

2018-05-25 15:21:17.117 17305 INFO nova.console.websocketproxy [req-7f589f70-f433-4646-9ea5-ed25cc18e8f3 - - - - -] 67: connect info: {u'instance_uuid': u'552a6cb9-0813-40c7-9e8e-8ca43b0aefbb', u'internal_access_path': None, u'last_activity_at': 1527254476.756034, u'console_type': u'novnc', u'host': u'172.16.16.20', u'token': u'2b5aa6a4-b403-47b6-9344-22d0189720b8', u'access_url': u'http://172.16.16.100:6080/vnc_auto.html?token=2b5aa6a4-b403-47b6-9344-22d0189720b8', u'port': u'5900'} 2018-05-25 15:21:17.118 17305 INFO nova.console.websocketproxy [req-7f589f70-f433-4646-9ea5-ed25cc18e8f3 - - - - -] 67: connecting to: 172.16.16.20:5900 2018-05-25 15:21:17.131 17305 INFO nova.console.websocketproxy [req-7f589f70-f433-4646-9ea5-ed25cc18e8f3 - - - - -] handler exception: Failed to complete auth handshake: Incorrect read from socket, wanted 12 bytes but got 0. Socket returned ''

According to the logs from /var/log/nova/nova-consoleauth.log, it seems there is no problem with authentication. 2018-05-25 15:21:17.083 2697 INFO nova.consoleauth.manager [req-7f589f70-f433-4646-9ea5-ed25cc18e8f3 - - - - -] Checking Token: 2b5aa6a4-b403-47b6-9344-22d0189720b8, True

The logs for instance launched from the same compute node (Compute Node 2) which is successfully consoled:

2018-05-25 14:16:13.981 16442 INFO nova.console.websocketproxy [req-61a172ce-2388-419d-bb27-b45f266553ca - - - - -] 62: connect info: {u'instance_uuid': u'a46480d3-9c82-4990-add5-06898fafcf61', u'internal_access_path': None, u'last_activity_at': 1527250570.092128, u'console_type': u'novnc', u'host': u'172.16.16.20', u'token': u'fdabf4b4-ace3-4a25-a1ab-d6529c78bccb', u'access_url': u'http://172.16.16.100:6080/vnc_auto.html?token=fdabf4b4-ace3-4a25-a1ab-d6529c78bccb', u'port': u'5901'}

2018-05-25 14:16:13.981 16442 INFO nova.console.websocketproxy [req-61a172ce-2388-419d-bb27-b45f266553ca - - - - -] 62: connecting to: 172.16.16.20:5901

2018-05-25 14:16:14.036 16442 INFO nova.console.securityproxy.rfb [req-61a172ce-2388-419d-bb27-b45f266553ca - - - - -] Finished security handshake, resuming normal proxy mode using secured socket

I am using OpenStack Queens with the following settings:

  • Controller Node: 172.16.16.100
  • Compute Node 1: 172.16.16.10
  • Compute Node 2: 172.16.16.20

The following are the nova.conf configuration files of these nodes:

  • Controller Node: [vnc] enabled = True novncproxy_host = 172.16.16.100 novncproxy_port = 6080 server_proxyclient_address = 172.16.16.100 novncproxy_base_url = http://172.16.16.100:6080/vnc_auto.html server_listen = 0.0.0.0 keymap = en-us
  • Compute Node 1: [vnc] enabled = True novncproxy_host = 172.16.16.10 novncproxy_port = 6080 server_proxyclient_address = 172.16.16.10 novncproxy_base_url = http://172.16.16.100:6080/vnc_auto.html server_listen = 172.16.16.10 keymap = en-us
  • Compute Node 2: [vnc] enabled = True novncproxy_host = 172.16.16.20 novncproxy_port = 6080 server_proxyclient_address = 172.16.16.20 novncproxy_base_url = http://172.16.16.100:6080/vnc_auto.html server_listen = 172.16.16.20 keymap = en-us

Can anyone tell me what's wrong with my configuration and setup?

Many Thanks, Joe

2018-05-22 01:59:45 -0500 received badge  Enthusiast