Ask Your Question

vamsee_007's profile - activity

2018-07-27 02:42:58 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Thanks alot @eblock and @BerndBaush for the help. Now its working. After giving the privileges to Keystone@localhost and @controllernode1, I've rebooted the Keystone and exported the env variables again. Now i'm able to create a domain, project, user, role etc.,

2018-07-27 00:23:51 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Error in Keystone.log: 2018-07-27 10:14:44.978 31282 WARNING keystone.common.wsgi [req-f0b657f5-6824-4dca-bc94-44799e79b7b3 - - - - -] Authorization failed. The request you have made requires authentication. from 172.19.251.126: Unauthorized: The request you have made requires authentication.

2018-07-27 00:22:31 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

I tried to resolve this issue by granting all privileges to Keystone@localhost and Keystone@controllernode1 but still facing the same issue.

2018-07-26 09:20:49 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Guys, I'm getting a new error: An unexpected error prevented the server from fulfilling your request. (HTTP 500) (Request-ID: req-d488ac49-3690-4a29-9eb5-984441567c81) Now evrything is fine, I masked the firewalld service and tried to stop the iptables but its showing Active: deactivating.

2018-07-26 08:15:13 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@eblock I've added the memcache grepped data from keystone.conf in the question. I'm using Fernet here.

2018-07-26 06:43:35 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@Bernd Bausch I've changed to driver = sql in [token] section and restarted the keystone, but still facing the same issue. Is there any other way?

2018-07-26 05:34:13 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@BerndBaush Everything is fine except firewalld. When i try to stop the firewalld service its failing. Is there any way to sort out this issue?

2018-07-26 05:34:13 -0600 received badge  Commentator
2018-07-26 05:20:26 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@eblock Yes I've followed the steps you suggested.

2018-07-26 04:58:10 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@eblock The apache service is running. I've update the question with the errors in Keystone-Error.log. Please check

2018-07-26 01:51:46 -0600 received badge  Famous Question (source)
2018-07-26 01:10:35 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@eblock I've edited the question, Please check once and can you lemme know what the mistake is. Thanks in advance

2018-07-25 05:20:26 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

@Bernd Baush this time i've followed the doc in the link but when i try to create a domain its throwing the following error: Failed to discover available identity versions when contacting http://controllernode1:5000/v3. Attempting to parse version from URL. Internal Server Error (HTTP 500)

2018-07-25 01:23:38 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Thanks Guys!

2018-07-24 17:11:35 -0600 received badge  Notable Question (source)
2018-07-24 08:49:18 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Thanks! Can't see any progress. I'm following a video in youtube. After the bootstrap command, how to create the keystone service? Please just guide me through any doc.

2018-07-24 06:48:38 -0600 received badge  Popular Question (source)
2018-07-24 02:28:42 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Hi @eblock , I've tried with the keystone bootstrap command. can you please guide me the next step?

2018-07-24 01:18:23 -0600 commented question openstack service create command throwing "Internal Server Error (HTTP 500)"

Thanks for the prompt reply. I've updated the question with the log data, can you please help?

2018-07-24 01:14:30 -0600 received badge  Editor (source)
2018-07-24 01:03:02 -0600 asked a question openstack service create command throwing "Internal Server Error (HTTP 500)"

I'm trying setup Openstack multi node environment in my CentOS VM. I've successfully installed the openstack Queens v. in both controllernode and compute node. When i try to create a service in controllernode, its throwing the following error: Internal Server Error (HTTP 500)

The command is: openstack service create --name keystone --description "OpenStack Identity" identity

The keystone.log file is as follows:

2018-07-24 11:10:19.210 5770 WARNING oslo_log.versionutils [-] Deprecated: UUID Token Provider "[token] provider=uuid" is deprecated as of Pike in favor of Fernet token Provider "[token] provider=fernet" and may be removed in R. 
2018-07-24 11:10:19.212 5770 WARNING oslo_config.cfg [-] Option "driver" from group "token" is deprecated for removal.  Its value may be silently ignored in the future. 
2018-07-24 11:10:19.213 5770 WARNING stevedore.named [-] Could not load memcache

The Keystone Bootstrap command is as follows:

keystone-manage bootstrap --bootstrap-password openstack --bootstrap-admin-url http://controllernode1:5000/v3/ --bootstrap-internal-url http://controllernode1:5000/v3/ --bootstrap-public-url http://controllernode1:5000/v3/ --bootstrap-region-id RegionOne

The environment variables are as follows:

OS_USER_DOMAIN_NAME=Default
OS_PROJECT_NAME=admin
OS_IDENTITY_API_VERSION=3
OS_PASSWORD=openstack
OS_AUTH_URL=http://controllernode1:5000/v3
OS_USERNAME=admin
OS_PROJECT_DOMAIN_NAME=Default

Error in the Keystone-error.log:

2018-07-26 14:42:21.279222 ImportError: (u'Unable to find %(name)r driver in %(namespace)r.', {'namespace': 'keystone.token.persistence', 'name': 'memcache'})
2018-07-26 14:42:25.097350 mod_wsgi (pid=7468): Target WSGI script '/usr/bin/keystone-wsgi-public' cannot be loaded as Python module.
2018-07-26 14:42:25.097435 mod_wsgi (pid=7468): Exception occurred processing WSGI script '/usr/bin/keystone-wsgi-public'.
2018-07-26 14:42:25.097503 Traceback (most recent call last):
2018-07-26 14:42:25.097549   File "/usr/bin/keystone-wsgi-public", line 54, in <module>
2018-07-26 14:42:25.097773     application = initialize_public_application()
2018-07-26 14:42:25.097812   File "/usr/lib/python2.7/site-packages/keystone/server/wsgi.py", line 134, in initialize_public_application
2018-07-26 14:42:25.098076     config_files=_get_config_files())
2018-07-26 14:42:25.098123   File "/usr/lib/python2.7/site-packages/keystone/server/wsgi.py", line 66, in initialize_application
2018-07-26 14:42:25.098185     startup_application_fn=loadapp)
2018-07-26 14:42:25.098216   File "/usr/lib/python2.7/site-packages/keystone/server/common.py", line 46, in setup_backends
2018-07-26 14:42:25.098381     drivers = backends.load_backends()
2018-07-26 14:42:25.098418   File "/usr/lib/python2.7/site-packages/keystone/server/backends.py", line 55, in load_backends
2018-07-26 14:42:25.098589     drivers = {d._provides_api: d() for d in managers}
2018-07-26 14:42:25.098653   File "/usr/lib/python2.7/site-packages/keystone/server/backends.py", line 55, in <dictcomp>
2018-07-26 14:42:25.098713     drivers = {d._provides_api: d() for d in managers}
2018-07-26 14:42:25.098743   File "/usr/lib/python2.7/site-packages/keystone/token/persistence/core.py", line 48, in __init__
2018-07-26 14:42:25.099084     super(PersistenceManager, self).__init__(CONF.token.driver)
2018-07-26 14:42:25.099129   File "/usr/lib/python2.7/site-packages/keystone/common/manager.py", line 181, in __init__
2018-07-26 14:42:25.099357     self.driver = load_driver(self.driver_namespace, driver_name)
2018-07-26 14:42:25.099392   File "/usr/lib/python2.7/site-packages ...
(more)
2018-07-02 02:06:11 -0600 received badge  Notable Question (source)
2018-07-02 02:06:11 -0600 received badge  Popular Question (source)
2018-06-29 03:02:35 -0600 commented question How to restrict the communication between two hosts in the same network?

Thanks for the quick response, can i know what to do exactly with Security groups?

2018-06-28 08:55:35 -0600 asked a question How to restrict the communication between two hosts in the same network?

I've installed Openstack in my CentOS VM using packstack installer. Have created a network, and also instances. Now I want to restrict the communication between those instances created in the same network. How can i do it.

2018-05-24 13:52:37 -0600 received badge  Notable Question (source)
2018-05-21 02:32:08 -0600 received badge  Supporter (source)
2018-05-20 07:38:08 -0600 received badge  Popular Question (source)
2018-05-08 02:32:59 -0600 received badge  Enthusiast
2018-04-29 11:39:42 -0600 asked a question ValueError while installing devstack in RHEL 7?

I'm installing devstack on my RHEL 7 VM. While installing the nova, its throwing the following error. How can i resolve this. Should i need to change the code in all the trace back files or any package is available which can resolve this issue? (The python version is 2.7)

 Traceback (most recent call last):
 File "/usr/bin/nova-manage", line 10, in <module>
 sys.exit(main())
 File "/opt/stack/nova/nova/cmd/manage.py", line 1725, in main
 config.parse_args(sys.argv)
File "/opt/stack/nova/nova/config.py", line 55, in parse_args
rpc.init(CONF)
File "/opt/stack/nova/nova/rpc.py", line 63, in init
TRANSPORT = create_transport(get_transport_url())
File "/opt/stack/nova/nova/rpc.py", line 172, in get_transport_url
return messaging.TransportURL.parse(CONF, url_str)
File "/usr/lib/python2.7/site-packages/debtcollector/removals.py", line 261, in wrapper
return f(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/oslo_messaging/transport.py", line 558, in parse
port = int(port)
ValueError: invalid literal for int() with base 10: 'abc'