Ask Your Question

baldo's profile - activity

2015-01-13 05:02:05 -0600 received badge  Nice Question (source)
2014-11-27 01:35:53 -0600 commented answer Unable to configure Neutron DB in Juno

It seems to work, but the last line of the command output states:

INFO [alembic.migration] Running upgrade 5ac1c354a051-> icehouse, icehouse

So it does not seem to be Juno version of Neutron, does it?

2014-11-27 01:30:23 -0600 commented question Unable to configure Neutron DB in Juno

Hi, it is MariaDB 5.5.40.

2014-11-24 05:18:30 -0600 received badge  Student (source)
2014-11-11 03:18:46 -0600 received badge  Popular Question (source)
2014-11-11 03:18:46 -0600 received badge  Notable Question (source)
2014-11-11 03:18:46 -0600 received badge  Famous Question (source)
2014-11-03 14:32:57 -0600 asked a question Unable to configure Neutron DB in Juno


I'm carefully following the OpenStack Juno installation manual, and I'm stuck in this step: (

First, and I guess this is a bug, when I execute the neutron-db-manage command, I'm getting the next error:

> Class router cannot be found

I can easily fix that, by writing the class name rather than the entry point name, i.e.: instead of router.

Fine, this is solved. But when executing the command again I get the next output:

> No handlers could be found for logger "neutron.common.legacy" INFO 
> [alembic.migration] Context impl MySQLImpl. INFO  [alembic.migration]
> Will assume non-transactional DDL.  
> No such revision 'juno'

And I'm stuck here, I don't know how to proceed. I've been looking for people with similar problems but I cannot find anything similar.


2014-06-06 04:20:24 -0600 received badge  Enthusiast
2014-06-05 04:31:00 -0600 commented answer Neutron: cannot connect to instance in Icehouse

I'm not sure, by default our enterprise always assign public IPs to all computers. Still, even if I could, I'd like to have a public IP so I can connect from outside the enterprise. How would I configure it without the public interface anyway? Could you show me a interfaces file example? Thanks.

2014-06-04 14:53:37 -0600 received badge  Famous Question (source)
2014-06-04 07:36:37 -0600 commented answer Neutron: cannot connect to instance in Icehouse

Hi Antonio, with that configuration I'm unable to connect to the Internet from the machine itself. This is my interfaces file:

2014-06-03 09:43:15 -0600 commented answer Neutron: cannot connect to instance in Icehouse

Hi Antonio, thanks for your answer. I am creating the subnet correctly, so the problem doesn't seem to be there. Still, I have a couple questions: 1. I should emulate 3 interfaces, but in your example I only see two, right? 2. If I remove the static public IP, how will I connect from the outside?

2014-06-03 07:57:59 -0600 received badge  Notable Question (source)
2014-06-03 05:10:42 -0600 commented question Neutron: cannot connect to instance in Icehouse

I could see that from Horizon. Sure, I can provide you with the output of that commands:

ovs-vsctl show

ip route

2014-06-03 03:48:03 -0600 received badge  Popular Question (source)
2014-06-03 03:36:57 -0600 commented question Neutron: cannot connect to instance in Icehouse

Hi, thanks for your response. When following the documentation, I have one router with two interfaces, i.e.: ACTIVE Internal interface UP
X.Y.174.142 DOWN External gateway UP

I can't ping VM even when assigning a floating IP. What do you mean by "don't give phys. int. an IP?

2014-06-02 14:20:04 -0600 asked a question Neutron: cannot connect to instance in Icehouse

Hello. I'm trying to configure OpenStack Icehouse on Ubuntu 14.04 following the official documentation and everything looks perfect until I have to configure networking. Let me advance that I'm far from being an expert in network configuration.

First, let me describe my scenario:

I want to deploy OpenStack in one node, which will act as controller, network and compute node. In the future I'd like to add further compute nodes, but I'm not into that so far.

In my enterprise, I have both public IP addresses and private IP addresses. Let's say they are as follows:

  • Public segment: XXX.YYY.174.128/27
  • Private segment:

So I would like to configure networking such that:

  1. All instances will have at the very least one private IP. This would enable communication between different machines and between instances and the host.
  2. Instances could be assigned a public IP, maybe through floating IPs. This way, only instances that required to be accessed from outside are assigned public IPs, which are more limited.

To be completely sincere, I'm not 100% sure about how to configure /etc/network/interfaces. In a first attempt, I configured it so that interface em1 had a public IP for the host (XXX.YYY.174.138) and interface em2 had a private IP ( The problem with this approach is that, later, if I add a port to br-ex using the command ovs-vsctl add-port br-ex em1 the host ends up loosing connectivity (so I cannot connect using SSH to the server). So finally, I ended up by setting up both em1 and em2 with public IPs (to say, XXX.YYY.174.138 and XXX.YYY.174.139). That way, I don't loose connectivity.

So as a result, I can create instances and actually, if I set them to have the first virtual NIC with the private network (what the documentation calls "tenant network"), then they can successfully connect to the Internet (for instance, ping will success). However, I have no means to connect to the instance, neither from the host nor from any other machine, and neither by pinging the private nor the public IP.

These are the steps I have followed: (

I'd be grateful if you could help me to understand what's going on, as I'm not really familiar to concepts such as GRE tunneling and not figuring out how all this is working actually.

Thanks a lot.

2013-11-29 12:09:20 -0600 commented answer 'no route to host' trying to ssh to new instance.

Hi! I'm following step-by-step the Chapter 1 of the 1st edition and I'm having the exact same problem. Although everything seems to be Ok, I cannot ping the new instance nor ssh it. Also, the machine also goes to "shutoff" status, yet I can handle that by running euca-start-instances command.