Ask Your Question

stacksam's profile - activity

2017-04-05 00:51:19 -0500 received badge  Notable Question (source)
2017-02-20 12:50:19 -0500 received badge  Famous Question (source)
2017-02-20 12:50:19 -0500 received badge  Notable Question (source)
2017-02-20 12:50:19 -0500 received badge  Popular Question (source)
2016-08-10 12:51:23 -0500 received badge  Famous Question (source)
2016-06-21 14:15:44 -0500 received badge  Popular Question (source)
2016-06-21 14:15:18 -0500 received badge  Famous Question (source)
2016-06-21 14:15:18 -0500 received badge  Notable Question (source)
2016-01-10 08:18:24 -0500 received badge  Famous Question (source)
2016-01-05 12:44:05 -0500 received badge  Notable Question (source)
2016-01-04 11:31:32 -0500 received badge  Popular Question (source)
2016-01-03 12:14:16 -0500 asked a question OVS add/delete Ports

Hello,

I've Havana setup of OpenStack with Neutron/Nicira/OVS plug-in. It seems when a compute node is shutdown/rebooted, OVS does delete and add tap ports. Does anyone know why it does that?

Sometimes OVS just won't add the in-use tap ports back in. Is this some sort of bug or something else?

Thanks

2015-08-23 23:59:10 -0500 commented question Instance Interface down

Still looking for a resolution.Anyone?

I don't know what the "tap" device name was but I do see the interface entry in the nova/network

2015-08-12 01:07:37 -0500 received badge  Notable Question (source)
2015-08-09 12:08:27 -0500 commented question Openstack on HP Integrity Machine

I guess not supported?

2015-08-03 14:10:49 -0500 received badge  Popular Question (source)
2015-08-02 13:48:35 -0500 asked a question Openstack on HP Integrity Machine

Hi,

Is it possible to install Openstack Helium or other distribution on HP integrity Machine?

Has anyone out there deployed it and know it works?

Thanks

2015-08-02 13:40:00 -0500 asked a question Can't ping or ssh a VM

I've this weird problem. A VM running RHEL 5 on a KVM hypervisor is not pingable from the hypersivor itself and can't ssh in to. It boots up fine and the network config are alright. I can ping out and ssh to another host from the VM though. There is no "iptables" running so that's out of question. All other VMs on the same hypervisor are accessible.

The "tap" interfaces are up and I restarted the OVS but no avail.

Any idea what could be wrong here?

Thanks

2015-07-26 00:41:09 -0500 commented question Instance Interface down

Yes the port state is DOWN in port-show. I tried the "port-update" but it gave this error - Cannot update read-only attribute status

I restarted the OVS agent but no avail.

All other VMs on the same HV don't have this problem.

2015-07-24 13:49:11 -0500 received badge  Nice Question (source)
2015-07-21 16:56:01 -0500 commented question Instance Interface down

I did reboot the instance but it won't see the interface eth1 and the cloud-init fails to setup the interface. I think there is something wrong at the Openvswitch/Neutron level. I can't seem to find what that is and how to enable the port.

2015-07-21 12:11:52 -0500 commented question Hypervisor - footprint

Anyone? Still looking for a way to find it.

2015-07-21 12:11:52 -0500 received badge  Commentator
2015-07-21 12:10:06 -0500 received badge  Popular Question (source)
2015-07-19 22:46:43 -0500 received badge  Notable Question (source)
2015-07-19 22:46:43 -0500 received badge  Famous Question (source)
2015-07-19 09:50:18 -0500 received badge  Popular Question (source)
2015-07-18 23:46:31 -0500 asked a question Instance Interface down

Hello,

One of the VMs on an hypervisor ( qemu-kvm ) lost one of its interfaces. The "nova interface-list" command show the port state as "Down" .

Looking for some help in troubleshooting and get the port "ACTIVE"

Thanks

2015-05-15 07:49:24 -0500 received badge  Famous Question (source)
2015-04-29 17:29:28 -0500 commented question Instance - fsck

Am not clear in my question or no one out there went through this problem?

2015-04-29 10:33:20 -0500 received badge  Notable Question (source)
2015-04-29 01:08:42 -0500 received badge  Popular Question (source)
2015-04-28 15:16:24 -0500 asked a question Hypervisor - footprint

Hello,

I've openstack havana setup with KVM/libvirt hypervisor running RHEL instances. I wonder if there is any footprint available on an instance to know on what hypervisor the instance is running?

Thanks

2015-04-28 15:07:33 -0500 asked a question Instance - fsck

Hi,

I've Havana Openstack setup using KVM/libvirt based instances. I've observed that when an hypervisor goes down abruptly for an hardware issue. After bringing up instances running RHEL 5, they end up read-only filesystem after boot up ( with clean filesystem check during boot up. The instances use the storage on the hypervisor ( raid controller and sata drives ). Sometimes during boot up the fsck is enforced to run manually.

I understand why the fsck is required but the when the fsck was clean on the hypervisor, shouldn't the instances devices get the clean view of the filesystem?

If the clean view is not there, why wouldn't instances enforced fsck during bootup instead of saying it's clean and reports that a filesystem is read only after boot up?

To me it seems the proper view of the hypervisor filesystem view doesn't get propagated to instances.

Any idea and comments?

2014-12-22 01:40:07 -0500 received badge  Famous Question (source)
2014-12-21 13:14:42 -0500 received badge  Notable Question (source)
2014-12-21 07:34:59 -0500 received badge  Popular Question (source)
2014-12-20 20:39:17 -0500 commented question Interactive console for an Instance

If I do virsh edit, the changes gets reverted back when I start the instance from nova. Is there any way to avoid the revert?

2014-12-20 20:38:01 -0500 commented question Interactive console for an Instance

So there is no "pty" serial 0 entry for console in the libvirt.xml. I've tty0 and ttyS0 set up in Grub. I think when the instance boots and reach the "INIT" stage, it use ttyS0 only if you want to get into single user mode and run fsck or other maintenance work.

2014-12-20 20:24:27 -0500 asked a question Libvirt/KVM VM Management

Hello,

I'm wondering what centralized management tool/application people use for managing VM based on Libvirt/KVM spread across many HVs.

Thanks

2014-12-15 13:55:31 -0500 asked a question Interactive console for an Instance

Hello,

I've Havana Openstack implementation and got KVM-Qemu instances running RHEL on Hypervisor running Ubuntu Precise. I'm looking for an option to have an interactive console for an instance. I know a way to get the console using "virsh vncdisplay" but I don't get interactive console ability when an instance need to provide root password to run fsck.

Thanks

2014-11-15 02:50:35 -0500 asked a question Instances with /var read only

Hi,

OpenStack Folsom setup with RHEL KVM Instances. This is a problem I saw recently - One of the hypervisors abruptly rebooted and all instances boot up but errors out with an Inode error and remounting /var read only. Runnine "fsck" didn't help.

Has anyone seen this before and know how to fix the problem without recreating the VMs?

Thanks

2014-10-04 23:20:37 -0500 received badge  Notable Question (source)
2014-09-15 00:51:30 -0500 received badge  Popular Question (source)
2014-08-17 01:19:20 -0500 received badge  Famous Question (source)
2014-08-01 21:47:03 -0500 received badge  Popular Question (source)
2014-05-29 11:24:27 -0500 received badge  Notable Question (source)
2014-05-25 18:17:00 -0500 asked a question Console access and log

Hello,

I've this Folsom/libvirt multi-host setup. On the compute node, the VMs have libvirt configuration which writes the console log of an instance to "console.log". However doesn't let "virsh conole <instance>" to work. In order to make it work, I modify the instance and setup pty device. But it won't write to "console.log" .

Is there a way to have both "virsh console" and console.log work together?

Thanks