donmasters755's profile - activity

2019-07-09 04:09:47 -0600 received badge  Student (source)
2018-03-24 13:54:56 -0600 received badge  Famous Question (source)
2018-03-24 13:54:56 -0600 received badge  Notable Question (source)
2018-03-24 13:54:56 -0600 received badge  Popular Question (source)
2018-01-14 04:09:38 -0600 received badge  Notable Question (source)
2017-11-07 23:56:10 -0600 received badge  Teacher (source)
2017-11-07 23:56:10 -0600 received badge  Self-Learner (source)
2017-11-06 22:02:35 -0600 received badge  Enthusiast
2017-11-06 00:12:51 -0600 received badge  Popular Question (source)
2017-11-04 19:09:25 -0600 answered a question Why is there no Projects -> Compute -> Access and Security in Dashboard?

Nevermind...I found that is not apart of Pike.

2017-11-04 15:40:50 -0600 asked a question Why is there no Projects -> Compute -> Access and Security in Dashboard?

I am new to Openstack and have a very basic question. I am running Openstack Pike under Ubuntu 16.04

I would like to know why there is no "Access and Security" section under Projects -> Compute?

Procedures to create my first Instance is pointing me to this section of the Dashboard.

2017-10-18 16:10:25 -0600 received badge  Famous Question (source)
2017-10-03 12:20:57 -0600 answered a question 403 Forbidden using glance image-create

@jafar,

May I ask what "unstacking and restacking" means?

Regards, Don

2017-09-05 12:46:07 -0600 received badge  Famous Question (source)
2017-09-04 04:37:17 -0600 received badge  Notable Question (source)
2017-09-03 09:32:36 -0600 received badge  Popular Question (source)
2017-09-02 19:12:32 -0600 asked a question Installation of Openstack using devstack, stable/pike fails

I have installed devstack using stack.sh before but now seems to fail. I have a feeling it has something to do with the latest upgrades to Ubuntu 16.04. Does someone see anything obvious?

I have installed on a fresh Ubuntu 16.04 installation with all updates and upgrades run. Also installed unsuccessfully using a VirtualBox VM with same results. Below is the last lines of stack.sh run at the failure.

2017-09-03 00:00:26.262 | ~/tempest /devstack 2017-09-03 00:00:26.268 | ++lib/tempest:install_tempest:636 tox -r --notest -efull 2017-09-03 00:00:27.619 | Traceback (most recent call last): 2017-09-03 00:00:27.619 | File "/usr/local/bin/tox", line 11, in <module> 2017-09-03 00:00:27.619 | sys.exit(cmdline()) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 38, in main 2017-09-03 00:00:27.619 | config = prepare(args) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 26, in prepare 2017-09-03 00:00:27.619 | config = parseconfig(args) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 242, in parseconfig 2017-09-03 00:00:27.619 | parseini(config, inipath) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 796, in __init__ 2017-09-03 00:00:27.619 | replace=name in config.envlist) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 827, in make_envconfig 2017-09-03 00:00:27.619 | res = meth(env_attr.name, env_attr.default, replace=replace) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 964, in getdict_setenv 2017-09-03 00:00:27.619 | definitions = self._getdict(value, default=default, sep=sep) 2017-09-03 00:00:27.619 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 975, in _getdict 2017-09-03 00:00:27.619 | name, rest = line.split('=', 1) 2017-09-03 00:00:27.619 | ValueError: need more than 1 value to unpack 2017-09-03 00:00:27.635 | +lib/tempest:install_tempest:1 exit_trap 2017-09-03 00:00:27.640 | +stack.sh:exit_trap:521 local r=1 2017-09-03 00:00:27.649 | ++stack.sh:exit_trap:522 jobs -p 2017-09-03 00:00:27.656 | +stack.sh:exit_trap:522 jobs= 2017-09-03 00:00:27.662 | +stack.sh:exit_trap:525 [[ -n '' ]] 2017-09-03 00:00:27.669 | +stack.sh:exit_trap:531 '[' -f '' ']' 2017-09-03 00:00:27.676 | +stack.sh:exit_trap:536 kill_spinner 2017-09-03 00:00:27.682 | +stack.sh:kill_spinner:417 '[' '!' -z '' ']' 2017-09-03 00:00:27.688 | +stack.sh:exit_trap:538 [[ 1 -ne 0 ]] 2017-09-03 00:00:27.694 | +stack.sh:exit_trap:539 echo 'Error on exit' 2017-09-03 00:00:27.694 | Error on exit 2017-09-03 00:00:27.701 | +stack.sh:exit_trap:540 generate-subunit 1504396548 279 fail 2017-09-03 00:00:28.238 | +stack.sh:exit_trap:541 [[ -z /opt/stack/logs ]] 2017-09-03 00:00:28.246 | +stack.sh:exit_trap:544 /devstack/tools/worlddump.py -d /opt/stack/logs ... (more)

2017-08-29 04:49:54 -0600 received badge  Notable Question (source)
2017-08-28 06:41:32 -0600 received badge  Popular Question (source)
2017-08-27 14:22:31 -0600 asked a question Openstack persistence after reboot

I am new to openstack. I installed openstack using devstack all on one server (for testing). All was well after installation but when I rebooted the server then openstack failed to work. Is this a normal issue? Is there additional steps to the installation so that my cloud installation survives a reboot?

I used this guide to install openstack on a single Ubuntu 16.04 server for testing and development:

This installation was installed on a FRESH install of Ubuntu 16.04 with all updates and upgrades applied. The only additional package installed outside of the default package of Ubuntu 16.04 was openssh-server.

After installation of Openstack (without rebooting) I was able to traverse all of the functions of the dashboard. I then shutdown for the evening. When I started up the next morning and started the dashboard I noticed many error messages (not able to retrieve usage data...etc...) but the big error was on Projects > Access and Security where I received the following error message:

ConnectionFailed at /project/access_and_security/

Connection to neutron failed: HTTPConnectionPool(host='192.168.1.8', port=9696): Max retries exceeded with url: //v2.0/extensions.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.httpconnection object="" at="" 0x7f2551657850="">: Failed to establish a new connection: [Errno 111] Connection refused',))

Request Method: GET Request URL: http://192.168.1.8/dashboard/project/access_and_security/ (http://192.168.1.8/dashboard/project/...) Django Version: 1.8.14 Exception Type: ConnectionFailed Exception Value:

Connection to neutron failed: HTTPConnectionPool(host='192.168.1.8', port=9696): Max retries exceeded with url: //v2.0/extensions.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.httpconnection object="" at="" 0x7f2551657850="">: Failed to establish a new connection: [Errno 111] Connection refused',))

Exception Location: /usr/local/lib/python2.7/dist-packages/neutronclient/client.py in _cs_request, line 111 Python Executable: /usr/bin/python Python Version: 2.7.12 Python Path:

['/opt/stack/horizon/openstack_dashboard/wsgi/../..', '/opt/stack/horizon', '/opt/stack/keystone', '/opt/stack/glance', '/opt/stack/cinder', '/opt/stack/neutron', '/opt/stack/nova', '/opt/stack/horizon', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/opt/stack/horizon/openstack_dashboard']

Server time: Sun, 27 Aug 2017 18:10:22 +0000

I have reproduced this 5 times, each time re-installing Linux and OpenStack fresh and rebooting. Each time I receive the error above.

I noticed there is NO /var/log/neutron directory so I do not know where the error logs are.

2017-08-23 01:36:24 -0600 received badge  Popular Question (source)
2017-08-22 19:08:45 -0600 commented question ppa:cloud-installer/stable gives error

I did not mean to add the quotation marks. Same error without.

2017-08-22 18:29:13 -0600 asked a question ppa:cloud-installer/stable gives error

I am trying to download the stable cloud-installer ppa with the following err and the following error:

sudo add-apt-repository "ppa:cloud-installer/stable"
Cannot add PPA: 'ppa:~cloud-installer/ubuntu/stable'.
The team named '~cloud-installer' has no PPA named 'ubuntu/stable'
Please choose from the following available PPAs:
 * 'simplestreams-testing':  Simplestreams Changes Testing

I am using Ubuntu 16.04. Am I running the command incorrectly?

2017-08-20 19:38:48 -0600 asked a question Can both nodes of an openstack installation be the same physical server?

I am getting ready to install openstack for the first time on a Dell PowerEdge R610 with (2) hex core E5670 processors, 128GB memory, (6) 1TB SATA dreves arranged in RAID 10.

Can this single server serve as both the controller an compute nodes? Or is this not a good idea and should purchase another physical server?

I will be using Linux Ubuntu 16.04.