Ask Your Question

pacman's profile - activity

2019-10-25 20:28:41 -0600 received badge  Popular Question (source)
2019-10-25 20:28:41 -0600 received badge  Famous Question (source)
2019-10-25 20:28:41 -0600 received badge  Notable Question (source)
2019-07-01 08:11:07 -0600 received badge  Student (source)
2019-01-15 06:08:56 -0600 received badge  Famous Question (source)
2019-01-15 06:08:56 -0600 received badge  Notable Question (source)
2018-02-20 11:41:52 -0600 received badge  Famous Question (source)
2017-11-28 06:42:54 -0600 asked a question openstack pike with ceph luminous

Hi

i tried to upgrade my testcluster to ceph luminous but on rerunning my ansible scripts I run into an error when installing the centos-release-openstack-pike repo. It appears that it has a dependency to the ceph juwel repo which conflicts with the ceph-luminous repo:

[root@controller02 ~]# yum install centos-release-openstack-pike
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.inode.at
 * extras: mirror.inode.at
 * updates: mirror.inode.at
Resolving Dependencies
--> Running transaction check
---> Package centos-release-openstack-pike.x86_64 0:1-1.el7 will be installed
--> Processing Dependency: centos-release-ceph-jewel for package: centos-release-openstack-pike-1-1.el7.x86_64
--> Running transaction check
---> Package centos-release-ceph-jewel.noarch 0:1.0-1.el7.centos will be installed
--> Processing Conflict: centos-release-ceph-luminous-1.0-1.el7.centos.noarch conflicts centos-release-ceph < 12.2
--> Finished Dependency Resolution
Error: centos-release-ceph-luminous conflicts with centos-release-ceph-jewel-1.0-1.el7.centos.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

is there any way to resolve this without screwing the whole package tree?

any help is greatly appreciated...

2017-10-11 04:20:08 -0600 received badge  Popular Question (source)
2017-10-08 13:58:06 -0600 received badge  Notable Question (source)
2017-10-08 13:58:06 -0600 received badge  Famous Question (source)
2017-09-08 09:05:06 -0600 received badge  Popular Question (source)
2017-09-07 06:49:37 -0600 commented question "no valid host found" when migrating

i just realized that it only happens for instances booted from cinder volumes - if i boot directly from an glance image migration works just fine

2017-09-07 04:54:06 -0600 asked a question "no valid host found" when migrating

hi

i have an openstack cloud runnung pike release on centos7. it has 5 identical compute nodes. i am able to spawn new instances without problems but when trying to migrate instances (cold migrate) i get following error:

[root@controller01 ~]# nova migrate e-1
ERROR (BadRequest): No valid host was found. No valid host found for cold migrate (HTTP 400) (Request-ID: req-b94b9aa1-f647-4ea0-af3f-80151bad231b)

there are no messages in scheduler log but some lines in conductor log:

2017-09-07 11:12:18.063 19264 DEBUG nova.conductor.tasks.migrate [req-5a76e692-f637-43d4-a5d9-f7685473d541 2c80438429c845138cc97e47d78733a8 767ad44cde3949ba9fbe2da5d75e948a - default default] [instance: f6bfd21c-8942-41d9-82c5-baa9b8bfffe8] Requesting cell 32d993fc-4209-40c7-8659-88e8ad0c449c(cell1) while migrating _execute /usr/lib/python2.7/site-packages/nova/conductor/tasks/migrate.py:58
2017-09-07 11:12:19.965 19264 WARNING nova.scheduler.utils [req-5a76e692-f637-43d4-a5d9-f7685473d541 2c80438429c845138cc97e47d78733a8 767ad44cde3949ba9fbe2da5d75e948a - default default] Failed to compute_task_migrate_server: No valid host was found. There are not enough hosts available.
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 232, in inner
    return func(*args, **kwargs)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/manager.py", line 149, in select_destinations
    alloc_reqs_by_rp_uuid, provider_summaries)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/filter_scheduler.py", line 104, in select_destinations
    raise exception.NoValidHost(reason=reason)

NoValidHost: No valid host was found. There are not enough hosts available.
: NoValidHost_Remote: No valid host was found. There are not enough hosts available.
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 232, in inner
    return func(*args, **kwargs)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/manager.py", line 149, in select_destinations
    alloc_reqs_by_rp_uuid, provider_summaries)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/filter_scheduler.py", line 104, in select_destinations
    raise exception.NoValidHost(reason=reason)

NoValidHost: No valid host was found. There are not enough hosts available.
2017-09-07 11:12:19.966 19264 WARNING nova.scheduler.utils [req-5a76e692-f637-43d4-a5d9-f7685473d541 2c80438429c845138cc97e47d78733a8 767ad44cde3949ba9fbe2da5d75e948a - default default] [instance: f6bfd21c-8942-41d9-82c5-baa9b8bfffe8] Setting instance to ACTIVE state.: NoValidHost_Remote: No valid host was found. There are not enough hosts available.
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/server.py", line 232, in inner
    return func(*args, **kwargs)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/manager.py", line 149, in select_destinations
    alloc_reqs_by_rp_uuid, provider_summaries)

  File "/usr/lib/python2.7/site-packages/nova/scheduler/filter_scheduler.py", line 104, in select_destinations
    raise exception.NoValidHost(reason=reason)

NoValidHost: No valid host was found. There are not enough hosts available.

i am stuck now since there are definitly enough ressources available and i am even able to spawn instances... any ideas?

2017-08-16 06:12:29 -0600 received badge  Notable Question (source)
2017-08-11 05:39:20 -0600 commented question nova connecting to amqp on 127.0.0.1

@Bernd Bausch i received an answer to my post per email but it does not show up here - any idea why? i will comment on it shortly since there is some strange behavior related to it which needs longer explanation

2017-08-11 04:25:14 -0600 received badge  Enthusiast
2017-08-11 03:09:11 -0600 received badge  Popular Question (source)
2017-08-10 06:15:45 -0600 received badge  Editor (source)
2017-08-08 09:10:40 -0600 commented question live migration failing with "Unexpected API Error"

i am just about to reinstall the cluster but i can say for sure that selinux is off - i added the hosts file in my original post as the comment size is to limited

2017-08-08 09:07:30 -0600 commented question live migration failing with "Unexpected API Error"

meanwhile i found some older manuals (2013) stating that some libvirt settings have to be adjusted: https://kimizhang.wordpress.com/2013/08/26/openstack-vm-live-migration/ (https://kimizhang.wordpress.com/2013/...) however i did not try it yet since i found out that neither cold migration nor resize are working as well (working on that now)

2017-08-08 09:06:15 -0600 commented question live migration failing with "Unexpected API Error"

Hi, i got 5 absolutely identical compute nodes. honestly at first i did not do any modifications - i just expected it to work when following the official setup.

2017-08-06 21:56:36 -0600 asked a question live migration failing with "Unexpected API Error"

Hi

I installed openstack according to the instructions in the official getting started guide. The Stack is working mostly except for some hickups. One of them are failing live migrations.

Everytime I try to live migrate an instance it fails with "Unexpected API Error". Here is my /var/log/nova/nova-api.log:

2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions [req-585db0ac-b3ef-4e07-afb5-914ad9005ae5 
735e4dd64a0e451bbb5254950af6e6ad f9873284dd3b40edbf9564703c0903ad - default default] Unexpected exception in API method
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions Traceback (most recent call last):
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/api/openstack/extensions.py", line 338, in wrapped
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return f(*args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 108, in wrapper
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return func(*args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 108, in wrapper
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return func(*args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 108, in wrapper
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return func(*args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/api/openstack/compute/migrate_server.py", line 100, in _migrate_live
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     disk_over_commit, host, force, async)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/compute/api.py", line 170, in inner
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return function(self, context, instance, *args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/compute/api.py", line 178, in _wrapped
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return fn(self, context, instance, *args, **kwargs)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/compute/api.py", line 151, in inner
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     return f(self, context, instance, *args, **kw)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/nova/compute/api.py", line 3903, in live_migrate
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     messaging_timeout)
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions   File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
2017-08-06 23:27:21.011 9550 ERROR nova.api.openstack.extensions     self.force_reraise()
2017-08-06 23 ...
(more)
2017-08-06 21:56:36 -0600 asked a question nova connecting to amqp on 127.0.0.1

Hi

I tried to setup openstack following the instructions in the getting started guide. OS is Centos7 with all updates applied.

openstack is working, i can spawn instances, create networks and volumes but for some reason there is this message popping up in /var/log/nova/nova-compute.log:

2017-08-06 23:51:18.816 1277 ERROR oslo.messaging._drivers.impl_rabbit [req-7e0a119f-7cf7-45ca-b1be-b0d7319798bb 735e4dd64a0e451bbb5254950af6e6ad f9873284dd3b40edbf9564703c0903ad - - -] [be3fc3c4-2729-4a21-8264-27225e2154f8] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 32 seconds. Client port: None

of course it cannot connect to rabbit on localhost since there is no rabbit running on localhost... but nowhere in my nova config i mentioned localhost. also it has to connect to the configured host (controller) as everything appears to be working besides live migration is not working for some reason ( not sure if it is related )

<edit> by now i figured out that those messages only appear when i try to cold migrate, resize or evacuate a vm. also those operations are stalling forever. i tried creating ssh tunnels to forward the local port to the amqp server and suddenly the messages stopped and the migration finished successfully </edit>

here is my complete /etc/nova/nova.conf:

[root@compute05 ~]# cat /etc/nova/nova.conf
[DEFAULT]
my_ip=10.12.1.25
enabled_apis = osapi_compute,metadata
transport_url = rabbit://openstack:rabbit@controller
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
[api]
auth_strategy = keystone
[api_database]
[barbican]
[cache]
[cells]
[cinder]
[cloudpipe]
[conductor]
[console]
[consoleauth]
[cors]
[cors.subdomain]
[crypto]
[database]
[ephemeral_storage_encryption]
[filter_scheduler]
[glance]
api_servers = http://controller:9292
[guestfs]
[healthcheck]
[hyperv]
[image_file_url]
[ironic]
[key_manager]
[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
#memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = nova
[libvirt]
[matchmaker_redis]
[metrics]
[mks]
[neutron]
url = http://controller:9696
auth_url = http://controller:35357
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = RegionOne
project_name = service
username = neutron
password = neutron
[notifications]
[osapi_v21]
[oslo_concurrency]
lock_path = /var/lib/nova/tmp
[oslo_messaging_amqp]
[oslo_messaging_kafka]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
[oslo_messaging_zmq]
[oslo_middleware]
[oslo_policy]
[pci]
[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://controller:35357/v3
username = placement
password = placement
[quota]
[rdp]
[remote_debug]
[scheduler]
[serial_console]
[service_user]
[spice]
[ssl]
[trusted_computing]
[upgrade_levels]
[vendordata_dynamic_auth]
[vmware]
[vnc]
enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = $my_ip
novncproxy_base_url = http://controller:6080/vnc_auto.html
[workarounds]
[wsgi]
[xenserver]
[xvp]

any ideas what might be causing this?