Ask Your Question

Ali's profile - activity

2018-03-01 03:09:52 -0500 received badge  Enthusiast
2016-11-28 07:14:40 -0500 received badge  Famous Question (source)
2016-09-19 13:40:28 -0500 received badge  Notable Question (source)
2016-09-19 13:40:28 -0500 received badge  Popular Question (source)
2016-05-21 10:12:48 -0500 asked a question Tripleo Template to create 3 controller and 3 compute with nfs for glance and cinder

I am trying Red Hat Openstack platform 8. on 7 UCS cisco servers 1 for the undercloud and 6 for overcloud (3 controller - 3 computes). NFS share for Glance and Cinder

10.104.1.40:/ifs/data/TVTC/CLD_GLANCE
10.104.1.40:/ifs/data/TVTC/CLD_CINDER

6 NIC interfaces on each blade

enp6s0, enp7s0, enp8s0, enp9s0 ,enp10s0 and enp11s0

I am using enp7s0 for provisioning PXE network and I am planing to use only enp6s0 for other overcloud networks with vlans.

Networks Vlans

Provisioning Network 10.108.58.0/24           Vlan 56 Gateway 10.108.56.254
  InternalApiNetCidr: 10.108.58.0/24              Vlan 58 Gateway 10.108.58.254
  StorageNetCidr: 10.108.57.0/24                   Vlan 57 Gateway 10.108.57.254
  StorageMgmtNetCidr: 192.168.59.0/24        Vlan 59 Gateway 10.108.58.254
  TenantNetCidr: 10.108.60.0/24                     Vlan 60 Gateway 10.108.59.254
  ExternalNetCidr: 10.108.55.0/24                   Vlan 55 Gateway 10.108.55.254

The servers registered to undercloud (#openstack baremetal introspection bulk start) command run successfully. and I tagged 3 servers to control profile and 3 servers tagged to compute profile.

I am facing many problems with the templates as I followed Red Hat official documentation to customise the templates to our storage and network but every time I run openstack deploy command It fail and give me many errors. so I would appreciate if you provide me the templates which suit my environment and how to run it using "#openstack deploy overcloud" to create the overcloud.

Thanks!

2014-09-29 14:01:44 -0500 received badge  Famous Question (source)
2014-09-24 03:50:57 -0500 received badge  Notable Question (source)
2014-09-21 02:17:40 -0500 received badge  Organizer (source)
2014-09-21 02:12:46 -0500 received badge  Popular Question (source)
2014-09-19 06:31:03 -0500 received badge  Supporter (source)
2014-09-18 05:20:29 -0500 received badge  Student (source)
2014-09-18 04:08:21 -0500 asked a question error when running "Ceilometer resource list " by admin user

Hi everybody,

I'm using Openstack release "havana" installed using RDO packstack.

Ceilometer version:strong text

python-ceilometer-2013.2.1-1.el6.noarch
openstack-ceilometer-collector-2013.2.1-1.el6.noarch
openstack-ceilometer-common-2013.2.1-1.el6.noarch
openstack-ceilometer-api-2013.2.1-1.el6.noarch
python-ceilometerclient-1.0.8-1.el6.noarch
openstack-ceilometer-central-2013.2.1-1.el6.noarch

Mongodb version:

mongodb-2.4.6-1.el6.x86_64
mongodb-server-2.4.6-1.el6.x86_64
python-pymongo-2.5.2-3.el6.x86_64

When I run ceilometer --debug resource list by admin user I got this error The same error with dashboard and /var/log/ceilometer/api.log

DEBUG (http:121) 
HTTP/1.0 500 Internal Server Error
date: Thu, 18 Sep 2014 08:37:47 GMT
content-length: 708
content-type: application/json
server: WSGIServer/0.1 Python/2.6.6

{"error_message": {"debuginfo": null, "faultcode": "Server", "faultstring": "command SON([('aggregate', u'meter'), ('pipeline', [{'$match': {}}, {'$sort': {'timestamp': -1, 'project_id': -1, 'user_id': -1}}, {'$group': {'meters_unit': {'$push': '$counter_unit'}, 'source': {'$first': '$source'}, 'project_id': {'$first': '$project_id'}, 'user_id': {'$first': '$user_id'}, 'last_sample_timestamp': {'$max': '$timestamp'}, 'meters_name': {'$push': '$counter_name'}, 'first_sample_timestamp': {'$min': '$timestamp'}, 'meters_type': {'$push': '$counter_type'}, '_id': '$resource_id', 'metadata': {'$first': '$resource_metadata'}}}])]) failed: exception: aggregation result exceeds maximum document size (16MB)"}}

WARNING (http:172) Request returned failure status.
HTTPInternalServerError (HTTP 500)

But when I run the same command with another user it works. Please help me to figure out and solve the problem considering my poor knowledge in mongodb.

Thank you