Ask Your Question

sebastien's profile - activity

2019-01-21 05:44:30 -0500 received badge  Notable Question (source)
2018-09-20 09:19:29 -0500 received badge  Popular Question (source)
2018-09-19 09:34:01 -0500 asked a question openvswitch provider network fails upon VM creation

Greetings,

here is my configuration:

controller node with 2 nic: one is mgmt network on eno2 with IP 192.168.10.60 (netmask 22), gateway/firewall is 192.168.8.1 on eth1 the other is eno1 as OVSPort for br-provider with fixe IP 192.168.12.60 (netmask 24), gateway firewall (same appliance as above= is 192.168.12.1 on eth2

storage/compute node with 2 nic: one is mgmt network on em4 with IP 192.168.10.59 (netmask 22), gateway/firewall is 192.168.8.1 on eth1 the other is em1 as OVSPort for br-provider with fixe IP 192.168.12.60 (netmask 24), gateway firewall (same appliance as above= is 192.168.12.1 on eth2

I had to create route rules as follows to be able to get network working properly:

192.168.12.0/24 dev br-provider tab 2
default via 192.168.12.1 dev br-provider tab 2
192.168.8.0/22 dev em4 tab 1
default via 192.168.8.1 dev em4 tab 1
from 192.168.12.59/32 tab 2 priority 200
from 192.168.10.59/32 tab 1 priority 100

Now, when I create a provider network on OpenStack, and then create a VM on that network, everything on the provider network falls down, ping don't reply no more from or to any of the 192.168.12.0/24 network, both compute and controller can't ping the gateway on its 192.168.12.1 address and only the mgmt network is working.

. admin-openrc
openstack subnet create --network bgx_provider --allocation-pool start=192.168.13.101,end=192.168.13.250 --dns-nameserver 208.67.222.222 --gateway 192.168.13.1 --subnet-range 192.168.13.0/24 bgx_provider-v4
. extra1-openrc
openstack server create --flavor 0S_A0 --image CentOS-7-x86_64-GenericCloud-1511 --nic net-id=9b33dc0a-0cad-4b27-a606-a5c8c79db32c --security-group default --key-name extra1_key tst-centos7-01

here are some more infos about my setup:

# ovs-vsctl list-ports br-provider
eno1
phy-br-provider
# ovs-vsctl list-ports br-tun
patch-int
# ovs-vsctl list-ports br-int
int-br-provider
patch-tun

how could I trace this behavior and check out the issue?

On another setup, I had the exact same configuration (hardware with 2 separated networks, same gateway) and it was working fine. The only difference was that the gateway was a Cisco appliance. On this current setup, the gateway is a watchguard appliance.

Best Regards,

2018-09-04 03:33:09 -0500 commented answer [SOLVED] Pike: Cinder Volume services are down on Controller Node without any apparent error in logs

Thank you!

The issue was NTP-related and despite of chronyd successfully started on both servers, the date/time between the 2 nodes were 5min apart.

That's the second time I miss checking on the date/time for an Openstack-related issue. On the third, I will got it tattooed on my forearm!

Cheers!

2018-09-04 03:29:52 -0500 received badge  Supporter (source)
2018-09-04 03:29:48 -0500 received badge  Scholar (source)
2018-09-03 08:51:33 -0500 commented question [SOLVED] Pike: Cinder Volume services are down on Controller Node without any apparent error in logs

running cinder-manage db sync does seem to work despied of a warning message:

[root@srv-heb-stack102 ~]# su -s /bin/sh -c "cinder-manage db sync" cinder
Option "logdir" from group "DEFAULT" is deprecated. Use option "log-dir" from group "DEFAULT".

volume and volume_type table are empty

2018-09-03 08:47:07 -0500 commented question [SOLVED] Pike: Cinder Volume services are down on Controller Node without any apparent error in logs

@eblock and @Bernd, I am sorry; it seems the openstack pastebin has a line limit. I ran the services more than 27 seconds, obviously. Here are the "complete" logs:

https://pastebin.com/QmWMzk76
https://pastebin.com/KrGxHntS
https://pastebin.com/7wwdqkdD

It's a fresh install, it never worked so far

2018-09-03 04:38:55 -0500 commented question [SOLVED] Pike: Cinder Volume services are down on Controller Node without any apparent error in logs

Thank you for your advice, Bernd!

I have added the systemctl output from both servers, and here is a pastebin from the DEBUG logs.

http://paste.openstack.org/show/729309/
http://paste.openstack.org/show/729311/
http://paste.openstack.org/show/729312/

Unfortunately, I'm still missing the issue here

2018-09-02 03:15:38 -0500 received badge  Popular Question (source)
2018-09-02 03:15:38 -0500 received badge  Famous Question (source)
2018-09-02 03:15:38 -0500 received badge  Notable Question (source)
2018-08-31 07:56:34 -0500 asked a question [SOLVED] Pike: Cinder Volume services are down on Controller Node without any apparent error in logs

Greetings,

I am experiencing issues regarding Cinder. Here are the configuration elements:

From storage node:

[DEFAULT]
osapi_volume_listen = 192.168.10.60
api_paste_config = /etc/cinder/api-paste.ini
glance_host = 192.168.10.60
auth_strategy = keystone
debug = False
use_syslog = False
my_ip = 192.168.10.59
transport_url = rabbit://openstack:0e932761f8ddf9d9f175@192.168.10.60:5672//openstack
log_dir = /var/log/cinder
state_path = /var/lib/cinder
volumes_dir = /var/lib/cinder/volumes/
rootwrap_config = /etc/cinder/rootwrap.conf
default_volume_type = lvm-192.168.10.59
glance_api_servers = http://192.168.10.60:9292
enabled_backends =lvm-192.168.10.59,nfs-192.168.10.59
volume_clear = zero
volume_clear_size = 50
volume_clear_ionice = -c3
nas_secure_file_operations = false
nas_secure_file_permissions = false
nova_catalog_info = compute:nova:internalURL
nova_catalog_admin_info = compute:nova:adminURL
os_region_name = Bagneux
notification_driver = messagingv2
control_exchange = cinder
[backend]
[backend_defaults]
[barbican]
[brcd_fabric_example]
[cisco_fabric_example]
[coordination]
[cors]
[database]
connection = mysql+pymysql://cinderdbuser:680b5b9b4b557830bfdd@192.168.10.60:3306/cinderdb
retry_interval = 10
idle_timeout = 3600
min_pool_size = 1
max_pool_size = 10
max_retries = 100
pool_timeout = 10
[fc-zone-manager]
[healthcheck]
[key_manager]
[keystone_authtoken]
auth_uri = http://192.168.10.60:5000
auth_url = http://192.168.10.60:35357
auth_type = password
memcached_servers = 192.168.10.60:11211
project_domain_name = default
user_domain_name = default
project_name = services
username = cinder
password = *snipped*
region_name = Bagneux
project_domain_id = default
user_domain_id = default
[matchmaker_redis]
[nova]
[oslo_concurrency]
lock_path = /var/oslock/cinder
[oslo_messaging_amqp]
[oslo_messaging_kafka]
[oslo_messaging_notifications]
driver = messagingv2
[oslo_messaging_rabbit]
[oslo_messaging_zmq]
[oslo_middleware]
[oslo_policy]
[oslo_reports]
[oslo_versionedobjects]
[profiler]
[ssl]
[lvm-192.168.10.59]
volume_group = centos
volume_driver = cinder.volume.drivers.lvm.LVMVolumeDriver
iscsi_protocol = iscsi
iscsi_helper = tgtadm
iscsi_ip_address = 192.168.10.59
volume_backend_name = LVM_iSCSI-192.168.10.59
volume_clear = zero
volume_clear_size = 50
volume_clear_ionice = -c3
lvm_type = default
[nfs-192.168.10.59]
volume_driver = cinder.volume.drivers.nfs.NfsDriver
nfs_shares_config = /etc/cinder/nfs_shares
nfs_mount_point_base = /var/lib/cinder/nfs
nsf_disk_util = df
nfs_sparsed_volumes = True
nfs_mount_options = rw,hard,intr,timeo=90,bg,vers=3,proto=tcp,rsize=32768,wsize=32768
volume_backend_name = NFS-192.168.10.59
nfs_qcow2_volumes = True
nfs_snapshot_support = True
nas_secure_file_operations = false
nas_secure_file_permissions = false
volume_clear = zero
volume_clear_size = 50
volume_clear_ionice = -c3

from the controller:

[DEFAULT]
osapi_volume_listen = 192.168.10.60
api_paste_config = /etc/cinder/api-paste.ini
glance_host = 192.168.10.60
auth_strategy = keystone
debug = False
use_syslog = False
my_ip = 192.168.10.60
transport_url = rabbit://openstack:0e932761f8ddf9d9f175@192.168.10.60:5672//openstack
log_dir = /var/log/cinder
state_path = /var/lib/cinder
volumes_dir = /var/lib/cinder/volumes/
rootwrap_config = /etc/cinder/rootwrap.conf
default_volume_type = lvm-192.168.10.60
glance_api_servers = http://192.168.10.60:9292
enabled_backends =
nova_catalog_info = compute:nova:internalURL
nova_catalog_admin_info = compute:nova:adminURL
os_region_name = Bagneux
notification_driver = messagingv2
control_exchange = cinder
[backend]
[backend_defaults]
[barbican]
[brcd_fabric_example]
[cisco_fabric_example]
[coordination]
[cors]
[database]
connection = mysql+pymysql://cinderdbuser:680b5b9b4b557830bfdd@192.168.10.60:3306/cinderdb
retry_interval = 10
idle_timeout = 3600
min_pool_size = 1
max_pool_size = 10
max_retries = 100
pool_timeout = 10
[fc-zone-manager]
[healthcheck]
[key_manager]
[keystone_authtoken]
auth_uri = http://192.168.10.60:5000
auth_url = http://192.168.10.60:35357
auth_type = password
memcached_servers = 192.168.10.60:11211
project_domain_name = default
user_domain_name = default
project_name = services
username = cinder
password = *snipped*
region_name = Bagneux
project_domain_id = default
user_domain_id = default
[matchmaker_redis]
[nova]
[oslo_concurrency]
lock_path = /var/oslock/cinder
[oslo_messaging_amqp]
[oslo_messaging_kafka]
[oslo_messaging_notifications]
driver = messagingv2
[oslo_messaging_rabbit]
[oslo_messaging_zmq]
[oslo_middleware]
[oslo_policy]
[oslo_reports]
[oslo_versionedobjects]
[profiler]
[ssl]

here is the output from controller:

$ openstack volume service list
+------------------+-----------------------------------------------------+------+---------+-------+----------------------------+
| Binary           | Host                                                | Zone | Status  | State | Updated At                 |
+------------------+-----------------------------------------------------+------+---------+-------+----------------------------+
| cinder-volume    | srv-heb-stack101@lvm-192.168.10.59 ...
(more)
2017-12-16 03:28:47 -0500 received badge  Famous Question (source)
2017-12-16 03:28:47 -0500 received badge  Notable Question (source)
2017-09-07 03:08:37 -0500 received badge  Enthusiast
2017-09-06 09:59:37 -0500 received badge  Popular Question (source)
2017-09-06 02:34:36 -0500 commented question Getting an error on Glance Image List

it's not a DNS issue since other URLs are working fine:

# curl -vv http://srv-virt-stack1:5000/v3/ * Connection #0 to host srv-virt-stack1 left intact {"version": {"status": "stable", "updated": "2017-02-22T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstac

2017-09-05 08:36:09 -0500 asked a question Getting an error on Glance Image List

Greetings,

I am getting an error on page https://docs.openstack.org/ocata/fr/install-guide-rdo/glance-verify.html (https://docs.openstack.org/ocata/fr/i...) of the Openstack installation manual and can't really figure out why ; I didn't get any error on glance deployment.

[root@srv-virt-stack1 ~]# curl -vv http://srv-virt-stack1:9292/v2/images
* About to connect() to srv-virt-stack1 port 9292 (#0)
*   Trying 192.168.122.119...
* Connection refused
* Failed connect to srv-virt-stack1:9292; Connection refused
* Closing connection 0
curl: (7) Failed connect to srv-virt-stack1:9292; Connection refused


[root@srv-virt-stack1 ~]# openstack image create "cirros" --file cirros-0.3.5-x86_64-disk.img --disk-format qcow2 --container-format bare --public
Error finding address for http://srv-virt-stack1:9292/v2/schemas/image: HTTPConnectionPool(host='srv-virt-stack1', port=9292): Max retries exceeded with url: /v2/schemas/image (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x40b0b90>: Failed to establish a new connection: [Errno 111] Connection refused',))


 [root@srv-virt-stack1 ~]#  openstack endpoint list
+----------------------------------+-----------+--------------+--------------+---------+-----------+----------------------------------+
| ID                               | Region    | Service Name | Service Type | Enabled | Interface | URL                              |
+----------------------------------+-----------+--------------+--------------+---------+-----------+----------------------------------+
| 14f980dbcc4c4b61808dee9b8a085341 | RegionOne | keystone     | identity     | True    | admin     | http://srv-virt-stack1:35357/v3/ |
| 41b0179bc32247c7aba4e34f9dbb9581 | RegionOne | keystone     | identity     | True    | public    | http://srv-virt-stack1:5000/v3/  |
| 6ae61f4e2a474a18928da8d0ff0ff60c | RegionOne | keystone     | identity     | True    | internal  | http://srv-virt-stack1:5000/v3/  |
| 723e15e86c974b149d6f8aa613a8615f | RegionOne | glance       | image        | True    | public    | http://srv-virt-stack1:9292      |
| bb2ce835d9cc4ecfbb68d804211bcc86 | RegionOne | glance       | image        | True    | internal  | http://srv-virt-stack1:9292      |
| e68310fda79c4240bdfaf3b83d64b912 | RegionOne | glance       | image        | True    | admin     | http://srv-virt-stack1:9292      |
+----------------------------------+-----------+--------------+--------------+---------+-----------+----------------------------------+

[root@srv-virt-stack1 ~]# systemctl restart openstack-glance-api.service openstack-glance-registry.service

[root@srv-virt-stack1 ~]# systemctl status openstack-glance-api.service openstack-glance-registry.service
● openstack-glance-api.service - OpenStack Image Service (code-named Glance) API server
   Loaded: loaded (/usr/lib/systemd/system/openstack-glance-api.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2017-09-05 15:29:53 CEST; 234ms ago
 Main PID: 21348 (glance-api)
   CGroup: /system.slice/openstack-glance-api.service
           └─21348 /usr/bin/python2 /usr/bin/glance-api

Sep 05 15:29:53 srv-virt-stack1 systemd[1]: openstack-glance-api.service holdoff time over, scheduling restart.
Sep 05 15:29:53 srv-virt-stack1 systemd[1]: Started OpenStack Image Service (code-named Glance) API server.
Sep 05 15:29:53 srv-virt-stack1 systemd[1]: Starting OpenStack Image Service (code-named Glance) API server...

● openstack-glance-registry.service - OpenStack Image Service (code-named Glance) Registry server
   Loaded: loaded (/usr/lib/systemd/system/openstack-glance-registry.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2017-09-05 15:29:45 CEST; 8s ago
 Main PID: 21288 (glance-registry)
   CGroup: /system.slice/openstack-glance-registry.service
           ├─21288 /usr/bin/python2 /usr/bin/glance-registry
           └─21308 /usr/bin/python2 /usr/bin/glance-registry

Sep 05 15:29:47 srv-virt-stack1 glance-registry[21288]: /usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py:22: DeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
Sep 05 15:29:47 srv-virt-stack1 glance-registry[21288]: return pkg_resources.EntryPoint.parse("x=" + s).load(False)
Sep 05 15:29:47 srv-virt-stack1 glance-registry[21288]: /usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py:22: DeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
Sep 05 15:29:47 srv-virt-stack1 glance-registry[21288]: return pkg_resources.EntryPoint.parse("x=" + s).load(False)
Sep 05 15:29:47 srv-virt-stack1 glance-registry[21288]: /usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py:22: DeprecationWarning: Parameters to load are ...
(more)
2017-07-31 04:53:38 -0500 received badge  Famous Question (source)
2017-07-19 02:58:33 -0500 commented answer [SOLVED] How to solve InternalServerError: Internal Server Error (HTTP 500) on first project creation following Ocata rdo guide?

Greetings Bernd,

You nailed it! I added the following line at the beginning of the VirtualHost and it worked!

WSGIDaemonProcess keystone-admin processes=1 threads=1 user=keystone group=keystone display-name=%{GROUP}

Thank you for your support, I'll update my answer right away. Cheers!

2017-07-19 02:33:48 -0500 received badge  Editor (source)
2017-07-18 18:19:51 -0500 received badge  Notable Question (source)
2017-07-18 09:48:35 -0500 commented answer [SOLVED] How to solve InternalServerError: Internal Server Error (HTTP 500) on first project creation following Ocata rdo guide?

[root@srv-virt-stack1 log]# openstack catalog list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Internal Server Error (HTTP 500)

I'll put the debug as an answer

2017-07-18 02:12:28 -0500 answered a question [SOLVED] How to solve InternalServerError: Internal Server Error (HTTP 500) on first project creation following Ocata rdo guide?

UPDATE: Bernd helped me solve this through.

the /usr/share/keystone/wsgi-keystone.conf file coming along with the openstack-keystone-11.0.1-1.el7.noarch package seems to have an error in it.

One line is missing on the keystone-admin VirtualHost :

<VirtualHost *:35357>
    WSGIDaemonProcess keystone-admin processes=1 threads=1 user=keystone group=keystone display-name=%{GROUP}
    WSGIProcessGroup keystone-admin
    WSGIScriptAlias / /usr/bin/keystone-wsgi-admin
    WSGIApplicationGroup %{GLOBAL}
    WSGIPassAuthorization On
    LimitRequestBody 114688
    <IfVersion >= 2.4>
      ErrorLogFormat "%{cu}t %M"
    </IfVersion>
    ErrorLog /var/log/httpd/keystone.log
    CustomLog /var/log/httpd/keystone_access.log combined
    LogLevel DEBUG
    <Directory /usr/bin>
        <IfVersion >= 2.4>
            Require all granted
        </IfVersion>
        <IfVersion < 2.4>
            Order allow,deny
            Allow from all
        </IfVersion>
    </Directory>
</VirtualHost>

Adding the first line (WSGIDaemonProcess ..) solved this issue. Thank you all for your support, I am now moving on with the installation guide ! I will keep you posted if I find any other issues.


Following, the logs that helped find the issue

Greetings Bernd,

Thank you for your reply.

here is what the VirtualHost look like with Ocata:

# ls -l /etc/httpd/conf.d/wsgi-keystone.conf
lrwxrwxrwx 1 root root 38 Jul 17 11:43 /etc/httpd/conf.d/wsgi-keystone.conf -> /usr/share/keystone/wsgi-keystone.conf

ls -l /usr/share/keystone/wsgi-keystone.conf
-rw-r--r-- 1 root keystone 1837 Jul 17 15:02 /usr/share/keystone/wsgi-keystone.conf

...
<VirtualHost *:35357>
    WSGIProcessGroup keystone-admin
    WSGIScriptAlias / /usr/bin/keystone-wsgi-admin
    WSGIApplicationGroup %{GLOBAL}
    WSGIPassAuthorization On
    LimitRequestBody 114688
    <IfVersion >= 2.4>
      ErrorLogFormat "%{cu}t %M"
    </IfVersion>
    ErrorLog /var/log/httpd/keystone.log
    CustomLog /var/log/httpd/keystone_access.log combined

    <Directory /usr/bin>
        <IfVersion >= 2.4>
            Require all granted
        </IfVersion>
        <IfVersion < 2.4>
            Order allow,deny
            Allow from all
        </IfVersion>
    </Directory>
</VirtualHost>
...

And here is what the package deployed:

# ls -l /usr/bin/keystone-wsgi-admin
-rwxr-xr-x 1 root root 1807 May 11 10:27 /usr/bin/keystone-wsgi-admin

   # ls -l /usr/bin/keystone-*
    -rwxr-xr-x 1 root root  159 May 11 10:27 /usr/bin/keystone-manage
    -rwxr-xr-x 1 root root 1807 May 11 10:27 /usr/bin/keystone-wsgi-admin
    -rwxr-xr-x 1 root root 1812 May 11 10:27 /usr/bin/keystone-wsgi-public

I am not so familiar with WSGI but it doesn't seem to me the VirtualHost is misconfigured.

Here is an update with the debug output of what was required :

[root@srv-virt-stack1 log]# openstack catalog list
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Internal Server Error (HTTP 500)
[root@srv-virt-stack1 log]# openstack catalog list --debug
START with options: [u'catalog', u'list', u'--debug']
options: Namespace(access_key='', access_secret='***', access_token='***', access_token_endpoint='', access_token_type='', auth_type='', auth_url='http://srv-virt-stack1:35357/v3/', cacert=None, cert='', client_id='', client_secret='***', cloud='', code='', consumer_key='', consumer_secret='***', debug=True, default_domain='default', default_domain_id='', default_domain_name='', deferred_help=False, discovery_endpoint='', domain_id='', domain_name='', endpoint='', identity_provider='', insecure=None, interface='', key='', log_file=None, old_profile=None, openid_scope='', os_beta_command=False, os_compute_api_version='', os_identity_api_version='3', os_image_api_version='', os_network_api_version='', os_object_api_version='', os_project_id=None, os_project_name=None, os_volume_api_version='', passcode='', password='***', profile=None, project_domain_id='', project_domain_name='Default', project_id='', project_name='admin', protocol='', redirect_uri='', region_name='', timing=False, token='***', trust_id='', url='', user_domain_id='', user_domain_name='Default', user_id='', username='admin', verbose_level=3, verify=None)
Auth ...
(more)
2017-07-18 02:06:08 -0500 received badge  Popular Question (source)
2017-07-17 10:34:29 -0500 asked a question [SOLVED] How to solve InternalServerError: Internal Server Error (HTTP 500) on first project creation following Ocata rdo guide?

Greetings,

I have been following the Ocata rdo guide to deploy Openstack and I am encountering the following error:

https://docs.openstack.org/ocata/fr/install-guide-rdo/keystone-install.html (https://docs.openstack.org/ocata/fr/i...) From this page, once at the openstack project create step, I get this:

# openstack project create --domain default --description "Projet 0 - Service" service --debug

START with options: [u'project', u'create', u'--domain', u'default', u'--description', u'Projet 0 - Service', u'service', u'--debug']
options: Namespace(access_key='', access_secret='***', access_token='***', access_token_endpoint='', access_token_type='', auth_type='', auth_url='http://srv-virt-stack1:35357/v3/', cacert=None, cert='', client_id='', client_secret='***', cloud='', code='', consumer_key='', consumer_secret='***', debug=True, default_domain='default', default_domain_id='', default_domain_name='', deferred_help=False, discovery_endpoint='', domain_id='', domain_name='', endpoint='', identity_provider='', insecure=None, interface='', key='', log_file=None, old_profile=None, openid_scope='', os_beta_command=False, os_compute_api_version='', os_identity_api_version='3', os_image_api_version='', os_network_api_version='', os_object_api_version='', os_project_id=None, os_project_name=None, os_volume_api_version='', passcode='', password='***', profile=None, project_domain_id='', project_domain_name='Default', project_id='', project_name='admin', protocol='', redirect_uri='', region_name='', timing=False, token='***', trust_id='', url='', user_domain_id='', user_domain_name='Default', user_id='', username='admin', verbose_level=3, verify=None)
Auth plugin password selected
auth_config_hook(): {'auth_type': 'password', 'beta_command': False, u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'cacert': None, 'auth_url': 'http://srv-virt-stack1:35357/v3/', u'network_api_version': u'2', u'message': u'', u'image_format': u'qcow2', 'networks': [], u'image_api_version': u'2', 'verify': True, u'dns_api_version': u'2', u'object_store_api_version': u'1', 'username': 'admin', u'container_infra_api_version': u'1', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': u'1', 'auth': {'user_domain_name': 'Default', 'project_name': 'admin', 'project_domain_name': 'Default'}, 'default_domain': 'default', u'container_api_version': u'1', u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', 'timing': False, 'password': '***', u'application_catalog_api_version': u'1', u'key_manager_api_version': u'v1', u'metering_api_version': u'2', 'deferred_help': False, u'identity_api_version': '3', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'status': u'active', 'debug': True, u'interface': None, u'disable_vendor_agent': {}}
defaults: {u'auth_type': 'password', u'status': u'active', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'api_timeout': None, u'baremetal_api_version': u'1', u'image_api_version': u'2', u'container_infra_api_version': u'1', u'metering_api_version': u'2', u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', 'cacert': None, u'network_api_version': u'2', u'message': u'', u'image_format': u'qcow2', u'application_catalog_api_version': u'1', u'key_manager_api_version': u'v1', 'verify': True, u'identity_api_version': u'2.0', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', u'dns_api_version': u'2', u'object_store_api_version': u'1', u'interface': None, u'disable_vendor_agent': {}}
cloud cfg: {'auth_type': 'password', 'beta_command': False, u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'cacert': None, 'auth_url': 'http://srv-virt-stack1:35357/v3/', u'network_api_version': u'2', u'message': u'', u'image_format': u'qcow2', 'networks': [], u'image_api_version': u'2', 'verify': True, u'dns_api_version': u'2', u'object_store_api_version': u'1', 'username': 'admin', u'container_infra_api_version': u'1', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': u'1', 'auth': {'user_domain_name': 'Default', 'project_name': 'admin', 'project_domain_name': 'Default'}, 'default_domain': 'default', u'container_api_version': u'1', u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', 'timing': False, 'password': '***', u'application_catalog_api_version': u'1', u'key_manager_api_version': u ...
(more)