Ask Your Question

zerog's profile - activity

2019-05-04 21:58:10 -0500 received badge  Popular Question (source)
2019-05-04 21:58:10 -0500 received badge  Notable Question (source)
2019-05-04 21:58:10 -0500 received badge  Famous Question (source)
2017-07-10 20:08:42 -0500 asked a question No Internet access from devstack instance

I have been trying to play around a bit with devstack (mitaka release) on a vagrant ubuntu trusty box. Everytime I associate a floating ip address to my cirros instance, I lose access to the internet from that instance.

My ovs vswitch results for br-int and br-ex also show that the tap and qr ports are down :-

For br-int

vagrant@vagrant-ubuntu-trusty-64:~/devstack$ sudo ovs-ofctl show br-int
OFPT_FEATURES_REPLY (xid=0x2): dpid:00002ab71da22d41
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(patch-tun): addr:12:1e:d7:dd:7b:02
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 2(tap6b657dfa-d9): addr:2a:b7:1d:a2:2d:41
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 3(qr-e60f1cb6-1a): addr:92:e9:27:58:a2:39
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 4(qr-7430a837-fb): addr:2a:b7:1d:a2:2d:41
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 5(qvod4519e2f-fb): addr:92:e9:27:58:a2:39
     config:     0
     state:      0
     current:    10GB-FD COPPER
     speed: 10000 Mbps now, 0 Mbps max
 LOCAL(br-int): addr:2a:b7:1d:a2:2d:41
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0
vagrant@vagrant-ubuntu-trusty-64:~/devstack$

For br-ex

vagrant@vagrant-ubuntu-trusty-64:~/devstack$ sudo ovs-ofctl show br-ex
OFPT_FEATURES_REPLY (xid=0x2): dpid:000062a775a8234d
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(qg-6e123780-53): addr:62:a7:75:a8:23:4d
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-ex): addr:62:a7:75:a8:23:4d
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0
vagrant@vagrant-ubuntu-trusty-64:~/devstack$

I have observed the current behavior as being that when the floating ip address is disassociated, the access to the internet is resumed; But with an associated floating ip address, I cannot ping 8.8.8.8 etc..

Can someone help me out ?

TIA.