Ask Your Question

Lucky's profile - activity

2018-05-28 08:09:17 -0500 received badge  Famous Question (source)
2017-07-31 17:24:39 -0500 received badge  Popular Question (source)
2017-07-31 08:31:53 -0500 commented question Openstack Liberty: VMs created via vlan based internal network aren't able to ping each other

Here is the answer file used: http://paste.openstack.org/show/617006/

2017-07-31 03:56:17 -0500 asked a question Openstack Liberty: VMs created via vlan based internal network aren't able to ping each other

Hi, I have installed openstack liberty via packstack. I have Controller and Network node on same machine and rest machines are Computes. I'm able to launch VMs and provide external IP [flat network] via cirros image which is pingable to and from the VM. But when i create an internal network of 192.168.x.x subnet [obviously vlan based] it doesn't get IP via DHCP, and 2VMs launched with same network on separate computes, don't ping each other. Packets didn't even pass to respective compute from where i started pinging, let alone reached to compute in front and VM on it. However; if VMs are on same compute, then they are able to ping each other. Any idea what could be causing this? Is there anything that i should check and paste output, then let me do. I'll do that. Here is my neutron.conf: http://paste.openstack.org/show/616979/ And here is my ml2_conf.ini http://paste.openstack.org/show/616980/ Also; here is openvswitch_agent.ini http://paste.openstack.org/show/616981/

Please revert in case there is any other file or output we need to look at.

2017-07-28 03:46:54 -0500 commented question Cinder service on compute not getting recognized at controller- Liberty

Thanks for the response Bernd Bausch. Turned out to be problem with cinder.conf. Few parameters i had to do here and there and it worked. :)

2017-07-28 03:45:25 -0500 received badge  Notable Question (source)
2017-07-28 03:44:55 -0500 received badge  Famous Question (source)
2017-07-24 01:06:59 -0500 commented question Cinder service on compute not getting recognized at controller- Liberty

This IP address is Controller and it's correct. All the things i've tried which i could find online. In Compute's volume.log it shows connected but on Controller's logs there is no entry of Compute or it's IP in any log. Should i provide cinder.conf or api-paste.ini file or answer-file?

2017-07-23 12:19:08 -0500 commented question Cinder service on compute not getting recognized at controller- Liberty

Still going about the same issue. Checked reinstalling from scratch, reexecuted packstack, shifted to public IPs instead of private IPs. But still same issue. Could you please help me resolve this? In the logs it shows: Connected to AMQP server on 135.249.93.210:5672 Doesn't show up at controller.

2017-07-23 11:20:06 -0500 received badge  Popular Question (source)
2017-07-19 01:08:52 -0500 received badge  Enthusiast
2017-07-17 10:48:44 -0500 commented question Cinder service on compute not getting recognized at controller- Liberty

On the compute, service of cinder is up and logs show that its connected to controller via AMQP. Cinder-api is also running. Anything else you want me to check?

2017-07-17 03:57:02 -0500 asked a question Cinder service on compute not getting recognized at controller- Liberty

Hi, I have installed openstack-liberty via packstack. I configured cinder host as controller as always. Normally cinder would go to all the computes but this time it didn't. I manually installed cinder on computes, configured it as mentioned in guide [also tried via some online links]. But it doesn't get recognized at controller.

    [root@Controller1 ~(keystone_admin)]# cinder service-list
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
|      Binary      |       Host      | Zone |  Status | State |         Updated_at         | Disabled Reason |
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
|  cinder-backup   |   Controller1   | nova | enabled |   up  | 2017-07-17T08:51:32.000000 |        -        |
| cinder-scheduler |   Controller1   | nova | enabled |   up  | 2017-07-17T08:51:30.000000 |        -        |
|  cinder-volume   | Controller1@lvm | nova | enabled |   up  | 2017-07-17T08:51:07.000000 |        -        |
+------------------+-----------------+------+---------+-------+----------------------------+-----------------+
[root@Controller1 ~(keystone_admin)]#

Is there something different in liberty release related to Cinder? Am i missing something? I updated cinder.conf and api-paste.ini but didn't work. Please help me resolve this. I can share cinder.conf if the need be.

2017-07-17 03:48:08 -0500 received badge  Notable Question (source)
2017-06-27 01:06:57 -0500 commented question Newton create VM - Failed to Bind Port, No valid host found

I deleted network and recreated it with physnet2 in place of default. And this time i was able to launch a cirros VM :) Thanks a lot buddy.

2017-06-27 00:19:31 -0500 received badge  Popular Question (source)
2017-06-26 23:58:15 -0500 commented question Newton create VM - Failed to Bind Port, No valid host found

Here is the answer-file http://paste.openstack.org/show/613776/

2017-06-26 06:07:38 -0500 commented question Newton create VM - Failed to Bind Port, No valid host found

Thanks Bernd Bausch for the comments. Yes i want to create flat network and map it to physnet2. Here is the output you requested: [root@Controller1 ~(keystone_admin)]# openstack network show public ResourceNotFound: No Network found for public I have shared=TRUE in existing external network.

2017-06-22 11:59:28 -0500 asked a question Newton create VM - Failed to Bind Port, No valid host found

Hi, I have installed an all-in-one setup of openstack-newton using packstack. I'm trying to launch a cirros vm, which gets failed with error "No valid host found" on dashboard. Checking neutron logs it says, failed to bind port. Could someone please help me out? I tried multiple solutions but couldn't get through.

Error is as follows:

PortBindingFailed: Binding failed for port 8056eb45-1122-4ba6-86ed-223f45c0109c, please check neutron logs for more information

ERROR neutron.agent.linux.async_process [-] Error received from [ovsdb-client monitor Interface name,ofport,external_ids --format=json]: None
2017-06-22 21:06:32.630 30776 ERROR neutron.agent.linux.async_process [-] Process [ovsdb-client monitor Interface name,ofport,external_ids --format=json] dies due to the error: None 

ERROR neutron.plugins.ml2.managers [req-ba927280-1b89-4266-a3e2-b4f13ce68236 a6a62cffdee14d4c86c24ca0c3e1796f eedcf4e363f841218d822c88347abc06 - - -] Failed to bind port 8056eb45-1122-4ba6-86ed-223f45c0109c on host Controller1 for vnic_type normal using segments [{'segmentation_id': None, 'physical_network': u'default', 'id': u'8a638929-c31f-4d59-8c50-e33fa503b7c4', 'network_type': u'flat'}]

my /etc/default/neutron-server file says:

NEUTRON_PLUGIN_CONFIG="/etc/neutron/plugins/ml2/openvswitch_agent.ini"

In /etc/neutron i have a soft link:

plugin.ini -> /etc/neutron/plugins/ml2/openvswitch_agent.ini

openvswitch_agent.ini is as follows:

[DEFAULT]

#
# From oslo.log
#

# If set to true, the logging level will be set to DEBUG instead of the default
# INFO level. (boolean value)
# Note: This option can be changed without restarting.
#debug = false

# DEPRECATED: If set to false, the logging level will be set to WARNING instead
# of the default INFO level. (boolean value)
# This option is deprecated for removal.
# Its value may be silently ignored in the future.
#verbose = true

# The name of a logging configuration file. This file is appended to any
# existing logging configuration files. For details about logging configuration
# files, see the Python logging module documentation. Note that when logging
# configuration files are used then all logging configuration is set in the
# configuration file and other logging configuration options are ignored (for
# example, logging_context_format_string). (string value)
# Note: This option can be changed without restarting.
# Deprecated group/name - [DEFAULT]/log_config
#log_config_append = <None>

# Defines the format string for %%(asctime)s in log records. Default:
# %(default)s . This option is ignored if log_config_append is set. (string
# value)
#log_date_format = %Y-%m-%d %H:%M:%S

# (Optional) Name of log file to send logging output to. If no default is set,
# logging will go to stderr as defined by use_stderr. This option is ignored if
# log_config_append is set. (string value)
# Deprecated group/name - [DEFAULT]/logfile
#log_file = <None>

# (Optional) The base directory used for relative log_file  paths. This option
# is ignored if log_config_append is set. (string value)
# Deprecated group/name - [DEFAULT]/logdir
#log_dir = <None>

# Uses logging handler designed to watch file system. When log file is moved or
# removed this handler will open a new log file with specified path
# instantaneously. It makes sense only if log_file option is specified and
# Linux platform is used. This option is ignored if log_config_append is set.
# (boolean value)
#watch_log_file = false

# Use syslog for logging. Existing syslog format is DEPRECATED and will be
# changed later to honor RFC5424. This option is ignored if log_config_append
# is ...
(more)