Ask Your Question

arminder's profile - activity

2017-09-26 01:22:27 -0500 answered a question In the cirrors instance, I can ping google's ip, but can not ping google.com

See if there is list of nameservers on /etc/resolv.conf? If not, most probably you didn't have DNS servers in your network, In your tenant private network, edit subnet and add DNS servers in there. You can use 8.8.8.8 and 4.2.2.2 and then save it. Then reboot the Cirros VM and check again. If you are directly using the external network on your VM, then do the above for public/external network settings too.

2017-04-06 05:55:34 -0500 received badge  Notable Question (source)
2016-05-09 00:06:40 -0500 received badge  Popular Question (source)
2013-11-22 01:41:29 -0500 answered a question Issue with IDE drives and Instances

If you create an instance with ISO attached, the same is added as IDE and so later if you add any further volume to that instance it tries to mount that too as IDE and hence hdx, but since IDE doesn't support hot-plugging, so it fails. In such a case I edit my libvirt.xml for that instance and remove drive record info for hda and then reboot my instance. Post that I can add any number of volumes without any issue.

2011-12-02 09:36:52 -0500 answered a question Openstack Dasboard login fails

Moved to MySQL as backend but still same bad luck.

Anyone with any other ideas. I have the service type identity in keystone.

2011-12-02 04:02:53 -0500 answered a question Openstack Dasboard login fails

Thanks Gabriel for pointing me out in right direction and I totally agree that error message could be improved.

I had already given the following command: $ sudo keystone-manage service add keystone identity "Keystone Identity Service" SUCCESS: Service keystone created successfully.

But now since you pointed it out, I checked & when I try to dump the services table in sqlite db, it shows null for the rest of the fields; infact, can't find the type field there: INSERT INTO "services" VALUES('keystone',NULL);

So I'll rather switch to mysql as backend and see how it goes.

2011-12-01 17:14:20 -0500 asked a question Openstack Dasboard login fails

I'm getting the error "Unexpected error: identity", while trying to login into the dashboard. I know the username and password is correct. I have picked on Repo from diablo-4 available at http://yum.griddynamics.net/yum/diablo-4/openstack/ (http://yum.griddynamics.net/yum/diabl...) and installed on CentOS 6.

openstack-compute-2.0a1-1.noarch openstack-dashboard-1.0-0.20111116.1230.el6.noarch openstack-glance-2011.3-0.20110825.996.1.el6.noarch openstack-keystone-1.0-0.20110928.1619.el6.noarch openstack-nova-2011.3-0.20110922.1520.5.el6.noarch openstack-client-2.6.4-1.1ed1f5e.noarch


DEBUG 2011-12-01 08:27:13,657 api: auth_api connection created using url "http://localhost:5000/v2.0/" ERROR 2011-12-01 08:27:13,675 forms: Nonspecific error while handling form Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/openstack_dashboard/forms.py", line 168, in maybe_handle return form, form.handle(request, data) File "/usr/lib/python2.6/site-packages/openstack_dashboard/plugins/auth/views.py", line 107, in handle return handle_login(request, data['username'], data['password'], None) File "/usr/lib/python2.6/site-packages/openstack_dashboard/plugins/auth/views.py", line 65, in handle_login info = api_ext.token_info(request, token) File "/usr/lib/python2.6/site-packages/openstack_dashboard/api_ext.py", line 78, in token_info o = urlparse.urlparse(token.serviceCatalog['identity'][0]['adminURL'])

KeyError: 'identity'

Any help on this would be highly appreciated.

2011-12-01 14:01:38 -0500 answered a question Error while running dashboard

I'm getting the same error, except for the error is 'identity'. I have picked on Repo from diablo-4 available at http://yum.griddynamics.net/yum/diablo-4/openstack/ (http://yum.griddynamics.net/yum/diabl...)

openstack-compute-2.0a1-1.noarch openstack-dashboard-1.0-0.20111116.1230.el6.noarch openstack-glance-2011.3-0.20110825.996.1.el6.noarch openstack-keystone-1.0-0.20110928.1619.el6.noarch openstack-nova-2011.3-0.20110922.1520.5.el6.noarch openstack-client-2.6.4-1.1ed1f5e.noarch


DEBUG 2011-12-01 08:27:13,657 api: auth_api connection created using url "http://localhost:5000/v2.0/" ERROR 2011-12-01 08:27:13,675 forms: Nonspecific error while handling form Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/openstack_dashboard/forms.py", line 168, in maybe_handle return form, form.handle(request, data) File "/usr/lib/python2.6/site-packages/openstack_dashboard/plugins/auth/views.py", line 107, in handle return handle_login(request, data['username'], data['password'], None) File "/usr/lib/python2.6/site-packages/openstack_dashboard/plugins/auth/views.py", line 65, in handle_login info = api_ext.token_info(request, token) File "/usr/lib/python2.6/site-packages/openstack_dashboard/api_ext.py", line 78, in token_info o = urlparse.urlparse(token.serviceCatalog['identity'][0]['adminURL'])

KeyError: 'identity'

Any help on this would be highly appreciated.