Ask Your Question

akarki's profile - activity

2019-09-10 13:13:00 -0500 received badge  Notable Question (source)
2019-09-10 13:13:00 -0500 received badge  Popular Question (source)
2019-09-10 13:13:00 -0500 received badge  Famous Question (source)
2019-08-26 09:18:17 -0500 asked a question admin tenant deleted accidentaly in openstac queens

Hi, I accidently deleted admin project . How do i recover from it. Updated Db as well in projects table. Please help

2019-08-05 12:03:29 -0500 received badge  Famous Question (source)
2019-07-22 05:45:59 -0500 received badge  Notable Question (source)
2019-06-06 02:16:22 -0500 received badge  Famous Question (source)
2019-06-06 02:16:22 -0500 received badge  Popular Question (source)
2019-06-06 02:16:22 -0500 received badge  Notable Question (source)
2019-06-06 01:49:03 -0500 asked a question use vmware snapshot to create openstack vm

Hi,

I Have a vmware vm snapshot which has vmdk,vmem,vmsk file. below size details

root@compute:/home/60# ls -lrt

total 8393892

-rw-r--r-- 1 root root 351 May 31 22:31 ubuntu_172.16.103.56-000003.vmdk

-rw-r--r-- 1 root root 5400918 May 31 22:33 ubuntu_172.16.103.56-Snapshot3.vmsn

-rw-r--r-- 1 root root 8589934592 May 31 22:33 ubuntu_172.16.103.56-Snapshot3.vmem

How to use these file to create openstack vm. Any help would be appriciated.

2019-05-08 05:04:03 -0500 received badge  Popular Question (source)
2019-05-08 05:04:03 -0500 received badge  Notable Question (source)
2019-02-19 09:54:04 -0500 received badge  Famous Question (source)
2019-01-31 20:37:21 -0500 received badge  Famous Question (source)
2019-01-29 03:33:49 -0500 received badge  Famous Question (source)
2019-01-29 03:33:44 -0500 received badge  Famous Question (source)
2019-01-29 03:33:44 -0500 received badge  Popular Question (source)
2019-01-29 03:33:44 -0500 received badge  Notable Question (source)
2019-01-15 20:05:00 -0500 received badge  Famous Question (source)
2019-01-10 21:56:04 -0500 received badge  Popular Question (source)
2019-01-10 21:56:04 -0500 received badge  Notable Question (source)
2018-12-20 05:01:05 -0500 asked a question configure keystone to use corporate id

Hi, Is it possible to use corporate id instead of token based authentication in keystone.

2018-12-17 03:12:03 -0500 received badge  Notable Question (source)
2018-11-12 08:14:19 -0500 received badge  Notable Question (source)
2018-11-12 08:14:19 -0500 received badge  Popular Question (source)
2018-10-30 02:42:02 -0500 received badge  Popular Question (source)
2018-10-25 01:39:11 -0500 received badge  Popular Question (source)
2018-10-24 23:35:57 -0500 asked a question manually create vxlan tunnel(br-tun) in openstack

Hi, I have deployed penstack setup in tripleo . However after installation i see that br-tun is not getting created: the ovs-vsctl command shows:

[root@localhost ~]# ovs-vsctl show
d1056b8d-94ca-4c40-beba-11b30256aa52
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        fail_mode: standalone
        Port "em2"
            Interface "em2"
        Port br-ex
            Interface br-ex
                type: internal
    ovs_version: "2.9.0

"

Are there any steps to create br-tun manually and configure the ovs-brigdes properly Any help would be much appriciated

2018-10-24 07:36:29 -0500 asked a question issue with tripleo

with installation of tripleo with predeployed server br-tun is not getting created. The version used is stable/queens is this upstrean issue??

2018-10-20 02:06:32 -0500 received badge  Notable Question (source)
2018-10-20 02:05:07 -0500 received badge  Notable Question (source)
2018-10-19 22:18:37 -0500 received badge  Notable Question (source)
2018-10-17 19:49:20 -0500 received badge  Famous Question (source)
2018-10-09 04:36:29 -0500 received badge  Popular Question (source)
2018-10-06 00:48:55 -0500 received badge  Famous Question (source)
2018-10-04 08:35:23 -0500 commented answer tripleo single-nic-vlans ip not assigned based on subnet in network_environment file

Hi cody, actualy use_dhcp was added by me..for reason that without it use_dhcp the error was sameso it thought about adding it.. Also in neutron net-show for undercloud i only see ctlplane network can that be an issue??

2018-10-04 04:38:54 -0500 asked a question tripleo single-nic-vlans ip not assigned based on subnet in network_environment file

Hi, I am trying to deploy openstack on predeployed servers: I have 3 nics:

a) nic1 as controlplane intreface(192.168.24.0/24) (connected to access port)

b) nic2 as vlan network interface(vlanid used: 1001,1002,1005,1700,1705)

c) nic3 for external network so as to install basic packges during deloyment(172.16.141.0/24)(connected to access port)

The network-isolation file used: http://paste.openstack.org/show/731457/

The network-enviroment file used: http://paste.openstack.org/show/731456/

The "ctlplane-assignments.yaml" file used: http://paste.openstack.org/show/731459/

The nic-config/controller used: http://paste.openstack.org/show/731460/

The nic-config/compute used: http://paste.openstack.org/show/731461/

The node-info.yaml used: http://paste.openstack.org/show/731463/

Cmmand used:

openstack overcloud deploy --templates --disable-validations -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-bootstrap-environment-centos.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-pacemaker-environment.yaml -e node-info.yaml -e network-isolation.yaml -e network-environment.yaml -e ctlplane-assignments.yaml -r /usr/share/openstack-tripleo-heat-templates/deployed-server/deployed-server-roles-data.yaml

Issue is the vlan interfaces creted all have the ip of ctlplane and not from the subnet defined in network-enviroment.yaml.: http://paste.openstack.org/show/731464/

Also the hosts file shows some ip for overcloud from the subnet defined bu does not get attached to the inteface, hosts file: http://paste.openstack.org/show/731466/

os-net-config/config.json file: http://paste.openstack.org/show/731468/

The thing to worry is it gets all the vlan info and default route correctly however it just seems not to get the interfcae ip correctly.

Please help

2018-10-03 10:56:26 -0500 received badge  Notable Question (source)
2018-09-30 08:01:05 -0500 received badge  Popular Question (source)
2018-09-26 23:13:33 -0500 asked a question issue with tripleo

Hi , I am trying to deploy tripleo with 2 bridges 1) br-ctl : for internal network (192.168.24.0/24)

2) br-ex for external connectivity(172.16.141.0/24)

so with some help we create controller and compute.yaml:

http://paste.openstack.org/show/730981/

Also created network-en.yaml : http://paste.openstack.org/show/730979/

Also define ctlplane.yaml to define ip of ctlplane: http://paste.openstack.org/show/730980/

so, my question is how do i define ip for br-ex network as right now it picks up same ip as that of ctlplane network whereas i want ip from subnet(172.16.141.0/24)

also there is a param in controller.yaml as ExternalIpSubnet(for br-ex)..where should i define its value

2018-09-19 08:18:12 -0500 received badge  Popular Question (source)
2018-09-19 07:41:57 -0500 commented question issue with tripleo installation

Will there be any configuration changes in undercloud as well?? Actually we ran tripleo setup as u described in answer..but we were not able to access horizon from outside lab network..we thought it might be because of external endpoint connection..

2018-09-19 07:02:09 -0500 commented answer issue with tripleo on pre-deployed nodes

Thanks cody can I get Ur contact info .like email...this tripleo has got me confused..:(

2018-09-19 06:53:42 -0500 commented question issue with tripleo installation

well i can have another nic say nic3 for external traffic what else should i need to do?

2018-09-19 04:25:19 -0500 commented answer issue with tripleo on pre-deployed nodes

hi cody,so i have set the nic 1 for ssh as well as external ip.we have created undercloud with public as well admin endpoint to external ip..what changes do i need to de in overcloud apart from setting ExternalInterfaceDefaultRoute in network-enviroment.yaml?

2018-09-18 22:02:29 -0500 commented question issue with tripleo installation

A little confused here: 1)Cant i use nic 1 for ssh and also for external traffic?? 2)also when i run docker ps -a it shows container with tag tripleo-current even though i used queens repo..a 3) why is my storage services enabled..i did not provde anywhere to enable storage