Ask Your Question

openstackplz's profile - activity

2018-01-08 07:06:16 -0500 received badge  Famous Question (source)
2017-07-07 13:17:29 -0500 received badge  Popular Question (source)
2017-07-07 13:17:29 -0500 received badge  Notable Question (source)
2017-06-22 05:08:27 -0500 received badge  Famous Question (source)
2017-06-22 05:08:27 -0500 received badge  Notable Question (source)
2017-05-29 03:02:33 -0500 received badge  Enthusiast
2017-05-28 18:14:42 -0500 received badge  Famous Question (source)
2017-05-27 10:00:17 -0500 asked a question Instance can't access outside network

I launched a new instance and successfully console into it by ssh@10.0.0.3. But in the instance, it cannot ping the external network, like ping 8.8.8.8, it can ping the host machine ip address which is 192.168.159.4 but cannot ping 192.168.159.1. I tried to solve this by modify /etc/sysctl.conf file and let net.ipv4.ip_forward=1 but it did't work.

So where is the problem? Thank you in advance for any ideas.

My local.conf file is:

[[local|localrc]]
HOST_IP=192.168.159.4
PUBLIC_INTERFACE=eth1
FLOATING_RANGE=192.168.159.225/27
PUBLIC_NETWORK_GATEWAY=192.168.159.226
FIXED_RANGE=10.0.0.0/24
NETWORK_GATEWAY=10.0.0.1
FIXED_NETWORK_SIZE=28
FLAT_INTERFACE=eth0

LOGFILE=/opt/stack/logs/stack.sh.log

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta

The ip a result for host is:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:71:a4:c8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.159.4/24 brd 192.168.159.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe71:a4c8/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:11:e9:c1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.56.10/24 brd 192.168.56.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe11:e9c1/64 scope link 
       valid_lft forever preferred_lft forever
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 3a:75:8e:d6:14:e5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether ba:f8:b9:d3:f2:73 brd ff:ff:ff:ff:ff:ff
14: br-int: <BROADCAST,UP,LOWER_UP> mtu 1450 qdisc noqueue state UNKNOWN group default qlen 1
    link/ether 46:b0:a5:a2:bb:43 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4057:d1ff:fe88:9eaf/64 scope link 
       valid_lft forever preferred_lft forever
15: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1
    link/ether 8a:88:a0:e4:7d:48 brd ff:ff:ff:ff:ff:ff
    inet 192.168.159.226/27 scope global br-ex
       valid_lft forever preferred_lft forever
    inet6 2001:db8::2/64 ...
(more)
2017-05-27 00:56:49 -0500 commented answer how to set up openstack local.conf in virtual box

I tried to set the two adapters I set for this virtual box instance to promiscuous type, for the host-only adapter I can set it to promiscuous, but for the NAT adaptor, it doesn't allow me to modify its promiscuous type, which is Deny on default. So how can I modify this NAT adapter's promisc type?

2017-05-27 00:54:04 -0500 commented answer how to set up openstack local.conf in virtual box

Hi Bernd, I checked some similar issues posted online, like the question https://ask.openstack.org/en/question/97658/mitaka-instance-cannot-be-allocated-ip-address/ (https://ask.openstack.org/en/question...). I set the eth0 and eth1 interfaces all to promiscuous type using ifconfig ethx promisc. But the problem did not gone.

2017-05-27 00:39:21 -0500 received badge  Popular Question (source)
2017-05-26 07:57:57 -0500 commented answer how to set up openstack local.conf in virtual box

Hi Bernd, I just add the ip a result and local.conf content, please have a look. By the way, thank you so much for your help. You have no idea what this means to me. Thank you.

2017-05-26 05:23:54 -0500 received badge  Supporter (source)
2017-05-26 05:09:45 -0500 answered a question how to set up openstack local.conf in virtual box

I installed successfully and created a new instance, but the same issue happened again that I couldn't console into the new instance. I tried openstack console log show test and found out the eth0 interface didn't have an IPv4 address at all. It seems like there was only a public address for it which is "10.0.2.227" but no private address provided for this instance. Is there anything wrong with the configuration?

Four agent services are running as shown by neutron agent-list, which are Open vSwitch agent, Metadata agent, HCP agent, and L3 agent.

Four compute services are running as shown by openstack compute service list, which are nova-conductor, nova-scheduler, nova-consoleauth, and nova-compute.


The public ip address is shown by openstack server list under column Networks, info is public=10.0.2.228, 2001:db8::4(I deleted the previous instance and created a new one so the address changed from 227 to 228).

The local.conf file is like:

PUBLIC_INTERFACE=eth1 (which is the host-only adapter I added from virtual box and has no ip address according to `ifconfig`)
FLOATING_RANGE=10.0.2.225/27 (based on the NAT adapter interface eth0, ip address `10.0.2.15`)
PUBLIC_NETWORK_GATEWAY=10.0.2.226
FIXED_RANGE=10.0.0.0/24
NETWORK_GATEWAY=10.0.0.1
FIXED_NETWORK_SIZE=256
FLAT_INTERFACE=eth0 (the NAT adaptor interface)
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta

The result of ip a is:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:7e:78:bd brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe7e:78bd/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:56:00:f5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a00:27ff:fe56:f5/64 scope link 
       valid_lft forever preferred_lft forever
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether da:35:56:c6:7f:01 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether 6e:26:f5:14:fb:90 brd ff:ff:ff:ff:ff:ff
13: br-int: <BROADCAST,UP,LOWER_UP> mtu 1450 qdisc noqueue state UNKNOWN group default qlen 1
    link/ether ...
(more)
2017-05-26 05:07:26 -0500 commented answer how to set up openstack local.conf in virtual box

The reason I need DevStack is because it is relevant to my job, so I don't have a choice... I successfully installed it but the same problem happened that I couldn't console into the instance, please see the answer I post under this question.

2017-05-26 05:03:47 -0500 received badge  Notable Question (source)
2017-05-26 04:31:52 -0500 answered a question how to set up openstack local.conf in virtual box

I just tried the installation, but failed again with an error shown in log:

+++lib/neutron-legacy:_neutron_create_public_subnet_v4:1274 neutron subnet-create --ip_version 4 --gateway 10.0.2.1 --name public-subnet xxxxxxxxxx 10.0.2.225/27 -- --enable_dhcp=False

Invalid input for operation: Gateway is not valid on subnet.

I don't quite understand this, shouldn't 10.0.2.1 be the gateway for subnet 10.0.2.225/27?

2017-05-26 02:26:38 -0500 received badge  Popular Question (source)
2017-05-26 02:13:15 -0500 received badge  Student (source)
2017-05-26 00:49:55 -0500 received badge  Editor (source)
2017-05-26 00:47:45 -0500 commented question Cannot console into new created Openstack instance

hi Bernd, I asked a new question, could you have a look? https://ask.openstack.org/en/question/106999/how-to-set-up-openstack-localcon-in-virtual-box/ (https://ask.openstack.org/en/question...)

2017-05-26 00:46:39 -0500 asked a question how to set up openstack local.conf in virtual box

Hi all, I installed Openstack Mitaka using devstack for many times and there were always some bugs. I think it has something to do with the initial network set up.

For virtual box, I added a new host-only network "vboxnet0" with configures:

IPv4:192.168.56.1

IPv4 network mask: 255.255.255.0

Disable DHCP server (the NAT network enabled DHCP)

And for the virtual machine I created, I used Ubuntu 14.04 Desktop, with network configures:

Adapter 1: NAT

Adapter 2: Host-only adapter - vboxnet0.

Then after virtual machine initialisation and basic update, I got:

>>ifconfig
lo - 127.0.0., Mask: 255.0.0.0, scope: host
eth0 - 10.0.2.15, Mask: 255.255.255.0, scope: link
eth1 - 0.0.0.1., Mask: 0.0.0.0, scope: link

So how should I set the devstack/local.conf file? I tried to install devstack without setting it but after I created an instance, I could't console into the instance. And also the instance got an IP like 174.24.4.x, which is quite weird because I thought it should be something like 10.0.0.x.

2017-05-24 21:26:29 -0500 asked a question Cannot console into new created Openstack instance

I installed Openstack Mitaka using Devstack on an Ubuntu virtual machine in Virtualbox. After installation, things seemed to be alright. Then I start a new Cirros instance, and it succeeded. However, when I tried to console this instance using ip nets exec xxxxxx ssh cirros@172.24.4.3 it returned ssh: connect to host 172.24.4.3 port 22: no route to host. Result for ip nets exec xxxxxx ping 172.24.4.3 is Destination Host Unreachable.

I checked the ip netsh, the result includes:

qrouter-xxxxxxx

qdhcp-xxxxxx

If I use ip nets exec qrouter-xxxxxx ip addr show , the result includes:

127.0.0.1, 10.0.0.1, 172.24.4.2, and another item with no ip address.

If I user ip nets exec qdhcp-xxxxxx ip addr show, the result includes:

127.0.0.1, 10.0.0.2

The instance is connected to public network as shown in Openstack Dashboard. And if I try to connect to the console in WebUI - Dashboard/Compute/Instances/xxxx/Console, there was an error shown on the page, saying:

    Error response. 
    Error code 404.Message: File not found.
    Error code explanation: 404 = Nothing matches the given URI.

So how can I console into the instances created by Openstack? Is it something to do with the network configuration?

Thank you for your answers in advance.

2017-05-24 21:26:29 -0500 asked a question Cannot console into new created Openstack instance

I installed Openstack Mitaka using Devstack on an Ubuntu virtual machine in Virtualbox. After installation, things seemed to be alright. Then I start a new Cirros instance, and it succeeded. However, when I tried to console this instance using ip nets exec xxxxxx ssh cirros@172.24.4.3 it returned ssh: connect to host 172.24.4.3 port 22: no route to host. Result for ip nets exec xxxxxx ping 172.24.4.3 is Destination Host Unreachable.

I checked the ip netsh, the result includes:

qrouter-xxxxxxx

qdhcp-xxxxxx

If I use ip nets exec qrouter-xxxxxx ip addr show , the result includes:

127.0.0.1, 10.0.0.1, 172.24.4.2, and another item with no ip address.

If I user ip nets exec qdhcp-xxxxxx ip addr show, the result includes:

127.0.0.1, 10.0.0.2

The instance is connected to public network as shown in Openstack Dashboard. And if I try to connect to the console in WebUI - Dashboard/Compute/Instances/xxxx/Console, there was an error shown on the page, saying:

    Error response. 
    Error code 404.Message: File not found.
    Error code explanation: 404 = Nothing matches the given URI.

So how can I console into the instances created by Openstack? Is it something to do with the network configuration?

Thank you for your answers in advance.