Ask Your Question

Harsha's profile - activity

2019-07-15 04:29:32 -0600 received badge  Student (source)
2018-06-04 08:43:17 -0600 received badge  Famous Question (source)
2018-06-04 08:43:17 -0600 received badge  Notable Question (source)
2018-04-04 03:05:02 -0600 received badge  Famous Question (source)
2017-06-01 11:21:06 -0600 received badge  Popular Question (source)
2017-05-19 07:00:39 -0600 received badge  Popular Question (source)
2017-05-17 04:17:10 -0600 received badge  Famous Question (source)
2017-05-09 01:52:24 -0600 commented question How to restore Openstack mysql database and to sync the database?

Thanks for the reply @Bernd Bausch. I tried restarting apache service, after that I'm getting this error An error occurred authenticating. Please try again later. After starting nova-api, I'm getting Failed to start nova-api.service: Unit nova-api.service is masked. this error, What may be issue

2017-05-08 04:19:59 -0600 asked a question How to restore Openstack mysql database and to sync the database?

Hello, I was running Openstack Newton on Ubuntu 16.04. Database is crashed because of some reason, I have mysql dump file now. I restored the mysql dump, but not able to sync mysql db. After restoring I tried to sync db using below commands for all services.

su -s /bin/sh -c "keystone-manage db_sync" keystone

su -s /bin/sh -c "glance-manage db_sync" glance

And same kind of commands for all other services. But I'm getting the error like

sh: 1: keystone-manage: not found

sh: 1: glance-manage: not found

What are the steps to restore, sync and to start all the services.

Please someone help me!!

2017-04-24 01:16:48 -0600 asked a question Error creating in load balancer "Error: source_type" and "Unable to launch load balancer"

I'm using Openstack Newton on top of Ubuntu 16.04, I have configured load balancer(lbaas) according to the Openstack documentation. After that, I'm able create load balancer through CLI, but it is not displaying in Horizon and if I try to create load balancer through the Horizon, I'm getting the error: source type and unable to create the load balancer. Please someone help me to resolve this issue?

Thanks in advance.

2017-04-20 04:59:45 -0600 received badge  Notable Question (source)
2017-04-20 01:44:06 -0600 received badge  Popular Question (source)
2017-04-20 01:12:01 -0600 commented answer Could not able start neutron-lbaasv2-agent

Thanks for the reply, I have already replaced this [existing service plugins] with existing service plugins i.e router. After doing that I'm getting the above errors.
Any prerequisites required to configure lbaasv2 and any other solution to resolve this.

2017-04-19 07:07:41 -0600 asked a question Could not able start neutron-lbaasv2-agent

I'm using Openstack Newton on Ubuntu 14.04. When I'm trying to start load balancer i.e lbaas v2 agent, I'm facing this issue.

2017-04-19 17:26:12.323 24871 INFO neutron.common.config [-] Logging enabled!
2017-04-19 17:26:12.323 24871 INFO neutron.common.config [-] /usr/bin/neutron-lbaasv2-agent version 9.2.0
2017-04-19 17:26:12.324 24871 WARNING stevedore.named [req-0cb0d983-92df-4aec-9267-abf5d02beb0b - - - - -] Could not load neutron_lbaas.drivers.haproxy.namespace_driver.HaproxyNSDriver
2017-04-19 17:27:12.548 24871 ERROR neutron.common.rpc [-] Timeout in RPC method get_ready_devices. Waiting for 40 seconds before next attempt. If the server is not down, consider increasing the rpc_response_timeout option as Neutron server(s) may be overloaded and unable to respond quickly enough.
2017-04-19 17:27:12.548 24871 WARNING neutron.common.rpc [-] Increasing timeout for get_ready_devices calls to 120 seconds. Restart the agent to restore it to the default value.
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager [-] Unable to retrieve ready devices
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager Traceback (most recent call last):
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/agent/agent_manager.py", line 151, in sync_state
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager     ready_instances = set(self.plugin_rpc.get_ready_devices())
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron_lbaas/agent/agent_api.py", line 34, in get_ready_devices
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager     return cctxt.call(self.context, 'get_ready_devices', host=self.host)
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/common/rpc.py", line 157, in call
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager     time.sleep(wait)
2017-04-19 17:27:52.744 24871 ERROR neutron_lbaas.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/oslo_utils/excutils.py", line 220, in __exit__

/etc/neutron/neutron.conf

service_plugins = [existing service plugins],neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2

service_provider = LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

/etc/neutron/lbaas_agent.ini

interface_driver = linuxbridge

Any changes need to be done in any file. How to resolve this issue? Please help me

2017-04-18 04:10:16 -0600 commented answer Instance creation fails (Block Device Mapping)

@Radhakrishnan RK @eblock I'm also facing the same issue. I'm beginner to Openstack, whether I should add those 3 lines manually or it is present in nova.conf defaultly?

2017-04-18 04:03:19 -0600 received badge  Famous Question (source)
2017-04-18 04:02:33 -0600 commented answer After rebooting server not able to access the floating IP of the instance?

@Bernd Bausch, Sure Stop all the neutron agents and neutron server. Kill all the dnsmasq process. Start all the neutron agents and server.

These steps worked for me.

2017-04-18 04:02:33 -0600 received badge  Commentator
2017-04-17 03:22:59 -0600 commented answer After rebooting server not able to access the floating IP of the instance?

Thanks.. the issue is resolved.

2017-04-10 06:21:20 -0600 commented answer metadata service not reachable from instance in neutron single flat provider network

Thanks, solution worked for me but after every reboot same steps to be followed. Any other permanent solution without restarting any services?

2017-04-10 06:17:37 -0600 commented answer After rebooting server not able to access the floating IP of the instance?

What changes you made in config files?

2017-04-10 05:20:11 -0600 commented answer All the nova services status are down and not displaying nova compute service

How can I invoke curl call from instance, I'm not getting the instance console it is showing error like server not found error in console?

2017-04-09 14:31:13 -0600 received badge  Notable Question (source)
2017-04-08 02:35:18 -0600 commented answer After rebooting server not able to access the floating IP of the instance?

Yeah..I tried with the cirros instance itself was working fine am able to ssh into that instance before restart, but after restarting servers..I'm not able to ping into that instance.

2017-04-08 02:24:06 -0600 commented question After rebooting server not able to access the floating IP of the instance?

@kuro..yes both internal and external ip remains same but not able to ping into that.. But I can ping the router IP

2017-04-07 18:13:41 -0600 received badge  Popular Question (source)
2017-04-07 07:40:41 -0600 asked a question After rebooting server not able to access the floating IP of the instance?

I'm running Openstack Newton, I configured a/c to Openstack documentation. Everything was working fine, I assigned floating IP to instances after that I'm able to ping and ssh into those instances. But after restarting the server I'm not able to ping into those instances( Floating IP was same ). I tried assigning other floating IP but after assigning also, I'm not able to communicate with those instances. External network:192.168.1.0/24 Internal network:10.10.11.0/24

Please help me resolve this issue!

2017-04-07 06:57:24 -0600 commented answer All the nova services status are down and not displaying nova compute service

The instance is having the same ip after rebooting also but not able ping to that instance. I have tried assigning other floating ip but after that also I'm not able ping other floating ip. Please help me to resolve this.

2017-04-07 06:32:49 -0600 commented answer All the nova services status are down and not displaying nova compute service

Thanks.I changed rabbitmq user pwd and allowed 5672 port through ufw after that it is working fine. I'm getting other issue,I have assigned floating ip for an instance, it was working fine I can able ping and ssh into that instance but after rebooting the server I'm not able to ping that instance.

2017-04-05 07:09:59 -0600 received badge  Notable Question (source)
2017-04-05 02:20:03 -0600 received badge  Enthusiast
2017-03-30 09:56:14 -0600 received badge  Popular Question (source)
2017-03-30 02:34:17 -0600 asked a question All the nova services status are down and not displaying nova compute service

Hi All, I'm beginner to openstack, I'm configuring openstack newton with 2 nodes. After configuring controller and compute node, It is getting nova compute service and all the nova services are enabled but it is in down state. How can I resolve this, please anyone help me!!

root@controller:/etc/nova# nova service-list +----+------------------+------------+----------+---------+-------+------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+------------+----------+---------+-------+------------+-----------------+ | 5 | nova-consoleauth | controller | internal | enabled | down | - | - | | 6 | nova-scheduler | controller | internal | enabled | down | - | - | | 7 | nova-conductor | controller | internal | enabled | down | - | - | +----+------------------+------------+----------+---------+-------+------------+---------------------

nova-compute.log

2017-03-29 17:05:31.678 5866 WARNING os_brick.initiator.connectors.remotefs [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] Connection details not present. RemoteFsClient may not initialize properly. 2017-03-29 17:05:31.721 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 1 seconds. Client port: None 2017-03-29 17:05:32.736 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 2 seconds. Client port: None 2017-03-29 17:05:34.753 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 4 seconds. Client port: None 2017-03-29 17:05:38.771 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 6 seconds. Client port: None 2017-03-29 17:05:44.789 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 8 seconds. Client port: None 2017-03-29 17:05:52.811 5866 ERROR oslo.messaging._drivers.impl_rabbit [req-e4048b13-8b89-460a-9d5e-2750e6a15720 - - - - -] [862cb83d-a4ed-4da2-ac1d-71a4a13dcd76] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 10 seconds. Client port: None

Please help me. Thanks in advance.

2017-03-30 02:34:17 -0600 commented answer All nova service list are in "down" state and there is no "nova-compute" service

Is this issue resolved for you. Because I'm also facing the same issue. please Can any one suggest other solution for resolving this issue.