Ask Your Question

student's profile - activity

2017-07-22 03:13:27 -0600 received badge  Famous Question (source)
2017-04-07 17:17:34 -0600 answered a question Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I found the problem it was /etc/nova/nova-compute.conf file where I had some random charachters. I think it was my configuration problem. I have different problem now.

2017-04-07 16:43:51 -0600 commented question OpenStack installation requirements

What do you mean you do not have provider network? And which steps are confusing for you?

2017-04-07 15:48:03 -0600 commented answer Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

You are right it is not allocation ratio it is no hypervisors available. There is nothing in the nova hypervisor list -> http://paste.openstack.org/show/605781/

But I do not know what can cause an issue

2017-04-07 15:46:40 -0600 commented answer Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I only have one device - controller node (no compute nodes) but I did find what is an issue. However I do not know how to fix it - Nova do not have any hypervisors, the table is empty. This is what it shows: http://paste.openstack.org/show/605781/

2017-04-07 10:58:57 -0600 received badge  Famous Question (source)
2017-04-06 17:12:24 -0600 received badge  Notable Question (source)
2017-04-06 13:48:43 -0600 received badge  Popular Question (source)
2017-04-06 13:47:59 -0600 commented answer Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I would like to avoid using ready solutions, especially when I am that close to actually running it. This is the last thing which is stopping me from running it.

2017-04-06 12:45:43 -0600 commented question Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

Here is my nova-scheduler.log file: http://paste.openstack.org/show/605647/

and errors from nova-conductor.log http://paste.openstack.org/show/605649/

2017-04-06 10:21:32 -0600 asked a question Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-statsIt seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-showproves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/ and errors from nova-conductor.log http://paste.openstack.org/show/605649/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

edit:

This is what probably causing an issue no hypervisors available in Nova, still I do not know how to solve this problem.

nova hypervisor-list http://paste.openstack.org/show/605781/

2017-04-06 09:56:08 -0600 received badge  Famous Question (source)
2017-04-02 09:38:56 -0600 received badge  Notable Question (source)
2017-03-31 16:07:45 -0600 answered a question Neutron: Unable to create the network.

I have fixed it by following a youtube video:

edit /etc/neutron/plugins/ml2/ml2_conf.ini

in the [ml2] section

I had (based on the installation help from OpenStack documentation)

type_drivers = flat,vlan

i did add vxlan

so it looks like this now

type_drivers = flat,vlan,vxlan

then in the [ml2 _type_ vxlan] section I did specify the vni_ranges

vni_ranges = 1:1000

Restarted all neutron services (probably you need to restart only neutron-server)

# service neutron-server restart
# service neutron-linuxbridge-agent restart
# service neutron-dhcp-agent restart
# service neutron-metadata-agent restart

and then created test network using command line:

neutron net-create some-network-name

Then I have created network using horizon dashboard, where I gave all details to network and it worked!

(I came up to another error when trying to lanuch an instance

[Error: No valid host was found. There are not enough hosts available.]

But probably it is not related to Neutron)

2017-03-31 09:32:25 -0600 received badge  Popular Question (source)
2017-03-30 14:05:23 -0600 asked a question Neutron: Unable to create the network.

I am running Newton on Ubuntu 16.04.

I did Install everything properly and I haven't had any issues during installation neutron.

When I am trying to add network using horizon dashboard or using command line I have an error:

Error: Failed to create network "Network 1": Unable to create the network. 
No tenant network is available for allocation. 
Neutron server returns request_ids: ['req-c1ef9fb9-2b9f-467b-9f54-e597cadd1a3f']

I was trying to add to Neutron - neutron.conf

core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
service_plugins=neutron.services.l3_router.l3_router_plugin.L3RouterPlugin

Then Restart services

here is some of mine logs

neutron ext-list
+---------------------------+---------------------------------+
| alias                     | name                            |
+---------------------------+---------------------------------+
| default-subnetpools       | Default Subnetpools             |
| availability_zone         | Availability Zone               |
| network_availability_zone | Network Availability Zone       |
| binding                   | Port Binding                    |
| agent                     | agent                           |
| subnet_allocation         | Subnet Allocation               |
| dhcp_agent_scheduler      | DHCP Agent Scheduler            |
| tag                       | Tag support                     |
| external-net              | Neutron external network        |
| flavors                   | Neutron Service Flavors         |
| net-mtu                   | Network MTU                     |
| network-ip-availability   | Network IP Availability         |
| quotas                    | Quota management support        |
| provider                  | Provider Network                |
| multi-provider            | Multi Provider Network          |
| address-scope             | Address scope                   |
| subnet-service-types      | Subnet service types            |
| standard-attr-timestamp   | Resource timestamps             |
| service-type              | Neutron Service Type Management |
| extra_dhcp_opt            | Neutron Extra DHCP opts         |
| standard-attr-revisions   | Resource revision numbers       |
| pagination                | Pagination support              |
| sorting                   | Sorting support                 |
| security-group            | security-group                  |
| rbac-policies             | RBAC Policies                   |
| standard-attr-description | standard-attr-description       |
| port-security             | Port Security                   |
| allowed-address-pairs     | Allowed Address Pairs           |
| project-id                | project_id field enabled        |
+---------------------------+---------------------------------+

openstack network agent list:

http://paste.openstack.org/show/604908/

content of neutron.conf:

http://paste.openstack.org/show/604910/

neutron-server.service - OpenStack Neutron Server && ps -ef | grep neutron-server:

http://paste.openstack.org/show/604907/

2017-03-30 13:39:04 -0600 answered a question Openstack Ocata installation on Ubuntu 16.04

It looks like you are missing:

. admin-openrc

to pass credentials details to make it working, before issuing your command

2017-03-28 08:54:14 -0600 received badge  Notable Question (source)
2017-03-28 08:42:32 -0600 answered a question Unable to establish connection to keystone endpoint. horizon dashboard

Thanks to robcresswell at OpenStack IRC I did realize I made a mistake in my config file at line 22

OPENSTACK_HOST = "192.168.100"

Tested - Working. Thanks all for input.

2017-03-28 08:25:45 -0600 received badge  Popular Question (source)
2017-03-28 06:20:57 -0600 commented answer ssh from openstack VM to host

You need to change it in your host machine network settings. What OS are you using as your base OS which is running VM?

2017-03-28 06:18:58 -0600 received badge  Organizer (source)
2017-03-28 06:16:55 -0600 received badge  Editor (source)
2017-03-28 06:15:00 -0600 received badge  Autobiographer
2017-03-28 04:19:04 -0600 asked a question Unable to establish connection to keystone endpoint. horizon dashboard

I am using ubuntu 16.04 updated to latest version and OpenStack Newton.

I was installing openstack and I am in last step of horizon - verification. I am trying to logging to horizon via my browser. I have an error saying "Unable to establish connection to keystone endpoint." While accesing on my.ip/horizon I can access my.ip which dsiplays apache page.

I don't see any errors in keystone or MySQL logs only in glance but I don't think this should affect it anyway. Services ha been restarted and then I have rebooted the machine

There is only one machine - controller.

This device is using static IP address in my network.

some log data here:

    netstat -lntp |  grep 5000
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp6       0      0 :::5000                 :::*                    LISTEN      -



Error in File: glance-api.log
2017-03-26 14:24:22.759 2552 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data

Error in File: keystone-wsgi-admin.log
2017-03-26 15:10:51.830 1592 WARNING keystone.common.wsgi [req-1b8252f3-fee2-4ada-86dd-8bedc8c6df56 94a84610405d4b3abc88f7415ee3618a 2e2b6f6a330f4ceca5ceff76aafd6938 - default default] Could not find service: network

content of my /etc/openstack-dashboard/local_settings.py

http://paste.openstack.org/show/604435

2017-03-28 04:19:04 -0600 commented question I am unable to launch the instance

Is it on the node or on the controller machine? Are you launching instance using Horizon or is it even when using command line? Make sure your IP configuration is correct and you are not using DHCP for the Openstack machines.

2017-03-28 04:19:04 -0600 asked a question Unable to establish connection to keystone endpoint.

I was installing openstack and I am in last step of horizon - verification. I am trying to logging to horizon via my browser. I have an error saying "Unable to establish connection to keystone endpoint." While accesing on my.ip/horizon I can access my.ip which dsiplays apache page. I don't see any errors in keystone or MySQL logs only in glance but I don't think this should affect it anyway. Services ha been restarted and then whole machine has rebooted. There is only one machine - controller. This device is using static IP address in my network.

some log data here:

    netstat -lntp |  grep 5000
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp6       0      0 :::5000                 :::*                    LISTEN      -



File: glance-api.log
2017-03-26 14:24:22.759 2552 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data

File: keystone-wsgi-admin.log
2017-03-26 15:10:51.830 1592 WARNING keystone.common.wsgi [req-1b8252f3-fee2-4ada-86dd-8bedc8c6df56 94a84610405d4b3abc88f7415ee3618a 2e2b6f6a330f4ceca5ceff76aafd6938 - default default] Could not find service: network
2017-03-27 11:10:10 -0600 received badge  Supporter (source)