Ask Your Question

exp5566's profile - activity

2018-03-13 10:30:13 -0500 received badge  Popular Question (source)
2018-03-13 10:30:13 -0500 received badge  Famous Question (source)
2018-03-13 10:30:13 -0500 received badge  Notable Question (source)
2018-01-31 13:50:55 -0500 received badge  Notable Question (source)
2018-01-18 09:16:33 -0500 received badge  Famous Question (source)
2018-01-18 09:16:33 -0500 received badge  Notable Question (source)
2017-09-19 19:13:14 -0500 received badge  Popular Question (source)
2017-09-11 03:34:28 -0500 asked a question kernel: vxlan: non-ECT from IP_ADDRESS with TOS=0x2

In our lab environment, we found these weird log in /var/log/messages

kernel: vxlan: non-ECT from IP_ADDRESS with TOS=0x2

This is kind of annoying messages and also, the vxlan tunnel networking would go wrong randomly. e.g. router: 192.168.100.1 vm1: 192.168.100.7 vm1: 192.168.100.8 private subnet connection between VMs is good (192.168.100.7 <---> 192.168.100.8)

but VM to router is no good ( 192.168.100.7 x 192.168.100.1) ( 192.168.100.8 x 192.168.100.1)

I've checked overlay network ip at compute node & network node is good (at least icmp) & neutron-l3-agent is up & running( other router can work normally)

So this is weird to us, why these troubled VMs could reach other but router?

Any advise is much appreciated.

2017-09-11 03:33:07 -0500 received badge  Popular Question (source)
2017-06-30 02:37:32 -0500 received badge  Scholar (source)
2017-06-30 02:30:21 -0500 commented answer Liberty Heat using Lbaasv2

Thanks for the fast reply. The situation is getting quite tricky.

2017-06-29 02:42:36 -0500 asked a question Liberty Heat using Lbaasv2

Heat support lbaasv2 in Mitaka. But our environment is Liberty & lbassV2

I install mitaka heat & upgrade osprofiler on my controller node but heat-api-cfn.log keep showing error msg


    2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/bin/heat-api-cfn", line 10, in <module>
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     sys.exit(main())
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/heat/cmd/api_cfn.py", line 57, in main
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     app = config.load_paste_app()
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/heat/common/config.py", line 439, in load_paste_app
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     app = wsgi.paste_deploy_app(conf_file, app_name, cfg.CONF)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/heat/common/wsgi.py", line 1088, in paste_deploy_app
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     return deploy.loadapp("config:%s" % paste_config_file, name=app_name)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     return loadobj(APP, uri, name=name, **kw)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     return context.create()
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     return self.object_type.invoke(self)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 204, in invoke
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     filters = [c.create() for c in context.filter_contexts]
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     return self.object_type.invoke(self)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 161, in invoke
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     context.global_conf, **context.local_conf)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 58, in fix_call
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     reraise(*exc_info)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/compat.py", line 23, in reraise
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     exec('raise t, e, tb', dict(t=t, e=e, tb=tb))
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn   File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 55, in fix_call
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn     val = callable(*args, **kw)
2017-06-29 12:01:40.687 32500 ERROR heat-api-cfn TypeError: factory() takes exactly 3 arguments (2 given); got ...
(more)
2017-02-21 00:07:10 -0500 received badge  Enthusiast
2017-02-17 13:16:28 -0500 asked a question cloud init multiple NICs in Ubuntu and CentOS

Hi everyone, I am working on the cloud init setting for ubuntu & centos cloud images .

Environment:

  • machine: 3 controller + 2 network + 2 compute Liberty

  • setting: user-data + config drive + template from this web http://blog.oddbit.com/2015/06/26/openstack-networking-without-dhcp/ (http://blog.oddbit.com/2015/06/26/ope...)

  • network: pub-network(flat) + private (vxlan) cloud-img: CentOS1701, Ubuntu1604

Test:

  1. both pub & pri network disable dhcp, the network interfaces would grow in interface.d or network-script/, but sometimes failed in CentOS
  2. both pub & pri network enable dhcp, the network interfaces would grow only in interface.d on Ubuntu; the root login, ssh seems fine for CentOS, but network interfaces no good. Also, couldn't curl http://169.254.169.254/openstack

because log shows as below


CentOS Linux 7 (Core)
Kernel 3.10.0-514.6.1.el7.x86_64 on an x86_64

localhost login: [  303.352248] cloud-init[780]: Cloud-init v. 0.7.5 running 'init' at Fri, 17 Feb 2017 09:45:05 +0000. Up 303.31 seconds.
[  303.373464] cloud-init[780]: ci-info: +++++++++++++++++++++++Net device info++++++++++++++++++++++++
[  303.373788] cloud-init[780]: ci-info: +--------+-------+-----------+-----------+-------------------+
[  303.374167] cloud-init[780]: ci-info: | Device |   Up  |  Address  |    Mask   |     Hw-Address    |
[  303.374482] cloud-init[780]: ci-info: +--------+-------+-----------+-----------+-------------------+
[  303.374804] cloud-init[780]: ci-info: |  lo:   |  True | 127.0.0.1 | 255.0.0.0 |         .         |
[  303.375152] cloud-init[780]: ci-info: | eth1:  | False |     .     |     .     | fa:16:3e:56:62:6d |
[  303.375471] cloud-init[780]: ci-info: | eth0:  |  True |     .     |     .     | fa:16:3e:42:2d:b2 |
[  303.375790] cloud-init[780]: ci-info: +--------+-------+-----------+-----------+-------------------+
[  303.376136] cloud-init[780]: ci-info: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!Route info failed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[  304.668380] cloud-init[2576]: Cloud-init v. 0.7.5 running 'modules:config' at Fri, 17 Feb 2017 09:45:07 +0000. Up 304.58 seconds.
[  305.133694] cloud-init[3181]: Cloud-init v. 0.7.5 running 'modules:final' at Fri, 17 Feb 2017 09:45:07 +0000. Up 305.04 seconds.

=================================

Any one has ideas about how to deal with the network configuration for CenOS cloud img? The time it take a couple minutes