Ask Your Question

Damian Dąbrowski's profile - activity

2019-10-13 16:21:55 -0600 received badge  Notable Question (source)
2019-10-13 16:21:55 -0600 received badge  Famous Question (source)
2019-08-14 04:23:27 -0600 received badge  Notable Question (source)
2019-08-14 04:23:27 -0600 received badge  Popular Question (source)
2019-08-13 10:11:32 -0600 answered a question ERROR: The Parameter (octavia_ingress_controller_tag) was not defined in template

same problem here

2019-07-16 23:54:46 -0600 received badge  Famous Question (source)
2019-07-16 23:54:46 -0600 received badge  Notable Question (source)
2019-07-16 23:54:46 -0600 received badge  Popular Question (source)
2019-05-29 07:01:30 -0600 received badge  Famous Question (source)
2019-02-15 10:10:57 -0600 received badge  Popular Question (source)
2019-02-15 10:10:57 -0600 received badge  Famous Question (source)
2019-02-15 10:10:57 -0600 received badge  Notable Question (source)
2019-02-15 07:48:02 -0600 received badge  Popular Question (source)
2019-02-07 16:38:54 -0600 asked a question Choosing right deployment method

Hello,

I've looked for any up-to-date deployment method comparison or anything that could help me make a right decision but unfortunately I haven't found anything.

I've some experience with Openstack, currently I have my production enviroment based on mirantis fuel, but they abandoned this project and support will end this year.

I'm looking for something new, my main requirements for deployment method are:

  • based on ansible(because my team already have experience with it)
  • production ready templates for many openstack components
  • easy customization
  • easy upgrades with short downtime(or no downtime at all)
  • has good monitoring system supplied out-of-the-box
  • is constantly being developed

Additional advantage will be possibility to automatically install operating system on openstack nodes

So I think I have to choose one of:

  • kolla using ansible in docker containers
  • openstack ansible
  • TripleO

I would be very grateful if someone could describe differences between this methods and help me to make right decision.

Thanks for any help.

2019-01-22 04:52:16 -0600 received badge  Famous Question (source)
2019-01-21 02:47:53 -0600 received badge  Popular Question (source)
2019-01-21 02:47:53 -0600 received badge  Notable Question (source)
2019-01-21 02:47:53 -0600 received badge  Famous Question (source)
2018-12-01 13:44:07 -0600 commented answer nova ceph copy-on-write images doesn't work even if it's configured to

Hi eblock, I apologize for the long response time. Yeah, all my images are raw and still it doesn't work.I've just abandoned this case because in few month I'll switch from mitaka to latest release and hope this will start to work properly.

2018-09-12 15:53:53 -0600 received badge  Famous Question (source)
2018-09-12 15:53:53 -0600 received badge  Notable Question (source)
2018-08-31 07:24:57 -0600 received badge  Famous Question (source)
2018-08-31 07:24:57 -0600 received badge  Notable Question (source)
2018-08-22 08:02:19 -0600 answered a question Can I attach many network interfaces to one instance ?

it's not an openstack problem, but routing problem.

look there: https://blog.ls-al.com/linux-routing-...

or there: https://access.redhat.com/solutions/3...

or probably you can try with network namespaces

2018-07-29 07:43:15 -0600 asked a question block non-admin user to grant admin role

Hello,

I want to create multi-domain environment. Domain admins will have role "DomainAdmin".

From keystone view: DomainAdmin have same rights as admin(done by "admin_required": "role:admin or role:DomainAdmin" in policy.json

It was solved this way because other projects(like nova or neutron) doesn't care about domains and I don't want domain admins to be treated like global admins. This users should only have privileges to create projects&users in their own domain.

And all would be fine, but "DomainAdmin" can assign "admin" role to anyone which causes a high security risk.

Maybe someone know any way, to prevent this situation? I would be very grateful for any help

2018-07-29 04:48:13 -0600 received badge  Notable Question (source)
2018-07-25 09:57:02 -0600 commented question Run custom script after executing specified API call

Bernd, thanks for reply.

Finally, I've decided to use solution based on rabbitmq notifications described here: http://alesnosek.com/blog/2015/05/25/...

2018-07-17 09:46:16 -0600 received badge  Popular Question (source)
2018-07-16 16:43:16 -0600 asked a question Run custom script after executing specified API call

Hello,

I'm looking for the simplest way to run custom script after executing specified API call.

For example: when anybody create new project, system will run my custom script.

It would be great if my script will be only executed if project creation completed successfully. (but i think it could be hard due to asynchrony in openstack API).

I would be grateful for any help.

2018-07-06 04:32:19 -0600 received badge  Popular Question (source)
2018-07-06 04:32:19 -0600 received badge  Notable Question (source)
2018-07-06 04:32:19 -0600 received badge  Famous Question (source)
2018-07-06 04:32:18 -0600 received badge  Student (source)
2018-06-18 01:06:08 -0600 received badge  Popular Question (source)
2018-06-11 09:57:39 -0600 commented answer flavors & images public only inside specified domain

Ok, now I understand, Thank You Bernd!

2018-06-11 09:57:26 -0600 answered a question flavors & images public only inside specified domain

Ok, now I understand, Thank You Bernd!

2018-06-10 12:52:14 -0600 asked a question flavors & images public only inside specified domain

Hello,

I'd like to start using multi-domain support, unfortunately I can't find any solution to make flavors&images public, but only inside specified domain.

Maybe someone know whether it is possible at all?

I would be very grateful for any help.

2018-06-08 10:42:06 -0600 received badge  Famous Question (source)
2018-06-08 10:42:06 -0600 received badge  Notable Question (source)
2018-06-08 06:05:44 -0600 received badge  Notable Question (source)
2018-06-07 02:00:58 -0600 received badge  Popular Question (source)
2018-06-06 11:59:06 -0600 asked a question seperate bandwidth limits for public and private networks

Hello,

For each flavor I want to assign seperate bandwidth limit for external and private networks.

Unfortunately, when I set Virtual Interface QoS to flavor, the limit applies for each interface connected to the VM, no matter if it is public or private.

I've came up with this idea:

  • assign virtual interface QoS to flavor, which will be limit for private network(which will be always bigger than for public network) - this will be default limit for all instance interfaces

  • for public network QoS: create own mechanism which will match the ports to the instances to which they are connected, and assign suitable QoS policy to these ports based on their instance flavor.

It will probably work, but seems to be very complicated.

Maybe You know any simpler way to implement this?

I will be very grateful for any answers.

2018-05-16 05:43:16 -0600 marked best answer instance boot halting for few minutes

Hello,

Every time when i boot or hard reboot server(problem doesn't occur on soft reboot), instance is on "active" state, but for system boot i need to wait few minutes. What i see in VNC depends on used image:

  • for ubuntu cloud image i see "booting from Hard Disk..."
  • for debian cloud image i see "booting from Hard Disk.." and below "SYSLINUX 6.03 EED[...]"
  • for ubuntu server install ISO i see blank purple screen

Few facts:

  • when machine finally starts i don't see any unstable IO, all works fine
  • I'm using openstack with ceph backend for cinder.
  • ceph health is ok, all hardware are brand new
  • i don't see anything interesting in libvirt logs but you can read them here: https://pastebin.com/raw/mqtbYX9u

Maybe someone supposes what's going on or know how to debug this problem? I've stuck with this for almost a week :/ I would be grateful for any help.

2018-05-16 05:43:13 -0600 commented answer instance boot halting for few minutes

You were right, problem was caused by too low MTU on ceph MON.

Thanks for help!

2018-05-15 02:12:50 -0600 received badge  Famous Question (source)