Ask Your Question

nebukazar's profile - activity

2017-09-11 14:49:07 -0500 commented question Can't force delete an instance

Bump, anyone ?

2017-08-31 11:03:26 -0500 commented answer Can't force delete an instance

Bump anyone ?

2017-08-08 13:54:52 -0500 answered a question Can't force delete an instance

Bump! I would really need some guidance on this one, any help would be appreciated!

2017-07-25 08:38:05 -0500 received badge  Famous Question (source)
2017-07-16 04:48:15 -0500 received badge  Notable Question (source)
2017-07-14 08:34:22 -0500 received badge  Popular Question (source)
2017-07-14 07:23:56 -0500 commented answer Can't force delete an instance

I'm using hyperv for the compute nodes. As for deleting the entries in the mysql db; what would be the exact entries ? I don't want to create any discrepancies as said previously. Thanks!

2017-07-13 13:43:28 -0500 asked a question Can't force delete an instance

Hi,

We are currently running a Packstack Ocata infrastructure. We do have 3 nodes running on Win2016 datacenter. We're currently using cloudbase's nova, neutron, ceilometer drivers on these nodes.

So far, the deployment is working well. Instance deletion is working fine as well, except for one instance where the image is no longer available / deleted. Therefore, doing a "nova delete" or even a "nova force delete" won't work. The instance stalls in a deletion process; even if we reset the state of the instance to active and try to re-delete/force delete the instance.

Would there be a way to remove the instance ? We've seen some solutions that requires to update some entries in the mysql nova db; but these date back from older version. We wouldn't want to have DB discrepancies.

Your help would be greatly appreciated.

Thanks!

2017-06-29 05:52:30 -0500 received badge  Famous Question (source)
2017-06-16 17:22:29 -0500 received badge  Famous Question (source)
2017-05-08 22:33:37 -0500 received badge  Notable Question (source)
2017-05-05 08:45:20 -0500 commented answer aodh alarm threshold not supported

I've made some progress... I found out that I have to use the "gnocchi_aggregation_by_resources_threshold" type when creating the aodh alarm. However, I'm still unable to provide my cluster_ID to the alarm's query as the resource-type provided is "instance" - is there a way to provide a cluster_id ?

2017-05-04 10:53:48 -0500 answered a question Neutron Router - Not working

Silly me... ethX devices had to be brought online.. for some reason, they weren't!

2017-05-03 23:51:45 -0500 received badge  Popular Question (source)
2017-05-03 04:19:05 -0500 received badge  Notable Question (source)
2017-05-02 12:17:51 -0500 asked a question Neutron Router - Not working

Hi,

I am currently testing out OpenStack using a packstack AIO installation, however, I'm having a hard time to get networking up and running. The packstack instance is running on a CentOS 7.3 hyperv guest with 6x NICs connected:

  • eth0 = openstack data/management network
  • eth1 = controller management ip
  • eth2 = br-public-network
  • eth3 = br-local-network
  • eth4 = br-load-balancing-network
  • eth5 = br-del-corp

I'm using OpenVSwitch and therefore, created the following bridges before running the packstack installer:

ovs-vsctl add-br br-public-network ; ovs-vsctl add-port br-public-network eth2
ovs-vsctl add-br br-local-network ; ovs-vsctl add-port br-local-network eth3
ovs-vsctl add-br br-load-balancing-network ; ovs-vsctl add-port br-load-balancing-network eth4
ovs-vsctl add-br br-del-corp ; ovs-vsctl add-port br-del-corp eth5

My packstack's answer file has the following details in regards to neutron/ovs:

CONFIG_NEUTRON_L3_EXT_BRIDGE=br-public-network
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vlan,flat
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vlan
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=openvswitch,hyperv
CONFIG_NEUTRON_ML2_FLAT_NETWORKS=*
CONFIG_NEUTRON_ML2_VLAN_RANGES=physnet1,physnet2:500:2000,physnet3:2010:3010
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=
CONFIG_NEUTRON_ML2_VXLAN_GROUP=
CONFIG_NEUTRON_ML2_VNI_RANGES=10:100
CONFIG_NEUTRON_L2_AGENT=openvswitch
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-public-network,physnet2:br-local-network,physnet3:br-load-balancing-network
CONFIG_NEUTRON_OVS_EXTERNAL_PHYSNET=physnet1

I've been able to create and use the following networks:

  • public-network, physnet1 (flat), no router, public routeable cidr subnet, no dhcp
  • private-network, physnet2 (vlan id: 501), no router, local non-routeable cidr subnet (10.0.10.0/24), no dhcp

Both networks are working fin. I can spin up instances and they can communicate to either the external network (eg: Internet) or the local network.

Now, when it comes to creating a public network that would be used for load balancing projects and therfore, would be providing a neutron router, this is where it becomes problematic... I'm creating the "load balancing network" using the following commands:

neutron net-create --provider:network_type=vlan --provider:physical_network=physnet3 --router:external=True PUBLIC-CLUSTER-NETWORK
neutron subnet-create PUBLIC-CLUSTER-NETWORK PUBLIC_CIDR_HERE/27 --gateway GW_IP_HERE --allocation-pool start=IP_START_HERE,end=IP_END_HERE --disable-dhcp --name PUBLIC-CLUSTER-SUBNET --dns-nameservers list=true 8.8.8.8 4.2.2.2
neutron router-create ROUTER-PUBLIC-CLUSTER-NETWORK
neutron router-gateway-set ID_ROUTER ID_NETWORK

Then, I'm creating a "local cluster network" that would be using the router created above:

neutron net-create --provider:network_type=vlan --provider:physical_network=physnet2 CLIENT0001-CLUSTER-NETWORK --tenant-id=e0f7fb96271f48588e2aac86d66ae42e
neutron subnet-create CLIENT0001-CLUSTER-NETWORK 192.168.23.0/24 --name CLIENT0001-CLUSTER-SUBNET --dns-nameservers list=true 8.8.8.8 4.2.2.2 --disable-dhcp
neutron router-interface-add ID_ROUTEUR ID_CLIENT_SUBNET

Result in the Neutron router IP configuration is:

# ip netns exec qrouter-78ab8780-6282-4b8b-b840-b92ba0916e62 ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
14: qg-0f38cb25-ae: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:76:7d:63 brd ff:ff:ff:ff:ff:ff
    inet 198.xxx.xxx.61/27 brd 198.xxx.xxx.63 scope global qg-0f38cb25-ae
       valid_lft forever preferred_lft forever
    inet6 xxxxxx/64 scope link
       valid_lft forever preferred_lft forever
15: qr-b4c68450-23: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:53:48:5f brd ff:ff:ff:ff:ff:ff
    inet ...
(more)
2017-05-01 09:29:12 -0500 answered a question aodh alarm threshold not supported

I've made some progess... I found out that I have to use the "gnocchi_aggregation_by_resources_threshold" type when creating the aodh alarm. However, I'm still unable to provide my cluster_ID to the alarm's query as the resource-type provided is "instance". Gnocchi doesn't seem to be providing a resource type for senlin cluster... Would I need to create the resource type manually ?

# aodh alarm create \
>   -t gnocchi_aggregation_by_resources_threshold --name cpu-high \
>   --metric cpu_util --threshold 5 --aggregation-method sum --comparison-operator ge --resource-type instance \
>   --period 60 --evaluation-periods 1 \
>   --alarm-action $ALRM_URL01 \
>   --repeat-actions False \
>   --query '{"=": {"cluster_id": "$MYCLUSTER_ID"}}'
Resource type instance has no cluster_id attribute (HTTP 400) (Request-ID: req-3292a595-67b2-4dc7-8858-338fb3da1344)

Thanks!

2017-05-01 03:37:48 -0500 received badge  Popular Question (source)
2017-04-29 21:53:53 -0500 received badge  Editor (source)
2017-04-29 21:41:11 -0500 received badge  Famous Question (source)
2017-04-29 21:37:52 -0500 asked a question aodh alarm threshold not supported

Hi,

We installed Packstack Ocata a few days ago and are currently testing auto-scaling through senlin/heat/ceilometer/aodh. We are able to create the cluster; nodes are being created, receiver is being created as well. The alarm is still being created with no issues; at least, we're not getting any error messages.

However, by taking a look at the the aodh's evaluator.log logfile, we're seeing the following error message:

2017-04-29 22:26:03.564 3380 WARNING aodh.evaluator.threshold [-] This telemetry installation is not configured to support alarm of type 'threshold', they should be disabled or removed.

We're stress-testing the 2 instances created by the cluster with CPUs usage averaging @ 96-100%, however, the alarm doesn't seem to be triggered.

By testing the receiver URL directly through curl, we're still able to manually trigger the receiver and therefore we're able to automatically add new instances to the senlin cluster.

When querying aodh directly; we're still seeing the alarm state at "insufficient data":

# aodh alarm list
+--------------------------------------+-----------+----------+-------------------+----------+---------+
| alarm_id                             | type      | name     | state             | severity | enabled |
+--------------------------------------+-----------+----------+-------------------+----------+---------+
| 9129ee5c-ae8e-4514-9736-a28d25f25b15 | threshold | cpu-high | insufficient data | low      | True    |
+--------------------------------------+-----------+----------+-------------------+----------+---------+

Not sure if this should be a "normal" behavior...

Does any one know what might be the problem ?

We're using:

  • Packstack AIO - Ocata;
  • CentOS 7.3 x64;
  • Senlin from GitHub repository, using the 'ocata' branch.

Which comes with the following RPMs:

openstack-heat-engine-8.0.0-1.el7.noarch
openstack-ceilometer-common-8.0.0-2.el7.noarch
openstack-ceilometer-collector-8.0.0-2.el7.noarch
openstack-aodh-common-4.0.0-1.el7.noarch
python-ceilometermiddleware-1.0.0-1.el7.noarch
openstack-heat-common-8.0.0-1.el7.noarch
openstack-ceilometer-central-8.0.0-2.el7.noarch
openstack-aodh-notifier-4.0.0-1.el7.noarch
puppet-heat-10.3.0-1.el7.noarch
puppet-aodh-10.3.0-1.el7.noarch
puppet-ceilometer-10.3.0-1.el7.noarch
openstack-heat-api-cloudwatch-8.0.0-1.el7.noarch
openstack-ceilometer-polling-8.0.0-2.el7.noarch
openstack-aodh-evaluator-4.0.0-1.el7.noarch
python2-ceilometerclient-2.8.0-1.el7.noarch
python2-aodhclient-0.8.0-1.el7.noarch
openstack-aodh-api-4.0.0-1.el7.noarch
openstack-heat-api-8.0.0-1.el7.noarch
python-ceilometer-8.0.0-2.el7.noarch
openstack-ceilometer-api-8.0.0-2.el7.noarch
openstack-aodh-listener-4.0.0-1.el7.noarch
openstack-heat-api-cfn-8.0.0-1.el7.noarch
openstack-ceilometer-notification-8.0.0-2.el7.noarch
python-aodh-4.0.0-1.el7.noarch
python2-heatclient-1.8.0-1.el7.noarch
2017-01-17 07:56:42 -0500 received badge  Notable Question (source)
2017-01-17 07:56:42 -0500 received badge  Popular Question (source)
2016-12-28 07:32:41 -0500 received badge  Enthusiast
2016-12-25 05:34:09 -0500 asked a question Ceilometer - No meters / stats ?

Hi,

We've been trying to install ceilometer on top of our RDO installation. We have been using the following documentation: http://docs.openstack.org/developer/c...

However, we are unable to collect any meters:

[root@rdo ~]# ceilometer meter-list
+------+------+------+-------------+---------+------------+
| Name | Type | Unit | Resource ID | User ID | Project ID |
+------+------+------+-------------+---------+------------+
+------+------+------+-------------+---------+------------+

The current ceilometer configuration file has the following for authentication:

[keystone_authtoken]
auth_uri = http://10.236.245.3:5000/v2.0
admin_password=CEILOMETER_USER_PASSWORD
identity_uri=http://10.236.245.3:35357
admin_tenant_name=services
admin_user=ceilometer

[service_credentials]
region_name=RegionOne
auth_url = http://10.236.245.3:5000
auth_type=password
password=CEILOMETER_USER_PASSWORD
project_name=services
tenant_name=services
username=ceilometer

The endpoint does exist:

[root@rdo ~]# openstack endpoint list
+----------------------------------+-----------+---------------+---------------+
| ID                               | Region    | Service Name  | Service Type  |
+----------------------------------+-----------+---------------+---------------+
| 2098f46dfa8e4f1c8989fd603b0e3cc0 | RegionOne | swift         | object-store  |
| 3291da5d4e014f0bb51ede83d97e6af5 | RegionOne | keystone      | identity      |
| 10484d7c3113484bb15b0463335b2073 | RegionOne | cinderv3      | volumev3      |
| b598245913fa4964869b4ee47a90464f | RegionOne | heat          | orchestration |
| 9442a363c28946f8a1b2bf3c9fe1bcce | RegionOne | neutron       | network       |
| c1873c87c9124d1a96904ebf4b0fef78 | RegionOne | novav3        | computev3     |
| fe06171a2cc94f4d89c0946a4b7511ff | RegionOne | nova          | compute       |
| b279efdb4d784a84a4055da091398edf | RegionOne | cinder        | volume        |
| d421a71d42a04f0dad0cc1aa982ebea8 | RegionOne | Image Service | image         |
| 60b7a4b71e434e3892793e6efd350c94 | RegionOne | ceilometer    | metering      |
| 7de135e5c14c47188dfd6b7aba5bb49b | RegionOne | cinderv2      | volumev2      |
+----------------------------------+-----------+---------------+---------------+

The DB doesn't seem to be containing any meters:

[root@rdo ~]# mongo 10.236.245.3
MongoDB shell version: 2.6.11
connecting to: 10.236.245.3/test
> use ceilometer
switched to db ceilometer
> db.meter.stats().count
0

I have pasted the errors found from the different ceilometer log files (/var/log/ceilometer/*) @ http://pastebin.com/4FyTYesK

Our hyperv node nova conf file has been modfied according to http://ask.cloudbase.it/question/654/...

We are still able to retrieve stats through PowerShell:

PS C:\Windows\system32> get-vm instance-0000001d|Enable-VMResourceMetering
PS C:\Windows\system32> get-vm instance-0000001d| measure-vm

VMName            AvgCPU(MHz) AvgRAM(M) MaxRAM(M) MinRAM(M) TotalDisk(M) NetworkInbound(M) NetworkOutbound(M)
------            ----------- --------- --------- --------- ------------ ----------------- ------------------
instance-0000001d 23          501       512       512       79           2                 2


PS C:\Windows\system32> get-vm instance-0000001d| measure-vm

VMName            AvgCPU(MHz) AvgRAM(M) MaxRAM(M) MinRAM(M) TotalDisk(M) NetworkInbound(M) NetworkOutbound(M)
------            ----------- --------- --------- --------- ------------ ----------------- ------------------
instance-0000001d 23          501       512       512       79           2                 2


PS C:\Windows\system32> get-vm instance-0000001d| measure-vm

VMName            AvgCPU(MHz) AvgRAM(M) MaxRAM(M) MinRAM(M) TotalDisk(M) NetworkInbound(M) NetworkOutbound(M)
------            ----------- --------- --------- --------- ------------ ----------------- ------------------
instance-0000001d 23          502       512       512       79           2                 2

Do you guys have any ideas what might be wrong ?

Please let me know if you guys need further information.

Thanks a lot !