devinacosta's profile - activity

2017-01-04 10:42:51 -0500 received badge  Famous Question (source)
2016-12-12 10:56:13 -0500 received badge  Famous Question (source)
2016-12-07 08:16:42 -0500 received badge  Notable Question (source)
2016-12-07 08:16:42 -0500 received badge  Popular Question (source)
2016-11-01 06:25:13 -0500 received badge  Notable Question (source)
2016-10-25 18:00:59 -0500 received badge  Popular Question (source)
2016-10-19 00:27:14 -0500 received badge  Famous Question (source)
2016-10-18 15:38:29 -0500 received badge  Famous Question (source)
2016-10-17 12:39:18 -0500 asked a question Newton / Launch Instance Create new Volume RBD fails.

I'm down to my very last issue with my upgrade to OpenStack, I am using Ceph for all my services for my backend and I notice that if i go to launch and instance and for the source I choose Image, and Create New Volume, then select the volume when it goes to launch it dies, and i see this error in my cinder logs?

400 Bad Request: Unknown scheme 'rbd' found in URI

I am able as my user from the command line to create volumes using: cinder create --display-name sample 1, and it will create a volume of 1GB in size.

 2016-10-17 10:10:09.111 431547 ERROR cinder.scheduler.filter_scheduler [req-f92812a9-9a23-47e0-bea0-a398af043e19 65463328d60a4e7bb16b84f5adfb4636 bb33fb34be514d21878c424cfe2e1ce7 - default default] Error scheduling None from last vol-service: jupiter.lnx.ninja@rbd#RBD : [u'Traceback (most recent call last):\n', u'  File "/usr/lib/python2.7/site-packages/taskflow/engines/action_engine/executor.py", line 53, in _execute_task\n    result = task.execute(**arguments)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/volume/flows/manager/create_volume.py", line 842, in execute\n    **volume_spec)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/volume/flows/manager/create_volume.py", line 761, in _create_from_image\n    image_service, context, image_id) as tmp_image:\n', u'  File "/usr/lib64/python2.7/contextlib.py", line 17, in __enter__\n    return self.gen.next()\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/image_utils.py", line 567, in fetch\n    fetch_verify_image(context, image_service, image_id, tmp)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/image_utils.py", line 212, in fetch_verify_image\n    None, None)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/image_utils.py", line 190, in fetch\n    image_service.download(context, image_id, image_file)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 335, in download\n    _reraise_translated_image_exception(image_id)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 572, in _reraise_translated_image_exception\n    six.reraise(type(new_exc), new_exc, exc_trace)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 333, in download\n    image_chunks = self._client.call(context, \'data\', image_id)\n', u'  File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 197, in call\n    return getattr(controller, method)(*args, **kwargs)\n', u'  File "/usr/lib/python2.7/site-packages/glanceclient/v1/images.py", line 148, in data\n    % urlparse.quote(str(image_id)))\n', u'  File "/usr/lib/python2.7/site-packages/glanceclient/common/http.py", line 287, in get\n    return self._request(\'GET\', url, **kwargs)\n', u'  File "/usr/lib/python2.7/site-packages/glanceclient/common/http.py", line 279, in _request\n    resp, body_iter = self._handle_response(resp)\n', u'  File "/usr/lib/python2.7/site-packages/glanceclient/common/http.py", line 107, in _handle_response\n    raise exc.from_response(resp, resp.content)\n', u"Invalid: 400 Bad Request: Unknown scheme 'rbd' found in URI (HTTP 400)\n"]
2016-10-17 10:10:10.017 431547 ERROR cinder.scheduler.filter_scheduler [req-f92812a9-9a23-47e0-bea0-a398af043e19 65463328d60a4e7bb16b84f5adfb4636 bb33fb34be514d21878c424cfe2e1ce7 - default default] Error scheduling None from last vol-service: jupiter.lnx.ninja ...
(more)
2016-10-17 05:07:48 -0500 received badge  Notable Question (source)
2016-10-17 02:19:04 -0500 received badge  Notable Question (source)
2016-10-17 00:59:33 -0500 received badge  Popular Question (source)
2016-10-16 23:14:30 -0500 received badge  Popular Question (source)
2016-10-16 19:07:58 -0500 asked a question Upgrade Liberty to Newton, Launch Instance (policy issue?)

I have been working all weekend on my migration from Mitaka to Newton. I have almost everything working the final issue I think I need to solve is when I go to launch an issue, Neutron gives the instance an IP address but then Nova freaks out about the policy i'm believing.

It complains about failing to notify Nova, however I have validated that i do have what i believe to be the correct settings in my neutron.conf to allow it to work?

2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova [-] Failed to notify nova on events: [{'tag': u'3b3c97ee-a05b-4388-af56-2f9b6379a429', 'name': 'network-vif-deleted', 'server_uuid': u'f92e14db-f356-4702-8fc7-335f4eadf155'}]
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova     raise exceptions.from_response(resp, method, url)
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova Unauthorized: The request you have made requires authentication. (HTTP 401) (Request-ID: req-00dd9bc3-264d-4a38-9517-6164ec7fa3cf)
2016-10-16 16:37:38.675 58844 ERROR neutron.notifiers.nova

I copied my old policy.json for Nova into the policy.json for Nova and that didn't fix the issue?

2016-10-16 18:52:56 -0500 asked a question Mitaka to Newton upgrade (Cinder complains ServiceTooOld)

I upgraded from Mitaka to Newton, and after the upgrade Cinder dies with, not sure what I need to do to correct issue so Cinder will start?

2016-10-14 15:41:32.431 1379701 INFO cinder.rpc [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version.
2016-10-14 15:41:32.438 1379701 INFO cinder.rpc [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] Automatically selected cinder-scheduler RPC version 3.0 as minimum service version.
2016-10-14 15:41:32.446 1379701 CRITICAL cinder [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] ServiceTooOld: One of the services is in Liberty version. We do not provide backward compatibility with Liberty now, you need to upgrade to Mitaka first.
2016-10-14 15:41:32.446 1379701 ERROR cinder Traceback (most recent call last):
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/bin/cinder-api", line 10, in <module>
2016-10-14 15:41:32.446 1379701 ERROR cinder     sys.exit(main())
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/cmd/api.py", line 60, in main
2016-10-14 15:41:32.446 1379701 ERROR cinder     server = service.WSGIService('osapi_volume')
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/service.py", line 499, in __init__
2016-10-14 15:41:32.446 1379701 ERROR cinder     self.app = self.loader.load_app(name)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/oslo_service/wsgi.py", line 353, in load_app
2016-10-14 15:41:32.446 1379701 ERROR cinder     return deploy.loadapp("config:%s" % self.config_path, name=name)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
2016-10-14 15:41:32.446 1379701 ERROR cinder     return loadobj(APP, uri, name=name, **kw)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
2016-10-14 15:41:32.446 1379701 ERROR cinder     return context.create()
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
2016-10-14 15:41:32.446 1379701 ERROR cinder     return self.object_type.invoke(self)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 144, in invoke
2016-10-14 15:41:32.446 1379701 ERROR cinder     **context.local_conf)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 55, in fix_call
2016-10-14 15:41:32.446 1379701 ERROR cinder     val = callable(*args, **kw)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/api/__init__.py", line 34, in root_app_factory
2016-10-14 15:41:32.446 1379701 ERROR cinder     return paste.urlmap.urlmap_factory(loader, global_conf, **local_conf)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/urlmap.py", line 25, in urlmap_factory
2016-10-14 15:41:32.446 1379701 ERROR cinder     app = loader.get_app(app_name, global_conf=global_conf)
2016-10-14 15:41:32.446 1379701 ERROR ...
(more)
2016-10-14 23:27:25 -0500 asked a question Cinder gives ServiceTooOld: One of the services is in Liberty version after upgrade.

I upgraded my Openstack from Mitaka to Newton this morning and now Cinder won't because it complains about some service being to old. Help anyone? :)

2016-10-14 15:41:32.431 1379701 INFO cinder.rpc [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version.
2016-10-14 15:41:32.438 1379701 INFO cinder.rpc [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] Automatically selected cinder-scheduler RPC version 3.0 as minimum service version.
2016-10-14 15:41:32.446 1379701 CRITICAL cinder [req-9b1d2a01-2747-4320-beed-508481bd3d73 - - - - -] ServiceTooOld: One of the services is in Liberty version. We do not provide backward compatibility with Liberty now, you need to upgrade to Mitaka first.
2016-10-14 15:41:32.446 1379701 ERROR cinder Traceback (most recent call last):
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/bin/cinder-api", line 10, in <module>
2016-10-14 15:41:32.446 1379701 ERROR cinder     sys.exit(main())
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/cmd/api.py", line 60, in main
2016-10-14 15:41:32.446 1379701 ERROR cinder     server = service.WSGIService('osapi_volume')
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/service.py", line 499, in __init__
2016-10-14 15:41:32.446 1379701 ERROR cinder     self.app = self.loader.load_app(name)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/oslo_service/wsgi.py", line 353, in load_app
2016-10-14 15:41:32.446 1379701 ERROR cinder     return deploy.loadapp("config:%s" % self.config_path, name=name)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
2016-10-14 15:41:32.446 1379701 ERROR cinder     return loadobj(APP, uri, name=name, **kw)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
2016-10-14 15:41:32.446 1379701 ERROR cinder     return context.create()
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
2016-10-14 15:41:32.446 1379701 ERROR cinder     return self.object_type.invoke(self)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 144, in invoke
2016-10-14 15:41:32.446 1379701 ERROR cinder     **context.local_conf)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 55, in fix_call
2016-10-14 15:41:32.446 1379701 ERROR cinder     val = callable(*args, **kw)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/cinder/api/__init__.py", line 34, in root_app_factory
2016-10-14 15:41:32.446 1379701 ERROR cinder     return paste.urlmap.urlmap_factory(loader, global_conf, **local_conf)
2016-10-14 15:41:32.446 1379701 ERROR cinder   File "/usr/lib/python2.7/site-packages/paste/urlmap.py", line 25, in urlmap_factory
2016-10-14 15:41:32.446 1379701 ERROR cinder     app = loader.get_app(app_name, global_conf=global_conf)
2016-10-14 15:41:32.446 1379701 ERROR cinder ...
(more)