Ask Your Question

wallander's profile - activity

2016-10-09 18:24:34 -0500 received badge  Popular Question (source)
2016-10-03 13:35:43 -0500 asked a question Mitaka connect to Home Lab connection - How to

Hi,

I am a Newbie to Openstack and just started to get the hang of it. I am trying create VMs on Openstack and connect them to exiting network at Lab. I searched in this forum quite a few things and I am missing a lot on the Neutron.

> openstack service list
> +----------------------------------+----------+----------+ | ID                               |
> Name     | Type     |
> +----------------------------------+----------+----------+ | 29f0a15b070e41d09b28175657a4ae55 |
> glance   | image    | |
> 59b18976e3e54b91afdebeaf80af205c |
> nova     | compute  | |
> 953a742a9a9f4b4c91fb20c6fcae9a2f |
> neutron  | network  | |
> e03afcb299a043b5a508c1fcf975d942 |
> keystone | identity |
> +----------------------------------+----------+----------+

My controller has IP, 192.168.1.201, which is the IP of the br-ex. I have the eth0 port to the br-ex.

My compute Node has the IP, 192.168.1.102 which is IP of br-ex on the compute node.

[

root@controller ~]# neutron agent-list
+--------------------------------------+--------------------+------------------+-------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host             | availability_zone | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+------------------+-------------------+-------+----------------+---------------------------+
| 346384e0-e86f-4a20-9af3-1fd44571ce4c | Open vSwitch agent | controller       |                   | :-)   | True           | neutron-openvswitch-agent |
| 5af85127-79b7-412e-828c-bd3e311a3b36 | Open vSwitch agent |openstack001 |                   | :-)   | True           | neutron-openvswitch-agent |
| 73e90411-84e9-4265-9fd3-8e0958dbe6ce | L3 agent           | controller       | nova              | :-)   | True           | neutron-l3-agent          |
| 9d6fa524-5e48-4ec0-a49c-700dec944409 | DHCP agent         | controller       | nova              | :-)   | True           | neutron-dhcp-agent        |
+--------------------------------------+--------------------+------------------+-------------------+-------+----------------+---------------------------+

I have OpemVswitch configured on both the machines and configured them to the best of my knowledge.

The network setup is flat

[ml2]
type_drivers = flat
tenant_network_types = 
mechanism_drivers = openvswitch

I followed the setup in this https://trickycloud.wordpress.com/2013/11/12/setting-up-a-flat-network-with-neutron/ (https://trickycloud.wordpress.com/201...)

However, I can not get any ip on the VM. My compute node runs KVM.

I am not getting the Network Part a lot, would really appreciate any help :)

Best Regards,

A