de1m's profile - activity

2017-01-24 05:11:39 -0500 received badge  Famous Question (source)
2016-12-08 08:40:59 -0500 received badge  Notable Question (source)
2016-12-08 08:40:59 -0500 received badge  Popular Question (source)
2016-12-08 08:39:03 -0500 received badge  Famous Question (source)
2016-12-05 01:49:19 -0500 received badge  Notable Question (source)
2016-12-04 23:59:52 -0500 received badge  Popular Question (source)
2016-12-02 02:21:52 -0500 asked a question Magnum second server?

Hi, I've two server for magnum. I installed on two my servers magnum like here. Now if i run "magnum service-list" I see only one server

adm1@op1:~$ magnum service-list
+----+------+------------------+-------+----------+-----------------+---------------------------+---------------------------+
| id | host | binary           | state | disabled | disabled_reason | created_at                | updated_at                |
+----+------+------------------+-------+----------+-----------------+---------------------------+---------------------------+
| 2  | -    | magnum-conductor | up    |          | -               | 2016-12-02T07:08:09+00:00 | 2016-12-02T07:44:59+00:00 |
+----+------+------------------+-------+----------+-----------------+---------------------------+---------------------------+

It is ok? Or it is a error?

If this is a error, what I need to do?

2016-11-23 03:17:38 -0500 answered a question HTTPInternalServerError(500) if create volume from image

I've solved my problem. The problem was my previous downgrade of ceph tools from 10.2.3 to 0.9.4 (related bug https://bugs.launchpad.net/cinder/+bug/1643462 (https://bugs.launchpad.net/cinder/+bu...))

When uninstalling I've need to reinstall some openstack packages, like cinder and nova. After that I could no longer use the images and networks from previous installation. So I created a new cirros image and now running this without any error.

2016-11-23 03:09:28 -0500 received badge  Enthusiast
2016-11-22 23:56:48 -0500 received badge  Famous Question (source)
2016-11-22 06:53:17 -0500 asked a question HTTPInternalServerError(500) if create volume from image

hi, I'll create a volume from cirros image, but I get the error 500 (like Subject). I can create a volume and I can create also a image, but not a volume from image. My backend is ceph. I use newton version of openstack

If I create a volume I can show following in cinder-volume.log

2016-11-22 13:46:50.805 3082 INFO cinder.volume.flows.manager.create_volume [req-eb11ff6c-c395-4360-91c6-72b2b23ec383 10d88eb7fbb74920b3340a9fcf6de4c2 2d084c7589db40cc9a518d01196689eb - default default] Volume 05143497-93ed-452a-85f4-99b7a91979e4: being created as image with specification: {'status': u'creating', 'image_location': (u'rbd://3c58a184-bf27-4273-8000-405513006a7b/opstore/460c4d90-c4af-4157-bc22-697fa0fe58c7/snap', None), 'volume_size': 1, 'volume_name': 'volume-05143497-93ed-452a-85f4-99b7a91979e4', 'image_id': '460c4d90-c4af-4157-bc22-697fa0fe58c7', 'image_service': <cinder.image.glance.GlanceImageService object at 0x7ff85ec3f950>, 'image_meta': {u'status': u'active', u'virtual_size': None, u'name': u'cirros', u'tags': [], u'container_format': u'bare', u'created_at': datetime.datetime(2016, 11, 15, 13, 51, 16, tzinfo=<iso8601.Utc>), u'disk_format': u'qcow2', u'updated_at': datetime.datetime(2016, 11, 15, 13, 51, 18, tzinfo=<iso8601.Utc>), u'visibility': u'public', 'properties': {u'description': u'cirros image'}, u'owner': u'2d084c7589db40cc9a518d01196689eb', u'protected': False, u'id': u'460c4d90-c4af-4157-bc22-697fa0fe58c7', u'file': u'/v2/images/460c4d90-c4af-4157-bc22-697fa0fe58c7/file', u'checksum': u'ee1eca47dc88f4879d8a229cc70a07c6', u'min_disk': 0, u'direct_url': u'rbd://3c58a184-bf27-4273-8000-405513006a7b/opstore/460c4d90-c4af-4157-bc22-697fa0fe58c7/snap', u'min_ram': 0, u'size': 13287936}}
2016-11-22 13:46:51.036 3082 WARNING cinder.volume.manager [req-eb11ff6c-c395-4360-91c6-72b2b23ec383 10d88eb7fbb74920b3340a9fcf6de4c2 2d084c7589db40cc9a518d01196689eb - default default] Task 'cinder.volume.flows.manager.create_volume.CreateVolumeFromSpecTask;volume:create' (3ceb2890-fb66-406e-a510-55660fce1b1c) transitioned into state 'FAILURE' from state 'RUNNING'
5 predecessors (most recent first):
  Atom 'cinder.volume.flows.manager.create_volume.NotifyVolumeActionTask;volume:create, create.start' {'intention': 'EXECUTE', 'state': 'SUCCESS', 'requires': {'volume': Volume(_name_id=None,admin_metadata={},attach_status='detached',availability_zone='nova',bootable=False,cluster=<?>,cluster_name=None,consistencygroup=<?>,consistencygroup_id=None,created_at=2016-11-22T12:46:50Z,deleted=False,deleted_at=None,display_description='',display_name='volume-from-image-test',ec2_id=None,encryption_key_id=None,glance_metadata=<?>,group=<?>,group_id=None,host='op1@ceph#RBD',id=05143497-93ed-452a-85f4-99b7a91979e4,launched_at=None,metadata={},migration_status=None,multiattach=False,previous_status=None,project_id='2d084c7589db40cc9a518d01196689eb',provider_auth=None,provider_geometry=None,provider_id=None,provider_location=None,replication_driver_data=None,replication_extended_status=None,replication_status='disabled',scheduled_at=2016-11-22T12:46:50Z,size=1,snapshot_id=None,snapshots=<?>,source_volid=None,status='creating',terminated_at=None,updated_at=2016-11-22T12:46:50Z,user_id='10d88eb7fbb74920b3340a9fcf6de4c2',volume_attachment=<?>,volume_type=<?>,volume_type_id=None), 'context': <cinder.context.RequestContext object at 0x7ff85ed83150>}, 'provides': None}
  |__Atom 'cinder.volume.flows.manager.create_volume.ExtractVolumeSpecTask;volume:create' {'intention': 'EXECUTE', 'state': 'SUCCESS', 'requires': {'volume': Volume(_name_id=None,admin_metadata={},attach_status='detached',availability_zone='nova',bootable=False,cluster=<?>,cluster_name=None,consistencygroup=<?>,consistencygroup_id=None,created_at=2016-11-22T12:46:50Z,deleted=False,deleted_at=None,display_description='',display_name='volume-from-image-test',ec2_id=None,encryption_key_id=None,glance_metadata=<?>,group=<?>,group_id=None,host='op1@ceph#RBD',id=05143497-93ed-452a-85f4-99b7a91979e4,launched_at=None,metadata={},migration_status=None,multiattach=False,previous_status=None,project_id='2d084c7589db40cc9a518d01196689eb',provider_auth=None,provider_geometry=None,provider_id=None,provider_location=None,replication_driver_data=None,replication_extended_status=None,replication_status='disabled',scheduled_at=2016-11-22T12:46:50Z,size=1,snapshot_id=None,snapshots=<?>,source_volid=None,status='creating',terminated_at=None,updated_at=2016-11-22T12:46:50Z,user_id='10d88eb7fbb74920b3340a9fcf6de4c2',volume_attachment=<?>,volume_type=<?>,volume_type_id=None), 'request_spec': RequestSpec(CG_backend=<?>,cgsnapshot_id=None,consistencygroup_id=None,group_backend=<?>,group_id=None,image_id=460c4d90-c4af-4157-bc22-697fa0fe58c7,snapshot_id=None,source_replicaid=None,source_volid=None,volume=Volume(05143497-93ed-452a-85f4-99b7a91979e4),volume_id=05143497-93ed-452a-85f4-99b7a91979e4,volume_properties=VolumeProperties,volume_type=None), 'context': <cinder.context.RequestContext object at 0x7ff85ed83150>}, 'provides': {'status ...
(more)
2016-11-22 06:17:37 -0500 answered a question openstack image list - The resource could not be found. (HTTP 404)

okay, it was a error in keystone configuration, but I cannot find this, it's have working after update

2016-11-22 06:14:32 -0500 answered a question openstack image list - The resource could not be found. (HTTP 404)

okay problem is solved, it was a error in config. I use haproxy to forward the request.

2016-10-27 06:17:54 -0500 received badge  Popular Question (source)
2016-10-27 06:17:54 -0500 received badge  Notable Question (source)
2016-09-22 22:33:32 -0500 asked a question openstack image list - The resource could not be found. (HTTP 404)

Hi, I hope someone can help me.

I've installed openstack (mitaka) now only the identity and glance service. So if I run "openstack user list" or "openstack service list" it's run without any error.

But when I'll run "openstack image list" I get the error "The resource could not be found. (HTTP 404) (Request-ID: req-bb96b52d-0fc0-4f1c-8e2f-8450ed134451)"

The ports 9191 and 9292 are accessible Here my environment vars for openstack auth:

export OS_TOKEN=ae17db86bba91c64eb82
export OS_URL=http://opcontroller:35357/v3
export OS_IDENTITY_API_VERSION=3

And the debug output:

https://gist.github.com/de1m/336985c5cba88cd14b74a1b6890f4df7 (Gist)

2016-09-22 22:33:31 -0500 asked a question openstack image list - The resource could not be found. (HTTP 404)

Hi, I hope someone can help me.

I've installed openstack (mitaka) now only the identity and glance service. So if I run "openstack user list" or "openstack service list" it's run without any error.

But when I'll run "openstack image list" I get the error "The resource could not be found. (HTTP 404) (Request-ID: req-bb96b52d-0fc0-4f1c-8e2f-8450ed134451)"

The ports 9191 and 9292 are accessible Here my environment vars for openstack auth:

export OS_TOKEN=ae17db86bba91c64eb82
export OS_URL=http://opcontroller:35357/v3
export OS_IDENTITY_API_VERSION=3

And the debug output:

https://gist.github.com/de1m/336985c5cba88cd14b74a1b6890f4df7 (Gist)