Dilipsun's profile - activity

2018-10-25 13:21:21 -0500 received badge  Famous Question (source)
2016-12-06 07:38:45 -0500 received badge  Notable Question (source)
2016-11-12 11:21:36 -0500 received badge  Nice Answer (source)
2016-11-02 05:59:17 -0500 received badge  Popular Question (source)
2016-11-01 09:33:45 -0500 commented question Failed to boot instance on Openstack

Could you post nova-conductor log

2016-11-01 09:10:51 -0500 asked a question Internet not reachable from instance

Hi All ,

I have created an openstack setup from docs.openstack.org/Mitaka ,everything works fine except the internet connectivity .

Iam using Linux bridge for this setuo Could someone help me out here .

mgmt network--(eth0 on all three nodes)
controller --192.168.10.129
compute--192.168.10.130
block--192.168.10.131

secondary interface eth1 on controller and compute node is configured like this in /etc/network/interfaces on controller and compute

# The provider network interface
auto eth1
iface eth1 inet manual
up ip link set dev eth1
down ip link set dev eth1 down

Its setup as hostonly in vmware virtual editor with gateway 203.0.113.1

root@controller:~# nova list
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+
| ID                                   | Name                 | Status | Task State | Power State | Networks                              |
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+
| 1fb5e81e-90d4-4f7d-8b1a-350498be03d2 | selfservice-instance | ACTIVE | -          | Running     | selfservice=172.16.1.3, 203.0.113.103 |
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+

root@controller:~#

I am able to ping to 172.16.1.1 , 203.0.113.102 and 203.0.113.1 .But it could not go beyond that .

routing table from controller and cpmpute

root@controller:~# netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.10.2    0.0.0.0         UG        0 0          0 eth0
192.168.10.0    0.0.0.0         255.255.255.0   U         0 0          0 eth0

root@controller:~#

routing table from Cirros image (instance)

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.16.1.1      0.0.0.0         UG    0      0        0 eth0
169.254.169.254 172.16.1.1      255.255.255.255 UGH   0      0        0 eth0
172.16.1.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0

#

ping doesnt work from cirros image to internet 8.8.8.8 or 8.8.4.4

Added by dbaxps from author's comment

neutron net-create --shared --provider:physical_network provider \ 
--provider:network_type flat provider 

neutron subnet-create --name provider \ 
--allocation-pool start=203.0.113.101,end=203.0.113.250 \
--dns-nameserver 8.8.4.4 --gateway 203.0.113.1 \ 
provider 203.0.113.0/24
2016-11-01 09:04:12 -0500 received badge  Famous Question (source)
2016-10-31 16:36:30 -0500 received badge  Teacher (source)
2016-10-26 12:33:42 -0500 received badge  Student (source)
2016-10-26 10:21:25 -0500 received badge  Enthusiast
2016-10-24 06:44:05 -0500 answered a question Change Glance image location

filesystem_store_datadir = /var/lib/glance/images/-->change this path in /etc/glance/glance-api.conf

su -s /bin/sh -c "glance-manage db_sync" glance

service glance-registry restart

service glance-api restart

and sync the database ,restart the glance services ,that should do it for you

2016-10-24 04:21:39 -0500 answered a question Mitaka Installation - Create Endpoint Failed

Source admin-openrc and also demo-openrc ,this will fix the issue

In case you have not got that far try this ,

Configure the authentication token:

$ export OS_TOKEN=ADMIN_TOKEN Replace ADMIN_TOKEN with the authentication token that you generated in the section called Install and configure. For example:

$ export OS_TOKEN=294a4c8a8a475f9b9836(your token) Configure the endpoint URL:

$ export OS_URL=http://controller:35357/v3 Configure the Identity API version:

$ export OS_IDENTITY_API_VERSION=3

2016-10-24 04:16:38 -0500 commented question Mitaka Installation - Create Endpoint Failed

are you using http://docs.openstack.org/mitaka if so can you tell where you are getting error wrt doc

2016-10-24 04:12:52 -0500 answered a question Mitaka Installation - Create Endpoint Failed

Are you following http://docs.openstack.org/mitaka ?

2016-10-23 10:10:13 -0500 commented question internet not reachable from openstack instance

I missed out your previous comment apologies

2016-10-23 10:09:38 -0500 commented question internet not reachable from openstack instance

/etc/neutron/plugins/ml2/linuxbridge_agent.ini its a linux bridge

2016-10-21 21:09:37 -0500 received badge  Notable Question (source)
2016-10-21 05:51:46 -0500 received badge  Popular Question (source)
2016-10-21 04:59:12 -0500 commented question internet not reachable from openstack instance

My controller and network are same node and I used Linux bridge for the same ,Please let me know in case more output is needed

2016-10-21 04:53:13 -0500 commented question internet not reachable from openstack instance

Hi I am using Linux bridge instead of OVS [ml2] type_drivers = flat,vlan,vxlan tenant_network_types = vxlan mechanism_drivers = linuxbridge,l2population extension_drivers = port_security [ml2_type_flat] flat_networks = provider [ml2_type_vxlan] vni_ranges = 1:1000 [securitygroup] enable_ipset =true

2016-10-21 04:51:41 -0500 commented question Nova fails to boot instance

might be late but hope it helps .

Please check if this file looks like this oot@compute:~# cat /etc/nova/nova-compute.conf [DEFAULT] compute_driver=libvirt.LibvirtDriver [libvirt] virt_type=qemu root@compute:~#

unless you have hardware acceleration enabled

2016-10-21 04:34:45 -0500 commented question internet not reachable from openstack instance

neutron net-create --shared --provider:physical_network provider \ --provider:network_type flat provider neutron subnet-create --name provider \ --allocation-pool start=203.0.113.101,end=203.0.113.250 \ --dns-nameserver 8.8.4.4 --gateway 203.0.113.1 \ provider 203.0.113.0/24

please find the

2016-10-21 02:15:45 -0500 asked a question internet not reachable from openstack instance

Hi All ,

I have created an openstack setup from docs.openstack.org/Mitaka ,everything works fine except the internet connectivity . Could someone help me out here .

mgmt network--(eth0 on all three nodes)
controller --192.168.10.129
compute--192.168.10.130
block--192.168.10.131

secondary interface eth1 on controller and compute node is configured like this in /etc/network/interfaces on controller and compute

# The provider network interface
auto eth1
iface eth1 inet manual
up ip link set dev eth1
down ip link set dev eth1 down

Its setup as hostonly in vmware virtual editor with gateway 203.0.113.1

root@controller:~# nova list
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+
| ID                                   | Name                 | Status | Task State | Power State | Networks                              |
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+
| 1fb5e81e-90d4-4f7d-8b1a-350498be03d2 | selfservice-instance | ACTIVE | -          | Running     | selfservice=172.16.1.3, 203.0.113.103 |
+--------------------------------------+----------------------+--------+------------+-------------+---------------------------------------+

root@controller:~#

I am able to ping to 172.16.1.1 , 203.0.113.102 and 203.0.113.1 .But it could not go beyond that .

routing table from controller and cpmpute

root@controller:~# netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.10.2    0.0.0.0         UG        0 0          0 eth0
192.168.10.0    0.0.0.0         255.255.255.0   U         0 0          0 eth0

root@controller:~#

routing table from Cirros image (instance)

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.16.1.1      0.0.0.0         UG    0      0        0 eth0
169.254.169.254 172.16.1.1      255.255.255.255 UGH   0      0        0 eth0
172.16.1.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0

#

ping doesnt work from cirros image to internet 8.8.8.8 or 8.8.4.4

Added by dbaxps from author's comment

neutron net-create --shared --provider:physical_network provider \ 
--provider:network_type flat provider 

neutron subnet-create --name provider \ 
--allocation-pool start=203.0.113.101,end=203.0.113.250 \
--dns-nameserver 8.8.4.4 --gateway 203.0.113.1 \ 
provider 203.0.113.0/24
2016-07-06 09:55:58 -0500 commented answer kilo error : openstack service create --name keystone --description "OpenStack Identity" identity

I am using Kilo2 and getting similar error .Seems the WSGI scipt is having some issues .I did it in similar way Fayaz said .hopefully some one can share right file .