Ask Your Question

PeterN's profile - activity

2016-08-15 10:29:29 -0600 received badge  Famous Question (source)
2016-08-15 10:29:29 -0600 received badge  Notable Question (source)
2016-07-09 11:23:36 -0600 received badge  Popular Question (source)
2016-06-23 10:43:00 -0600 received badge  Supporter (source)
2016-06-23 02:43:48 -0600 received badge  Enthusiast
2016-06-15 20:08:01 -0600 asked a question Unable to connect to keystone database

Hello. I'm trying to install & configure keystone on openSUSE 42.1 like described in the official docs. When I run: sudo /bin/sh -c "keystone-manage db_sync" keystone

I get this:

Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
2016-06-14 18:33:11.660 27213 WARNING oslo_db.sqlalchemy.engines [-] SQL connection failed. 10 attempts left.

Thats what I changed in the /etc/keystone/keystone.conf

[DEFAULT]
admin_token = ... # from openssl rand -hex 10`

[database]
connection = mysql+pymysql://keystone:PASSWORD@controller/keystone

[token]
provider = fernet

And my /etc/my.cnf.d/openstack.cnf file

[mysqld]
bind-address = 0.0.0.0
default-storage-engine = innodb
innodb_file_per_table
collation-server = utf8_general_ci
character-set-server = utf8

Can someone help me to get the keystone database running?

2016-06-15 20:08:00 -0600 asked a question Unable to connect to keystone database

Hello. I'm trying to install & configure keystone on openSUSE 42.1 like described in the official docs. When I run: sudo /bin/sh -c "keystone-manage db_sync" keystone

I get this:

Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
2016-06-14 18:33:11.660 27213 WARNING oslo_db.sqlalchemy.engines [-] SQL connection failed. 10 attempts left.

Thats what I changed in the /etc/keystone/keystone.conf

[DEFAULT]
admin_token = ... # from openssl rand -hex 10`

[database]
connection = mysql+pymysql://keystone:PASSWORD@controller/keystone

[token]
provider = fernet

And my /etc/my.cnf.d/openstack.cnf file

[mysqld]
bind-address = 0.0.0.0
default-storage-engine = innodb
innodb_file_per_table
collation-server = utf8_general_ci
character-set-server = utf8

Can someone help me to get the keystone database running?