Ask Your Question

craja's profile - activity

2017-02-21 00:26:50 -0500 commented question Newton - Instance can't access internet

Are you able to access the instance from your home network? Also, did you add an ICMP rule in security group?

Thanks

2017-02-14 12:43:37 -0500 received badge  Famous Question (source)
2017-02-14 12:43:37 -0500 received badge  Notable Question (source)
2017-01-20 01:28:15 -0500 answered a question devstack installation error - horizon django

Hi,

You no need to install django manually. Sometimes, it will not integrate properly when you do it manually. It will be installed and configured automatically during the stacking process itself.

So, my suggestion is to do a clean install.

RUN, sudo apt-get update ./stack

cheers!

2017-01-20 00:55:41 -0500 answered a question Openstack Dashboard is unreachable.

If you have created your Openstack/Nagios environment using Devstack, then yes, you have to unstack and stack it again. Reboot is not supported for devstack installation.

cheers!

2017-01-17 10:07:00 -0500 commented answer stable/mitaka installation issues

Glad that you problem has been solved.

This is the only problem with devstack. If you reboot the machine, you have to unstack and stack it again. rejoin-stack.sh currently not available. If you don't want to reclone the packages on every unstack/stack, just set "RECLONE=no" in local.conf file.

Thx

2017-01-16 04:25:10 -0500 answered a question stable/mitaka installation issues

After cloning the devstack, you need to create "stack" user with proper privilege. Follow the below steps before running ./stack :

$git clone https://git.openstack.org/openstack-d... -b stable/mitaka

$sudo ./devstack/tools/create-stack-user.sh

$sudo usermod -a -G sudo stack

$sudo mv devstack /opt/stack

$sudo su - stack

$sudo chown -R stack:stack devstack

2017-01-16 04:14:34 -0500 commented question Unable to create flow-classifier for service function chaining: The resource could not be found

Are you able to run other SFC commands like port-pair/port group create successfully? Try to run the command with "--debug" and paste here, so that we will get more logs.

Example: neutron --debug flow-classifier-create...

2017-01-10 01:18:06 -0500 asked a question Devstack is not using my own private network configuration

Hello,

I am trying to setup a devstack environment using my own private network configuration with the variables "FIXED_RANGE=192.168.1.0/24" and "NETWORK_GATEWAY=192.168.1.1". But, the devstack always uses its hard coded private network configuration, i.e Network: 10.0.0.0/8 and GW: 10.0.0.1.

After some googling, I feels that there is some bug around this area. But, I'm unsure about that and wanted to check it here.

My local.conf excerpt showing the network configuration:

NEUTRON_CREATE_INITIAL_NETWORKS=True

FLOATING_RANGE=10.6.0.0/16 #Your LAN network segment

Q_FLOATING_ALLOCATION_POOL=start=10.6.20.100,end=10.6.20.200

FIXED_RANGE=192.168.1.0/24 #Private network for guest VMs

FIXED_NETWORK_SIZE=256

NETWORK_GATEWAY=192.168.1.1 #Gateway used for guest VMs

PUBLIC_NETWORK_GATEWAY=10.6.0.1

Thanks

2016-11-27 00:15:08 -0500 answered a question where is the "settings.py" file for horizon located?

You can use "usr/share/openstack-dashboard/openstack_dashboard/settings.py" to modify horizon settings. But, it always a good practice to use local_settings.py located under "/etc/openstack_dashboard/local_settings.py" for any horizon configuration.

Best, Raja

2016-11-02 01:23:17 -0500 commented question Connection to neutron failed

Various reasons for this issue and you have to sort one by one. 1. Make sure you have properly configured the bridge interface in "/etc/network/interfaces". 2. If you are running devstack with single NIC, please add "PUBLIC_BRIDGE=br-ex" in your local.conf file. 3. Try to restack it.

Best,

2016-10-18 01:36:49 -0500 commented question Devstack and OpenvSwitch v2.3+

Thanks dbaxps for the pointer and thanks darragh-oreilly for your suggestion. I will try it by commenting the line.

2016-10-17 14:31:18 -0500 received badge  Popular Question (source)
2016-10-17 13:26:19 -0500 received badge  Student (source)
2016-10-17 08:08:43 -0500 asked a question Devstack and OpenvSwitch v2.3+

Hello,

I'm installing devstack All-In-One in Ubuntu 14.04 and I would like to use OpenvSwitch v2.3 or more for my experiment. I have installed OpenvSwitch 2.3.1 manually and started the devstack script. But, the script removed OpenvSwitch v2.3.1 and installed v2.0.2, as part of the installation.

I would like to install devstack + OpenvSwitch v2.3.1. Is there anyway to do this?

Thanks in Advance!!!

Kind Regards, Raja

2016-07-20 07:22:11 -0500 received badge  Famous Question (source)
2016-06-30 01:14:00 -0500 commented answer Openstack for production evironment

Thank You for the pointers!

2016-06-26 12:27:31 -0500 received badge  Notable Question (source)
2016-06-24 05:16:07 -0500 received badge  Popular Question (source)
2016-06-23 21:58:06 -0500 asked a question Openstack for production evironment

Greetings,

We are just planning to setup a data-center and deploy "openstack" as production environment. We just wanted to know what is the best architecture which suites the production environment, how high availability is achieved, etc.

It would be very good if we have any document/guide for installing latest openstack on production environment.

Thanks in Advance!!!

craja

2016-06-23 21:44:04 -0500 received badge  Famous Question (source)
2016-05-26 18:17:07 -0500 received badge  Teacher (source)
2016-05-26 18:17:07 -0500 received badge  Self-Learner (source)
2016-05-26 09:44:08 -0500 received badge  Notable Question (source)
2016-05-26 05:44:19 -0500 answered a question How to install FWaaS in Openstack kilo.

Finally, I enabled the Firewall as a Service in Openstack kilo by the below procedure. Just adding this so that it may help someone.

  1. Added "service_plugins = router,neutron_fwaas.services.firewall.fwaas_plugin.FirewallPlugin" in neutron.conf on both controller and network node.
  2. Added the below line in fwaas_driver.ini on network node.

    [DEFAULT] [fwaas] driver = neutron_fwaas.services.firewall.drivers.linux.iptables_fwaas.IptablesFwaasDriver enabled = True

  3. Restarted all neutron services in Network node and neutron server in controller node.
  4. Set "True" against firewall in local_settings.py on controller node and restarted apache.

That's it! Got the firewall panel on the Horizon GUI. Also able to apply FW policies to the VMs from the router level.

Thanks, craja

2016-05-26 05:37:08 -0500 received badge  Popular Question (source)
2016-05-20 01:12:04 -0500 received badge  Enthusiast
2016-05-19 02:36:31 -0500 commented answer Getting error while creating firewall " Unable to retrieve routers (Request Failed: internal server error while processing your request.)." . How to can i solve this issue ?

Thank You Very Much!!! I solved this problem by following your step.

2016-05-06 06:15:10 -0500 received badge  Editor (source)
2016-05-04 11:16:15 -0500 asked a question How to install FWaaS in Openstack kilo.

Hello All,

I am a new user and I couldn't find any relevant answers for my question.

I have installed Openstack kilo with 3 node architecture in Ubuntu 14.04 using the below link:

http://docs.openstack.org/kilo/install-guide/install/apt/content/ (http://docs.openstack.org/kilo/instal...)

I am able to stage it successfully. Now, I want to install Fwaas in this architecture(Looks like there is a panel named Firewall appears in Horizon > network link after installing this?)

I couldn't find any doc related to this. Could someone please provide any pointer for this?

Thanks in Advance!!!