Ask Your Question

D3LTA9's profile - activity

2018-08-29 04:07:16 -0500 received badge  Famous Question (source)
2017-03-28 12:39:23 -0500 received badge  Notable Question (source)
2017-03-28 12:39:23 -0500 received badge  Popular Question (source)
2017-02-05 12:45:32 -0500 received badge  Famous Question (source)
2016-10-02 00:49:23 -0500 received badge  Famous Question (source)
2016-08-10 09:54:10 -0500 received badge  Notable Question (source)
2016-06-15 04:21:12 -0500 received badge  Famous Question (source)
2016-06-08 01:24:24 -0500 received badge  Popular Question (source)
2016-06-07 19:16:59 -0500 answered a question Use Swift as Backend for Glance Images

After checking the logs there are a bunch of errors but the one that sticks out is:

2016-06-08 12:10:36.177 16908 ERROR glance.common.wsgi [req-1b62c167-0e31-410e-acc5-a2f973d826ac 3e26e02df83a4c2cae4d98dba4f24a8f 5ee06ce2b2fb49e390cde66370504fc3 - - -] Caught error: Unauthorized. Check username, password and tenant name/id.

So this would suggest that its error with the lines:

swift_store_user = service:glance

swift_store_key = GLANCE_PASS

But I dont see how they could be any different. The swift_store_user line should be formatted:

project(tenant):user so service:glance

and I have used the same password for all services (I know, you shouldn't but this is just a proof of concept project essentially) so I cant see how it could be wrong either.

2016-06-07 18:54:39 -0500 commented answer Use Swift as Backend for Glance Images

Thanks for the reply but I am still getting the same error using that configuration too - "The server has either erred or is incapable of performing the requested operation. (HTTP 500)". Of course, I changed the authentication address and password to my own before attempting to create an image.

2016-06-07 18:39:16 -0500 received badge  Commentator
2016-06-07 05:34:46 -0500 asked a question Use Swift as Backend for Glance Images

Having difficulty getting swift to work as my image datastore for glance.

I just get a server error when I try and create a image after applying the below configuration and restarting glance.

/etc/glance/glance-api.conf

[glance_store]

default_store = swift
stores = glance.store.swift.Store (have tried just "swift" as well)

swift_store_auth_version = 2

swift_store_auth_address = http://controller:35357/v2.0/

swift_store_user = service:glance

swift_store_key = GLANCE_PASS

swift_store_container = glance

swift_store_create_container_on_put = True

swift_store_large_object_size = 5120

swift_store_large_object_chunk_size = 200

swift_enable_snet = False

Commented out:

filesystem_store_datadir = /var/lib/glance/images/

Really not sure what I am missing as every other guide I have looked at has a similar configuration if not less options, which I have also tried.

The only thing I can think of is somehow it cannot create the container due a permission issue but as my glance user has the admin role I do not see how this could be an issue.

Any hell would be appreciated thanks!

2016-06-07 03:56:30 -0500 asked a question Change Public Container Link Swift

When I set a container to public and then get the URL for said container, the link has the host name of my controller node at the start. For example - http://controller:8080/ etc......

This obviously will not work for any remote access that cannot resolve the controller host name. I want the to change the host name for a domain name like I have done for the novnc console in the nova.conf file.

How would I change this? Would it require changing the API endpoint?

Thanks for any help!

2016-05-23 18:22:02 -0500 received badge  Notable Question (source)
2016-05-23 18:22:02 -0500 received badge  Popular Question (source)
2016-05-09 13:06:20 -0500 received badge  Famous Question (source)
2016-05-07 15:40:14 -0500 received badge  Famous Question (source)
2016-05-05 17:26:24 -0500 asked a question New stack instance related questions

I finally have got my stack configured and working correctly. But now I have a couple of basic questions relating to my freshly created instances.

First - I have launched one instance via CLI and one via dashboard. However, I can only see them in their respective launch mediums. I.e. my CLI created instance does not show up in my instance list on my dashboard and vice versa. Is this normal? I would have thought not.

Second - I cannot ping from my controller to either of my instances but can ping the default gateway, internet, controller and everything else I tried from the either instance. I assumed this was a security group issue so I added a rule allowing all ICMP traffic both ways to the default security group that both instances and controller are part of. This did not fix it though.

On further testing, I also noticed I cannot ping from my controller to my default gateway on the 192.168.2.0 network (provider network) that my controller is attached to. This is not effecting my stack at this stage but more concerned it will later and just want to understand why this does not work - I assume it is because my controller, while attached to my provider network, does not actually have an IP assigned to it on this network so cannot ping the default gateway ? But if that is the case how would it ping instances on said network as the documentation clearly states it should?

Thanks in advance for any advice!

2016-05-05 17:09:35 -0500 commented answer Memcached: All nodes or just controller?

Ok will remember that if I scale out. Thanks

2016-05-05 13:12:29 -0500 received badge  Notable Question (source)
2016-05-05 07:28:56 -0500 received badge  Notable Question (source)
2016-05-05 03:59:43 -0500 received badge  Enthusiast
2016-05-05 03:47:22 -0500 received badge  Popular Question (source)
2016-05-05 02:39:49 -0500 received badge  Notable Question (source)
2016-05-05 00:25:17 -0500 received badge  Popular Question (source)
2016-05-04 23:38:16 -0500 answered a question Nothing works after reboot of controller node - internal server error 500

I think I have fixed the problem, still holding my breath as I already had a random internal server error earlier today but everything has been working since.

Due to me being an idiot when I disabled the temporary authentication token mechanism I deleted an extra character after admin_token_auth in the [pipeline:public_api] section of keystone-paste.ini file.

Gonna blame it on the terrible internet here in Hawaii and the lag over my VPN into my home network in New Zealand, the delay in the CLI input meant I deleted more than I meant to...haha.

I really hope this is the issue as everything has worked so far other than that one random internal server error.

Thanks for helping me though, it is appreciated!

2016-05-04 20:39:37 -0500 answered a question Keystone: As the demo user, request an authentication token error

My own fault, I made a mistake when I disabled the temporary authentication token mechanism.

2016-05-04 20:39:05 -0500 commented answer Keystone: As the demo user, request an authentication token error

Thanks for the help but as it turns out I had messed up when I disabled the temporary authentication token mechanism. Working now.

2016-05-04 18:15:41 -0500 asked a question Memcached: All nodes or just controller?

Very quick question that I cant seem to find the answer to:

Do I have to install the memcached packages and configure for just the controller node or for all nodes in my stack?

Thanks!

2016-05-04 16:49:07 -0500 commented question Nothing works after reboot of controller node - internal server error 500

Will try that shortly, I think I have tracked the problem down to apache2 reloading, this seems to be the actual operation that breaks everything for me. Soon as apache is reloaded I get the above error. Thanks for your continued help, it is appreciated.

2016-05-04 09:27:49 -0500 received badge  Notable Question (source)
2016-05-04 09:27:49 -0500 received badge  Famous Question (source)
2016-05-04 09:27:49 -0500 received badge  Popular Question (source)
2016-05-03 21:36:15 -0500 received badge  Scholar (source)
2016-05-03 21:36:07 -0500 commented answer Neutron agent-list missing linux bridge agent

thank you! of course, so stupid of me, it will be the name of the interface the provider network should be running on. Clearly been staring at a CLI too long its melting my brain haha.

2016-05-03 20:21:17 -0500 asked a question Neutron agent-list missing linux bridge agent

After install neutron and using option 1 provider networks when I run a agent-list command I only see dhcp and metadata agents running on my controller node and not the linux bridge agent that I should see as well on both my controller and compute node. I have tried restarting the linuxbridge agent and it is definitely running, I have also followed the installation guide on configuration.

The only issue I can think of is:

In the [linux_bridge] section, map the provider virtual network to the provider physical network interface: Here I have put

"physical_interface_mappings = provider:Provider_Network"

I was not 100% sure what to put for this as I am running a logical network for the provider network on 192.168.2.0 and running physical for my management network on 192.168.1.0.

The name of the virtual machine port group is "Provider_Network" and both my compute and controller nodes are attached to this port group and I have a vyos virtual router also connected to the Provider_Network port group which provides internet access to the 192.168.2.0 network.

I also have another "VM Network" port group which handles the management traffic, all nodes are connected to, and is connected to my physical 192.168.1.0 network and my Asus router (192.168.1.1)

This area was the only part I really was not sure about during my initial environment configuration, have I completely messed up my basic network environment configuration? I still do not completely understand the network layout part of the install guide here:

http://docs.openstack.org/mitaka/install-guide-ubuntu/environment-networking.html (http://docs.openstack.org/mitaka/inst...)

In a basic home lab environment with only one publicly routable IP that via NAT on my physical router provides internet access to my private address space network, how do you also have a second direct connection to a publicly routable IP?

Thanks again for any help!