mkhan's profile - activity

2019-07-29 09:03:06 -0600 received badge  Famous Question (source)
2019-04-09 08:34:26 -0600 commented question How can I enable VM_memory metrics and Hardware.network?

they were enabled in pike version also and having the same issue in with queens and rocky as well. I can see all the metrics except vm_memory.used and hardware.network.*

2019-04-09 08:32:43 -0600 commented answer how to enable hardware metrics on gnocchi

these metrics are enable in pipline.yaml and polling.yaml files but not getting vm_memory.used and hardware.network metrics

2019-04-07 09:07:12 -0600 answered a question how to enable hardware metrics on gnocchi

I have used same polling.yaml and pipeline.yaml file as I have used in Ocata but I am unable collect vm metrics and hardware network metrics.

2019-04-04 13:09:48 -0600 asked a question How can I enable VM_memory metrics and Hardware.network?

I have enables hardware metrics to collect metrics but I cannot get vm_mem and hardware.network.* metrics. need some help on theseC:\fakepath\Screen Shot 2019-04-04 at 2.07.27 PM.png metrics. The current of OpenStack version is Queens

2019-04-04 12:22:08 -0600 received badge  Notable Question (source)
2018-12-19 16:28:03 -0600 commented answer rocky linux_bridge selfsevice network router interface down

I am also facing the same kind of issue with my Rocky and queens Release. Cannot ping external network from Instances. I could ssh to instance from a controller node. Both if these environments deployed using packstack. Need solution to solve this issue.

2018-09-25 19:47:44 -0600 received badge  Taxonomist
2018-08-10 09:37:02 -0600 received badge  Famous Question (source)
2018-07-02 15:43:31 -0600 received badge  Famous Question (source)
2018-07-02 13:22:31 -0600 commented answer how to Change default ports of endpoints?

I am trying to create a separate node for each of the service where public and admin endpoint will be different.

2018-07-02 13:20:37 -0600 answered a question how to Change default ports of endpoints?

I have installed image service on a separate node and the endpoints created on the controller node.-----------+---------------------------+ | interface | url | +-----------+---------------------------+ | internal | http://10.10.150.101:9292 | | public | http://10.10.150.102:9292 | | admin | http://10.10.150.101:9292 | curl is refusing from controler node but it curl command is working fine on a host where glance service is running. +-----------+---------------------------+ [root@pike-test-controller ~]# curl http://10.10.150.101:9292 curl: (7) Failed connect to 10.10.150.101:9292; Connection refused [root@pike-test-neutron ~]# curl http://10.10.150.102:9292 {"versions": [{"status": "CURRENT", "id": "v2.5", "links": [{"href": "http://10.10.150.102:9292/v2/", "rel": "self"}]}, {"status": "SUPPORTED", "id": "v2.4", "links": [{"href": "http://10.10.150.102:9292/v2/", "rel": "self"}]}, {"status": "SUPPORTED", "id": "v2.3", "links": [{"href": "http://10.10.150.102:9292/v2/", "rel": "self"}]}, {"status": "SUPPORTED"[root@pike-test-neutron ~]#

t-neutron ~] {"status": "DEPRECATED", "id": "v1.0", "links": [{"href": "http://10.10.150.102

2018-06-29 14:59:41 -0600 received badge  Notable Question (source)
2018-06-28 16:40:48 -0600 received badge  Popular Question (source)
2018-06-28 08:29:32 -0600 commented answer how to Change default ports of endpoints?

Thank you Baush!!!! One more question how would we bind ports admin, internal, and public ports different than each other. I did bind public port 9999 but I l also have other ports for admin and internal. Public ports after bind working fine. I don't see any error when I call image list and port.

2018-06-28 04:22:46 -0600 commented answer how to Change default ports of endpoints?

Actually, I would like to change port number instead of using default ports. Where and how would changes make and which files?

2018-06-27 17:40:40 -0600 asked a question how to Change default ports of endpoints?

How can I change the default ports of each an every endpoint? I want to change port number of public, admin and internal endpoints. for example; glance endpoints ports are 9292 for admin, internal, and admin. I have created an endpoint alreatty with different port numbers, when I ran glance image-list it's notreturning anything and giving me an error; openstack image list Unable to establish connection to http://10.10.150.101:9999/v2/images: HTTPConnectionPool(host='10.10.150.101', port=9999): Max retries exceeded with url: /v2/images (Caused by NewConnectionError('<requests.packages.urllib3.connection.httpconnection 0x7fb840be4910="" at="" object="">: Failed to establish a new connection: [Errno 111] Connection refused',))</requests.packages.urllib3.connection.httpconnection>

2018-06-19 07:45:03 -0600 received badge  Famous Question (source)
2018-04-23 15:44:09 -0600 commented question Multi-Region authentication

I haven't resolved this yet. I try to configure the way I have configured in Mitaka. It's working fine in mitaka but not in pike.

2018-04-20 09:50:25 -0600 commented question Multi-Region authentication

but when I have changed to keystone_authtoken to region one it's not autenticating.

2018-04-20 09:14:20 -0600 commented question Multi-Region authentication

I have run the command with debug option, however, I have the multi-region environment of Mitaka where authentication of a glance, Nova, and etc are taking in there own region except identity service where Keystone is working in one RegionOne.Some more screenshots of Mitaka glance conf files. THX.

2018-04-19 20:40:46 -0600 commented question Multi-Region authentication

I have added few more screenshots of keystone.conf files of both regions.

2018-04-19 15:46:45 -0600 commented question Multi-Region authentication

after changing both files glance-api and glance-registry.conf files I facing an issue. please see attached screenshots. Thanks again

2018-04-19 14:08:02 -0600 received badge  Notable Question (source)
2018-04-18 16:52:29 -0600 commented question Multi-Region authentication

both the regions have a separate database for each region.

2018-04-18 16:29:51 -0600 commented question Multi-Region authentication

I have changed the keystone_authtoken in glance -api.comf file and it started giving me error Invalid OpenStack Identity credentials. I also changed rabbitmq-server instead of transport_url but from Regione to calling Region two api is not validating identity. Does pike support to active/active

2018-04-17 13:18:08 -0600 commented question Multi-Region authentication

I have added few more screenshots of keystone.conf and glance.conf files of 2nd controller node. please take a look and point me out where am I making a mistake. Thanks in advance

2018-04-16 21:47:54 -0600 commented question Multi-Region authentication

If I am wrong, please clearly multi region concept. Keystone works on one controller node and the other cobtroller will authenticate from main controller mode.

2018-04-16 09:58:23 -0600 received badge  Famous Question (source)
2018-04-16 09:35:38 -0600 commented question Multi-Region authentication

I do have an endpoint of region2 in region one but it's not authenticating RegionTwo any endpoint except OpenStack endpoint list from RegionOne.

2018-04-16 09:33:42 -0600 commented question Multi-Region authentication

this is the output from region2. I delete the image but running the above command in region2 its working

[root@pike-gnocchi-region2 ~(keystone_admin)]# glance --os-region-name RegionTwo image-list
+----+------+
| ID | Name |
+----+------+
+----+------+
2018-04-16 09:28:55 -0600 commented question Multi-Region authentication

when I run this command from RegionOne

[root@pike-gnocchi ~]# source keystonerc_admin 
[root@pike-gnocchi ~(keystone_admin)]# openstack endpoint list | grep keystone
| 263e7f4df4af40099d857585114070d0 | RegionTwo | keystone     | identity     | True    | internal  | http://10.10.150.148:5000/v3
2018-04-15 11:49:59 -0600 commented question Multi-Region authentication

I have deployed multi-regions on Mitaka but on a pike, the same way deployment giving me issues with authentication on other than Keystone API

2018-04-15 11:44:03 -0600 answered a question Multi-Region authentication
2018-04-15 11:43:35 -0600 commented question Multi-Region authentication

The keystone authentication works fine between two regions. I have glance endpoint in region1 and keystone identity in the region1 for the region2. Attached screenshots will show the endpoints of both regions. The entire environment is deployed by RDO.

2018-04-15 06:00:40 -0600 received badge  Popular Question (source)
2018-04-15 06:00:40 -0600 received badge  Notable Question (source)
2018-04-13 10:19:15 -0600 asked a question Multi-Region authentication

My environment(PIKE) has two regions, RegionOne and RegionTwo. Keystone is working perfectly fine when switching between two regions. I have also created endpoints for the glance and another service as well in RegionOne for RegionTwo Points. C:\fakepath\Screen Shot 2018-04-13 at 11.13.00 AM.png

when I ran openstack endpoint list it display all the endpoints but when I ran glance --os-region-name RegionTwo --debug image-list its show me this error C:\fakepath\Screen Shot 2018-04-13 at 11.15.47 AM.png

Request returned failure status 401.
DEBUG:glanceclient.common.http:Request returned failure status 401.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/glanceclient/shell.py", line 699, in main
    OpenStackImagesShell().main(argv)
  File "/usr/lib/python2.7/site-packages/glanceclient/shell.py", line 605, in main
    raise exc.CommandError("Invalid OpenStack Identity credentials.")
CommandError: Invalid OpenStack Identity credentials.

when test the same same command in regiontwo susch as glance image-list it works fine but not working from different region

018-04-13 11:07:41.168 18701 WARNING keystonemiddleware.auth_token [-] Authorization failed for token: InvalidToken: Token authorization failed
2018-04-13 11:07:41.170 18701 INFO eventlet.wsgi.server [-] 10.10.150.148 - - [13/Apr/2018 11:07:41] "GET /v2/images?limit=20 HTTP/1.1" 401 572 0.164411
2018-04-13 11:17:38.418 18701 WARNING keystonemiddleware.auth_token [-] Authorization failed for token: NotFound: This is not a recognized Fernet token gAAAAABa0Me7e6utYFNXDrBT7xtBzPe45w7ibfYZuJQssCZ1g_EyTqunXgJNamqZC0yg7yCBHSNftBZ8rHI-CKdSIMnraYNcWLAqQwx3cFaYxurEesYx5QnyQpuuhMeIRTuXdr8BvWNhuEmrsDN81hFGVUvE-vXA0rqmOpkE1QgKlpxCB_Uh-zk= (HTTP 404) (Request-ID: req-cbd8ff3c-5b86-4353-9e9a-82f07019571f)
2018-04-13 11:17:38.420 18701 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "This is not a recognized Fernet token gAAAAABa0Me7e6utYFNXDrBT7xtBzPe45w7ibfYZuJQssCZ1g_EyTqunXgJNamqZC0yg7yCBHSNftBZ8rHI-CKdSIMnraYNcWLAqQwx3cFaYxurEesYx5QnyQpuuhMeIRTuXdr8BvWNhuEmrsDN81hFGVUvE-vXA0rqmOpkE1QgKlpxCB_Uh-zk=", "code": 404, "title": "Not Found"}}: NotFound: This is not a recognized Fernet token gAAAAABa0Me7e6utYFNXDrBT7xtBzPe45w7ibfYZuJQssCZ1g_EyTqunXgJNamqZC0yg7yCBHSNftBZ8rHI-CKdSIMnraYNcWLAqQwx3cFaYxurEesYx5QnyQpuuhMeIRTuXdr8BvWNhuEmrsDN81hFGVUvE-vXA0rqmOpkE1QgKlpxCB_Uh-zk= (HTTP 404) (Request-ID: req-cbd8ff3c-5b86-4353-9e9a-82f07019571f)
2018-04-13 11:17:38.420 18701 WARNING keystonemiddleware.auth_token [-] Authorization failed for token: InvalidToken: Token authorization failed
2018-04-13 11:17:38.422 18701 INFO eventlet.wsgi.server [-] 10.10.150.148 - - [13/Apr/2018 11:17:38] "GET /v2/images?limit=20 HTTP/1.1" 401 572 0.131338
2018-04-13 11:17:39.142 18699 WARNING keystonemiddleware.auth_token [-] Authorization failed for token: NotFound: This is not a recognized Fernet token gAAAAABa0MoRoo0lngtou8uis4G1UeH5lmLepApLVZ_Y2lrXT6CtY0ybh0yYqGrMVp58HIX5IpdAWowI3DGRLCzpdBf4-fZ9eFkLQc02EUlCZd-JOderO2QbTFjKQt1RUerdQRmA5NzCk3fGeggJD-fcpjQY_M2wid3OhwKAkTj_OvBA94NA2bk= (HTTP 404) (Request-ID: req-7f2693b2-168b-4898-903e-f5d245e129a2)
2018-04-13 11:17:39.154 18699 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "This is not a recognized Fernet token gAAAAABa0MoRoo0lngtou8uis4G1UeH5lmLepApLVZ_Y2lrXT6CtY0ybh0yYqGrMVp58HIX5IpdAWowI3DGRLCzpdBf4-fZ9eFkLQc02EUlCZd-JOderO2QbTFjKQt1RUerdQRmA5NzCk3fGeggJD-fcpjQY_M2wid3OhwKAkTj_OvBA94NA2bk=", "code": 404, "title": "Not Found"}}: NotFound: This is not a recognized Fernet token gAAAAABa0MoRoo0lngtou8uis4G1UeH5lmLepApLVZ_Y2lrXT6CtY0ybh0yYqGrMVp58HIX5IpdAWowI3DGRLCzpdBf4-fZ9eFkLQc02EUlCZd-JOderO2QbTFjKQt1RUerdQRmA5NzCk3fGeggJD-fcpjQY_M2wid3OhwKAkTj_OvBA94NA2bk= (HTTP 404) (Request-ID: req-7f2693b2-168b-4898-903e-f5d245e129a2)
2018-04-13 11:17:39.154 18699 WARNING keystonemiddleware.auth_token [-] Authorization failed for token: InvalidToken: Token authorization failed
2018-04-13 11:17:39.156 18699 INFO eventlet.wsgi.server [-] 10.10.150.148 - - [13/Apr/2018 11:17:39] "GET /v2/images?limit=20 HTTP/1.1" 401 572 0.130965
2018-04-04 10:46:43 -0600 commented answer how to enable hardware metrics on gnocchi

memory.used is also not publishing. Thank you so much for your help.

2018-04-04 10:45:42 -0600 commented answer how to enable hardware metrics on gnocchi

PM_NET_OUT(hardware.network.outgoing.bytes.rate) isn't being published PM_NET_IN(hardware.network.incoming.bytes.rate) isn't being published PM_IO_OUT(hardware.system_stats.io.outgoing.blocks.rate) isn't being published PM_IO_IN(hardware.system_stats.io.incoming.blocks.rate) isn't being publis