Ask Your Question

zetret12's profile - activity

2019-07-22 23:24:42 -0500 received badge  Notable Question (source)
2019-07-22 23:24:42 -0500 received badge  Famous Question (source)
2019-07-22 23:24:42 -0500 received badge  Popular Question (source)
2019-03-09 21:44:39 -0500 received badge  Famous Question (source)
2019-02-03 20:01:44 -0500 received badge  Notable Question (source)
2019-01-27 15:52:27 -0500 received badge  Popular Question (source)
2019-01-25 13:43:24 -0500 answered a question How to configure Neutron on public cloud immediately after OpenStack installation?

Fixed point 3 by doing this, but the other 2 questions remain; 3) This was fixed by finding the dashboard configuration file under /etc/httpd/conf.d and simply adding a server alias with the public IP information. For example; ServerAlias private_IP public_IP

1) ?

2) ?

2019-01-25 13:42:33 -0500 answered a question Replacing /dashboard URL with / doesn't work in OpenStack Horizon?

This was fixed by finding the dashboard configuration file under /etc/httpd/conf.d and simply adding a server alias with the public IP information. For example;

ServerAlias private_IP public_IP

2019-01-25 12:49:48 -0500 asked a question Replacing /dashboard URL with / doesn't work in OpenStack Horizon?

After setting up, I went to the local_settings file under the /etc/openstack-dashboard directory, and replaced all occurrences of /dashboard with just '/'. I restarted the httpd.service and memcahed. Still, I am unable to reach the OpenStack dashboard from the / URL and need to use /dashboard.

ERROR: Not Found

The requested URL /auth/login/ was not found on this server.

2019-01-24 22:22:16 -0500 asked a question How to configure Neutron on public cloud immediately after OpenStack installation?

I have just installed an OpenStack distribution (RDO) on a public cloud (Google Cloud Platform). They have given me ONE public IP address.

1) I see a 172.24... default public IP address configured automatically which I am unable to remove. How did this get there and why can't I remove it?

2) How to add just one public IP address given to me (34.73.225.xxx)? The /32 CIDR notation on Add Network doesn't work on OpenStack Horizon.

3) After installation, OpenStack says the dashboard is available as http://internal_IP/dashboard and it works. However, I want to configure routing such that http://allocated_external_IP/dashboard routes to http://internal_IP/dashboard. How to do that. By default http://allocated_external_IP/ routes to http://internal_IP/ (without the /dashboard).

If anyone has set this up with one floating IP address before on a public cloud platform, please let me know. Thanks!

image description

2019-01-08 11:28:25 -0500 received badge  Famous Question (source)
2018-11-27 18:40:34 -0500 received badge  Famous Question (source)
2018-11-22 02:18:52 -0500 received badge  Famous Question (source)
2018-08-08 18:12:40 -0500 received badge  Notable Question (source)
2018-08-01 16:58:41 -0500 commented answer How to update REST API command for Gnocchi Client because of Ceilometer Deprecation?

Thanks, Why POST request? Trying to GET the metrics for vcpu usage in a project or it could be memory in the project. Custom 'total_vcpus' metric defined in the Archive Policy, simply a mean of vcpu usage for a particular time period (granularity) - idea to take this and gen. billing report.

2018-08-01 16:54:45 -0500 received badge  Popular Question (source)
2018-08-01 16:54:45 -0500 received badge  Notable Question (source)
2018-08-01 06:35:49 -0500 received badge  Popular Question (source)
2018-07-31 15:59:18 -0500 asked a question What is the REST API CURL command to get a list of available images? (2018)

I am using the following with my token exported, and still nothing is returned. However 2 images are available in the environment (openstack image list).

curl -s -k -X GET "http://localhost:9292/v2/images" \ -H "X-Auth-Token:$TOKEN" \ -H "Accept: application/json" \ -H "Content-Type: application/json"

Please help! Nothing is returned. This is the output I get: {"images": [], "schema": "/v2/schemas/images", "first": "/v2/images"}

2018-07-31 11:27:45 -0500 received badge  Notable Question (source)
2018-07-31 11:27:45 -0500 received badge  Popular Question (source)
2018-07-31 11:25:51 -0500 asked a question How to update REST API command for Gnocchi Client because of Ceilometer Deprecation?

I was using the following command to get usage "total_vcpu" information from Ceilometer.

curl -s -1 -k -H "X-Auth-Token:$TOKEN" \ -X GET "http://localhost:8777/v2/meters/total_vcpu/statistics?q.field=timestamp&q.op=gt&q.value=$TIMESTAMP&aggregate.func=max&period=86400&q.field=project_id&q.value=$PROJECTID" 1>myOutput

After updating to OpenStack Queens, I get a Ceilometer client deprecated message asking me to use Gnocchi or Panko instead. Can someone help translate this so I can get the same result from Gnocchi? Thanks.

2018-03-28 04:48:10 -0500 received badge  Notable Question (source)
2018-03-28 04:48:10 -0500 received badge  Popular Question (source)
2018-03-28 04:48:10 -0500 received badge  Famous Question (source)
2018-03-21 00:54:06 -0500 received badge  Notable Question (source)
2018-03-15 06:48:14 -0500 received badge  Popular Question (source)
2018-03-14 14:56:34 -0500 asked a question Can I setup OpenStack RDO and Capture that VM for reuse on VMware?

I am running OpenStack RDO on an x86 machine running VMware ESXi.

I am guessing the answer is NO, but just wanted to confirm. After installing an all-in-one OpenStack instance on this VM, can I simply capture it, and then deploy that image with a new IP address again? Would that kill all the OpenStack services as they have the previous IP address on all the service endpoints? How do I achieve this? i.e. creating an OVF or any other image that I can quickly reuse to get a running OpenStack instance?

2017-08-03 15:11:30 -0500 received badge  Famous Question (source)
2017-06-26 12:50:00 -0500 received badge  Famous Question (source)
2017-06-18 23:01:48 -0500 received badge  Notable Question (source)
2017-06-18 13:53:48 -0500 received badge  Popular Question (source)
2017-06-17 19:29:02 -0500 commented question Error (Systemd start for rabbitmq-server failed) while installing Packstack on new CentOS?

nc tryopenstack 4369 says "Connection refused". Also, my /etc/host file's IP and hostname are accurate.

2017-06-17 19:18:50 -0500 asked a question RDO installation - systemd start for rabbitmq server failed - Is this normal?

Here is the error message; Please explain in layman's terms why this is happening and how to fix. Thanks. (But Horizon seems to work as usual - so I am confused if the setup is good or not)

ERROR : Error appeared during Puppet run: 192.168.0.201_controller.pp
Error: Systemd start for rabbitmq-server failed!
You will find full trace in log /var/tmp/packstack/20170617-192203-xo8a4u/manifests/192.168.0.201_controller.pp.log

Here is the log;

[mNotice: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]/ensure: created
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]/owner: owner changed 'rabbitmq' to 'root'
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]/group: group changed 'rabbitmq' to 'root'
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]/ensure: created
Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]/content: content changed '{md5}c8e444b74c6294006936abdaea55a079' to '{md5}54e1c4e776fd87d974a4ce52a80720fa'
Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]/mode: mode changed '0644' to '0640'
Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]/ensure: defined content as '{md5}d1faed99ee5f85f2e3ef458c2d19f3a8'
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d]/ensure: created
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d/limits.conf]/ensure: defined content as '{md5}8eb9ff6c576b9869944215af3a568c2e'
Notice: /Stage[main]/Rabbitmq::Config/Exec[rabbitmq-systemd-reload]: Triggered 'refresh' from 1 events
Notice: /Stage[main]/Rabbitmq::Config/File[/etc/security/limits.d/rabbitmq-server.conf]/ensure: defined content as '{md5}5ddc6ba5fcaeddd5b1565e5adfda5236'
Error: Systemd start for rabbitmq-server failed!
journalctl log for rabbitmq-server:
-- Logs begin at Sat 2017-06-17 19:00:56 EDT, end at Sat 2017-06-17 19:34:12 EDT. --
Jun 17 19:34:10 <my_domain_name> systemd[1]: Starting RabbitMQ broker...
Jun 17 19:34:11 <my_domain_name> rabbitmq-server[18966]: ERROR: epmd error for host tryopenstack: address (cannot connect to host/port)
Jun 17 19:34:11 <my_domain_name> systemd[1]: rabbitmq-server.service: main process exited, code=exited, status=1/FAILURE
Jun 17 19:34:12 <my_domain_name> rabbitmqctl[19062]: Stopping and halting node rabbit@tryopenstack ...
Jun 17 19:34:12 <my_domain_name> rabbitmqctl[19062]: Error: unable to connect to node rabbit@tryopenstack: nodedown
Jun 17 19:34:12 <my_domain_name> rabbitmqctl[19062]: DIAGNOSTICS
Jun 17 19:34:12 <my_domain_name> rabbitmqctl[19062]: ===========
Jun 17 19:34:12 <my_domain_name> systemd[1]: Failed to start RabbitMQ broker.
Jun 17 19:34:12 <my_domain_name> systemd[1]: Unit rabbitmq-server.service entered failed state.
Jun 17 19:34:12 <my_domain_name> systemd[1]: rabbitmq-server.service failed.

Error: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]/ensure: change from stopped to running failed: Systemd start for rabbitmq-server failed!
journalctl log for rabbitmq-server:
-- Logs begin at Sat 2017-06-17 19:00:56 EDT, end at Sat 2017-06-17 19:34:12 EDT. --
Jun 17 19:34:10 <my_domain_name> systemd[1]: Starting RabbitMQ broker...
Jun 17 19:34:11 <my_domain_name> rabbitmq-server[18966]: ERROR: epmd error for host tryopenstack: address (cannot connect to host/port)
Jun 17 19:34:11 <my_domain_name> systemd[1]: rabbitmq-server.service: main process exited, code=exited, status=1/FAILURE
Jun 17 ...
(more)
2017-06-13 13:54:56 -0500 received badge  Notable Question (source)
2017-06-12 05:36:31 -0500 received badge  Popular Question (source)
2017-06-10 01:58:20 -0500 received badge  Editor (source)
2017-06-10 01:54:36 -0500 asked a question Error (Systemd start for rabbitmq-server failed) while installing Packstack on new CentOS?

This is the error:

ERROR : Error appeared during Puppet run: 192.168.0.201_controller.pp
Error: Systemd start for rabbitmq-server failed!
You will find full trace in log /var/tmp/packstack/20170610-021122-_QyFqg/manifests/192.168.0.201_controller.pp.log

I am not able to see why the rabbitmq-server can't start. I think my issue maybe related to the fact that I am using my wireless port as the primary interface to setup RDO. But I may be wrong.

Here is the log in more detail. Please help:

Jun 10 02:12:44 tryopenstack.xyz.com systemd[1]: Starting RabbitMQ broker...
Jun 10 02:12:44 tryopenstack.xyz.com rabbitmq-server[6235]: ERROR: epmd error for host tryopenstack: address (cannot connect to host/port)
Jun 10 02:12:44 tryopenstack.xyz.com systemd[1]: rabbitmq-server.service: main process exited, code=exited, status=1/FAILURE
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: Stopping and halting node rabbit@tryopenstack ...
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: Error: unable to connect to node rabbit@tryopenstack: nodedown
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: DIAGNOSTICS
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: ===========
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: attempted to contact: [rabbit@tryopenstack]
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: rabbit@tryopenstack:
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: * unable to connect to epmd (port 4369) on tryopenstack: address (cannot connect to host/port)
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: current node details:
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: - node name: 'rabbitmq-cli-04@tryopenstack'
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: - home dir: /var/lib/rabbitmq
Jun 10 02:12:45 tryopenstack.xyz.com rabbitmqctl[6336]: - cookie hash: lfdPDB0qOFq1ConYdHDj+w==
Jun 10 02:12:45 tryopenstack.xyz.com systemd[1]: Failed to start RabbitMQ broker.
Jun 10 02:12:45 tryopenstack.xyz.com systemd[1]: Unit rabbitmq-server.service entered failed state.
Jun 10 02:12:45 tryopenstack.xyz.com systemd[1]: rabbitmq-server.service failed.
^[[0m
^[[mNotice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Service[rabbitmq-server] has failures: true^[[0m
^[[1;33mWarning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Skipping because of failed dependencies^[[0m
@                                                                                                                                             
^[[0m
^[[mNotice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Service[rabbitmq-server] has failures: true^[[0m
^[[1;33mWarning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Glance::Api::Authtoken/Keystone::Resource::Authtoken[glance_api_config]/Glance_api_config[keystone_authtoken/password]/value: value changed '[old secret redacted]' to '[new secret redacted]'^[[0m
^[[mNotice: /Stage[main]/Glance::Api::Db/Oslo::Db[glance_api_config]/Glance_api_config[database/connection]/value: value changed '[old secret redacted]' to '[new secret redacted]'^[[0m
^[[1;31mError: Systemd start for rabbitmq-server failed!
journalctl log for rabbitmq-server:
-- Logs begin at Sat 2017-06-10 02:02:16 EDT, end at Sat 2017-06-10 02:12:45 EDT. --
Jun 10 02:12:44 tryopenstack.xyz.com systemd[1]: Starting RabbitMQ broker...
Jun 10 02 ...
(more)
2017-06-07 23:11:13 -0500 commented answer Failed to discover available identity versions

So, which version is meant for beginners then?

2017-06-07 19:16:29 -0500 asked a question How to configure horizon for HTTPS and SSL in the latest DevStack release?

Hi, Here is the horizon.conf file;

< VirtualHost *:80 > #added space because this website doesn't seem to allow the tags

WSGIScriptAlias /dashboard /opt/stack/horizon/openstack_dashboard/wsgi/django.wsgi

WSGIDaemonProcess horizon user=stack group=stack processes=3 threads=10 home=/opt/stack/horizon display-name=%{GROUP}

WSGIApplicationGroup %{GLOBAL}

SetEnv APACHE_RUN_USER stack
SetEnv APACHE_RUN_GROUP stack
WSGIProcessGroup horizon

DocumentRoot /opt/stack/horizon/.blackhole/
Alias /dashboard/media /opt/stack/horizon/openstack_dashboard/static
Alias /dashboard/static /opt/stack/horizon/static

RedirectMatch "^/$" "/dashboard/"

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory /opt/stack/horizon/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    # Apache 2.4 uses mod_authz_host for access control now (instead of
    #  "Allow")
    <IfVersion < 2.4>
        Order allow,deny
        Allow from all
    </IfVersion>
    <IfVersion >= 2.4>
        Require all granted
    </IfVersion>
</Directory>
<IfVersion >= 2.4>
  ErrorLogFormat "%{cu}t %M"
</IfVersion>
ErrorLog /var/log/apache2/horizon_error.log
LogLevel warn
CustomLog /var/log/apache2/horizon_access.log combined

</virtualhost>

WSGISocketPrefix /var/run/apache2

I have generated certificates for SSL and HTTPS seems to be working.

However, I DON'T UNDERSTAND how to set the Document root for the Horizon dashboard and there seems to be no documentation on it. I copy-pasted the same from above (port 80) to my default-ssl.conf file, and enabled it - but it doesn't work. Can someone explain what to set as the document root for HTTPS?

2016-09-26 13:47:30 -0500 commented question Openstack APIs testing using REST Client - 403 Forbidden Response

Can you provide an example of your successive API calls that fail? Thanks.

2016-03-16 20:20:14 -0500 received badge  Student (source)