Ask Your Question

apdibbo's profile - activity

2018-12-06 12:46:16 -0500 received badge  Famous Question (source)
2018-12-04 04:28:44 -0500 received badge  Notable Question (source)
2018-12-03 15:28:54 -0500 received badge  Popular Question (source)
2018-11-29 03:47:41 -0500 asked a question Instances fail to start failed to allocate network

Hi,

All our instance creations are currently failing with the following error :

Message
Exceeded maximum number of retries. Exhausted all hosts available for retrying build failures for instance 23e172ea-a13f-4bb4-9ae4-5f694644d9c1.
Code
500
Details
File "/usr/lib/python2.7/site-packages/nova/conductor/manager.py", line 580, in build_instances raise exception.MaxRetriesExceeded(reason=msg)
Created
Nov. 29, 2018, 9:12 a.m.

We are running Queens on Centos 7 with KVM and OpenVSwitch, we have both vlan and vxlan tenant networks, neither of which are working.

Config files are as follows Neutron.conf (controller):

[DEFAULT]
allow_automatic_l3agent_failover=True
allow_overlapping_ips=True
auth_strategy=keystone
core_plugin=ml2
debug=True
dhcp_agents_per_network=5
dhcp_domain=
dvr_base_mac=FA:CA:FF:02:00:00
memcached_servers=keystone1.nubes.rl.ac.uk:11211,keystone2.nubes.rl.ac.uk:11211,keystone3.nubes.rl.ac.uk:11211
notification_driver=messagingv2
notify_nova_on_port_data_changes=True
notify_nova_on_port_status_changes=True
nova_url=https://openstack.nubes.rl.ac.uk:8774/v2
router_distributed=True
rpc_backend=rabbit
rpc_response_timeout=60
service_plugins=router
transport_url=rabbit://openstack:<rabbitpass>@rabbit1.nubes.rl.ac.uk:5672,openstack:<rabbitpass@rabbit2.nubes.rl.ac.uk:5672,openstack:<rabbitpass@rabbit3.nubes.rl.ac.uk:5672/
verbose=True

[cache]
backend=oslo_cache.memcache_pool
enabled=True
memcache_servers=keystone1.nubes.rl.ac.uk:11211,keystone2.nubes.rl.ac.uk:11211,keystone3.nubes.rl.ac.uk:11211

[database]
connection=mysql+pymysql://neutron:<neutrondbpass>@OpenStack.nubes.rl.ac.uk:3306/neutron
max_overflow=200
max_pool_size=200

[keystone_authtoken]
auth_plugin=password
auth_type=password
auth_uri=https://openstack.nubes.rl.ac.uk:5000
auth_url=https://openstack.nubes.rl.ac.uk:35357
password=<neutronpassword>
project_domain_name=default
project_name=service
user_domain_name=default
username=neutron

[nova]
auth_plugin=password
auth_type=password
auth_url=https://openstack.nubes.rl.ac.uk:35357
password=<novapassword>
project_domain_name=default
project_name=service
region_name=RegionOne
user_domain_name=default
username=nova

[oslo_concurrency]
lock_path=/var/lib/neutron/tmp

Neutron.conf (compute):

[DEFAULT]
auth_strategy=keystone
debug=True
rpc_backend=rabbit
rpc_response_timeout=600
transport_url=rabbit://openstack::<rabbitpass>@rabbit1.nubes.rl.ac.uk:5672,openstack::<rabbitpass>@rabbit2.nubes.rl.ac.uk:5672,openstack::<rabbitpass>@rabbit3.nubes.rl.ac.uk:5672/
verbose=True

[keystone_authtoken]
auth_plugin=password
auth_type=password
auth_uri=https://openstack.nubes.rl.ac.uk:5000
auth_url=https://openstack.nubes.rl.ac.uk:35357
password=<neutronpassword>
project_domain_name=default
project_name=service
user_domain_name=default
username=neutron

[oslo_concurency]
lock_path=/var/lib/neutron/tmp

openvswitchagent.ini (compute):

[agent]
arp_responder=True
enable_distributed_routing=True
l2_population=True
prevent_arp_spoofing=False
tunnel_types=vxlan
debug=True

[ovs]
bridge_mappings=provider:br0
local_ip=130.246.208.89

[securitygroup]
enable_security_group=True
firewall_driver=iptables_hybrid

Log files are as follows:

nova-compute (compute)

2018-11-29 09:11:39.252 4860 DEBUG nova.scheduler.client.report [req-a81f40e4-8a44-452e-82c0-99d1d11dab5d - - - - -] Instance 23e172ea-a13f-4bb4-9ae4-5f694644d9c1 allocations are unchanged:
VCPU=1,MEMORY_MB=1024,DISK_GB=10 _allocate_for_instance /usr/lib/python2.7/site-packages/nova/scheduler/client/report.py:1419
2018-11-29 09:11:39.261 4860 DEBUG nova.compute.resource_tracker [req-a81f40e4-8a44-452e-82c0-99d1d11dab5d - - - - -] Auto-correcting allocations. _update_usage_from_instance /usr/lib/python
2.7/site-packages/nova/compute/resource_tracker.py:1121
2018-11-29 09:11:39.340 4860 DEBUG nova.scheduler.client.report [req-a81f40e4-8a44-452e-82c0-99d1d11dab5d - - - - -] Instance 373ecd6a-8b10-4486-b3af-b6a4953dfb1c allocations are unchanged:
VCPU=4,MEMORY_MB=16384,DISK_GB=100 _allocate_for_instance /usr/lib/python2.7/site-packages/nova/scheduler/client/report.py:1419
2018-11-29 09:11:39.536 ...
(more)
2018-09-26 01:07:37 -0500 received badge  Notable Question (source)
2018-09-26 01:07:37 -0500 received badge  Popular Question (source)
2018-03-02 10:13:39 -0500 asked a question Nova-scheduler weight question - prefer smaller hypervisors

Hi,

I would like to configure the nova scheduler to prefer placing VMs on smaller hypervisors.

How would I go about doing this?

I can see that meters and weights are probably the way but I cant see good examples of this.

Thanks

Alex

2017-06-06 04:35:42 -0500 received badge  Notable Question (source)
2017-06-06 04:35:42 -0500 received badge  Famous Question (source)
2017-06-06 04:35:42 -0500 received badge  Popular Question (source)
2017-05-09 06:02:44 -0500 asked a question Python SDK: Could not find endpoint in service catalog

Hi Everyone,

My OpenStack deployment is Mitaka and the python client versions are as follows:

@vm305 ~]# rpm -qa | grep keystone
python2-keystoneauth1-2.4.1-1.el7.noarch
python-keystonemiddleware-4.4.1-1.el7.noarch
python-keystoneclient-2.3.1-2.el7.noarch
[root@vm305 ~]# rpm -qa | grep openstack
python2-openstacksdk-0.8.3-1.el7.noarch
openstack-dashboard-9.0.1-1.el7.noarch
openstack-horizon-scd-0.2-1.noarch
python-openstackclient-2.3.0-1.el7.noarch
python-django-openstack-auth-2.2.1-1.el7.noarch

I have run into a problem while attempting to use the Python SDK as described here https://docs.openstack.org/developer/python-keystoneclient/api/keystoneclient.v3.html#module-keystoneclient.v3.client (https://docs.openstack.org/developer/...) the example code I am using is:

from keystoneclient.v3 import client as ksclient
from keystoneauth1.identity import v3
from keystoneauth1 import session
import novaclient.client as client
import ConfigParser


config = ConfigParser.ConfigParser()

config.read("/var/www/frontend/config/global.conf")

json = { "username":"admin","password":"SomePassword"}

NOVA_VERSION="2.1"
KEYSTONE_URL = config.get("global","keystone")
OPENSTACK_HOST = config.get("global","openstack_host")
OPENSTACK_DEFAULT_DOMAIN = config.get("global","openstack_default_domain")
auth = v3.Password(auth_url=KEYSTONE_URL, username=json.get("username"),password=json.get("password"),user_domain_name="default",domain_name="default")
print auth
sess = session.Session(auth=auth,verify='/etc/ssl/certs/ca-bundle/crt')
print sess
nova = client.Client(NOVA_VERSION,session=sess)
print nova
print sess.get_endpoint()
print sess.get_token()
print sess.get('/users', endpoint_filter={'service_type': 'identity',
                                        'interface': 'admin',
                                        'region_name': 'RegionOne'})
keystone = ksclient.Client(session=sess,endpoint=KEYSTONE_URL+"/v3")
print keystone
projects = keystone.projects.list()
print projects

The response I am getting is the following:

[root@vm305 ~]# python user.py
<keystoneauth1.identity.v3.password.Password object at 0x329cc90>
<keystoneauth1.session.Session object at 0x43d9650>
<novaclient.v2.client.Client object at 0x43d9990>
No handlers could be found for logger "keystoneauth.identity.base"
None
Traceback (most recent call last):
  File "user.py", line 25, in <module>
    print sess.get_token()
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 840, in get_token
    return (self.get_auth_headers(auth) or {}).get('X-Auth-Token')
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 818, in get_auth_headers
    return auth.get_headers(self, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/plugin.py", line 90, in get_headers
    token = self.get_token(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 90, in get_token
    return self.get_access(session).auth_token
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
    self.auth_ref = self.get_auth_ref(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/v3/base.py", line 167, in get_auth_ref
    authenticated=False, log=False, **rkwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 766, in post
    return self.request(url, 'POST', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 516, in request
    raise exceptions.EndpointNotFound()
keystoneauth1.exceptions.catalog.EndpointNotFound: Could not find requested endpoint in Service Catalog.

When i run a regular openstack endpoint list i get the following:

+----------------------------------+-----------+--------------+----------------+---------+-----------+---------------------------------------------+
| ID                               | Region    | Service Name | Service Type   | Enabled | Interface | URL                                         |
+----------------------------------+-----------+--------------+----------------+---------+-----------+---------------------------------------------+
| 17c49729f4b246189680dcf655b36d44 | RegionOne | neutron      | network        | True    | admin     | https ...
(more)
2017-03-15 09:43:15 -0500 asked a question Neutron agents dbconectionerror

Hi All,

I am running an OpenStack deployment with mutiple instances of each service behind haproxy. The database connections are to a galera cluster though the same set of load balancers.

I am having some issues with Neutron agents displaying the following error in their logs:

    2017-03-15 14:23:28.398 22029 ERROR neutron Traceback (most recent call last):
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/bin/neutron-openvswitch-agent", line 10, in <module>
2017-03-15 14:23:28.398 22029 ERROR neutron     sys.exit(main())
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/cmd/eventlet/plugins/ovs_neutron_agent.py", line 20, in main
2017-03-15 14:23:28.398 22029 ERROR neutron     agent_main.main()
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/main.py", line 49, in main
2017-03-15 14:23:28.398 22029 ERROR neutron     mod.main()
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/openflow/ovs_ofctl/main.py", line 36, in main
2017-03-15 14:23:28.398 22029 ERROR neutron     ovs_neutron_agent.main(bridge_classes)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/ovs_neutron_agent.py", line 2160, in main
2017-03-15 14:23:28.398 22029 ERROR neutron     agent = OVSNeutronAgent(bridge_classes, cfg.CONF)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/ovs_neutron_agent.py", line 237, in __init__
2017-03-15 14:23:28.398 22029 ERROR neutron     self.dvr_agent.setup_dvr_flows()
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/ovs_dvr_neutron_agent.py", line 149, in setup_dvr_flows
2017-03-15 14:23:28.398 22029 ERROR neutron     self.setup_dvr_mac_flows_on_all_brs()
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/openvswitch/agent/ovs_dvr_neutron_agent.py", line 318, in setup_dvr_mac_flows_on_all_brs
2017-03-15 14:23:28.398 22029 ERROR neutron     dvr_macs = self.plugin_rpc.get_dvr_mac_address_list(self.context)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/oslo_log/helpers.py", line 46, in wrapper
2017-03-15 14:23:28.398 22029 ERROR neutron     return method(*args, **kwargs)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/api/rpc/handlers/dvr_rpc.py", line 52, in get_dvr_mac_address_list
2017-03-15 14:23:28.398 22029 ERROR neutron     return cctxt.call(context, 'get_dvr_mac_address_list')
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/neutron/common/rpc.py", line 136, in call
2017-03-15 14:23:28.398 22029 ERROR neutron     return self._original_context.call(ctxt, method, **kwargs)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/client.py", line 158, in call
2017-03-15 14:23:28.398 22029 ERROR neutron     retry=self.retry)
2017-03-15 14:23:28.398 22029 ERROR neutron   File "/usr/lib/python2.7 ...
(more)
2016-09-20 03:51:58 -0500 received badge  Famous Question (source)
2016-08-11 11:21:44 -0500 commented answer VMs on compute node unable to use network

No the controllers are VMs in a HyperV cluster. The Network nodes are VMs running in KVM at the moment. I have confirmed that the appropriate agents are reachable from the compute node

2016-08-10 18:01:02 -0500 received badge  Notable Question (source)
2016-08-10 04:06:12 -0500 commented answer VMs on compute node unable to use network

I have added the output of iptables -L -vn to the OP

I have a security group set up which allows all traffic at the moment

2016-08-10 01:23:01 -0500 received badge  Popular Question (source)
2016-08-09 05:06:17 -0500 asked a question VMs on compute node unable to use network

Hi, I am having an issue with neutron on my compute nodes. I am using mitaka on SL7 with linux bridge networking.

I had previously been having this problem https://ask.openstack.org/en/question/94395/linux-bridge-rtnetlink-exists/ (https://ask.openstack.org/en/question...) which I have resolved. Now my VMs on my flat public network are unable to get dhcp or if set with a static ip cannot ping anything. The same is true for VMs on a private network.

The DHCP agent and other agents on the network node are reachable from the compute node and other locations on the network.

I have statically assigned an ip address to a VM on the compute node and am unable to ping the compute node, the gateway or anything else on the network.

Below are config files: linuxbridge_agent.ini

[agent]
prevent_arp_spoofing=false

[linux_bridge]
bridge_mappings=public:br0
physical_interface_mappings=public:br0

[securitygroup]
enable_security_group=True
firewall_driver=neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

[vxlan]
enable_vxlan=True
l2_population=True
local_ip=130.246.223.142

output of brctl show

bridge name     bridge id               STP enabled     interfaces
br0             8000.a0369f32db38       no              p1p1
brq5a97f9b0-0f          8000.fecaad283f39       no              tap46a6bf63-f8
                                                        tap4f8b5d7a-9d

output of ifconfig

br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 130.246.223.142  netmask 255.255.248.0  broadcast 130.246.223.255
        inet6 fe80::a236:9fff:fe32:db38  prefixlen 64  scopeid 0x20<link>
        ether a0:36:9f:32:db:38  txqueuelen 0  (Ethernet)
        RX packets 3026204  bytes 1402700536 (1.3 GiB)
        RX errors 0  dropped 4274  overruns 0  frame 0
        TX packets 248857  bytes 876764427 (836.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

brq5a97f9b0-0f: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::6cdc:78ff:fee7:ccbb  prefixlen 64  scopeid 0x20<link>
        ether fe:ca:ad:28:3f:39  txqueuelen 0  (Ethernet)
        RX packets 261  bytes 11132 (10.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16  bytes 1376 (1.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 137153  bytes 7279941 (6.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 137153  bytes 7279941 (6.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p1p1: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        ether a0:36:9f:32:db:38  txqueuelen 1000  (Ethernet)
        RX packets 4106724  bytes 1621228855 (1.5 GiB)
        RX errors 0  dropped 291  overruns 0  frame 0
        TX packets 807762  bytes 913750540 (871.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap46a6bf63-f8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::fcca:adff:fe28:3f39  prefixlen 64  scopeid 0x20<link>
        ether fe:ca:ad:28:3f:39  txqueuelen 500  (Ethernet)
        RX packets 9  bytes 1458 (1.4 KiB)
        RX ...
(more)
2016-07-21 10:18:05 -0500 received badge  Famous Question (source)
2016-07-21 04:04:46 -0500 received badge  Enthusiast
2016-07-13 09:32:20 -0500 received badge  Notable Question (source)
2016-07-11 03:12:25 -0500 commented question Linux bridge RTNETLINK exists

@darragh-oreilly - thanks, I have found and added the running command which is generating the error to the op

2016-07-11 03:11:35 -0500 received badge  Editor (source)
2016-07-10 11:39:53 -0500 received badge  Popular Question (source)
2016-07-08 08:23:24 -0500 commented question Linux bridge RTNETLINK exists

@darragh-oreilly - I cant see anything which begins with "Running command" in the Linuxbridge log

2016-07-08 02:38:27 -0500 commented question Linux bridge RTNETLINK exists

@darragh-oreilly - I have edited my opening post as I had misspoken when I stated the behavior I am seeing. This error does indeed relate to a flat network for the external port of a router. When you say an unnumbered interface do you mean an interface without an IP? This isn't possible on my set up

2016-07-07 09:40:20 -0500 asked a question Linux bridge RTNETLINK exists

EDIT: I have updated the behavior I am seeing

EDIT2: I have added the running command from the debug

Hi,

I am running Mitaka on Centos 7 and am getting the following error in the linuxbridge log on the network node

2016-07-11 08:54:54.062 29032 DEBUG neutron.agent.linux.utils [req-e5b5a87c-2a0b-4497-b151-0ae67ef27eda - - - - -] Running command (rootwrap daemon): ['ip', '-4', 'addr', 'add', '130.246.221 .144/21', 'scope', 'global', 'dev', 'brq24a664ef-e8', 'brd', '130.246.223.255'] execute_rootwrap_daemon /usr/lib/python2.7/site-packages/neutron/agent/linux/utils.py:100 2016-07-11 08:54:54.066 29032 ERROR neutron.agent.linux.utils [req-e5b5a87c-2a0b-4497-b151-0ae67ef27eda - - - - -] Exit code: 2; Stdin: ; Stdout: ; Stderr: RTNETLINK answers: File existss

I am able to have VMs connected to the public and private networks however interfaces created on the network node never leave the BUILD state

Thanks

Alex

full log section below: 2016-07-07 13:25:00.269 24579 INFO neutron.plugins.ml2.drivers.agent._common_agent [req-5674c1e9-b040-4972-9e21-3d4ecb7ef931 - - - - -] Port tap72287883-0a updated. Details: {u'profile': {}, u'network_qos_policy_id': None, u'qos_policy_id': None, u'allowed_address_pairs': [], u'admin_state_up': True, u'network_id': u'24a664ef-e877-4f78-a5e1-cab7e0d4fbb5', u'segmentation_id': No ne, u'device_owner': u'network:router_gateway', u'physical_network': u'public', u'mac_address': u'fa:ca:ad:aa:72:41', u'device': u'tap72287883-0a', u'port_security_enabled': False, u'port_id ': u'72287883-0ad4-458b-8602-c46cba5c0024', u'fixed_ips': [{u'subnet_id': u'2d9c9815-ee0d-40d1-84c4-3ee0108c4c54', u'ip_address': u'130.246.222.244'}], u'network_type': u'flat', u'security_g roups': []} 2016-07-07 13:25:00.274 24579 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.arp_protect [req-5674c1e9-b040-4972-9e21-3d4ecb7ef931 - - - - -] Skipping ARP spoofing rules for port 'tap722 87883-0a' because it has port security disabled 2016-07-07 13:25:00.294 24579 ERROR neutron.agent.linux.utils [req-5674c1e9-b040-4972-9e21-3d4ecb7ef931 - - - - -] Exit code: 2; Stdin: ; Stdout: ; Stderr: RTNETLINK answers: File exists 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent [req-5674c1e9-b040-4972-9e21-3d4ecb7ef931 - - - - -] Error in agent loop. Devices info: {'current': set(['tap72287883-0a', 'tape3d8b231-27', 'tap21af721c-b1', 'tape60c14e9-b3']), 'timestamps': {'tap72287883-0a': None, 'tape3d8b231-27': 1467623591.6060283, 'tape60c14e9-b3': 1467623591.6060283, 'tap21af721c-b1': 1467623591.6060283}, 'removed': set([]), 'added': set(['tap72287883-0a', 'tape3d8b231-27', 'tap21af721c-b1', 'tape60c14e9-b3']), 'updated': set([])} 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent Traceback (most recent call last): 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/agent/_common_agent.py", line 419, in daemon_loop 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent sync = self.process_network_devices(device_info) 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/agent/_common_agent.py", line 199, in process_network_devices 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent resync_a = self.treat_devices_added_updated(devices_added_updated) 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/agent/_common_agent.py", line 235, in treat_devices_added_updated 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent device, device_details['device_owner']) 2016-07-07 13:25:00.299 24579 ERROR neutron.plugins.ml2.drivers.agent._common_agent File "/usr ... (more)