Ask Your Question

abhilash-goyal's profile - activity

2018-03-20 02:18:45 -0500 received badge  Famous Question (source)
2017-08-03 14:25:25 -0500 received badge  Famous Question (source)
2017-04-13 05:26:31 -0500 received badge  Famous Question (source)
2017-02-09 20:28:48 -0500 received badge  Famous Question (source)
2017-02-04 12:12:18 -0500 received badge  Notable Question (source)
2017-01-29 21:01:03 -0500 received badge  Popular Question (source)
2017-01-29 10:07:54 -0500 received badge  Notable Question (source)
2017-01-29 10:07:54 -0500 received badge  Popular Question (source)
2017-01-27 08:32:34 -0500 received badge  Nice Question (source)
2017-01-26 15:49:24 -0500 received badge  Student (source)
2017-01-24 00:37:07 -0500 received badge  Famous Question (source)
2017-01-16 15:29:20 -0500 received badge  Popular Question (source)
2017-01-12 05:47:01 -0500 asked a question tacker user_data not working for OpenWRT image

Following tosca template is not working as expected for OpenWRT image. It is not updating the /etc/hosts file. In contrast when I am using cirros image instead, it is working perfectly.

Any help regarding would be appreciated.

> tosca_definitions_version:
> tosca_simple_profile_for_nfv_1_0_0
> 
> description: OpenWRT with services
> 
> metadata:   template_name: OpenWRT
> 
> topology_template:   node_templates:
> 
>     VDU1:
>       type: tosca.nodes.nfv.VDU.Tacker
>       properties:
>         image: OpenWRT
>         flavor: m1.tiny
>         config: |
>           param0: key1
>           param1: key2
>         mgmt_driver: openwrt
>         user_data_format: RAW
>         user_data: |
>           #!/bin/sh
>           i=$(ifconfig eth0|grep 'inet addr'|awk -F: '{print $2}'| awk '{print $1}')
>           w="OpenWRT"
>           y=$i"  "$w
>           sed -i -e "\$a$y" /etc/hosts
>           sed -i -e "s/cirros/$w/g" /etc/hosts
>         monitoring_policy:
>           name: ping
>           parameters:
>             count: 3
>             interval: 10
> 
>     CP1:
>       type: tosca.nodes.nfv.CP.Tacker
>       properties:
>         management: true
>         anti_spoofing_protection: false
>       requirements:
>         - virtualLink:
>             node: VL1
>         - virtualBinding:
>             node: VDU1
> 
>     CP2:
>       type: tosca.nodes.nfv.CP.Tacker
>       properties:
>         anti_spoofing_protection: false
>       requirements:
>         - virtualLink:
>             node: VL2
>         - virtualBinding:
>             node: VDU1
> 
>     CP3:
>       type: tosca.nodes.nfv.CP.Tacker
>       properties:
>         anti_spoofing_protection: false
>       requirements:
>         - virtualLink:
>             node: VL3
>         - virtualBinding:
>             node: VDU1
> 
>     VL1:
>       type: tosca.nodes.nfv.VL
>       properties:
>         network_name: net_mgmt
>         vendor: Tacker
> 
>     VL2:
>       type: tosca.nodes.nfv.VL
>       properties:
>         network_name: net0
>         vendor: Tacker
> 
>     VL3:
>       type: tosca.nodes.nfv.VL
>       properties:
>         network_name: net1
>         vendor: Tacker
2017-01-11 00:38:46 -0500 answered a question Queries related to TOSCA templates

Following the same. Any help regarding this.

2017-01-11 00:36:35 -0500 answered a question tacker vnf-create: how to customize my VNF ?

Hello William. Can you please tell if you are still facing issues related to VNFs ?

2017-01-11 00:33:48 -0500 asked a question How to create management network for tacker ?

I have Devstack Single Node (Mitaka version) installed with tacker component enabled. Many documents talks about the Tacker Management Network through which it provisions the VNFs it had spawned, enable or disable the functionality of VNF. Can anyone help me how to create this management network.

2017-01-04 05:02:16 -0500 commented question Count number of hosts per network

Hi Bernd, this command gives all nodes. What I am trying to do is count hosts attached to a specific network-id. The process of using openstack server list --all-projects would be very inefficient, I think.

2017-01-04 01:33:37 -0500 asked a question Count number of hosts per network

I am trying to calculate number of hosts connected to a specific network in openstack. Is there any efficient way to do so ?

KIndly Help.

2016-12-20 03:09:35 -0500 received badge  Notable Question (source)
2016-12-20 03:09:35 -0500 received badge  Popular Question (source)
2016-09-15 00:12:56 -0500 commented answer how to add extra static route in neutron (Havana)

does this command work !!!

2016-09-15 00:11:52 -0500 commented answer how to add extra static route in neutron (Havana)

Is there a way to add routes based on source address ?

2016-08-30 09:21:23 -0500 received badge  Notable Question (source)
2016-08-30 09:21:23 -0500 received badge  Popular Question (source)
2016-08-26 03:19:26 -0500 received badge  Notable Question (source)
2016-08-26 00:52:35 -0500 answered a question Tacker VNF deployment is not able to bringup all interfaces

facing the same issue. Any progress ?

2016-08-26 00:22:09 -0500 asked a question tacker vnf-update results in error state of a VNF

I am creating openwrt VNF through the following command:

tacker vnf-create --vnfd-id <id of openwrt vnf-d> --name openwrt_1

This vnfd have three connecting points which results in creation of eth0, eth1, eth2. This vnf is getting in Active mode,but when I am trying to update this vnf by following command,

stack@abhilash-VirtualBox:~$ tacker vnf-update --config-file tosca-cirros-firewall-update.yaml     c1fe94f6-4eb1-49b1-9eaa-0e56ded15a29
Updated vnf: c1fe94f6-4eb1-49b1-9eaa-0e56ded15a29

this says that vnf updated, but results in leaving vnf in error state with reason saying 'VNF configuration failed'.

tosca-cirros-firewall-update.yaml file looks like:

vdus:
  VDU1:
    config:
      network: |
       package network
        config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
        config interface 'lan'
            option ifname 'eth0'
            option type 'bridge'
            option proto 'dhcp'
            option ip6assign '60'
        config interface 'wan'
            option ifname 'eth1'
            option proto 'dhcp'
        config interface 'wan6'
            option ifname 'eth1'
            option proto 'dhcpv6'
        config interface 'wan'
            option ifname 'eth2'
            option proto 'dhcp'
        config interface 'wan6'
            option ifname 'eth2'
            option proto 'dhcpv6'
        config globals 'globals'
            option ula_prefix 'fdb3:e323:e93b::/48'

Kindly suggest, where am I going wrong. Thanks in advance.

2016-07-19 03:17:12 -0500 received badge  Popular Question (source)
2016-07-08 05:01:25 -0500 asked a question Error in tacker installation

While installing tacker component in existing openstack setup, I am getting the following error:

2016-07-08 09:52:11.896 | Obtaining file:///opt/stack/tacker-horizon
2016-07-08 09:52:19.476 | Requirement already satisfied (use --upgrade to upgrade): pbr===1.8.1 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 223))
2016-07-08 09:52:19.661 | Installing collected packages: tacker-horizon
2016-07-08 09:52:19.661 | Running setup.py develop for tacker-horizon
2016-07-08 09:52:22.322 | Successfully installed tacker-horizon-0.3.1.dev19
2016-07-08 09:52:22.573 | You are using pip version 7.1.2, however version 8.1.2 is available.
2016-07-08 09:52:22.573 | You should consider upgrading via the 'pip install --upgrade pip' command.
2016-07-08 09:52:24.939 | * Stopping web server apache2
2016-07-08 09:52:39.821 | *
2016-07-08 09:52:42.833 | * Starting web server apache2
2016-07-08 09:52:43.108 | AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
2016-07-08 09:52:44.308 | *
2016-07-08 09:52:44.770 | Deleting networks
2016-07-08 09:53:08.025 | Creating networks
2016-07-08 09:53:23.639 | Assign ip address to BR_MGMT
2016-07-08 09:53:30.731 | 1ff08fc3001744b2b236521c2fef846b
2016-07-08 09:53:32.503 | 0bfca6651c854934b65aa39edb95f3b8
2016-07-08 09:53:37.308 | a898ec21b65c46a7b5397fdfc3ad7a3d
2016-07-08 09:53:42.071 | 37dcf3d01fce47e2bc0855c4d6d45a36
2016-07-08 09:53:49.500 | 'module' object has no attribute 'mask_dict_password'
2016-07-08 09:53:49.533 | Error on exit 2016-07-08 09:53:59.572 | /bin/sh: 1: kill: Operation not permitted 2016-07-08 09:53:59.572 |

Kindly help.

2016-06-02 21:48:40 -0500 received badge  Famous Question (source)
2016-04-27 04:31:08 -0500 asked a question Test case passing by tox py27 and py34 but failing in jenkins gate-nova-python27-db, gate-nova-python34-db

In submitting a solution to a nova bug, I am facing a issue where I have written a test case in nova component, which is passing in local testing through tox -e py27 and tox -e py34 but failing in Jenkins testing in gate-nova-python34-db and gate-nova-python34-db.

Any answer why is it so, or what else is needed to be done in local testing.

2016-04-27 04:19:31 -0500 received badge  Enthusiast
2016-04-23 10:12:20 -0500 received badge  Notable Question (source)
2016-04-20 23:01:39 -0500 commented answer Effect of change in /etc/hostname to the openstack devstack setup

Its a single node setup. So all I did was changed the hostname of my machine on which openstack single node setup is running.

2016-04-20 03:53:05 -0500 received badge  Popular Question (source)
2016-04-19 23:21:52 -0500 asked a question Effect of change in /etc/hostname to the openstack devstack setup

My single node openstack devstack setup is currently running perfectly, but when I change hostname of my system i.e. I made changes in /etc/hosts and /etc/hostname to set a new hostname. After rebooting system setup is running with error of oslo messaging saying

ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server 127.0.0.1:5672 closed the connection. Check login credentials: Socket closed

On running nova list error shows up saying

ERROR (ClientException): The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-c4251e32-c59e-4ebf-aad1-9f13236f41a1)

Any idea what is potential solution to this.

PS: If I revert back the changes, it start running perfectly.

2016-03-08 06:26:30 -0500 asked a question Error facing while submitting openstack bug. Following is the error snapshot.

Your change was committed before the commit hook was installed. Amending the commit to add a gerrit change id. remote: Processing changes: refs: 1, done
To ssh://<id>@review.openstack.org:29418/openstack/python-novaclient.git ! [remote rejected] HEAD -> refs/publish/master/bug/<bug number=""> (you are not allowed to upload merges) error: failed to push some refs to ssh://<id>@review.openstack.org:29418/openstack/python-novaclient.git

Kindly Help

2016-02-24 10:13:28 -0500 answered a question Please share some best documents to startup with openstack.

Best documentation would be official documentation: http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_preface.html (http://docs.openstack.org/kilo/instal...)

for openstack networking, best documentation: https://www.rdoproject.org/networking/networking-in-too-much-detail/ (https://www.rdoproject.org/networking...)

Rest get your hands dirty in openstack to understand it better.

2016-02-24 10:13:28 -0500 asked a question Traceroute floating IP of VM hosted by openstack shows 0 hops, but we have a virtual router which is connecting external network and tenant network.

I have a doubt, when I am pinging instances hosted by openstack which is in tenant network(10.0.0.0/24) and I have a virtual router connecting tenant network with external network(192.168.1.0/24). I have floating IP associated with each instances. This states that there is one hop(router) between my external PC and instance in tenant network, therefore traceroute should show 1 hop when pinging instance, but its showing 0 hops.

Any explanation to this ?