Ask Your Question

cecco's profile - activity

2018-11-09 09:06:06 -0500 commented answer l2 neutron port

Did you figure this one out?

2018-06-11 22:48:51 -0500 received badge  Famous Question (source)
2018-06-11 22:48:51 -0500 received badge  Notable Question (source)
2017-11-25 14:12:04 -0500 received badge  Famous Question (source)
2017-11-20 16:13:53 -0500 received badge  Popular Question (source)
2017-11-17 10:20:13 -0500 asked a question Nova api failed Rabbit authentication

Hi,

the nova api module is failing not allowing the creation of new instances. The error seems to be related to the rabbit server authentication, however the credential are defined in the nova.conf and they work for the other modules.

(openstack) hypervisor list
+----+---------------------+-----------------+-----------------+-------+
| ID | Hypervisor Hostname | Hypervisor Type | Host IP         | State |
+----+---------------------+-----------------+-----------------+-------+
|  1 | compute1            | QEMU            | 192.168.100.241 | up    |
+----+---------------------+-----------------+-----------------+-------+
(openstack) hypervisor show compute1
Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.
<class 'amqp.exceptions.AccessRefused'> (HTTP 500) (Request-ID: req-7f402b55-fe57-4f83-8f32-6b5a328c1133)
(openstack) 


[root@controller ~]# grep rabbit /etc/nova/nova.conf
transport_url = rabbit://openstack:RABBIT_PASS@controller
# DEPRECATED: The messaging driver to use, defaults to rabbit. Other drivers
#rpc_backend=rabbit
# rabbit://USERNAME:PASSWORD@HOSTNAME:PORT/VIRTUAL_HOST
# The scheme can be either qpid or rabbit, the following sample shows
#             "transport_url": "rabbit://rabbit.example.com",
#             "transport_url": "rabbit://rabbit1.example.com",
#             "transport_url": "rabbit://rabbit2.example.com",
[oslo_messaging_rabbit]
# Deprecated group;name - DEFAULT;rabbit_durable_queues
# Deprecated group;name - [oslo_messaging_rabbit]/kombu_reconnect_timeout
# Deprecated group;name - DEFAULT;rabbit_host
#rabbit_host=localhost
# Deprecated group;name - DEFAULT;rabbit_port
#rabbit_port=5672
# Deprecated group;name - DEFAULT;rabbit_hosts
#rabbit_hosts=$rabbit_host:$rabbit_port
# Deprecated group;name - DEFAULT;rabbit_use_ssl
#rabbit_use_ssl=false
# Deprecated group;name - DEFAULT;rabbit_userid
#rabbit_userid=guest
# Deprecated group;name - DEFAULT;rabbit_password
#rabbit_password=guest
# Deprecated group;name - DEFAULT;rabbit_login_method
#rabbit_login_method=AMQPLAIN
# Deprecated group;name - DEFAULT;rabbit_virtual_host
#rabbit_virtual_host=/
#rabbit_retry_interval=1
# Deprecated group;name - DEFAULT;rabbit_retry_backoff
#rabbit_retry_backoff=2
#rabbit_interval_max=30
# Deprecated group;name - DEFAULT;rabbit_max_retries
#rabbit_max_retries=0
# names) are mirrored across all nodes, run: "rabbitmqctl set_policy HA
# Deprecated group;name - DEFAULT;rabbit_ha_queues
#rabbit_ha_queues=false
#rabbit_transient_queues_ttl=1800
#rabbit_qos_prefetch_count=0
# Deprecated group;name - DEFAULT;fake_rabbit
#fake_rabbit=false



  [root@controller rabbitmq]# rabbitmqctl cluster_status
Cluster status of node rabbit@controller ...
[{nodes,[{disc,[rabbit@controller]}]},
 {running_nodes,[rabbit@controller]},
 {cluster_name,<<"rabbit@controller">>},
 {partitions,[]},
 {alarms,[{rabbit@controller,[]}]}]
[root@controller rabbitmq]# rabbitmqctl authenticate_user openstack RABBIT_PASS
Authenticating user "openstack" ...
Success


=INFO REPORT==== 17-Nov-2017::16:12:48 ===
accepting AMQP connection <0.2035.0> (192.168.100.135:56124 -> 192.168.100.135:5672)

=INFO REPORT==== 17-Nov-2017::16:12:48 ===
Connection <0.2035.0> (192.168.100.135:56124 -> 192.168.100.135:5672) has a client-provided name: nova-api:1908:8da30385-8429-4dc4-a1fa-1e55e558eba0

=ERROR REPORT==== 17-Nov-2017::16:12:48 ===
Error on AMQP connection <0.2035.0> (192.168.100.135:56124 -> 192.168.100.135:5672, state: starting):
AMQPLAIN login refused: user 'openstack' - invalid credentials

=INFO REPORT==== 17-Nov-2017::16:12:48 ===
closing AMQP connection <0.2035.0> (192.168.100.135:56124 -> 192.168.100.135:5672 - nova-api:1908:8da30385-8429-4dc4-a1fa-1e55e558eba0)

Cheers!

2017-11-08 23:55:21 -0500 received badge  Self-Learner (source)
2017-11-08 23:55:21 -0500 received badge  Teacher (source)
2017-11-08 14:54:46 -0500 received badge  Notable Question (source)
2017-11-08 07:36:22 -0500 answered a question Dashboard login not working

Issue solved reinstalling the dashboard and upgrading the keystoneauth module

2017-11-07 23:52:25 -0500 received badge  Popular Question (source)
2017-11-07 18:26:51 -0500 received badge  Editor (source)
2017-11-06 20:05:49 -0500 asked a question Dashboard login not working

Hi all,

I am installing a lab https://docs.openstack.org/ocata/install-guide-rdo/horizon-install.html#install-and-configure-components and everything is working fine thus far, but the login on the Horizon dashboard. I can use the cli, but not the GUI, the login is successful however the dashboard doesn't load.

[Wed Nov 08 00:27:53.870239 2017] [:error] [pid 4706] DEBUG:keystoneauth.identity.v3.base:Making authentication request to http://controller:5000/v3/auth/tokens
[Wed Nov 08 00:27:54.181977 2017] [:error] [pid 4706] DEBUG:keystoneauth.identity.v3.base:{"token": {"issued_at": "2017-11-08T00:27:54.000000Z", "user": {"domain": {"id": "default", "name": "Default"}, "password_expires_at": null, "name": "admin", "id": "cb0a3286f4d24ee5bf8524f6e21dfcb5"}, "methods": ["password"], "expires_at": "2017-11-08T01:27:54.000000Z", "audit_ids": ["PvpALT5zTYa4zV-cjFwqCA"]}}
[Wed Nov 08 00:27:54.183528 2017] [:error] [pid 4706] DEBUG:keystoneauth.identity.v3.base:Making authentication request to http://controller:5000/v3/auth/tokens
[Wed Nov 08 00:27:54.337090 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:Request returned failure status: 401
[Wed Nov 08 00:27:54.337306 2017] [:error] [pid 4706] Attempted scope to domain Default failed, will attemptto scope to another domain.
[Wed Nov 08 00:27:54.347003 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:REQ: curl -g -i -X GET http://controller:5000/v3 -H "Accept: application/json" -H "User-Agent: keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"
[Wed Nov 08 00:27:57.974689 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:RESP: [200] Date: Wed, 08 Nov 2017 00:27:54 GMT Server: Apache/2.4.6 (CentOS) mod_wsgi/3.4 Python/2.7.5 Vary: X-Auth-Token x-openstack-request-id: req-1e3f424e-134c-4e55-895d-f3b558c6b22d Content-Length: 249 Keep-Alive: timeout=5, max=100 Connection: Keep-Alive Content-Type: application/json 
[Wed Nov 08 00:27:57.974926 2017] [:error] [pid 4706] RESP BODY: {"version": {"status": "stable", "updated": "2017-02-22T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v3+json"}], "id": "v3.8", "links": [{"href": "http://controller:5000/v3/", "rel": "self"}]}}
[Wed Nov 08 00:27:57.974940 2017] [:error] [pid 4706] 
[Wed Nov 08 00:27:57.975080 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:GET call to None for http://controller:5000/v3 used request id req-1e3f424e-134c-4e55-895d-f3b558c6b22d
[Wed Nov 08 00:27:57.978566 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:REQ: curl -g -i -X GET http://controller:5000/v3/users/cb0a3286f4d24ee5bf8524f6e21dfcb5/projects? -H "User-Agent: python-keystoneclient" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}b2f30b1bc12c8dff8a617a89da251e035f2364cb"
[Wed Nov 08 00:27:58.226271 2017] [:error] [pid 4706] DEBUG:keystoneauth.session:RESP: [200] Date: Wed, 08 Nov 2017 00:27:57 GMT Server: Apache/2.4.6 (CentOS) mod_wsgi/3.4 Python/2.7.5 Vary: X-Auth-Token x-openstack-request-id: req-4b9bd79d-c79e-48fb-a143-7be22380f638 Content-Length: 442 Keep-Alive: timeout=5, max=99 Connection: Keep-Alive Content-Type: application/json 
[Wed Nov 08 00:27:58.226300 2017] [:error] [pid 4706] RESP BODY: {"links": {"self": "http://controller:5000/v3/users/cb0a3286f4d24ee5bf8524f6e21dfcb5/projects", "previous": null, "next": null}, "projects": [{"is_domain": false, "description": "Bootstrap project for initializing the cloud.", "links": {"self": "http://controller:5000/v3/projects/9530310392714459b2e34cf2dc00ba8e"}, "enabled": true, "id ...
(more)
2016-02-26 04:55:33 -0500 received badge  Enthusiast
2016-02-23 05:58:20 -0500 commented answer Kilo RDO on Fedora 23

Hi Edu! It is exactly the same error, I installed the RDO package on Fedora 23, but the Puppet module nova_api.pp is failing anyway. I have a feeling that updating Fedora before running packstack wasn't a good idea...

2016-02-23 01:17:48 -0500 commented answer Kilo RDO on Fedora 23

Hello,

I have the same issue, but I didn't solve it following the tips in the post. I'm using packstack to configure a lab environment with three nodes, but I got stuck on this error of nova_api, which actually seems to be a Puppet error.

2016-02-23 01:17:48 -0500 answered a question Kilo RDO on Fedora 23

Hello,

I have the same issue, but I didn't solve it following the tips in the post. I'm using packstack to configure a lab environment with three nodes, but I got stuck on this error of nova_api, which actually seems to be a Puppet error.