Ask Your Question

Lee's profile - activity

2018-02-27 04:03:47 -0500 received badge  Famous Question (source)
2018-02-27 04:03:47 -0500 received badge  Notable Question (source)
2018-02-27 04:03:47 -0500 received badge  Popular Question (source)
2018-02-12 12:43:48 -0500 received badge  Famous Question (source)
2017-03-30 12:31:34 -0500 received badge  Notable Question (source)
2016-09-28 04:45:43 -0500 asked a question neutron-plugin-openvswitch-agent start / running, process #

Hi!

I have already running openstack in single machine (say compute0).

I am adding a another compute node (say compute1) which configure compute0 for running more instances.

However, I have a problem with openvswitch.

When I restarted the Open vSwitch (using service neutron-plugin-openvswitch-agent restart ) on compute node, it is increasing number.

For example:

neutron-plugin-openvswitch-agent start/running, process 11111

neutron-plugin-openvswitch-agent start/running, process 11221

neutron-plugin-openvswitch-agent start/running, process 13331

neutron-plugin-openvswitch-agent start/running, process 14441

I comment the configure rabbitMQ in neutron.conf on additional compute node (compute1).

I can be changed into the following:

//rpc_backend = rabbit

It is not increasing number.

For example: neutron-plugin-openvswitch-agent start/running, process 11111

Can anyone help me to figure out the issue??

2016-09-26 04:41:51 -0500 received badge  Popular Question (source)
2016-09-23 03:45:13 -0500 asked a question IP is not getting assigned to VM instances interface

I complete to configure additory compute node (say compute1) to run more instances.

However, IP is not getting assigned to the VM's interface.

I need to see the IP is getting allocated for the VM.

I also configure all instances with NTP synchronization.

I think DHCP is not discover over the gre tunnel.

ovs-vswitchd.log:

2016-09-23T07:07:26.104Z|14861|tunnel(miss_handler)|WARN|Dropped 5 log messages in last 82 seconds (most recently, 81 seconds ago) due to excessive rate

2016-09-23T07:07:26.104Z|14862|tunnel(miss_handler)|WARN|receive tunnel port not found (192.168.0.70->192.168.15.30, key=0x6, dp port=3, pkt mark=0)

2016-09-23T07:07:26.104Z|14863|ofproto_dpif_upcall(miss_handler)|INFO|Dropped 5 log messages in last 82 seconds (most recently, 81 seconds ago) due to excessive rate

2016-09-23T07:07:26.104Z|14864|ofproto_dpif_upcall(miss_handler)|INFO|received packet on unassociated datapath port 3

Any ideas where I should look to problem this please?

2016-08-26 05:16:29 -0500 received badge  Popular Question (source)
2016-08-25 03:32:29 -0500 asked a question [Adding compute node]

I complete to configure additory compute node (say compute1) to run more instances.

However, IP is not getting assigned to the VM's interface.

I need to see the IP is getting allocated for the VM.

I also configure all instances with NTP synchronization.

I think DHCP is not discover over the gre tunnel.

ovs-vswitchd.log:

2016-09-23T07:07:26.104Z|14861|tunnel(miss_handler)|WARN|Dropped 5 log messages in last 82 seconds (most recently, 81 seconds ago) due to excessive rate

2016-09-23T07:07:26.104Z|14862|tunnel(miss_handler)|WARN|receive tunnel port not found (192.168.0.70->192.168.15.30, key=0x6, dp port=3, pkt mark=0)

2016-09-23T07:07:26.104Z|14863|ofproto_dpif_upcall(miss_handler)|INFO|Dropped 5 log messages in last 82 seconds (most recently, 81 seconds ago) due to excessive rate

2016-09-23T07:07:26.104Z|14864|ofproto_dpif_upcall(miss_handler)|INFO|received packet on unassociated datapath port 3

Any ideas where I should look to problem this please?

2016-06-28 00:19:04 -0500 commented answer Adding new compute nodes

I would try it.

Thank you very much ^^.

2016-06-27 19:34:49 -0500 commented answer Adding new compute nodes

I checked all the node (controller, compute0, compute1) using ovs-vsctl show. I saw both br-int and br-tun.

2016-06-27 19:31:11 -0500 commented answer Adding new compute nodes

Yes. The IP of nodes (controller, compute0, compute1) are composed of same subnet (192.168.0.xx). Also, the tunnel IP of nodes are connected using same subnet (192.168.15.xx). Network are operating properly (ping 192.168.15.xx or 192.168.0.xx).

2016-06-27 00:28:48 -0500 commented answer Adding new compute nodes

However, the error still exist. Have you ever experienced this problem?

2016-06-27 00:28:34 -0500 commented answer Adding new compute nodes

Thanks! This is the log on my compute node openvswitch-agent.log: WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Unable to create tunnel port. Invalid remote IP: 192.168.15.20, 192.168.15.70. So I update local_ip in ml2_conf.ini file, and then restart the agent service.

2016-06-20 23:58:20 -0500 commented answer Adding new compute nodes

I reflected your answer. However, the compute node (compute1) is not working. The neutron-plugin-openvswitch-agent is still wating. I try to think about more ways and i will refer your blog. I am korean^^.

Thanks!

2016-06-20 09:27:48 -0500 received badge  Famous Question (source)
2016-06-20 03:24:44 -0500 commented answer Adding new compute nodes

*controller node (controller):

my_ip: 192.168.0.10

local_ip in ml2_conf.ini: 192.168.15.10

2016-06-20 03:22:51 -0500 commented answer Adding new compute nodes

The ip of the nodes are as follows:

*one compute node (compute0):

my_ip: 192.168.0.30

local_ip (INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS) in ml2_conf.ini: 192.168.15.30


*another compute node (compute1):

my_ip: 192.168.0.70

local_ip in ml2_conf.ini:

2016-06-20 03:10:29 -0500 commented answer Adding new compute nodes

I deleted the configure rabbitMQ in neutron.conf on additional compute node (compute1).

I can be changed into the following:

//rpc_backend = rabbit

rabbit_host = controller

rabbit_password = RABBIT_PASS

If i do not delete the rpc_backend, neutron-plugin-openvswitch-agent is still wating.

2016-06-20 03:04:23 -0500 commented answer Adding new compute nodes

Thanks. The instances are created on original compute node (compute0). However, the additional compute node (compute1) was not created for making instance. When i show the dashboard (horizon) for the state of new instance, it is still scheduling. I think that it is network problems.

2016-06-20 03:04:23 -0500 received badge  Commentator
2016-06-20 02:09:21 -0500 received badge  Notable Question (source)
2016-06-20 01:03:04 -0500 received badge  Popular Question (source)
2016-06-20 00:22:20 -0500 commented answer Adding new compute nodes

Thanks. Your suggestion worked for me. I already change your suggestion. The compute nodes is normal for the state. I do not sure how to make an instance according to the compute nodes. Do you have any idea? Thanks!

2016-06-20 00:06:40 -0500 answered a question Adding new compute nodes

I already change your suggestion.

List service components to verify successful launch of each process: $neutron agent-list +--------------------------------------+--------------------+------------+-------+----------------+---------------------------+ | id | agent_type | host | alive | admin_state_up | binary | +--------------------------------------+--------------------+------------+-------+----------------+---------------------------+ | 0e487d2f-226a-4fe8-a50f-4fc63988e5b1 | Open vSwitch agent | controller | :-) | True | neutron-openvswitch-agent | | 475b9118-cd62-4d6d-93ee-8696f25e7405 | L3 agent | controller | :-) | True | neutron-l3-agent | | 4d0de49c-d957-4609-9643-30092f2522c3 | Open vSwitch agent | compute0 | :-) | True | neutron-openvswitch-agent | | 60fb0a58-361b-42b9-97c5-ffb20202e3d4 | Open vSwitch agent | compute1 | :-) | True | neutron-openvswitch-agent | | 940126d2-fef4-48e8-8266-832c7978aaf6 | Metadata agent | controller | :-) | True | neutron-metadata-agent | | 9717df41-b384-4b3d-9b5b-3cf32fbdb3b5 | DHCP agent | controller | :-) | True | neutron-dhcp-agent | | edabdb4a-4144-4506-b2da-4c17ed0e4f71 | Metadata agent | compute0 | :-) | True | neutron-metadata-agent | +--------------------------------------+--------------------+-----------+--------+----------------+---------------------------+

$nova service-list +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+ | 1 | nova-cert | controller | internal | enabled | up | 2016-06-20T04:58:30.000000 | - | | 2 | nova-consoleauth | controller | internal | enabled | up | 2016-06-20T04:58:29.000000 | - | | 3 | nova-scheduler | controller | internal | enabled | up | 2016-06-20T04:58:28.000000 | - | | 4 | nova-conductor | controller | internal | enabled | up | 2016-06-20T04:58:22.000000 | - | | 6 | nova-compute | compute0 | nova | enabled | up | 2016-06-20T04:58:30.000000 | None | | 8 | nova-compute | compute1 | nova | enabled | up | 2016-06-20T04:58:23.000000 | - | +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+

I do not know how to make an instance according to the compute nodes.

2016-06-20 00:06:06 -0500 answered a question Adding new compute nodes

Thanks. Your suggestion worked for me.

I already change your suggestion.

List service components to verify successful launch of each process: $neutron agent-list +--------------------------------------+--------------------+------------+-------+----------------+---------------------------+ | id | agent_type | host | alive | admin_state_up | binary | +--------------------------------------+--------------------+------------+-------+----------------+---------------------------+ | 0e487d2f-226a-4fe8-a50f-4fc63988e5b1 | Open vSwitch agent | controller | :-) | True | neutron-openvswitch-agent | | 475b9118-cd62-4d6d-93ee-8696f25e7405 | L3 agent | controller | :-) | True | neutron-l3-agent | | 4d0de49c-d957-4609-9643-30092f2522c3 | Open vSwitch agent | compute0 | :-) | True | neutron-openvswitch-agent | | 60fb0a58-361b-42b9-97c5-ffb20202e3d4 | Open vSwitch agent | compute1 | :-) | True | neutron-openvswitch-agent | | 940126d2-fef4-48e8-8266-832c7978aaf6 | Metadata agent | controller | :-) | True | neutron-metadata-agent | | 9717df41-b384-4b3d-9b5b-3cf32fbdb3b5 | DHCP agent | controller | :-) | True | neutron-dhcp-agent | | edabdb4a-4144-4506-b2da-4c17ed0e4f71 | Metadata agent | compute0 | :-) | True | neutron-metadata-agent | +--------------------------------------+--------------------+-----------+--------+----------------+---------------------------+

$nova service-list +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+ | 1 | nova-cert | controller | internal | enabled | up | 2016-06-20T04:58:30.000000 | - | | 2 | nova-consoleauth | controller | internal | enabled | up | 2016-06-20T04:58:29.000000 | - | | 3 | nova-scheduler | controller | internal | enabled | up | 2016-06-20T04:58:28.000000 | - | | 4 | nova-conductor | controller | internal | enabled | up | 2016-06-20T04:58:22.000000 | - | | 6 | nova-compute | compute0 | nova | enabled | up | 2016-06-20T04:58:30.000000 | None | | 8 | nova-compute | compute1 | nova | enabled | up | 2016-06-20T04:58:23.000000 | - | +----+------------------+-----------+----------+---------+-------+-----------------------------+-----------------+

I do not know how to make an instance according to the compute nodes.

2016-06-19 20:19:36 -0500 asked a question Adding new compute nodes

Hi All,

I already deployed the openstack on servers (say controller0 and compute0).

I want to add compute node (say compute1) to run more instances.

When adding more compute node (compute1) it is the same compute node (compute0) configuration.

I change IP address of compute nods (compute0 and compute1).

I want to verify my compute node, I am not sure it works that way.

How to verify the compute nodes?

Thanks!

2016-05-02 04:00:27 -0500 asked a question Internet speed of window instance

Hello!

I am trying to create a Windows Image on juno openstack. My openstack is running on a ubuntu server under 2-node architecture. I have created base images for window 7 using cloudbase-init. When i used a window instance, it is very slowly to connect the internet. An internet speed is 10Gbps. It is normal?

2016-04-20 19:41:36 -0500 received badge  Famous Question (source)
2016-03-14 23:24:46 -0500 commented answer No memory and disk.ephemeral.size usage meters from ceilometer

@yprokule Thanks for your comments. I already checked in ceilometer/compute.log. I did not discover the error. Because of log records like:INFO ceilometer.agent [-] Polling pollster hardware.memory.used in the context of meter_source.

2016-03-10 18:36:42 -0500 commented answer No memory and disk.ephemeral.size usage meters from ceilometer

@yprokule What do you mean by memory* pollsters?

2016-03-01 18:21:56 -0500 commented answer No memory and disk.ephemeral.size usage meters from ceilometer

@yprokule I modified my pipeline.yaml at compute and controller nodes. However, I was confirmed that an error had occurred.

2016-02-29 00:46:44 -0500 commented answer No memory and disk.ephemeral.size usage meters from ceilometer

@yprokule Thanks for the response yprokule. This is my pipeline.yaml code. - Check notes https://git.openstack.org/cgit/openstack/ceilometer/tree/etc/ceilometer/pipeline.yaml (https://git.openstack.org/cgit/openst...)

You mean the pipeline.yaml has to revise it? - name: mem_source interval: 600 meters: - "memory.usage" - "memory.resident"