Ask Your Question

Vikas M's profile - activity

2018-06-22 10:16:35 -0500 received badge  Famous Question (source)
2018-04-05 04:41:56 -0500 received badge  Notable Question (source)
2018-04-04 15:12:04 -0500 received badge  Popular Question (source)
2018-04-04 10:44:33 -0500 commented answer Unable to integrate openstack with ceph

When I revert back to stores = rbd,file,http,swift , Glance works fine and port 9292 also listen

[root@controller ~]# netstat -anp |grep 9292
tcp        0      0 0.0.0.0:9292            0.0.0.0:*               LISTEN      22674/python2

But when I change it to stores = rbd It stops workin

2018-04-04 09:29:28 -0500 answered a question Unable to integrate openstack with ceph

Yes I have tried to upload image many times. It is uploading without error. But If I change stores = rbd,file,http,swift to stores = rbd in glance-api.conf and try to upload the image it is showing below error.

[root@controller ~]# openstack image create --file cirros-0.3.4-x86_64-disk.raw --container-format bare --disk-format raw --public cirros-0.3.4.ceph

Error finding address for http://10.19.19.101:9292/v2/schemas/image: HTTPConnectionPool(host='10.19.19.101', port=9292): Max retries exceeded with url: /v2/schemas/image (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x3a2c4d0>: Failed to establish a new connection: [Errno 111] Connection refused',))

[root@controller ~]#

2018-04-04 08:22:22 -0500 asked a question Unable to integrate openstack with ceph

I have installed 5 node ceph( ceph version 10.2.10) setup ( 1 ceph-admin + 1 mon + 3 osd nodes ) and prepared one node openstack pike(packstack).

I am trying to integrate ceph with openstack , All steps executed with out error But when I run #rbd ls images OR #rbd -p images ls It is showing no output.

[root@ceph-admin ~]# ceph osd pool ls
rbd
volumes
images
backups
vms
[root@ceph-admin ~]#
[root@ceph-admin ~]# rbd ls images
[root@ceph-admin ~]#

I executed below commands to integrate ceph with openstack

    1. #ceph auth get-or-create client.glance mon 'allow r' osd 'allow class-read object_prefix rbd_children, allow rwx pool=images'
    2. #ceph auth get-or-create client.glance | ssh controller sudo tee /etc/ceph/ceph.client.glance.keyring
    3. #ssh controller chown glance:glance /etc/ceph/ceph.client.glance.keyring
    4.  edited ceph.conf on openstack node as per below

    [root@controller ~]# cat /etc/ceph/ceph.conf
    [global]
    fsid = 91336825-14db-4daf-ad42-ccf29e598b2b
    mon_initial_members = mon1
    mon_host = 10.19.19.93
    auth_cluster_required = cephx
    auth_service_required = cephx
    auth_client_required = cephx

    public network = 10.19.19.0/24
    osd pool default size = 2

    [client.glance]
    keyring = /etc/ceph/ceph.client.glance.keyring
    [root@controller ~]#

   5. added below entries in /etc/glance/glance-api.conf 

    [glance_store]
    stores = rbd
    rbd_store_pool = images
    rbd_store_user = glance
    rbd_store_ceph_conf = /etc/ceph/ceph.conf
    rbd_store_chunk_size = 8
2018-04-04 08:05:39 -0500 received badge  Famous Question (source)
2018-04-04 08:05:39 -0500 received badge  Notable Question (source)
2018-04-04 08:05:39 -0500 received badge  Popular Question (source)
2017-11-08 06:01:03 -0500 asked a question Deployment stops in Mirantis openstack with error

I am trying to create 3 mode Openstack environment in Mirantis 9.0 ( Mitaka on Ubuntu 14.04 ) I could check on server console and GUI that OS/Ubuntu installation was successful but OpenStack installation was stopped. It is showing below error.

Deployment has failed. All nodes are finished. Failed tasks: Task[setup_repositories/24], Task[setup_repositories/25], Task[setup_repositories/26] Stopping the deployment process!

2017-11-08 05:55:57 -0500 received badge  Famous Question (source)
2017-11-08 05:55:57 -0500 received badge  Notable Question (source)
2017-07-23 20:04:34 -0500 received badge  Popular Question (source)
2017-07-20 09:10:31 -0500 commented question nova-compute service is not added for compute node in Devstack

I have resolved the issue , I enable service - placement-api in Compute node, Now I can see compute node additional in #nova service-list

root@compute:~# cat /opt/stack/devstack/local.conf | grep -i enable_service enable_service placement-api root@compute:~#

2017-07-20 04:44:21 -0500 asked a question nova-compute service is not added for compute node in Devstack

I have created 2 nodes devstack environment. First I create Controller node ( which is having all nova services ). It is running fine. I am using - stable/ocata repo local.conf on Controller node

root@ubuntu:/opt/stack/devstack# cat local.conf | egrep -iv "^#|^$" [[local|localrc]] ADMIN_PASSWORD=techm123 DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD HOST_IP=10.53.173.181 LOGFILE=$DEST/logs/stack.sh.log LOGDAYS=2 SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5 SWIFT_REPLICAS=1 SWIFT_DATA_DIR=$DEST/data enable_service heat h-api h-api-cfn h-api-cw h-eng MULTI_HOST=True root@ubuntu:/opt/stack/devstack#

After this I added compute node in it by editing local.con as per below

root@compute:/opt/stack/devstack# cat local.conf | egrep -iv "^#|^$" [[local|localrc]] SERVICE_TOKEN=Admin123 ADMIN_PASSWORD=Admin123 DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD HOST_IP=10.53.173.182 SERVICE_HOST=10.53.173.181 MYSQL_HOST=$SERVICE_HOST RABBIT_HOST=$SERVICE_HOST GLANCE_HOSTPORT=$SERVICE_HOST:9292 CONFIG_IP=10.53.173.181 KEYSTONE_AUTH_HOST=$SERVICE_HOST KEYSTONE_SERVICE_HOST=$SERVICE_HOST MULTI_HOST=True ENABLED_SERVICES=n-cpu,rabbit,neutron,q-agt,n-api-meta,c-vol disable_service cinder disable_service horizon disable_service key disable_service glance disable_service neutron LOGFILE=$DEST/logs/stack.sh.log LOGDAYS=2 SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5 SWIFT_REPLICAS=1 SWIFT_DATA_DIR=$DEST/data NOVA_VNC_ENABLED=True NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html" VNCSERVER_LISTEN=0.0.0.0 VNCSERVER_PROXYCLIENT_ADDRESS=$HOST_IP INSTALL_PROFILE=COMPUTE COMPUTE_HOST_IP=$HOST_IP Q_META_DATA_IP=$SERVICE_HOST root@compute:/opt/stack/devstack#

./stack.sh executed on compute node with out any error but I can not see the compute node in #nova service-list or #nova host-list output.

root@ubuntu:~# nova service-list +----+------------------+--------+----------+---------+-------+----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+--------+----------+---------+-------+----------------------------+-----------------+ | 4 | nova-conductor | ubuntu | internal | enabled | up | 2017-07-20T09:31:02.000000 | - | | 5 | nova-scheduler | ubuntu | internal | enabled | up | 2017-07-20T09:31:02.000000 | - | | 6 | nova-consoleauth | ubuntu | internal | enabled | up | 2017-07-20T09:30:59.000000 | - | | 7 | nova-compute | ubuntu | nova | enabled | up | 2017-07-20T09:31:00.000000 | - | +----+------------------+--------+----------+---------+-------+----------------------------+-----------------+ root@ubuntu:~#

logs in compute node

stack@compute:~/logs$ tail -20 n-cpu.log.2017-07-20-123840 2017-07-20 12:58:50.209 DEBUG oslo_service.service [req-54e9c1f8-572d-4bda-9c7b-5937fa92b3e4 None None] ************************** from (pid=15819) log_opt_values /usr/local/lib/python2.7/dist-packages/oslo_config/cfg.py:2746 2017-07-20 12:58:50.210 INFO nova.service [-] Starting compute node (version 15.0.7) 2017-07-20 12:58:50.211 ERROR oslo_service.service [-] Error starting thread. 2017-07-20 12:58:50.211 TRACE oslo_service.service Traceback (most recent call last): 2017-07-20 12:58:50.211 TRACE oslo_service.service File "/usr/local/lib/python2.7/dist-packages/oslo_service/service.py", line 722, in run_service 2017-07-20 12:58:50.211 TRACE oslo_service.service service.start() 2017-07-20 12:58:50.211 TRACE oslo_service.service File "/opt/stack/nova/nova/service.py", line 144, in start 2017-07-20 12:58:50.211 TRACE oslo_service.service self.manager.init_host() 2017-07-20 12:58:50.211 TRACE oslo_service.service File "/opt/stack/nova/nova/compute/manager.py", line 1137, in init_host 2017-07-20 12:58:50.211 TRACE oslo_service.service raise exception.PlacementNotConfigured() 2017-07-20 12:58:50.211 TRACE oslo_service.service PlacementNotConfigured: This compute is not configured to talk to the placement service. Configure the [placement] section of nova.conf and restart the service. 2017-07-20 12:58:50.211 TRACE oslo_service.service 2017-07-20 12:58 ... (more)

2017-04-05 04:34:13 -0500 received badge  Enthusiast
2016-03-14 09:24:46 -0500 received badge  Famous Question (source)
2016-02-26 21:44:07 -0500 commented answer ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Please check outputs - I have attached

2016-02-26 21:43:20 -0500 received badge  Editor (source)
2016-02-26 21:40:53 -0500 answered a question ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Please find output

[root@controller2 ~]# nova-manage service list Option "verbose" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future.

Binary Host Zone Status State Updated_At nova-conductor controller2 internal enabled :-) 2016-02-27 03:32:08 nova-consoleauth controller2 internal enabled :-) 2016-02-27 03:32:02 nova-scheduler controller2 internal enabled :-) 2016-02-27 03:32:05 nova-cert controller2 internal enabled XXX 2016-02-19 16:12:15 nova-compute compute1 nova enabled XXX 2016-02-19 16:09:31 nova-network compute1 internal enabled XXX 2016-02-19 16:09:29 [root@controller2 ~]#

[root@controller2 ~]# ls -ld /var/www/cgi-bin/keystone drwxr-xr-x 2 keystone keystone 29 Jan 23 07:02 /var/www/cgi-bin/keystone

[root@controller2 ~]# ls -ltr /var/www/cgi-bin/keystone total 8 -rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 main -rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 admin [root@controller2 ~]#

I did not find any update - once the it was showing error . Before that everything was working fine

[root@controller2 nova]# ls -ltr /var/log/nova/ | tail

-rw-r--r-- 1 nova nova 279940 Feb 6 00:53 nova-consoleauth.log-20160206.gz -rw-r--r-- 1 nova nova 281536 Feb 6 01:02 nova-cert.log-20160206.gz -rw-r--r-- 1 nova nova 321412 Feb 6 03:46 nova-scheduler.log-20160206.gz -rw-r--r-- 1 nova nova 892202 Feb 10 05:57 nova-conductor.log-20160210.gz -rw-r--r-- 1 nova nova 2527405 Feb 19 11:12 nova-consoleauth.log -rw-r--r-- 1 nova nova 2903495 Feb 19 11:12 nova-scheduler.log -rw-r--r-- 1 nova nova 2597521 Feb 19 11:12 nova-cert.log -rw-r--r-- 1 nova nova 3832452 Feb 19 11:12 nova-conductor.log -rw-r--r-- 1 nova nova 227691 Feb 19 11:12 nova-api.log -rw-r--r-- 1 nova nova 24258 Feb 19 11:12 nova-novncproxy.log [root@controller2 nova]#

2016-02-26 21:28:44 -0500 received badge  Notable Question (source)
2016-02-23 07:36:19 -0500 received badge  Popular Question (source)
2016-02-21 09:21:04 -0500 asked a question ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Hi

I have setup 5 node lab using CentOS7. Everything was working fine , I also launch a instance which was showing in output of nova list but later when I installed telemetry module as per the kilo installation guide and rebooted all nodes. Now nothing is working fine , I am getting below error. same is in nova list output

 [root@controller2 ~]# openstack user list

WARNING: keystoneclient.auth.identity.generic.base Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
ERROR: openstack Internal Server Error (HTTP 500)


[root@controller2 ~]# nova list

No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (InternalServerError): Internal Server Error (HTTP 500)

UPDATE:

Please find output

[root@controller2 ~]# nova-manage service list
Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.

Binary           Host                                 Zone             Status     State Updated_At
nova-conductor   controller2                          internal         enabled    :-)   2016-02-27 03:32:08
nova-consoleauth controller2                          internal         enabled    :-)   2016-02-27 03:32:02
nova-scheduler   controller2                          internal         enabled    :-)   2016-02-27 03:32:05
nova-cert        controller2                          internal         enabled    XXX   2016-02-19 16:12:15
nova-compute     compute1                             nova             enabled    XXX   2016-02-19 16:09:31
nova-network     compute1                             internal         enabled    XXX   2016-02-19 16:09:29
[root@controller2 ~]#

[root@controller2 ~]# ls -ld  /var/www/cgi-bin/keystone
drwxr-xr-x 2 keystone keystone 29 Jan 23 07:02 /var/www/cgi-bin/keystone

[root@controller2 ~]# ls -ltr  /var/www/cgi-bin/keystone
total 8
-rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 main
-rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 admin
[root@controller2 ~]#

I did not find any update - once the it was showing error . Before that everything was working fine

[root@controller2 nova]# ls -ltr /var/log/nova/ | tail

-rw-r--r-- 1 nova nova  279940 Feb  6 00:53 nova-consoleauth.log-20160206.gz
-rw-r--r-- 1 nova nova  281536 Feb  6 01:02 nova-cert.log-20160206.gz
-rw-r--r-- 1 nova nova  321412 Feb  6 03:46 nova-scheduler.log-20160206.gz
-rw-r--r-- 1 nova nova  892202 Feb 10 05:57 nova-conductor.log-20160210.gz
-rw-r--r-- 1 nova nova 2527405 Feb 19 11:12 nova-consoleauth.log
-rw-r--r-- 1 nova nova 2903495 Feb 19 11:12 nova-scheduler.log
-rw-r--r-- 1 nova nova 2597521 Feb 19 11:12 nova-cert.log
-rw-r--r-- 1 nova nova 3832452 Feb 19 11:12 nova-conductor.log
-rw-r--r-- 1 nova nova  227691 Feb 19 11:12 nova-api.log
-rw-r--r-- 1 nova nova   24258 Feb 19 11:12 nova-novncproxy.log
[root@controller2 nova]#