Ask Your Question

BM Shukla's profile - activity

2016-06-07 19:49:54 -0600 received badge  Famous Question (source)
2016-06-07 19:49:54 -0600 received badge  Notable Question (source)
2016-06-02 03:18:48 -0600 received badge  Famous Question (source)
2016-05-25 02:26:57 -0600 commented answer Unable to ping private network interface on router or any instances attached to router

No. It is a normal server system.

2016-05-20 01:46:29 -0600 answered a question Unable to ping private network interface on router or any instances attached to router

I am also facing the exactly same problem. My base OS is Cent OS with Liberty.

BM Shukla (bms@iitk.ac.in)

2016-04-25 11:53:14 -0600 received badge  Notable Question (source)
2016-04-24 03:31:45 -0600 asked a question Key based Authentication failing due to MetaData Service

I have OpenStack Liberty installation. Earlier I used to access any VM through public-private key authentication. We used CentOS 7, Debian 8, Ubutu 15 VMs. I was able to launch around 2500+ VMs. All worked well But now I am able to see my VM through ssh but it is asking directly password after ignoring my private keys. It started after 12 March 2016. I traced and found that it is due to Metadata Service misbehaviour. If somebody can tell be how to solve it? Note: Every week I usually update my base OS (Cent OS 7.2) along with OpenStack. This might be the cause or I cleaned my configuration files which caused this issue I am not sure about it.

2016-04-23 03:47:58 -0600 asked a question OpenStack Liberty MetaData ssh authentication problem

I have OpenStack Liberty installation. Earlier I used to access any VM through public-private key authentication. We used CentOS 7, Debian 8, Ubutu 15 VMs. I was able to launch around 2500+ VMs. All worked well But now I am able to see my VM through ssh but it is asking directly password after ignoring my private keys. It started after 12 March 2016. I traced and found that it is due to Metadata Service misbehaviour. If somebody can tell be how to solve it?
Note: Every week I usually update my base OS (Cent OS 7.2) along with OpenStack. This might be the cause or I cleaned my configuration files which caused this issue I am not sure about it.

2016-03-29 04:07:16 -0600 received badge  Nice Question (source)
2016-03-20 19:45:44 -0600 received badge  Popular Question (source)
2016-03-06 22:53:26 -0600 asked a question DVR Installation in Liberty

Liberty CentOS Installation manual tells to use LinuxBridge in place of OVS (Open V Switch) then how to do DVR Installation in Liberty using LinuxBridge? I am not in favour of using OVS as it has broadcast storming issue.

2016-03-02 07:32:37 -0600 received badge  Notable Question (source)
2016-02-21 22:20:40 -0600 received badge  Popular Question (source)
2016-02-21 19:06:48 -0600 received badge  Popular Question (source)
2016-02-21 02:04:21 -0600 received badge  Notable Question (source)
2016-02-17 06:20:39 -0600 commented question Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance

Dear Jamie, In our cloud we have 20 compute nodes. Each has 24 VCPUs (= 480 VCPS), Sufficient memory and storage. I have checked db access for nova.I have checked /var/log/nova/nova-conductor.log. It says could not open disk image /var/lib/nova/instance/xxx/disk

2016-02-17 06:11:38 -0600 answered a question Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance

Dear Jamie, In our cloud we have 20 compute nodes. Each has 24 VCPUs (= 480 VCPS), Sufficient memory and storage. I have checked db access for nova. It is OK. Till yesterday I was able to file VMs. Today I am unable to fire.

2016-02-17 06:00:10 -0600 received badge  Enthusiast
2016-02-16 23:33:36 -0600 asked a question Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance

We are using Open Stack Liberty. We launched at least 8-9 instances with various Linux flavors but we try to launch more instances it gives the error "Exceeded maximum number of retries. Exceeded max scheduling attempts 3 for instance ...". Public IP gets assigned and after IP assignment above error appears. Any clue

2016-01-18 07:13:43 -0600 received badge  Student (source)
2016-01-15 01:17:29 -0600 received badge  Popular Question (source)
2016-01-13 23:06:27 -0600 commented answer Adminitrator will access dashboard but how user will access the dashboard as 10.0.0.x is not available to users.

I have already done this but Openstack Installation manual never says so. Thanks for reply.

2016-01-13 06:24:13 -0600 asked a question lliberty cannot ping qrouter gateway

Please refer the following outputs

[root@controller3 ~]# ip netns
qrouter-af524c91-516d-4375-aee9-75595bcba769 (id: 1)
qdhcp-cd9b17c1-f14d-4888-b925-ee9b52dbb48e (id: 3)
qdhcp-15f89395-6d8b-4576-8a4e-e3a4b64e1ef7 (id: 0)


 [root@controller3 ~]# neutron router-port-list router
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 6abd55f0-f96d-4ec7-b980-0a9d20557ba3 |      | fa:16:3e:ce:f1:12 | {"subnet_id": "2f58d428-5169-43fc-8104-ece124c6a26d", "ip_address": "192.168.0.254"} |
| d1349c65-d5ea-4124-8982-fcda9c9ecf8d |      | fa:16:3e:0c:bf:59 | {"subnet_id": "85fa318b-d87e-4fd1-b53e-766383853cac", "ip_address": "172.27.0.7"}    |
+--------------------------------------+------+-

I am unable to ping "172.27.0.7". Also on dashboard router icon does not show this interface. I am using my departmental network 172.27.0.0/16 as public network and 192.168.0.0/16 as private network. My compute nodes are using 2 NICs (one 10.0.0.x and other one in unnumbered) My controller has 3 NIC (10.0.0x, 172.27.16.x and one unnumbered) please see below.

[root@controller3 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master brqcd9b17c1-f1 state UP qlen 1000
    link/ether a0:36:9f:a1:42:40 brd ff:ff:ff:ff:ff:ff
3: enp1s0f1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
4: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.27.16.31/16 brd 172.27.255.255 scope global eno1
       valid_lft forever preferred_lft forever
5: eno2: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
6: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 00:1e:67:ad:ad:c3 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.13/24 brd 10.0.0.255 scope global bond0
       valid_lft forever preferred_lft forever
7: tape2e82c07-71@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether aa:9a:ce:71:51:0e brd ff:ff:ff:ff:ff:ff link-netnsid 0
10: brqcd9b17c1-f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 46:4f:a3:14:a4:47 brd ff:ff:ff:ff:ff:ff
11: tapa4b98a60-1b@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master brqcd9b17c1-f1 state UP qlen 1000
    link/ether 46:4f:a3:14:a4:47 brd ff:ff:ff:ff:ff:ff link-netnsid 3
16: tap6abd55f0-f9@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 4e:7c:3e:b7:e2:7b brd ff:ff:ff:ff:ff:ff link-netnsid 
----
[root@controller3 ~]# ip netns exec qrouter-af524c91-516d-4375-aee9-75595bcba769 ip a
1: lo: <LOOPBACK,UP,LOWER_UP ...
(more)
2016-01-12 23:01:53 -0600 asked a question Adminitrator will access dashboard but how user will access the dashboard as 10.0.0.x is not available to users.

Please refer Open-stack (Liberty) Installation Manual (CentOS) chapter "Add Dashboard" Access the dashboard using a web browser at http://controller/dashboard.

Authenticate using admin or demo user credentials.

Controller ip is 10.0.0.11 . Users are sitting on public network i.e. 172.27.x.y. How users will access the dashboard?

VMs are using 192.168.x.y IP as private IP whereas 172.27.1.x as public IP. No where VM is aware of 10.0.0.x N/W.

2016-01-05 18:55:17 -0600 received badge  Popular Question (source)
2016-01-04 10:09:48 -0600 asked a question ip netns showing 1 qdhcp entity in place of two

As per Liberty installation guide ip netns command must give 3 entities that is one qrouter and two qdhcp but I am getting only one qdhcp entity as shown below.

[root@controller3 ~]# ip netns qrouter-df014de6-b1e1-4592-bbd8-cc08fa12b97a (id: 1) qdhcp-87c58629-c074-4689-82d7-1fdfa72345f1 (id: 0)