Ask Your Question

StevenLi's profile - activity

2016-06-13 08:05:12 -0500 received badge  Famous Question (source)
2016-01-10 05:52:17 -0500 received badge  Teacher (source)
2016-01-07 23:17:27 -0500 answered a question Use floating IP of instances in outgoing packages

The behavior is as designed.

When the VM is trying to reach external network, no matter there is a floating IP is assigned, it works via SNAT by Neutron in network node. When the VM is reached by an external machine, the floating ip must be assigned and used.

2016-01-07 02:58:19 -0500 answered a question Default Availability_Zone setting

The issue is resolved after a few trials in my system. It can be implemented by doing the following steps:

1) add the following line into /etc/nova/nova.conf in Control node(s) in which nova-api and nova-scheduler services is located: default_availability_zone = test_only # or any name you want

2) Restart nova-api and nova-scheduler services in Controll node

What I really did is working on the Compute nodes, instead of Control node, so it does not take effect.

After the two steps, nova default availability zone will gone, and be replaced by the one you indicated in the configuration.

2016-01-07 02:51:31 -0500 received badge  Enthusiast
2016-01-05 18:58:53 -0500 received badge  Notable Question (source)
2016-01-04 05:42:03 -0500 received badge  Popular Question (source)
2016-01-04 02:49:10 -0500 commented answer Default Availability_Zone setting

Thanks. I read the document, and all the commands work. However, it does not solve my problem. I want the new added compute node automatically be in a particular AZ, instead of changing it after it was in nova.

2016-01-01 08:31:37 -0500 asked a question Default Availability_Zone setting

I set up an OpenStack with Kilo release. It works very well, we have about 30 Compute nodes in the system now, and it is growing up when more users move in. When we add in a new Compute Node, I hope it can be automatically put in another availability_zone for a test before adding it into the normal zone (nova by default).

What I did is to add the following line in default section of the file /etc/nova/nova.conf in the new compute node: node_availability_zone = test_only

However, it does not take effect, when it is up, the system put it into nova zone after I start nova service. And then, I tried: default_availability_zone = test_only does not work either.

Is there any other setting I missed? Thanks.