Ask Your Question

bardhi232's profile - activity

2018-11-14 17:05:53 -0500 received badge  Famous Question (source)
2018-07-02 09:34:30 -0500 received badge  Notable Question (source)
2018-06-14 16:02:31 -0500 received badge  Famous Question (source)
2018-05-07 19:39:56 -0500 received badge  Famous Question (source)
2018-02-11 20:00:52 -0500 received badge  Popular Question (source)
2017-11-29 11:03:39 -0500 commented answer How to use both ldap and sql for authentication

I understand. Thank you for your help. I will look into that.

2017-11-29 05:10:16 -0500 asked a question How to use both ldap and sql for authentication

Hello,

I have an Openstack installation that keystone is integrated with LDAP backend for authentication and it does not allow me to create local accounts. I would like to be able to use both LDAP and local authentication. If someone that has done that before could point me in the right direction that would be great.

Thank you

2017-09-06 09:57:21 -0500 received badge  Famous Question (source)
2017-07-26 02:33:57 -0500 received badge  Notable Question (source)
2017-06-09 06:01:07 -0500 received badge  Popular Question (source)
2017-06-03 08:33:14 -0500 received badge  Famous Question (source)
2017-04-28 01:38:56 -0500 received badge  Notable Question (source)
2017-04-25 09:20:47 -0500 received badge  Popular Question (source)
2017-04-25 03:03:16 -0500 asked a question Upgrade from newton to ocata

Hello,

I am trying to upgrade from newton to ocata. Everything goes well except the compute nodes. When i remove the newton package sources and add the ocata sources and run the command to upgrade all the packages it fails to the nova-compute upgrade. From the installation log i can understand that there is something going on with the local nova.sqlite database that it cannot be upgraded properly. I tried removing the nova.sqlite database and then the installation proceeds, but then nova-compute service doesn't work properly and i cannot manage the current VMs that have been created with the newton release. The installation log is below. If someone could help it would be great. Thank you

Reading package lists...
Building dependency tree... 
Reading state information...
nova-compute is already the newest version (2:15.0.2-0ubuntu1~cloud0).
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Setting up nova-common (2:15.0.2-0ubuntu1~cloud0) ...



ERROR: could not access cell mapping database - has api db been created?
An error has occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/nova/cmd/manage.py", line 1594, in main
  ret = fn(*fn_args, **fn_kwargs)
File "/usr/lib/python2.7/dist-packages/nova/cmd/manage.py", line 644, in sync
  return migration.db_sync(version)
File "/usr/lib/python2.7/dist-packages/nova/db/migration.py", line 26, in db_sync
 return IMPL.db_sync(version=version, database=database, context=context)
File "/usr/lib/python2.7/dist-packages/nova/db/sqlalchemy/migration.py", line 57, in db_sync
  repository, version)
File "/usr/lib/python2.7/dist-packages/migrate/versioning/api.py", line 186, in upgrade
  return _migrate(url, repository, version, upgrade=True, err=err, **opts)
File "<decorator-gen-15>", line 2, in _migrate
File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 160, in with_engine
  return f(*a, **kw)
File "/usr/lib/python2.7/dist-packages/migrate/versioning/api.py", line 366, in _migrate
 schema.runchange(ver, change, changeset.step)
File "/usr/lib/python2.7/dist-packages/migrate/versioning/schema.py", line 93, in runchange
 change.run(self.engine, step)
File "/usr/lib/python2.7/dist-packages/migrate/versioning/script/py.py", line 148, in run
 script_func(engine)
File "/usr/lib/python2.7/dist-
 packages/nova/db/sqlalchemy/migrate_repo/versions/345_require_online_migration_completion.py", line 44, in upgrade
 raise exception.ValidationError(detail=msg)
ValidationError: Migration cannot continue until all these have been migrated to the api database. Please run `nova-manage db online_migrations' on Newton code before continuing.There are still 5 unmigrated flavors. 

dpkg: error processing package nova-common (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of nova-compute:
nova-compute depends on nova-common (= 2:15.0.2-0ubuntu1~cloud0); however:
Package nova-common is not configured yet.

dpkg: error processing package nova-compute (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of nova-compute-libvirt: nova-compute-libvirt depends on nova-compute (= 2:15 ... (more)

2017-04-13 09:37:10 -0500 commented answer After rebooting server not able to access the floating IP of the instance?

@Bernd Bausch for sure that DHCP uses DHCP protocol to assign the ip to the instance but in order for the instance to get the ip address DHCP Server passes the IP information to metadata and then metadata passes it to the instance while booting up. It is something that i experienced myself. Anyways.

2017-04-13 04:45:18 -0500 commented answer After rebooting server not able to access the floating IP of the instance?

@Bernd Bausch off course IP comes from the DHCP service, but if the metadata server is not working your vm wont get the ip address. DCHP allocates the IP and then metadata writes it to the VM's network config files.

2017-04-13 04:43:23 -0500 commented answer After rebooting server not able to access the floating IP of the instance?

I dont remember correctly now what changes i made to my config files because i did that over a year ago but as far as i can remember in my case i forgot to uncomment some config lines that had to do with the metadata service. if you could post in here your neutron logs so i could take a look

2017-04-07 08:29:55 -0500 answered a question After rebooting server not able to access the floating IP of the instance?

Can you try to launch a cirros instance and log into it from the web console and see if you can communicate to the internet. For example ping 8.8.8.8 or your physical router? If that doesnt work then i would say that there is something wrong with your metadata server that is not giving the ip again after you reboot your instance. I had a similar issue myself and when i was checking the config files again i found out that i made a mistake there. After correcting the mistake everything was normal again.

2017-03-31 02:37:08 -0500 commented question Cinder not starting after upgrade from liberty to newton

Thank you very much. I followed your advice and i deleted the rows on the cinder database to the service table and then i synced the database again and everything worked like a charm. Again thank you very much.

2017-03-29 15:00:17 -0500 asked a question Cinder not starting after upgrade from liberty to newton

Hello

I am trying to upgrade openstack form liberty to newton. All the services went smooth and everything worked except the cinder service. Cinder services on the controller node seem to be ok and they are started, but cinder service on the block storage node fails to start. from the logs i see the following:

2017-03-29 16:50:09.159 1871 ERROR cinder.cmd.volume [req-333d6725-2e9e-47c0-9760-81784d9d6a3a - - - - -] No volume service(s) started successfully, terminating.
2017-03-29 16:50:10.870 1916 WARNING oslo_reports.guru_meditation_report [-] Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports.
2017-03-29 16:50:10.947 1916 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
2017-03-29 16:50:10.980 1916 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume [req-fcf4cf55-8ea8-4c93-994c-a1f5161656ab - - - - -] Volume service block1@lvm failed to start.
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume Traceback (most recent call last):
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 100, in main
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     cluster=cluster)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 382, in create
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     cluster=cluster)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     self.is_upgrading_to_n = self.is_svc_upgrading_to_n(binary)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 223, in is_svc_upgrading_to_n
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     return rpc_api.determine_obj_version_cap() == '1.3'
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 233, in determine_obj_version_cap
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     cinder.context.get_admin_context(), cls.BINARY)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/objects/service.py", line 188, in get_minimum_obj_version
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     binary)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume   File "/usr/lib/python2.7/dist-packages/cinder/objects/service.py", line 173, in _get_minimum_version
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume     raise exception.ServiceTooOld(msg)
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume ServiceTooOld: One of the services is in Liberty version. We do not provide backward compatibility with Liberty now, you need to upgrade to Mitaka first.
2017-03-29 16:50:11.166 1916 ERROR cinder.cmd.volume
2017-03-29 16:50:11.168 1916 ERROR cinder.cmd.volume [req-fcf4cf55-8ea8-4c93-994c-a1f5161656ab - - - - -] No volume service(s ...
(more)
2017-01-25 03:39:54 -0500 received badge  Notable Question (source)
2017-01-22 22:35:23 -0500 received badge  Popular Question (source)
2017-01-19 15:21:19 -0500 asked a question how to monitor openstack cloud

Hello

I would like to monitor my openstack deployment like get statistical data from NICs, hard drive usage, when a service goes down, when a vm gets created or deleted, statistical data from vms like network usage, hard drive usage, cpu usage. I have seen online that tools like Cacti and Nagios can do that but from my searches I could not find any information on how to do that. If someone that has done that before could point me in the right direction it would be awesome.

Thank you

2017-01-15 10:49:16 -0500 received badge  Notable Question (source)
2017-01-11 09:56:05 -0500 commented question Openstack Magnum

@Eduardo Also you are saying that installing magnum on controller node it will create the containers in the compute nodes? If that is so i would just install magnum service on controller and not go through the mess on having it separately and wasting a whole server just for a small service.

2017-01-11 09:54:30 -0500 commented question Openstack Magnum

@Eduardo I tried to do just that but i could not get it to work. I get some errors with AMPQ server and i cannot seem to figure out what is wrong in there. Later i will take a look at the logs and post them in here so that maybe someone faced that issue before and can help me with that.

2017-01-11 09:52:42 -0500 commented question Openstack Magnum

@dbaxps i use ubuntu 16.04 LTS

2017-01-11 09:52:42 -0500 received badge  Commentator
2017-01-10 12:44:37 -0500 received badge  Popular Question (source)
2017-01-10 08:52:44 -0500 asked a question Openstack Magnum

Hello

I have an OpenStack Newton installation in my test lab set up and i wanted to try and add the magnum service. From the manual that i read from the http://openstack.org website i see that the service is installed in the controller node and containers are also created in the controller node. I would really like to have the magnum service on a separate node if that is possible as i would not want to affect the controllers performance. Before i try that i would like to ask if that is possible and if someone had tried that before so i would have a reference point on where to start.

Thank you

2016-08-23 03:23:10 -0500 received badge  Supporter (source)
2016-08-23 03:23:01 -0500 received badge  Scholar (source)
2016-08-23 03:22:58 -0500 commented answer Using both neutron and legacy on the same os cloud

Thank you. I followed your instructions and it worked. I am using Linux Bridge so my configuration was slightly different but the idea of that is the same. Thanks again.

2016-08-21 09:07:09 -0500 asked a question Using both neutron and legacy on the same os cloud

Hello

We are deploying an OpenStack cloud and we would like to be able to use both neutron networking and legacy networking with VLANs. I would like to know if that is possible and if maybe that could be applied in different regions. I mean to have a region with Neutron networking and another region with Legacy networking. If that cannot be done is it possible to have 2 different controllers for each deployment and be able to like use both on the same interface?

2016-08-21 08:58:14 -0500 received badge  Notable Question (source)
2016-08-17 15:26:17 -0500 received badge  Famous Question (source)
2016-07-02 06:59:41 -0500 received badge  Popular Question (source)
2016-06-24 02:54:43 -0500 commented answer Openstack Mitaka cannot see Database button on horizon

Hello Did you have time to check on my question? It would help me a lot if you had an answer to that.

Regards

2016-06-20 02:46:53 -0500 commented answer Openstack Mitaka cannot see Database button on horizon

http://docs.openstack.org/mitaka/install-guide-ubuntu/common/get_started_database_service.html (http://docs.openstack.org/mitaka/inst...) I followed the guide for the openstack mitaka. I installed it on my lab to test it out before preparing it for production. I have been trying for at lest 1 month to solve this issue. Thank you

2016-06-17 03:17:30 -0500 asked a question Openstack Mitaka cannot see Database button on horizon

Hello

I have successfully installed Openstack Mitaka on a test environment and everything is working fine except Trove. I have followed the guide on how to install Trove and after installation i don't see any errors, but i cannot see the database button displayed on horizon. From command line i can use trove normally, but i would like to also have the Database button displayed. Any idea on how to do that would be highly appreciated.

Thank you!

2016-06-04 08:56:07 -0500 received badge  Notable Question (source)
2016-06-02 03:51:43 -0500 received badge  Popular Question (source)
2016-04-26 02:32:29 -0500 received badge  Enthusiast
2016-04-21 08:43:14 -0500 received badge  Organizer (source)
2016-04-21 08:42:45 -0500 asked a question openstack trove instances

Hello I am experimenting with the new release Mitaka and i want to try DbaaS. I can get the service installed and working, but i am having a hard time creating the DbaaS instances with dib. In the official documentation it says that the tool works but i could not get it to work in any way. Could someone please help me on how to create a trove instance? Thank you