Ask Your Question

Gourav Singla's profile - activity

2016-09-27 01:10:51 -0500 received badge  Nice Answer (source)
2016-08-02 04:52:21 -0500 received badge  Necromancer (source)
2016-08-02 04:52:21 -0500 received badge  Teacher (source)
2016-07-27 04:19:54 -0500 received badge  Famous Question (source)
2016-03-06 09:59:28 -0500 received badge  Notable Question (source)
2016-03-04 04:50:54 -0500 answered a question Keystone token generation fails for DevStack

If you are behind the proxy, then you have to set no_proxy environmental variable for your localhost and all the IPs acquire by you host. Like if ip is 192.168.10.10, then:

 ./unstack.sh
export  no_proxy=127.0.0.1,192.168.10.10
./stack.sh

Hope this will help!!

2016-03-04 04:46:36 -0500 received badge  Supporter (source)
2016-02-21 19:21:30 -0500 received badge  Popular Question (source)
2016-02-16 04:03:53 -0500 asked a question MariaDB-Galera cluster problem

I have setup a HA Openstack with Kilo. I have deployed MariaDB-Galera cluster on 2 nodes with master-master setup using link: http://behindtheracks.com/2014/04/mysql-high-availability-with-galera-and-haproxy/ (http://behindtheracks.com/2014/04/mys...)

Everything works fine when both the nodes up, but when I switch off any of the cluster node then DB stops responding and I get the exception in logs: 'wsrep has may not yet prepared node'.

My cluster.cnf file: Node1:

[mysqld] query_cache_size=0 binlog_format=ROW default-storage-engine=innodb innodb_autoinc_lock_mode=2 query_cache_type=0 bind-address=0.0.0.0

Galera Provider Configuration

wsrep_provider=/usr/lib/galera/libgalera_smm.so

wsrep_provider_options="gcache.size=32G"

Galera Cluster Configuration

wsrep_cluster_name="test_cluster" wsrep_cluster_address="gcomm://192.168.10.53,192.168.10.54"

Galera Synchronization Congifuration

wsrep_sst_method=rsync

wsrep_sst_method=xtrabackup

wsrep_sst_auth=user:pass

Galera Node Configuration

wsrep_node_address="192.168.10.53" wsrep_node_name="hacontroller1" wsrep_debug=ON

And Node 2 [mysqld] query_cache_size=0 binlog_format=ROW default-storage-engine=innodb innodb_autoinc_lock_mode=2 query_cache_type=0 bind-address=0.0.0.0

Galera Provider Configuration

wsrep_provider=/usr/lib/galera/libgalera_smm.so

wsrep_provider_options="gcache.size=32G"

Galera Cluster Configuration

wsrep_cluster_name="test_cluster" wsrep_cluster_address="gcomm://192.168.10.53,192.168.10.54"

Galera Synchronization Congifuration

wsrep_sst_method=rsync

wsrep_sst_method=xtrabackup

wsrep_sst_auth=user:pass

Galera Node Configuration

wsrep_node_address="192.168.10.54" wsrep_node_name="hacontroller2" wsrep_debug=ON

Could anyone let me know what am I doing wrong here?

2016-02-01 00:06:23 -0500 received badge  Enthusiast
2016-01-20 09:16:01 -0500 received badge  Notable Question (source)
2016-01-20 09:16:01 -0500 received badge  Popular Question (source)
2016-01-19 04:35:13 -0500 commented answer ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.

I just moved my rabbit configuration to [Default] section and it worked. I don't know why it is so..

2016-01-19 04:14:38 -0500 commented answer ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.

I am also facing this issue on cinder node. Did you find any solution for it?

2015-12-17 12:20:13 -0500 answered a question "Expecting authentication method" error when doing a `keystone role-list`

Either append username in the command or set the username as an environmental variable

To append in command: sudo keystone --os-username admin role-list

To set username as environmental variable export OS_USERNAME=admin

Note: here 'admin' is a username for example

2015-12-03 18:40:54 -0500 asked a question Does Fuel 7.0 support Openstack Kilo?

I want to deploy Openstack Kilo using Mirantis Fuel 7.0. I read that currently Fuel supports only Grizzly release. Can I deploy any other latest release using Fuel?