Ask Your Question

Eggy's profile - activity

2017-01-05 21:47:16 -0500 received badge  Notable Question (source)
2017-01-05 21:47:16 -0500 received badge  Famous Question (source)
2016-11-30 05:56:10 -0500 received badge  Notable Question (source)
2016-10-20 04:13:02 -0500 received badge  Famous Question (source)
2016-05-19 15:44:33 -0500 received badge  Notable Question (source)
2016-05-19 15:44:33 -0500 received badge  Popular Question (source)
2016-05-03 04:32:21 -0500 received badge  Popular Question (source)
2016-04-27 22:54:03 -0500 received badge  Popular Question (source)
2016-04-13 00:04:46 -0500 answered a question Auto Scaling Instances with OpenStack Liberty Unauthorized problem

any one can help?

2016-04-13 00:04:36 -0500 answered a question Heat Missing required credential: X-Auth-User from Heat trusts method auto scaling

any one can help?

2016-04-12 01:59:22 -0500 received badge  Enthusiast
2016-04-08 05:18:55 -0500 asked a question Heat Missing required credential: X-Auth-User from Heat trusts method auto scaling

Hello I tried to implement an Auto Scaling expirement with openstack heat & ceilometer. I use trusts method to authorization.

here is my config in heat.conf:

[DEFAULT]

rpc_backend = rabbit

heat_metadata_server_url = http://controller:8000

heat_waitcondition_server_url = http://controller:8000/v1/waitcondition

stack_domain_admin = heat_domain_admin

stack_domain_admin_password = password

stack_user_domain_name = heat

verbose = True

deferred_auth_method = trusts

trusts_delegated_roles = heat_stack_owner

[database]

connection = mysql+pymysql://heat:password@controller/heat

[keystone_authtoken]

auth_uri = http://controller:5000

auth_url = http://controller:35357

auth_plugin = password

project_domain_id = default

user_domain_id = default

project_name = service

username = heat

password = password

[oslo_messaging_rabbit]

rabbit_host = controller

rabbit_userid = openstack

rabbit_password = password

[trustee]

auth_uri = http://controller:5000

auth_url = http://controller:35357

auth_plugin = password

project_domain_id = default

user_domain_id = default

username = heat

password = password

[clients_keystone]

auth_uri = http://controller:5000

[ec2authtoken]

auth_uri = http://controller:5000

and these is my .yaml file: https://www.cs.ccu.edu.tw/~cth104m/openstack/cirros.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...)
https://www.cs.ccu.edu.tw/~cth104m/openstack/environment.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...) https://www.cs.ccu.edu.tw/~cth104m/openstack/example.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...)

then I create a auto scaling stack:

root@controller:/home/controller/heat# heat stack-create auto-scale -f example.yaml -e environment.yaml ERROR: Missing required credential: X-Auth-User

here is the error, i don't know how to fix it. Can anyone help? thanks!

2016-04-08 04:15:16 -0500 asked a question openstack autoscaling with heat & ceilometer

Hello I tried to implement an Auto Scaling expirement with openstack heat & ceilometer. I followed these article: http://keithtenzer.com/2015/09/02/auto-scaling-instances-with-openstack/ (http://keithtenzer.com/2015/09/02/aut...) http://blog.csdn.net/zhangli_perdue/article/details/50359171 (http://blog.csdn.net/zhangli_perdue/a...)

and these is my .yaml file: https://www.cs.ccu.edu.tw/~cth104m/openstack/cirros.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...) )https://www.cs.ccu.edu.tw/~cth104m/openstack/environment.yaml https://www.cs.ccu.edu.tw/~cth104m/openstack/example.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...)

and I create a stack , it will failed. I checked the heat-engine.log then I found it: https://www.cs.ccu.edu.tw/~cth104m/openstack/ss1.JPG (https://www.cs.ccu.edu.tw/~cth104m/op...) (image description)

It seem like authentication problem but I really don't know how to fix it. I checked the keystone-wsgi-public.log: 2016-04-08 16:37:22.728 4417 WARNING keystone.common.wsgi [req-25cdbb92-74cf-4364-9f5c-11c8f2983258 - - - - -] Authorization failed. The request you have made requires authentication. from <my controller="" ip="" addr="">

And there are my heat.conf and ceilometer.py:

https://www.cs.ccu.edu.tw/~cth104m/openstack/heat.conf (https://www.cs.ccu.edu.tw/~cth104m/op...) https://www.cs.ccu.edu.tw/~cth104m/openstack/ceilometer.py (https://www.cs.ccu.edu.tw/~cth104m/op...)

Hope someone can help me, thanks!

2016-04-08 03:51:38 -0500 asked a question Auto Scaling Instances with OpenStack Liberty Unauthorized problem

Hello I tried to implement an Auto Scaling expirement with openstack heat & ceilometer. I followed these article: http://keithtenzer.com/2015/09/02/auto-scaling-instances-with-openstack/ (http://keithtenzer.com/2015/09/02/aut...) http://blog.csdn.net/zhangli_perdue/article/details/50359171 (http://blog.csdn.net/zhangli_perdue/a...)

and these is my .yaml file: https://www.cs.ccu.edu.tw/~cth104m/openstack/cirros.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...) https://www.cs.ccu.edu.tw/~cth104m/openstack/environment.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...) https://www.cs.ccu.edu.tw/~cth104m/openstack/example.yaml (https://www.cs.ccu.edu.tw/~cth104m/op...)

and I create a stack , it will failed. I checked the heat-engine.log then I found it: https://www.cs.ccu.edu.tw/~cth104m/openstack/ss1.JPG (image description)

It seem like authentication problem but I really don't know how to fix it. I checked the keystone-wsgi-public.log: 2016-04-08 16:37:22.728 4417 WARNING keystone.common.wsgi [req-25cdbb92-74cf-4364-9f5c-11c8f2983258 - - - - -] Authorization failed. The request you have made requires authentication. from <my controller="" ip="" addr="">

And there are my heat.conf and ceilometer.py:

https://www.cs.ccu.edu.tw/~cth104m/openstack/heat.conf (https://www.cs.ccu.edu.tw/~cth104m/op...) https://www.cs.ccu.edu.tw/~cth104m/openstack/ceilometer.py (https://www.cs.ccu.edu.tw/~cth104m/op...)

Hope someone can help me, thanks!

2015-12-18 08:18:07 -0500 received badge  Famous Question (source)
2015-12-15 20:53:22 -0500 received badge  Notable Question (source)
2015-12-15 20:53:22 -0500 received badge  Popular Question (source)
2015-11-19 08:31:18 -0500 commented question liberty Self-service bridge can't build

anyone can help?

2015-11-17 19:19:15 -0500 answered a question liberty Self-service bridge can't build

anyone can help?

2015-11-17 01:05:15 -0500 asked a question liberty Self-service bridge can't build

I use VMware workstation12 to build openstack. And I got a problem about building the bridge with Networking Option 2: Self-service networks. I don't know how to edit /etc/neutron/plugins/ml2/linuxbridge_agent.ini http://docs.openstack.org/liberty/install-guide-ubuntu/neutron-controller-install-option2.html (http://docs.openstack.org/liberty/ins...) openstack docs said Replace PUBLIC_INTERFACE_NAME with the name of the underlying physical public network interface. and Replace OVERLAY_INTERFACE_IP_ADDRESS with the IP address of the underlying physical network interface that handles overlay networks. The example architecture uses the management interface.

I don't understand it.

my setting is like this http://discovery.ccu.edu.tw/tools/api_get_thumbs.php?page_url=/Site/nu21186/.nuweb_forum/.nuweb_msg/attach/86083209.jpg&type=Image&size=1920&cs= (image description)

I set local_ip with the VM's IP itself.

and I list my neutron component , it didn't show bridge. http://discovery.ccu.edu.tw/tools/api_get_thumbs.php?page_url=/Site/nu21186/.nuweb_forum/.nuweb_msg/attach/33066128.jpg&type=Image&size=1920&cs= (image description)

do anyone know what should I set in PUBLIC_INTERFACE_NAME and OVERLAY_INTERFACE_IP_ADDRESS?

2015-11-09 19:36:11 -0500 received badge  Notable Question (source)
2015-11-09 03:46:51 -0500 received badge  Popular Question (source)
2015-11-08 20:33:55 -0500 received badge  Editor (source)
2015-11-07 22:36:49 -0500 answered a question Vm in openstack can't download anything

any one can help??

2015-11-07 17:01:16 -0500 asked a question Vm in openstack can't download anything

My OpenStack version is Juno. I had installed my Openstack and the VM in OpenStack's netwrok is work. VMs can ping outer netwrok like http://google.com. But I have no idea why I can't download anything in outer network.The command (like wget,apt-get update all) can't work.I install Ubuntu 14.04 desktop in the VM. Can anyone help??

http://discovery.ccu.edu.tw/tools/api_get_thumbs.php?page_url=/Site/nu21186/.nuweb_forum/.nuweb_msg/attach/33786014.jpg&type=Image&size=1920&cs= (image description)

The picture is that I open my browser and I can't browse anything.Why???