Ask Your Question

Haifeng's profile - activity

2015-06-22 21:42:00 -0600 received badge  Supporter (source)
2014-10-19 00:46:38 -0600 commented answer RDO deploy openstack, Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list

if packstack --allinone,the default value of epel option now is "CONFIG_USE_EPEL=n",you can execute "#yum-config-manager --enable epel" after "Preparing servers [ DONE ]" to enable epel repo

2014-10-18 00:42:46 -0600 answered a question RDO deploy openstack, Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list

the same as me,I have reported a bug on launchpad:https://bugs.launchpad.net/packstack/+bug/1382731

FWIW, the same issue has recently been reported on the Japan OpenStack User Group mailing list: https://groups.google.com/forum/#!topic/openstack-ja/b6wojDFUw40 (https://groups.google.com/forum/#!top...)

The easy workaround is to use --use-epel=y, but it's still a bug as Packstack is supposed to recognize enterprise distros automatically and enable EPEL instead of disable it.

2014-10-18 00:42:44 -0600 commented answer RDO deploy openstack, Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list

you have to modify the epel.repo file after you execute packstack command,because packstack will disable epel repo ,show you a segment of packstack logs:

2014-10-17 22:11:27::INFO::shell::81::root:: [10.0.3.15] Executing script: yum-config-manager --disable epel

2014-10-18 00:42:44 -0600 commented answer RDO deploy openstack, Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list

the packstack disable epel ,the install logs show these:

2014-10-17 22:11:27::INFO::shell::81::root:: [10.0.3.15] Executing script: yum-config-manager --disable epel

2014-02-19 13:27:38 -0600 received badge  Famous Question (source)
2013-12-19 02:38:20 -0600 received badge  Notable Question (source)
2013-12-12 21:25:06 -0600 commented answer Quantum (neutron) gre slow performance

it really works in my environment.thanks

2013-12-04 21:35:01 -0600 received badge  Popular Question (source)
2013-12-01 04:16:13 -0600 asked a question L3 router ip

I used packstack to install Havana (ovs+gre).Firstly, I created an external network--“ex-net"(10.50.9.0/24) and an internal-network--"in-net"(10.0.2.0/24),then created a router-

-"route-1", set the "route-1" gateway useing "ex-net"and added an interfaces using "in-net"; launch a instance, fixed a floating ip to a instance, so this instance got a floating ip--"10.50.9.231",at this time I can see from the Dashboard the "ex-net" has 3 ports:10.50.9.230(network:router_gateway),10.50.9.232(network:dhcp),10.50.9.231(network:floatingip).

[root@controller-2 ~]# ip netns list qdhcp-ddcbc547-dfe5-4215-b034-5fcb20707340 qrouter-e40b75c3-ed14-4a7f-a6d8-72528c64cf82 qdhcp-e638ff4a-05e0-4107-8d17-47aac3b32d3a

[root@controller-2 ~]# ip netns exec qrouter-e40b75c3-ed14-4a7f-a6d8-72528c64cf82 ifconfig lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:8 errors:0 dropped:0 overruns:0 frame:0 TX packets:8 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:784 (784.0 b) TX bytes:784 (784.0 b)

qg-d6312667-d3 Link encap:Ethernet HWaddr FA:16:3E:9C:D0:2A
inet addr:10.50.9.230 Bcast:10.50.9.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe9c:d02a/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:2639831 errors:0 dropped:0 overruns:0 frame:0 TX packets:2649684 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1137087455 (1.0 GiB) TX bytes:3332698391 (3.1 GiB)

qr-1182ca10-68 Link encap:Ethernet HWaddr FA:16:3E:63:36:3E
inet addr:10.0.2.1 Bcast:10.0.2.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe63:363e/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:4501199 errors:0 dropped:0 overruns:0 frame:0 TX packets:3182913 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5557876026 (5.1 GiB) TX bytes:3249028216 (3.0 GiB) Everything is ok. But when a add another router--"route-2", I used the command : ip netns list, it returned the same result as above. the new router--"route-2" didn't work. when I unset the gateway of "route-1", and set it's gateway using another external-network--"ex-net-2", I used the command: ip netns exec qrouter-e40b75c3-ed14-4a7f-a6d8-72528c64cf82 ifconfig, I find that the inet addr of qg-d6312667-d3 didn't change ,it's the same as above. my instance cannot access Internet,

I reset the gateway of "route-1",using "ex-net",and fixed a floating ip to my instance(10.50.9.230).see "ex-net" frome Dashboard,it's different as the first time I used it,3 ports now are as follow: has 3 ports:10.50.9.231(network:router_gateway),10.50.9.232(network:dhcp),10.50.9.230(network:floatingip).used the command: ip netns exec qrouter-e40b75c3-ed14-4a7f-a6d8-72528c64cf82 ifconfig,it's also the same as above. and ... (more)