hackman's profile - activity

2014-04-16 02:01:43 -0600 received badge  Famous Question (source)
2014-03-05 11:50:50 -0600 received badge  Famous Question (source)
2014-01-23 07:02:36 -0600 received badge  Self-Learner (source)
2013-11-29 21:29:23 -0600 received badge  Notable Question (source)
2013-11-11 23:38:28 -0600 received badge  Notable Question (source)
2013-10-22 04:05:13 -0600 received badge  Popular Question (source)
2013-10-17 19:04:58 -0600 received badge  Nice Question (source)
2013-10-17 07:00:52 -0600 received badge  Famous Question (source)
2013-10-17 02:01:48 -0600 commented question cannot ssh to spawned vms

I am not sure if this has to do with the fact that had updated my local git branches (devstack, nova, nuetron etc.) to latest master yesterday.

2013-10-17 01:58:15 -0600 received badge  Enthusiast
2013-10-16 23:56:10 -0600 received badge  Editor (source)
2013-10-16 23:41:36 -0600 asked a question cannot ssh to spawned vms

The previous content was wrong.

The problem is: I had logged in as demo, and started the default cirros image instance. I added the security rule to the default group to open up the SSH connection:

nova secgroup-add-rule default tcp 22 22 172.24.4.0/24

I still cannot ssh login to the vm from the host where devstack is running. ie. ssh cirros@10.0.0.3 hangs. This used to work before after adding the security rule above without any tampering of iptables.

To debug the problem, I enabled trace on iptables, and I found that the rule:

-A nova-compute-sg-fallback -j DROP

ultimately matches, and as a result, the firewall is rejecting the SSH connection.

If I change it manually to:

-A nova-compute-sg-fallback -j ACCEPT

it works. However, if I spawn a second VM, the rule goes back to the DROP target, and as a result, I cannot connect. I have to put the ACCEPT target back once more to get the login to work again.

My question is what am I doing wrong that what used to work before does not work now, and as a temporary fix, I have to change the rule above.

Thanks

2013-10-11 19:25:16 -0600 commented question devstack does not start when enabling neutron

I have been busy with other things, but the main problem was my localrc was pointing to stable/grizzly while the main devstack repository - the devstack.git was pointing to master. after doing 'git clone git://github.com/openstack-dev/devstack.git', I should have checked out origin/stable/grizzly for devstack.git if I really wanted to experiment with that branch. I simply removed the 'xxx_BRANCH' lines above and let the defaults in stackrc take effect (ie. master branch), and now everything works.

2013-09-24 18:44:06 -0600 received badge  Famous Question (source)
2013-09-24 18:42:46 -0600 received badge  Nice Question (source)
2013-09-21 16:19:49 -0600 commented question devstack does not start when enabling neutron

After going through the execution of stack.sh in debug, I understand a lot more about its operation. I should not have set the 'ENABLED_SERVICES' variable. Instead, modify the default that is specified in stackrc by invoking enable_service or disable_service appropriately. After doing that, I ran into the problem that was posted on stackoverflow: http://stackoverflow.com/questions/17681226/cloudfoundry-grizzly-keystone-with-devstack-install-configparser-error-in-keyst/18937657#18937657 I have posted an answer there as user2802945. My question is why should my repositories point to 'master' when 'stable/grizzly' should have worked. Is there anything else that needs to be done.

2013-09-21 16:13:17 -0600 commented answer Virtual machine does not come up

Thanks for the pointer. It was the first time for my post. After posting I realized that the format was messed up, and then found the code formatting button above.

2013-09-21 05:57:55 -0600 received badge  Notable Question (source)
2013-09-20 20:42:50 -0600 received badge  Popular Question (source)
2013-09-20 09:24:26 -0600 received badge  Popular Question (source)
2013-09-20 05:24:20 -0600 received badge  Nice Answer (source)
2013-09-19 20:24:06 -0600 asked a question devstack does not start when enabling neutron

I am getting this error:

2013-09-19 18:07:45 + /usr/local/bin/neutron-db-manage --config-file /etc/neutron/neutron.conf --con
fig-file /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini upgrade head
2013-09-19 18:07:45 Traceback (most recent call last):
2013-09-19 18:07:45   File "/usr/local/bin/neutron-db-manage", line 6, in <module>
2013-09-19 18:07:45     from neutron.db.migration.cli import main
2013-09-19 18:07:45 ImportError: No module named neutron.db.migration.cli

My localrc is:

DATABASE_PASSWORD=<password>
RABBIT_PASSWORD=<password>
SERVICE_TOKEN=<some token>
SERVICE_PASSWORD=<password>
ADMIN_PASSWORD=<password>
HOST_IP=192.168.210.204
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
ENABLED_SERVICES=q-meta,q-lbaas,n-obj,n-cpu,n-sch,n-cauth,horizon,mysql,rabbit,cinder,c-api,c-vol,c-sc
h,n-cond,q-svc,q-agt,q-dhcp,q-l3,n-novnc,n-xvnc,q-lbaas,g-api,g-reg,key,n-api,n-crt
LOGFILE=$DEST/logs/stack.log
# SCREEN_LOGDIR=/opt/stack/logs
CINDER_BRANCH=stable/grizzly
GLANCE_BRANCH=stable/grizzly
HORIZON_BRANCH=stable/grizzly
KEYSTONE_BRANCH=stable/grizzly
NOVA_BRANCH=stable/grizzly
NEUTRON_BRANCH=stable/grizzly
SWIFT_BRANCH=stable/grizzly
SERVICE_TOKEN=devstack
SCHEDULER=nova.scheduler.chance.ChanceScheduler
enable_service swift
SWIFT_HASH=devstack
2013-09-19 14:35:59 -0600 received badge  Notable Question (source)
2013-09-19 08:22:29 -0600 received badge  Self-Learner (source)
2013-09-19 08:22:29 -0600 received badge  Teacher (source)
2013-09-19 08:18:16 -0600 received badge  Popular Question (source)
2013-09-18 15:48:39 -0600 answered a question Virtual machine does not come up

Thanks for pointing me to the logs. Looks like there is no simple scheduler. I used the chance schduler in /opt/stack/nova/nova/scheduler/chance.py

After changing my localrc line from SCHEDULER=nova.scheduler.simple.SimpleScheduler to SCHEDULER=nova.scheduler.chance.ChanceScheduler

I am able to get the image running.

2013-09-18 14:45:14 -0600 received badge  Scholar (source)
2013-09-18 14:44:55 -0600 received badge  Supporter (source)
2013-09-18 14:42:31 -0600 commented question Virtual machine does not come up

Thanks a lot for the immediate reply. I replied to this via e-mail, but posting it again here: Looks like an issue with the python code for the 'simple' module. I am just getting started with Openstack, and so I need to get familiar with what is going on under the hood. The n-sch program output is on screen 19, and here is the log from that: 2013-09-17 21:17:12.075 DEBUG nova.servicegroup.api [-] ServiceGroup driver defined as an instance of db from (pid=12836) __new__ /opt/stack/nova/nova/servicegroup/api.py:62 2013-09-17 21:17:12.184 DEBUG stevedore.extension [-] found extension EntryPoint.parse('file = nova.image.download.file') from (pid=12836) _load_plugins /usr/local/lib/python2.7/dist-packages/stevedore/extension.py:84 2013-09-17 21:17:12.272 INFO nova.openstack.common.periodic_task [-] Skipping periodic task _periodic_update_dns because its interval is negative 2013-09-17 21:17:12 ... (more)

2013-09-18 14:16:24 -0600 received badge  Student (source)
2013-09-18 02:08:34 -0600 asked a question Using postgres database with devstack

How do I run devstack with postgres as the db

2013-09-18 01:54:39 -0600 asked a question Virtual machine does not come up

I am running devstack (grizzly) with Ubuntu 12.04 Precise (desktop version). When I switch project to demo, and try to start the default cirros m1.tiny image, it is stuck at the "Scheduling" step for ever.

The localrc enabled services has this: ENABLED_SERVICES=q-meta,q-lbaas,n-obj,n-cpu,n-sch,n-cauth,horizon,mysql,rabbit,cinder,c-api,c-vol,c-sch,n-cond,neutron,q-svc,q-agt,q-dhcp,q-l3,n-novnc,n-xvnc,q-lbaas,g-api,g-reg,key,n-api,n-crt

I don't know if this is related to this message seen on console output Error: Service n-sch is not running

This is a Supermicro rack mounted unit with 8GB memory.