Ask Your Question

Gamekiller77's profile - activity

2015-11-26 03:14:18 -0500 received badge  Famous Question (source)
2014-08-16 08:47:23 -0500 received badge  Student (source)
2014-08-16 08:47:19 -0500 received badge  Famous Question (source)
2014-08-11 10:45:11 -0500 received badge  Notable Question (source)
2014-08-11 10:45:11 -0500 received badge  Popular Question (source)
2014-06-23 22:35:06 -0500 asked a question heat-manage reports ImportError: No module named sqlalchemy

Running RHEL 6.5 RDO Icehouse

When i run heat-manage db-sync after a clean install or upgrade i get this same traceback.

# heat-manage 
Traceback (most recent call last):
  File "/usr/bin/heat-manage", line 31, in <module>
    from heat.cmd import manage
  File "/usr/lib/python2.6/site-packages/heat/cmd/manage.py", line 24, in <module>
    from heat.db import api
  File "/usr/lib/python2.6/site-packages/heat/db/api.py", line 42, in <module>
    IMPL = db_api.DBAPI(backend_mapping=_BACKEND_MAPPING)
  File "/usr/lib/python2.6/site-packages/heat/openstack/common/db/api.py", line 53, in __init__
    backend_mod = importutils.import_module(backend_path)
  File "/usr/lib/python2.6/site-packages/heat/openstack/common/importutils.py", line 57, in import_module
    __import__(import_str)
  File "/usr/lib/python2.6/site-packages/heat/db/sqlalchemy/api.py", line 21, in <module>
    import sqlalchemy

ImportError: No module named sqlalchemy

I then looked and notice sqlalchemy python package was not installed at all so i yum install it and it installed just fine.

I then ran the heat-manage command just to get the switchs and i get this traceback now.

heat-manage
Traceback (most recent call last):
  File "/usr/bin/heat-manage", line 31, in <module>
    from heat.cmd import manage
  File "/usr/lib/python2.6/site-packages/heat/cmd/manage.py", line 24, in <module>
    from heat.db import api
  File "/usr/lib/python2.6/site-packages/heat/db/api.py", line 42, in <module>
    IMPL = db_api.DBAPI(backend_mapping=_BACKEND_MAPPING)
  File "/usr/lib/python2.6/site-packages/heat/openstack/common/db/api.py", line 53, in __init__
    backend_mod = importutils.import_module(backend_path)
  File "/usr/lib/python2.6/site-packages/heat/openstack/common/importutils.py", line 57, in import_module
    __import__(import_str)
  File "/usr/lib/python2.6/site-packages/heat/db/sqlalchemy/api.py", line 24, in <module>
    cfg.CONF.import_opt('max_events_per_stack', 'heat.common.config')
  File "/usr/lib/python2.6/site-packages/oslo/config/cfg.py", line 1796, in import_opt
    __import__(module_str)
  File "/usr/lib/python2.6/site-packages/heat/common/config.py", line 26, in <module>
    from heat.common import wsgi
  File "/usr/lib/python2.6/site-packages/heat/common/wsgi.py", line 39, in <module>
    from paste import deploy
ImportError: cannot import name deploy

Again this is from and upgrade from havana to icehouse and a clean wipe and reinstall i get this same error.

Any insight in to what going on would really help.

Also here is the url to the bug i filed. https://bugzilla.redhat.com/show_bug....

2014-06-17 08:42:50 -0500 received badge  Famous Question (source)
2014-06-17 08:42:50 -0500 received badge  Notable Question (source)
2014-04-04 18:42:00 -0500 received badge  Nice Answer (source)
2014-04-04 10:40:46 -0500 commented answer TypeError: libvirt_info() takes exactly 6 arguments (7 given)

Yup there working on it from what i see on the bug.

2014-04-04 10:25:59 -0500 received badge  Teacher (source)
2014-04-04 10:25:59 -0500 received badge  Necromancer (source)
2014-04-04 09:44:39 -0500 answered a question TypeError: libvirt_info() takes exactly 6 arguments (7 given)

The OPST team have published a patch to this bug.

https://launchpad.net/nova/+milestone/2013.2.3 (https://launchpad.net/nova/+milestone...)

As soon as this hit the RDO repo you should be fine. I have a ticket open with RH to find out when this will hit upstream.

The bug is here if you want to read it.

https://bugs.launchpad.net/nova/+bug/1233188 (https://bugs.launchpad.net/nova/+bug/...)

2014-03-30 23:58:16 -0500 received badge  Notable Question (source)
2014-03-27 15:12:27 -0500 received badge  Enthusiast
2014-03-25 08:37:13 -0500 commented question How to debug cluster where instance status is stuck on "scheduling"?

Did you find any good ways of debuging this problem?

2014-02-19 11:38:35 -0500 received badge  Popular Question (source)
2014-02-14 15:24:13 -0500 commented answer ldap with 100k user Horizon dashboard not letting edit projects

This worked 100% thank you so much. FYI for those of you looking for this for havana it in the cloud admin guide. Also i notice it will not read a group in a group. Only the users in the group. Need to look at this.

2014-02-13 19:59:52 -0500 asked a question ldap with 100k user Horizon dashboard not letting edit projects

I was able to get keystone to talk to my ldap and i able to log in to the dashboard with a admin AD user in ldap. That work find and great. BTW this on Havana

When I go to add a user to a project/tenant on the dashboard I get the pinwheel of death. After many minutes (15+ if not longer) a simple error pops up that it can not be done.

The problem is my ldap system has close to 110,000 users in the user sub OU. When I did a simple keystone user-list at the command line the output is of all my ldap users and I mean all 110,000 users.

What I see in the logs is when I try and click modify users is every user be validated and then check to see if there in a role then on and on and on and on. I am also thinking it cacheing the username to give me the list to add to a project.

I am use assignment field in keystone to track AD user assigned to a role or project and yes command line adding users is fast and works great. I need the dashboard to work for the Tire1 people that will run this system for me down the line. Giving them CLI access to a linux box is a little bit to extreme.

What really needs to happen is not list all users in LDAP but just those assignments already made in the SQL system. For adding new users that are in LDAP then just a simple search or if i know the users name place and check.

Looking for advice or setting that i over looked.

I did make all the changes in the dashboard config files that are stated on all the pages i found with google.

2014-02-02 12:55:11 -0500 answered a question Port on router to public gateway always down.

First Off i have the same problem with my router port on my public network showing down. I found this problem while i was searching for why the port was down.

One thing i found was the order in which i built the network setup. I had to first build the pulbic network and floating ip pool. then the subnet stuff. then the private network then subnet. Then create a router and add the private network. Last add the public network GW and boom it worked. So odd i heard this was a problem non to the neutron setup with CentOS and RDO build.

If i find my fix i post it here too.

Andy

2014-01-24 16:51:33 -0500 answered a question What is a "publishing policy" for ceilometer

I am seeing the same error. If you found a fix and you post it please.

2013-11-27 11:00:38 -0500 received badge  Popular Question (source)
2013-10-24 18:30:20 -0500 asked a question Heat db_sync fails with socket

Running the this command.

heat-manage db_sync

The out put i get a the end of the trace is this.

    # heat-manage db_sync
2013-10-24 21:58:45.035 5451 DEBUG migrate.versioning.repository [-] Loading repository /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/repository.py:76
2013-10-24 21:58:45.036 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/015_grizzly.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.036 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/015_grizzly.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:30
2013-10-24 21:58:45.036 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/016_timeout_nullable.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.036 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/016_timeout_nullable.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:30
2013-10-24 21:58:45.037 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/017_event_state_status.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.037 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/017_event_state_status.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:30
2013-10-24 21:58:45.037 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/018_resource_id_uuid.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.037 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/018_resource_id_uuid.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:30
2013-10-24 21:58:45.038 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/019_resource_action_status.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.038 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/019_resource_action_status.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:30
2013-10-24 21:58:45.038 5451 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/020_stack_action.py... __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script/base.py:27
2013-10-24 21:58:45.038 5451 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.6/site-packages/heat/db/sqlalchemy/migrate_repo/versions/020_stack_action.py loaded successfully __init__ /usr/lib/python2.6/site-packages/migrate/versioning/script ...
(more)
2013-09-04 07:51:12 -0500 received badge  Famous Question (source)
2013-08-19 10:49:04 -0500 received badge  Notable Question (source)
2013-08-16 10:55:13 -0500 commented answer Dashboard showing tenant_usage in debug window

I would love to run the keystone catalog command but i can net get it to output at all. I get stuck in a look of wanting something else to auth to get data or that i do not have catalogs setup which i do with in the config setup.

2013-08-16 10:53:01 -0500 commented answer Dashboard showing tenant_usage in debug window

I had found this error late yesteray when doing a review with come co workers. I swear i had changed it in my script. But yes we had /v2.0 not /v2. Also for my Quantum/Neutron setup i had a / on the after the port numbers which broke stuff.

2013-08-16 10:51:28 -0500 received badge  Scholar (source)
2013-08-16 10:51:26 -0500 received badge  Supporter (source)
2013-08-16 04:36:48 -0500 received badge  Popular Question (source)
2013-08-14 18:37:30 -0500 asked a question Dashboard showing tenant_usage in debug window

I have testing keystone and other setup and it all looks fine. The enpoint-list look clean but keystone catalog i can not get to output. I am using CentOS 6.4 with RDO repo to install Grizzly.

Here is the log out put from apache that point to a funny line where it addes a /v2/v2.0 i think it should be only /2.0/tenant_id

[Wed Aug 14 16:11:15 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Aug 14 16:11:15 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Aug 14 16:11:15 2013] [notice] Digest: done
[Wed Aug 14 16:11:15 2013] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations
[Wed Aug 14 23:12:35 2013] [error] DeprecationWarning: The ADMIN_MEDIA_PREFIX setting has been removed; use STATIC_URL instead.DeprecationWarning: The SECRET_KEY setting must not be empty.DeprecationWarning: Translations in the project directory aren't supported anymore. Use the LOCALE_PATHS setting instead.DeprecationWarning: The syntax for the url template tag is changing. Load the `url` tag from the `future` tag library to start using the new behavior.DeprecationWarning: Authentication backends without a `supports_inactive_user` attribute are deprecated. Please define it in <class 'openstack_auth.backend.KeystoneBackend'>.DEBUG:openstack_auth.backend:Beginning user authentication for user "admin".
[Wed Aug 14 23:12:35 2013] [error] INFO:urllib3.connectionpool:Starting new HTTP connection (1): 10.35.41.30
[Wed Aug 14 23:12:35 2013] [error] DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 1133
[Wed Aug 14 23:12:35 2013] [error] INFO:urllib3.connectionpool:Starting new HTTP connection (1): 10.35.41.30
[Wed Aug 14 23:12:35 2013] [error] DEBUG:urllib3.connectionpool:"GET /v2.0/tenants HTTP/1.1" 200 144
[Wed Aug 14 23:12:35 2013] [error] INFO:urllib3.connectionpool:Starting new HTTP connection (1): 10.35.41.30
[Wed Aug 14 23:12:36 2013] [error] DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 5179
[Wed Aug 14 23:12:36 2013] [error] INFO:urllib3.connectionpool:Starting new HTTP connection (1): 10.35.41.30
[Wed Aug 14 23:12:36 2013] [error] DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 5179
[Wed Aug 14 23:12:36 2013] [error] DEBUG:openstack_auth.backend:Authentication completed for user "admin".
[Wed Aug 14 23:12:36 2013] [error]
[Wed Aug 14 23:12:36 2013] [error] REQ: curl -i http://10.35.41.31:8774/v2.0/bfdd3d0edda44a4aada8614464f5385e/os-simple-tenant-usage?start=2013-08-01T00:00:00&end=2013-08-14T23:12:36.165985&detailed=1 -X GET -H "X-Auth-Project-Id: 7eff471610fd4f67908a7c1b4741a63a" -H "User-Agent: python-novaclient" -H "Accept: application/json" -H "X-Auth-Token: fe1a5f98c2300dc615df8916348e4699"
[Wed Aug 14 23:12:36 2013] [error]
[Wed Aug 14 23:12:36 2013] [error] INFO:urllib3.connectionpool:Starting new HTTP connection (1): 10.35.41.31
[Wed Aug 14 23:12:36 2013] [error] DEBUG:urllib3.connectionpool:"GET /v2.0/bfdd3d0edda44a4aada8614464f5385e/os-simple-tenant-usage?start ...
(more)