Ask Your Question

shalmali's profile - activity

2016-07-23 05:00:17 -0500 received badge  Great Question (source)
2015-01-11 02:45:16 -0500 received badge  Good Question (source)
2015-01-10 13:18:00 -0500 received badge  Nice Question (source)
2014-06-18 04:47:04 -0500 marked best answer What is default username and password for Ubuntu image uploaded using glance image-create ?

What is default username and password for Ubuntu image uploaded using glance image-create ?

I have created image using following command -

glance image-create --name=ubuntu-12.04.2-server-cloudimg-amd64 --is-public=true --container-format=bare --disk-format=qcow2 </ubuntu-12.04.2-server-cloudimg-amd64-disk1.img

Image is getting created. But when I launch instance I am not able to Login to the instance .

Can anybody tell me what is default username and password for ubuntu-12.04.2-server ?

2014-05-28 00:44:35 -0500 received badge  Famous Question (source)
2014-05-28 00:43:43 -0500 commented answer Launching Instance on VMware shows Guest OS Not Found

Hi Chinmay, Even I am facing the same issue. Instance gets launched shows running state. But on console it shows "Operating system not found". I am using Havana. I Configured Controller and Compute on the Same ESXi. Is there any missing configuration or is it the only issue with vmdk ? Because I tried converting img to vmdk also But in that case I am getting error"unacceptable image". Could you please help me in this ?

2014-03-05 07:22:38 -0500 received badge  Notable Question (source)
2014-02-25 08:22:29 -0500 received badge  Taxonomist
2014-02-07 01:33:07 -0500 commented answer facing networking issue with VM instance on distributed deployment - Havana release

Hard rebooting all the nodes resolved my isuue.

2014-01-23 18:44:25 -0500 marked best answer how can I install OpenStack with two node architecture i.e. one controller and one compute? and add multiple compute nodes to controller ?

how can I install OpenStack with two node architecture i.e. one controller and one compute? and add multiple compute nodes to controller ?

I have installed All-in-one OpenStack node. Do I need to disable nova-services from this node and add compute node having only nova services running pointing to controller node ?

How to disable nova-compute services ?

2014-01-21 07:11:21 -0500 received badge  Nice Question (source)
2014-01-20 03:46:28 -0500 answered a question Howto use Horizon with nova-network (Havana / Ubuntu 12.04)

Go to the mysql and run flush hosts command.

run following commands: 1. # mysql -u root -p 2. mysql> use keystone; Database changed 3.FLUSH HOSTS;

and Done. These steps resolved my issue !! hope this works for you as well !!

2014-01-20 03:43:12 -0500 answered a question dashboard issue

Go to the mysql and run flush hosts command.

run following commands: 1. # mysql -u root -p 2. mysql> use keystone; Database changed 3.FLUSH HOSTS;

and Done. These steps resolved my issue !! hope this works for you as well !!

2014-01-15 10:05:53 -0500 received badge  Popular Question (source)
2014-01-15 01:08:47 -0500 answered a question facing networking issue with VM instance on distributed deployment - Havana release

Following is the Deployment diagram for the same. Posting on behalf of Shridhar. Network-topology-diagram.jpg

Attaching logs

/var/log/openvswitch/ovs-vswitchd.log (Network node)

2014-01-16T11:50:39Z|00051|bridge|INFO|bridge br-tun: added interface br-tun on port 65534 2014-01-16T11:50:39Z|00052|bridge|INFO|bridge br-tun: using datapath ID 00001ef18ac7254b 2014-01-16T11:50:39Z|00053|connmgr|INFO|br-tun: added service controller "punix:/var/run/openvswitch/br-tun.mgmt" 2014-01-16T11:50:39Z|00054|netdev_linux|WARN|ethtool command ETHTOOL_GFLAGS on network device patch-tun failed: No such device 2014-01-16T11:50:39Z|00055|dpif|WARN|system@ovs-system: failed to add patch-tun as port: No such device 2014-01-16T11:50:39Z|00056|netdev_vport|ERR|patch-tun: patch type requires valid 'peer' argument 2014-01-16T11:50:39Z|00057|bridge|WARN|could not configure network device patch-tun (Invalid argument) 2014-01-16T11:50:39Z|00058|bridge|INFO|bridge br-int: added interface patch-tun on port 3 2014-01-16T11:50:39Z|00059|netdev_linux|WARN|ethtool command ETHTOOL_GFLAGS on network device patch-int failed: No such device 2014-01-16T11:50:39Z|00060|dpif|WARN|system@ovs-system: failed to add patch-int as port: No such device 2014-01-16T11:50:39Z|00061|netdev_vport|ERR|patch-int: patch type requires valid 'peer' argument 2014-01-16T11:50:39Z|00062|bridge|WARN|could not configure network device patch-int (Invalid argument) 2014-01-16T11:50:39Z|00063|bridge|INFO|bridge br-tun: added interface patch-int on port 1 2014-01-16T11:50:40Z|00064|netdev_linux|WARN|ethtool command ETHTOOL_GFLAGS on network device gre-2 failed: No such device 2014-01-16T11:50:40Z|00065|dpif|WARN|system@ovs-system: failed to add gre-2 as port: No such device 2014-01-16T11:50:40Z|00066|netdev_vport|ERR|gre-2: gre type requires valid 'remote_ip' argument 2014-01-16T11:50:40Z|00067|bridge|WARN|could not configure network device gre-2 (Invalid argument) 2014-01-16T11:50:40Z|00068|bridge|INFO|bridge br-tun: added interface gre-2 on port 2 2014-01-16T11:50:43Z|00069|bridge|INFO|bridge br-int: added interface qr-021a5d17-d0 on port 4 2014-01-16T11:50:44Z|00070|netdev_linux|INFO|ioctl(SIOCGIFHWADDR) on qr-021a5d17-d0 device failed: No such device 2014-01-16T11:50:44Z|00071|bridge|INFO|bridge br-ex: added interface qg-f43c42c9-94 on port 3 2014-01-16T11:50:44Z|00072|netdev_linux|WARN|ioctl(SIOCGIFINDEX) on qr-021a5d17-d0 device failed: No such device 2014-01-16T11:50:44Z|00073|netdev_linux|WARN|qr-021a5d17-d0: removing policing failed: No such device 2014-01-16T11:50:44Z|00074|netdev_linux|INFO|ioctl(SIOCGIFHWADDR) on qg-f43c42c9-94 device failed: No such device 2014-01-16T11:50:44Z|00075|netdev_linux|WARN|ioctl(SIOCGIFINDEX) on qg-f43c42c9-94 device failed: No such device 2014-01-16T11:50:44Z|00076|netdev_linux|WARN|qg-f43c42c9-94: removing policing failed: No such device 2014-01-16T11:50:45Z|00077|bridge|INFO|bridge br-tun: added interface br-tun on port 65534 2014-01-16T11:50:45Z|00078|bridge|INFO|bridge br-tun: using datapath ID 000042b6ef888e4f 2014-01-16T11:50:45Z|00079|connmgr|INFO|br-tun: added service controller "punix:/var/run/openvswitch/br-tun.mgmt" 2014-01-16T11:50:45Z|00080|netdev_linux|WARN|ethtool command ETHTOOL_GFLAGS on network device patch-tun failed: No such device 2014-01-16T11:50:45Z|00081|dpif|WARN|system@ovs-system: failed to add patch-tun as port: No such device 2014-01-16T11:50:45Z|00082|netdev_vport|ERR|patch-tun: patch type requires valid 'peer' argument 2014-01-16T11:50:45Z|00083|bridge|WARN ... (more)

2014-01-13 06:45:23 -0500 asked a question 'bin' folder missing in nova hyper v configuration

Hi ,

We are trying to setup compute Hyper V node .We are running into a issue where ' bin' folder is missing from under 'Nova' .The description is as below :

  1. we started with the steps given in doc @ -http://docs.openstack.org/grizzly/openstack-compute/admin/content//hyper-v-virtualization-platform.html#running_compute-with-hyper-vhttp://blog.wesupportit.in/2012/11/hyper-v-as-compute-node-in-openstack.html.
  2. we executed steps successfully till " Installing nova-compute" section.
  3. After step 2 , we downloaded the 'git' installer and cloned nova using - C:\git.exe clone https://github.com/openstack/nova.git
  4. Nova.git was cloned successfully .
  5. we found out that 'bin' folder was missing under 'nova' @ location - c:\nova\

We are not sure why 'bin' is missing from nova , is it something related to cloning nova as mentioned in step 3 ?

We also tried the same with already available exe from -http://www.cloudbase.it/installing-openstack-nova-compute-on-hyper-v but we found that it has a known limitation for 'gre' type of network .Hence we could not proceed with this as well . Is there any other exe or similar configuration file available for 'gre' type of network ?

Any help will be much appreciated.

Note : we are trying this for Havana release.

2014-01-02 04:01:52 -0500 commented answer How to use mysql as backend in ceilometer installed by devstack?

Hi Rain Guan, I tried with CEILOMETER_BACKEND=mysql option in localrc. But I am still getting errors in ceilometer-api saying ceilometer-api failed to start.

2013-12-22 11:32:18 -0500 received badge  Famous Question (source)
2013-12-18 09:08:38 -0500 received badge  Notable Question (source)
2013-12-13 05:14:32 -0500 received badge  Enthusiast
2013-12-13 01:14:48 -0500 received badge  Popular Question (source)
2013-12-10 08:17:37 -0500 marked best answer How should I authenticate against keystone?

While installing openstack grizzly using github document for All-in one installation for ubuntu 12.04 server got error

command: keystone user-list 
Error:
Unable to communicate with identity service: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Not Authorized"}}. (HTTP 401)
2013-12-09 06:50:45 -0500 received badge  Supporter (source)
2013-12-09 06:46:25 -0500 asked a question ERROR failed synchronizing routers ... rpc timeout

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log

2013-12-09 22:18:20.756 2510 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Traceback (most recent call last):
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 750, in _sync_routers_task
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     context, router_ids)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 75, in get_routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     topic=self.topic)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/proxy.py", line 130, in call
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     exc.info, real_topic, msg.get('method'))
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Timeout: Timeout while waiting on RPC response - topic: "q-l3-plugin", RPC method: "sync_routers" info: "<unknown>"
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 598.002945 sec
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 560.003462 sec

I am getting following output after running command "ip a"

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:56:56 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.18/16 brd 172.16.255.255 scope global eth0
    inet6 fe80::250:56ff:fe91:5656/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:6c:43 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.111/16 brd 172.16.255.255 scope global eth1
    inet6 fe80::250:56ff:fe91:6c43/64 scope link
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::250:56ff:fe91:32e5/64 scope link
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 5a:ef:48:02:d3:69 brd ff:ff:ff:ff:ff:ff
6: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.113/16 brd 172.16.255 ...
(more)
2013-12-09 06:38:41 -0500 received badge  Scholar (source)
2013-12-06 03:31:20 -0500 received badge  Famous Question (source)
2013-11-05 16:36:08 -0500 received badge  Good Question (source)
2013-09-30 01:10:19 -0500 commented answer cinder-volume dependence problem

Hi, this solution didn't work for me. Can you suggest me any other solution for this dependence problem ?

2013-09-30 00:52:35 -0500 commented question Error while installing cinder-volume

Hi, I am also facing the same problem.. are you able to fix this issue ?

2013-09-23 08:45:04 -0500 received badge  Famous Question (source)
2013-09-17 05:04:23 -0500 received badge  Notable Question (source)
2013-09-17 05:04:23 -0500 received badge  Famous Question (source)