Ask Your Question

billy's profile - activity

2017-12-19 03:45:18 -0500 received badge  Famous Question (source)
2017-10-20 13:48:15 -0500 commented question pike neutron cannot populate database 'unexpected keyword argument 'sqlite_db''

you have to comment that sqllite lines

2017-10-09 01:35:57 -0500 commented question pike neutron cannot populate database 'unexpected keyword argument 'sqlite_db''

Uncomment sqllite in connection parameter in neutron.cof file and define your mysql user/pass string after that you can populate db if this help kindly mark this answer

2017-09-29 02:04:56 -0500 commented answer In the cirrors instance, I can ping google's ip, but can not ping google.com

you can define nameserver ip while you create subnet for your tenant

2017-09-27 10:16:58 -0500 answered a question In the cirrors instance, I can ping google's ip, but can not ping google.com

i think issue will be resolve if you use public dns server ip such as 8.8.8.8 instead of 192.168.1.2

2017-09-27 10:13:22 -0500 commented answer In the cirrors instance, I can ping google's ip, but can not ping google.com

also why you mentioned google.com in single quote ?

2017-09-27 10:11:24 -0500 commented answer In the cirrors instance, I can ping google's ip, but can not ping google.com

for example in cli type below command

nslookup 
server 192.168.1.2
google.com

if you name to ip works then you mentiond ip is dns sever if not try out side network if it in public netoworkenter code here

2017-09-23 08:43:22 -0500 received badge  Notable Question (source)
2017-09-19 14:21:09 -0500 received badge  Teacher (source)
2017-09-19 14:21:09 -0500 received badge  Self-Learner (source)
2017-09-19 14:16:48 -0500 received badge  Popular Question (source)
2017-09-14 07:37:28 -0500 answered a question ERROR: 'unicode' object has no attribute 'get' Heat

Hahah issue resolved issue was with neutron router section get_paramter was invalid we should use network instead of get param like below

LAB_ROUTER1:
    type: OS::Neutron::Router
    properties:
      external_gateway_info: { network: pub_net }
2017-09-13 14:17:58 -0500 commented question Error Could not find domain: default when import core Murano libaray during manual installation

Try to use env script given below export OS_PROJECT_DOMAIN_NAME=Default export OS_USER_DOMAIN_NAME=Default export OS_PROJECT_NAME=admin export OS_USERNAME=admin export OS_PASSWORD=admin export OS_AUTH_URL=http://controller:35357/v3 export OS_IDENTITY_API_VERSION=3 export OS_IMAGE_API_VERSION=2

2017-09-13 14:09:07 -0500 asked a question ERROR: 'unicode' object has no attribute 'get' Heat

Dear all

am facing an issue with my heat template . while creating stack its throwing an exception( given in below) , also verified with heat template validate command and its validated successfully without any error

kindly advise me about this situation


ERROR: 'unicode' object has no attribute 'get'

heat_template_version: 2017-02-24
description: HOT Templates for SALIM lab cloud 

parameters:
  my_key:
    type: string
    label: my-prv
    description: Key name for salim lab enviorment
  win_image:
    type: string
    label: 2012 server
    description: Windows image 
  centos_image:
    type: string
    label: centos 7 x86
    description: centos 7 linux images
  flavor_40G:
    type: string
    label: flavor-40G
    default: flavor-40G
  flavor_80G:
    type: string
    label: flavor-80G
    default: flavor-80G
    description: ORACLE and TOMCAT Server Flavour
  pub_net:
    type: string
    label: oracle and tomcat 
    description: public network name

resources:
  private_net:
    type: OS::Neutron::Net
    properties:
      name: LAB-PRV-NET1
  private_subnet:
    type: OS::Neutron::Subnet
    properties:
      network_id: { get_resource: private_net }
      cidr: 192.168.9.0/24
      gateway_ip: 192.168.9.1
  LAB_ROUTER1:
    type: OS::Neutron::Router
    properties:
      external_gateway_info: { get_param: pub_net }
  LAB_ROUTER1_INT:
    type: OS::Neutron::RouterInterface
    properties:
      router_id: { get_resource:  LAB_ROUTER1 }
      subnet_id: { get_resource: private_subnet }
  TOM1_Port1:
    type: OS::Neutron::Port
    properties:
      network_id: { get_resource: private_net }
      fixed_ips:
        - subnet_id: { get_resource: private_subnet }
  TOM2_Port1:
    type: OS::Neutron::Port
    properties:
      network_id: { get_resource: private_net }
      fixed_ips:
        - subnet_id: { get_resource: private_subnet }
  WIN_AD_Port1:
    type: OS::Neutron::Port
    properties:
      network_id: { get_resource: private_net }
      fixed_ips:
        - subnet_id: { get_resource: private_subnet }
  TOM1_FL_IP:
    type: OS::Neutron::FloatingIP
    properties:
      floating_network_id: { get_param: pub_net }
      port_id: { get_resource: TOM1_Port1 }
  TOM2_FL_IP:
    type: OS::Neutron::FloatingIP
    properties:
      floating_network_id: { get_param: pub_net}
      port_id: { get_resource: TOM2_Port1 }
  WIN_AD_FL_IP:
    type: OS::Neutron::FloatingIP
    properties:
      floating_network_id: { get_param: pub_net }
      port_id: { get_resource: WIN_AD_Port1 }
  TOM1_SERVER1:
    type: OS::Nova::Server
    properties:
      name: APP2
      image: { get_param: centos_image }
      flavor: { get_param: flavor_40G }
      networks:
       - port: { get_resource: tom1_Port1}
  TOM2_SERVER1:
    type: OS::Nova::Server
    properties:
      name: APP1
      image: { get_param: centos_image }
      flavor: {get_param: flavor-40G }
      networks:
        - port: {get_resource: TOM2_Port1 }

  WIN-AD1:
    type: OS::Nova::Server
    properties:
      name:   win-AD
      image: { get_param: win_image }
      flavor: { get_param: flavor-40G }
      networks:
        - port: {get_resource: WIN_AD_Port1 }

outputs:
  TOM1_PRV_IP:
    description: Private ip For TOM1 Server
    value: { get_attr: [TOM1_SERVER1, first_address] }
  TOM2_PRV_IP:
    description: Private ip FOR tom2 Server
    value: { get_attr: [TOM2_SERVER1, first_address] }
  WIN-AD_prv_IP:
    description: Private iP FOR WIN AD Server
    value: { get_attr: [WIN-AD1, first_address] }

  TOM2_PUB_IP:
    description: Public ip for APP
    value: { get_attr: [TOM2_FL_IP, floating_ip_address] }

  TOM1_PUB_IP:
    description: Public IP FOR TOM1-SERVER
    value: { get_attr: [TOM1_FL_IP, floating_ip_address] }

  WIN_AD_PUB_IP:
    description: Public ip for WIN Server
    value: {get_attr: [WIN_AD_FL_IP, floating_ip_address] }

ERROR LOG details


2017-09-14 10:20:54.977 2735 INFO eventlet.wsgi.server [req-0e84ce74-a51e-45e1-9ebf-093b7022ad38 - admin - - -] 192.168.8.116 - - [14/Sep/2017 10:20:54] "POST /v1/139aa024373b4d4d99cf706508465f1a/validate HTTP/1.1" 200 767 0.389691
2017-09-14 10:25:48.389 2738 ERROR heat.common.wsgi [req-2fa7f6ca-812b-4fa1-8151-94d9a019900c - admin - - -] Unexpected error occurred serving API: 'unicode' object has no attribute 'get'
Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/server.py", line 155, in _process_incoming
    res = self.dispatcher.dispatch(message)

  File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatcher.py", line 222, in dispatch
    return self._do_dispatch(endpoint, method, ctxt, args)

  File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatcher.py", line 192, in _do_dispatch
    result = func(ctxt, **new_args)

  File "/usr/lib/python2.7/dist-packages/osprofiler/profiler.py", line 153, in ...
(more)
2017-09-08 16:45:19 -0500 commented question Boot from volume after the volume was migrated

seems to me an xen hypervisor issue ( did you cheked xen logs for any erros ?) i never faced this kind issue with KVM ,it will be good if you paste nova-compute logs with this call

2017-09-08 16:38:43 -0500 commented question Is it safe to snapshot an attached volume if it's unmounted?

is that volume mounted for database , if its dbi would recommend take db backup instead of taking snapshot, snapshot genertally take more disk utilization this could be the reason your vender opposing to take snapshots

2017-09-08 14:04:53 -0500 commented question Boot from volume after the volume was migrated

is that volume encrypted before ?

2017-09-08 14:02:39 -0500 received badge  Editor (source)
2017-09-08 13:49:28 -0500 answered a question Three nodes setup with neutron, cannot ping VMs either internal or External IP

did you try ping your extegnal gw from router example given below ip netns exec qrouter00000 ping your external gw ip address

also check neutron-linuxbridge-agent.ini file provider network section

2017-09-06 15:40:02 -0500 commented question Kilo: compute node binding_failed

external network should be public network not bridge tunnel interface if you are using ovs ceheck the interface mapping aswell

2017-09-06 15:36:27 -0500 commented answer Getting an error on Glance Image List

check is there any error in glance-api.log may be glance api cannot commpunicate with keystone this could be the error 500 error means glace -api have access issue with keystone

2017-09-06 15:32:56 -0500 commented question provider networks and vxlan

if you are using linuxbridge for provider network you have to map externel interfecace in neutron-libuxbridge gent.ini file compute node should have seperate public interface for externel access

2017-09-06 15:29:48 -0500 commented question unable to migrate instance after it has been resized

have any error notification in horizon ?

2017-09-06 15:05:19 -0500 commented question professional assistance

let me know where you stuck in your open stack environment am happy to help you can reach me on eepeesalimep@gmail.com

2017-01-30 06:20:35 -0500 received badge  Famous Question (source)
2016-10-27 01:26:35 -0500 received badge  Famous Question (source)
2016-08-16 07:51:59 -0500 received badge  Notable Question (source)
2016-08-16 07:51:38 -0500 received badge  Notable Question (source)
2016-07-14 05:56:55 -0500 commented question Error while accessing dashboard

did you create this file inside your controller node for mariadb connection /etc/my.cnf.d/mariadb_openstack.cnf

pls check http://docs.openstack.org/kilo/instal... mentions link basic enviorement steps similar to ot environments

2016-07-12 18:12:34 -0500 received badge  Popular Question (source)
2016-07-10 20:31:15 -0500 received badge  Student (source)
2016-07-10 04:28:34 -0500 asked a question how can i mount cdrom in to opentack instance

Dears,

Is there any way to mount cdrom in to openstack environment . i want create local repository for my redhat instances

2016-07-08 12:13:18 -0500 received badge  Popular Question (source)
2016-07-07 08:06:03 -0500 asked a question what are the benefits if i change tenant network types from gre to vxlan in openstack neutron

in my lab i have 5 node( 3 compute node) open stack environment all my computes nodes are communicating with neutron using gre tunnel types . i curios to know if i change layer 2 tenant network type from gre to vxlan what are the benefits when it comes to big farm (i mean more than 2000 compute nodes) is it feasible to use GRE protocol in production environment ?

2016-07-07 07:47:58 -0500 commented question What is the expected range of root disk sizes?

that will depending upon your glane image . also you can create custom flavor depending upon your requirement

2016-07-07 07:43:22 -0500 answered a question do i need to add any entries in physical router while going for gre type in openstack networking?

look like dhcp manager not running or metadata agent have config issues

2016-07-07 07:38:17 -0500 commented question Why I am getting error for keystone during Liberty single node setup?

check did have any extra space in beginning of the line keystone.conf file also past here the keystone.conf file

2016-07-07 07:38:17 -0500 received badge  Commentator